Parker C3 powerPLmC with Servo Axis C3T40

CANopen controller with IEC61131-3 programming language and cam function integrated into a Compax3 axis C3T40

Description: C3 Sxxx Vx C1xT40
Help verison: C1xT40 192-120203N1 May 2005

C3 powerPLmC version: as from V1.1.0

Version of the Compax3 axis: as from V2.3.18

Data required for operation:
  • Compax3 ServoManager as from version V1.4.x.
  • Programming system CoDeSys as from version V2.3.4.1.
  • C3 powerPLmC - Target as from V1.1.0
    (can be downloaded as tooltip from the InstallTarget program.)
Designation / Versions of connected servo axes:
  • Compax3 I21Txx as from version V2.3.18.

Commissioning recipe

C3 powerPLmC C1x system network


Copyright / addresses

____________________________

Copyright © 2005 Parker Hannifin GmbH EME
All rights reserved.

Windows NT®, Windows 2000™, Windows XP™ are trademarks of Microsoft Corporation.

EME - Electromechanical Automation Europe

Germany:

Parker Hannifin GmbH&Co.KG
Electromechanical Automation
PO Box: 77607-1720
Robert-Bosch-Str. 22
D-77656 Offenburg
Tel.: +49 (0)781 509-0
Fax: +49 (0)781 509-98176

ISO-Sign

E-mail: sales.hauser@parker.com

Internet: www.parker-eme.com

England:

Parker Hannifin plc
Electromechanical Automation
Arena Business Centre
Holy Rood Close
Poole, Dorset BH17 7BA UK
Tel.: +44 (0)1202 606300
Fax: +44 (0)1202 606301

E-mail: sales.digiplan@parker.com

Internet: www.parker-eme.com

Italy:

Parker Hannifin S. p. A
Electromechanical Automation
Via Gounod 1
I-20092 Cinisello Balsamo (MI), Italy
Tel.: +39 (0)2660 12459
Fax: +39 (0)2660 12808

E-mail: sales.sbc@parker.com

Internet: www.parker-eme.com

EMN - Electromechanical Automation North America

USA:

Parker Hannifin Corporation
Electromechanical Automation
5500 Business Park Drive
Rohnert Park, CA 94928
Phone #: (800) 358-9068
FAX #: (707) 584-3715

E-mail: CMR_help@parker.com
Internet: www.compumotor.com


Introduction

In this chapter you can read about:

Device assignment

Type specification plate

Safety Instructions

Warranty conditions

Conditions of utilization


Device assignment

This manual applies to the following devices:
  • Compax3 S025 V2 + supplement
  • Compax3 S063 V2 + supplement
  • Compax3 S100 V2 + supplement
  • Compax3 S150 V2 + supplement
  • Compax3 S015 V4 + supplement
  • Compax3 S038 V4 + supplement
  • Compax3 S075 V4 + supplement
  • Compax3 S150 V4 + supplement
  • Compax3 S300 V4 + supplement
With the supplement:
  • F10 (Resolver)
  • F11 (SinCos)
  • F12 (linear and rotary direct drives)
  • C10T40
  • C13T40


Type specification plate

You will find the exact description of the device on the type specification plate, which is located on the right side of the device:

Compax3 - Type specification plate:

Type specification plate

Explanation:
1 | Type designation The complete order designation of the device (2, 5, 6, 9, 8)
2 | C3S025V2 C3: Abbreviation for Compax3 S: Single axis device with direct AC mains power supply 025: Device current drain in 100mA (025=2.5A) V2: 230VAC/240VAC; V4: 400VAC/480VAC
3 | Unique number of the particular device
4 | Nominal supply voltage: 1AC = single phase, 3AC = three phase / input current
5 | Designation of the feedback system F10: Resolver F11: SinCos© / Single- or Multiturn F12:Feedback module for direct drives
6 | Device interface I10: Analog, step/direction and encoder input I11 / I12: Digital Inputs / Outputs and RS232 / RS485 I20: Profibus DP I21: CANopen C10:integrated controller C3 powerPLmC C13:integrated controller C3 powerPLmC with Profibus
7 | Date of factory test
8 | Options
9 | Technology function T10: Servo controller T11: Positioning T30: Motion control programmable according to IEC61131-3 T40: Electronic cam generation
10 | CE compliance
11 | BG - Prüfzert Safe standstill as per EN954-1, category 3
12 | UL certification


Safety Instructions

In this chapter you can read about:

General hazards

Safety-conscious working

Special safety instructions


General hazards

General Hazards on Non-Compliance with the Safety Instructions

The device described in this manual is designed in accordance with the latest technology and is safe in operation. Nevertheless, the device can entail certain hazards if used improperly or for purposes other than those explicitly intended.

Electronic, moving and rotating components can

  • constitute a hazard for body and life of the user, and
  • cause material damage

Usage in accordance with intended purpose

The device is designed for operation in electric power drive systems (VDE0160). Motion sequences can be automated with this device. Several motion sequences can be combined by interconnecting several of these devices. Mutual interlocking functions must be incorporated for this purpose.


Safety-conscious working

This device may be operated only by qualified personnel.

Qualified personnel in the sense of these operating instructions consists of:

  • Persons who, by virtue to their training, experience and instruction, and their knowledge of pertinent norms, specifications, accident prevention regulations and operational relationships, have been authorized by the officer responsible for the safety of the system to perform the required task and in the process are capable of recognizing potential hazards and avoiding them (definition of technical personnel according to VDE105 or IEC364),
  • Persons who have a knowledge of first-aid techniques and the local emergency rescue services.
  • Persons who have read and will observe the safety instructions.
  • Those who have read and observe the manual or help (or the sections pertinent to the work to be carried out).

    This applies to all work relating to setting up, commissioning, configuring, programming, modifying the conditions of utilization and operating modes, and to maintenance work.

    This manual and the help information must be available close to the device during the performance of all tasks.


Special safety instructions

  • Check the correct association of the device and its documentation.
  • Never detach electrical connections while voltage is applied to them.
  • Safety devices must be provided to prevent human contact with moving or rotating parts.
  • Make sure that the device is operated only when it is in perfect condition.
  • Implement and activate the stipulated safety functions and devices.
  • Operate the device only with the housing closed.
  • Ensure that motors and any linear drives present are mounted securely.
  • Check that all live terminals are secured against contact. Fatal voltage levels of to 750V occur.
  • Attention when performing a configuration download for master-slave couplings (electronic gearbox, cam)
    Always switch Compax3 to currentless before starting the configuration download Master and Slave axis

  • Before generating a boot project, (program is saved in FLASH), perform a program stop, since uncontrolled movements are possible while a boot project is being generated.
  • Attention!
    During the program test, note the motion sequences of your drive.
    Especially when working with break points, online changes, coercing variables, sequence control or debugging, it is always essential to ensure that only controlled motion sequences take place.
    These functions can change the control sequence of the program and affect behavior related to the program sequence and program execution time!
    Online change and forcing variables directly affects sequence logic.


Warranty conditions

  • The device must not be opened.
  • Do not make any modifications to the device, except for those described in the manual.
  • Make connections to the inputs, outputs and interfaces only in the manner described in the manual.
  • When installing the device, make sure the heat dissipator receives sufficient air.
Attach the devices according to the mounting instructions, using the provided fixing holes. We cannot provide any guarantee for any other mounting methods.
Note on exchange of options

Compax3 options must be exchanged in the factory to ensure hardware and software compatibility.


Conditions of utilization


Conditions of utilization for CE-conform operation

- Industry and trade -

The EC guidelines for electromagnetic compatibility 89/336/EEC and for electrical operating devices for utilization within certain voltage limits 73/23/EEC are fulfilled when the following boundary conditions are observed:

Operation of the devices only in the condition in which they were delivered, i.e. with all housing panels.

Mains filter:

A mains filter is required in the mains input line if the motor cable exceeds a certain length. Filtering can be provided centrally at the plant mains input or separately at the mains input to each device.

Commercial and residential area (limit values of Class A in accordance with EN 61800-3)

The following mains filters are available for independent utilization:

Device: Compax3 family | Order No.: | Condition:
S0xxV2 | NFI01/01 | Only for motor lines longer than 10m
S1xxV2, S0xxV4, S150V4 | NFI01/02 | Only for motor lines longer than 10m
S300V4 | NFI01/03 | independent of the length of the motor cable (always required)
Industrial area (limit values in accordance with EN 61800-3)

Longer motor cable lengths are possible in industrial areas without a mains power filter.

Connection length: Connection between mains filter and device:

unshielded: < 0,5m
shielded: < 5m (fully shielded on ground – e.g. ground of control cabinet)

Motor and Feedback cable:

Operation of the devices only with Parker motor and feedback cables (their plugs contain a special full surface area screening).

The following cable lengths are permitted:

Motor cable

< 100 m (the cable should not be rolled up!)

A motor output filter is required for motor cables >20m.

  • MDR01/04 (max. 6.3A rated motor current)
  • MDR01/01 (max. 16A rated motor current)
  • MDR01/05 (max. 30A rated motor current)

Shielding connection of the motor cable

The motor cable should be fully screened and connected to the Compax3 – housing. We offer a special shield connecting terminal as an accessory.

The shield of the motor cable must also be connected with the motor housing. The fixing (via plug or screw in the terminal box) depends on the motor type.

Feedback cable

< 100 m

Motors:

Operation with standard motors.

Control:

Use only with aligned controller (to avoid control loop oscillation).

Grounding:

Connect the filter housing and the Compax3 (grounding screw on the underside) to the cabinet frame, making sure that the contact area is adequate and that the connection has low resistance and low inductance.

Never mount the filter housing and the device on paint-coated surfaces!

Cable installation:

Signal lines and power lines should be installed as far apart as possible.

Signal leads should never pass close to excessive sources of interference (motors, transformers etc.).

Accessories:

Make sure to use only the accessories recommended by Parker

Connect all cable shields at both ends, ensuring large contact areas!

Warning:

This is a product in the restricted sales distribution class according to EN 61800-3. In a domestic area this product can cause radio frequency disturbance, in which case the user may be required to implement appropriate remedial measures.


Conditions of utilization for UL permission

UL certification

conform to UL:
  • according to UL508C

Certified
  • E-File_No.: E235 342

The UL certification is documented by a ”UL” logo on the device (type specification plate).

”UL” logo

UL logo

Conditions of utilization
  • The devices are only to be installed in a degree of contamination 2 environment (maximum).
  • The devices must be appropriately protected (e.g. by a switching cabinet).
  • The X2 terminals are not suitable for field wiring.
  • Tightening torque of the field wiring terminals ( green Phoenix plugs)
    • C3S0xxV2

    0.57-0.79Nm

    5 - 7Lb.in

    • C3S1xxV2,
      C3S0xxV4, C3S150V4

    0.57-0.79Nm

    5 - 7Lb.in

    • C3S300V4

    1.25-1.7Nm

    11 - 15Lb.in
  • Temperature rating of field installed conductors shall be at least 60°C Use only copper conductors
    Please use the cables described in the Accesories they do have a temperature rating aof at least 60°C.
  • Maximum ambient temperature: 45°C.
  • Suitable for use on a circuit capable of delivering not more than 5000 rms symmetrical amperes and 480 volts maximum.

ATTENTION
Danger of electric shock.
Discharge time of the bus capacitator is 5 minutes.

  • The drive provides internal motor overload protection.
    This must be set so that 200% of the motor – nominal current are not exceeded.
  • Cable cross-sections
    • Mains input: corresponding to the recommended fuses.
    • Motor cable corresponding to the nominal output currents
    • Maximum cross-section limited by the terminals mm2 / AWG
      • C3S0xxV2

      2.5mm2

      AWG 12

      • C3S1xxV2,
        C3S0xxV4, C3S150V4

      4.0mm2

      AWG 10

      • C3S300V4

      6.0mm2

      AWG 7
  • Fuses
    In addition to the main fuse, the devices must be equipped with a S 271 K or S 273 K fuse made by ABB.
    • C3S025V2: ABB, nominal 480V 10A, 6kA
    • C3S063V2: ABB, nominal 480V, 16A, 6kA
    • C3S100V2: ABB, nominal 480V, 16A, 6kA
    • C3S150V2: ABB, nominal 480V, 20A, 6kA
    • C3S015V4: ABB, nominal 480V, 6A, 6kA
    • C3S038V4: ABB, nominal 480V, 10A, 6kA
    • C3S075V4: ABB, nominal 480V, 16A, 6kA
    • C3S150V4: ABB, nominal 480V, 20A, 6kA
    • C3S300V4: ABB, nominal 480V, 25A, 6kA


Current on the mains PE (leakage current)

The leakage current (current on the mains PE) is mainly caused by the capacitive resistance between the conductor and the shielding of the motor cable. If a radio interference filter is used, this results in an additional leakage current, as the filter circuit is linked to protective earth by condensers.

The figure of the leakage current depends on the following factors:

  • Length of the motor cable
  • Switching frequency
  • With or without radio interference filter.
  • Shielded or not shielded motor cable
  • Motor grounded or not
  • The leakage current is important with respect to the handling and usage safety of the device.
Please note:

The device must be operated with effective grounding connection, which must comply with the local regulations for high leakage currents (>3.5mA).

The servo amplifier must, because of higher leakage currents, not be operated with an earth leakage circuit breaker.

An earth leakage (FI) circuit breaker (e.g. ABB series F804) installed must not interrupt the circuit in spite of the following conditions:

  • DC component in leakage current (3 phase rectifier bridge).
  • Brief occurrence of pulse-shaped leakage currents when switching on.
  • High levels of leakage current.


C3 powerPLmC: Control via IEC61131-3 and PLCopen

C3 powerPLmC is a control system for combined PLC, motion and visualization tasks.

The power range of commands based IEC61131-3 is available for control tasks. Multi-axis motion tasks are supported by PLCopen function modules.

The program can be subdivided into free-running, cyclic and event-controlled tasks.

Visualization can be implemented via the OPC server, on the PC of the programming system itself or with a bus component (for example Parker Operator Panel).

CANopen combines the bus components with the CANopen master "C3 powerPLmC".

The C3 powerPLmC can be programmed using the "CoDeSys" high-power programming system via the Ethernet interface.

The "CoDeSys" programming system is described in detail in a help system (C:\Programme\3S Software\CoDeSys V2.3\Help\) or in a manual (C:\Programme\3S Software\CoDeSys V 2.3\Documents\) available as a PDF.

System layout with Compax3

C3 powerPLmC C1xTxx consists of a control system and a Compax3 axis. Additional Compax3s of the type I21Txx can be integrated into the system very easily, in fact almost automatically with CANopen using the "Drive Interface".

The externally connected Compax3 axes are operated in the CANopen operating mode "slave with C3 powerPLmC as master" (should be set in the device configuration of the corresponding Compax3 in the CANopen wizard window).

The Compax3 axes are configured via RS232 interface, including the axis that includes the C3 powerPLmC with the aid of the C3 ServoManager.

Compax3 control technology

High-performance control technology and openness for various sender systems are fundamental requirements for a fast and high-quality automation of movement.

Model / standards / auxiliary material

The structure and size of the device are of considerable importance. Powerful electronics is an important feature which made it possible to manufacture the Compax3 so small and compact. All connectors are located on the front of the Compax3.

Internal mains filters permit connection of motor cables up to a certain length without requiring additional measures. EMC compatibility is within the limits set by EN 61800-3, Class A. The Compax3 is CE-conform.

The intuitive user interface familiar from many applications – together with the oscilloscope function, wizards and online help, simplifies making and modifying settings via the PC.

The optional Operator control unit (BDM01/01 ) makes it possible to exchange devices quickly without requiring a PC.

Configuration

Configuration is made on a PC using the Compax3 – ServoManager.
Install the programme on your PC and connect to the Compax3 X10 via the RS232 (cable plan).


Step-by-step set-up

Sequence for setting-up an axis with C3 powerPlmC:

1. Installation
  • Compax3 ServoManager
  • CoDeSys from the Compax3 CD (C3 powerPLmC Target is automatically installed at the same time
    (remove old Parker targets previously if any are present)
2. connections
  • PC - Compax3 - axis (X10) via RS232 cable SSK1.
  • PC - C3 powerPLmC (X24) via Ethernet cable SSK28.
  • Motor on Compax3 X3 (motor cable) and X13 (feedback cable)
  • Compax3 power supply: AC on X1; DC on X4
  • Enable Compax3: X4/3 = 24 VDC
3. Compax3 - configure servo axis
  • Start Compax3 ServoManager
  • Start device selection wizard (select type or identify online)
  • Start configuration wizard – configure servo axis
4. Configure C3 powerPLmC
  • Make LAN-settings In the Compax3 ServoManager in the tree under C3 powerPLmC.
  • Call up CoDeSys (in the tree under C3 powerPLmC: CoDeSys: Start CoDeSys)
  • In CoDeSys: File new; select target system "CoDeSys for C3 powerPLmC" -> OK
  • Select programming language (for example CFC)
  • Under Online: Set LAN-Address of the C3 powerPLmC communication parameters CoDeSys
  • Integrate a Compax3 group and a Compax3 axis under ressources: controller configuration
  • Insert a task under ressources: Task configuration::
    • Same task name as for the Compax3 group
    • Type: cyclic; interval 10 ms, for example
    • Append program call (PLC_PRG();)
5. Create IEC61131-3 program
  • Initialize the Compax3 drive interface in the PLC_PRG module.
  • Create IEC61131-3 program
  • Compile the project
  • Online: Log in and start the program with Online: Start.
    The program can be permanently stored in the C3 powerPLmC with Generate Boot Project.


Compax3 device description

In this chapter you can read about:

Plug and connector assignment for Compax3 powerPLmC

Installation and dimensions Compax3

Safety function – safe standstill -


Plug and connector assignment for Compax3 powerPLmC

In this chapter you can read about:

Meaning of the Compax3 front panel LEDs (via X10)

Main voltage supply (plug X1)

Braking resistor / high voltage DC (plug X2)

Motor / Motor brake (plug X3)

Resolver / Feedback (connector X13)

Control voltage 24VDC / enable (plug X4)

RS232 / RS485 interface (plug X10)

Analog / Encoder (plug X11)

Profibus plug X25 with Interface C13

CANopen connector X22

Ethernet connector X24 / switch S23

Digital inputs/outputs (plug X12)

Connector assignment C3 powerPLmC

Always switch devices off before wiring them!
Dangerous voltages are still present until 5 minutes after switching off the power supply!

Caution!

When the control voltage is missing there is no indication whether or not high voltage supply is available.


Meaning of the Compax3 front panel LEDs (via X10)

State | LED red | LED green
Voltages missing | off | off
While booting | alternately flashing
- No configuration present. - SinCos feedback not detected. - Compax3 IEC61131-3 program not compatible with Compax3 Firmware. - no Compax3 IEC61131-3 program - For F12: Hall signals invalid. | flashing | off
Axis without current excitation | off | Flashes slowly
Power supplied to axis; commutation calibration running | off | Flashes quickly
Axis with current excitation | off | on
Axis in fault status / fault present | on | off


Main voltage supply (plug X1)

In this chapter you can read about:

Power supply plug X1 for 1 AC 230VAC/240VAC devices

Power supply plug X1 for 3AC 230VAC/240VAC devices

Power supply plug X1 for 3AC 400VAC/480VAC devices


Power supply plug X1 for 1 AC 230VAC/240VAC devices

Compax3 plug X1

PIN | Description
1 | L
2 | N
3 | PE

Mains connection for Compax3 S0xx 1AC V2

Controller type | S025 V2 | S063 V2
Mains voltage | Single phase 230VAC/240VAC 80-253 VAC/50-60Hz
Input current | 6Aeff | 13Aeff
Maximum fuse rating per device | 10 A (automatic circuit breaker K) | 16 A (automatic circuit breaker K)
Always switch devices off before wiring them!
Dangerous voltages are still present until 5 minutes after switching off the power supply!


Power supply plug X1 for 3AC 230VAC/240VAC devices

Compax3 plug X1 V4

PIN | Description
1 | L1
2 | L2
3 | L3
4 | PE

Mains connection Compax3 S1xx 3AC V2

Controller type | S100 V2 | S150 V2
Mains voltage | Three phase 3* 230VAC/240VAC 80-253 VAC/50-60Hz
Input current | 10Aeff | 13Aeff
Maximum fuse rating per device | 16 A (automatic circuit breaker K) | 20 A (automatic circuit breaker K)

Caution!

The 3AC V2 – devices must only be operated with three phases!
Always switch devices off before wiring them!
Dangerous voltages are still present until 5 minutes after switching off the power supply!


Power supply plug X1 for 3AC 400VAC/480VAC devices

Compax3 plug X1 V4

PIN | Description
1 | L1
2 | L2
3 | L3
4 | PE

Mains connection Compax3 Sxxx 3AC V4

Controller type | S015 V4 | S038 V4 | S075 V4 | S150 V4 | S300 V4
Mains voltage | Three phase 3*400VAC/480VAC 80-528VAC / 50-60Hz
Input current | 3Aeff | 6Aeff | 10Aeff | 16Aeff | 22Aeff
Maximum fuse rating per device | 6A | 10A | 16A | 20A | 25A
 | Automatic circuit breaker K |  |  |  | D*

*for CE-conform operation: Automatic circuit breaker K S273-K.

Caution!

The 3AC V4 – devices must only be operated with three phases!
Always switch devices off before wiring them!
Dangerous voltages are still present until 5 minutes after switching off the power supply!


Braking resistor / high voltage DC (plug X2)

In this chapter you can read about:

Braking resistor / high voltage supply plug X2 for1AC 230VAC/240VAC devices

Braking resistor / high voltage supply plug X2 for 3AC 230VAC/240VAC devices

Braking resistor / high voltage supply plug X2 for 3AC 400VAC/480VAC devices

Connection of the power voltage of 2 Compax3 3AC devices

The energy generated during braking operation is absorbed by the Compax3 storage capacity.

If this capacity is too small, the braking energy must be drained via a braking resistor.


Braking resistor / high voltage supply plug X2 for1AC 230VAC/240VAC devices

Compax3 plug X2

PIN | Description
1 | reserved
2 | - Braking resistor
3 | PE
4 | + Braking resistor
5 | reserved

Braking operation Compax3 S0xx 1AC V2

Controller type | S025 V2 | S063 V2
Capacitance / storable energy | 560mF / 15Ws | 1120mF / 30Ws
Minimum ballast - resistance | 100W | 56W
Recommended nominal power rating | 20 ... 60W | 60 ... 180W
Pulse power rating for 1s | 1kW | 2.5kW

Caution!

The power voltage DC of two Compax3 1AC V2 devices (230VAC/240VAC devices) must not be connected.


Braking resistor / high voltage supply plug X2 for 3AC 230VAC/240VAC devices

Compax3 plug X2

PIN | Description
1 | + Braking resistor
2 | - Braking resistor
3 | PE
4 | + DC high voltage supply
5 | - DC high voltage supply

Braking operation Compax3 S1xx 3AC V2

Controller type | S100 V2 | S150 V2
Capacitance / storable energy | 780mF / 21Ws | 1170mF / 31Ws
Minimum ballast - resistance | 22W | 15W
Recommended nominal power rating | 60 ... 450W | 60 ... 600W
Pulse power rating for 1s | 4kW | 6kW


Braking resistor / high voltage supply plug X2 for 3AC 400VAC/480VAC devices

Compax3 plug X2 V4

PIN | Description
1 | + Braking resistor
2 | - Braking resistor
3 | PE
4 | + DC high voltage supply
5 | - DC high voltage supply

Brake operation Compax 3 Sxxx 3AC V4

Controller type | S015V4 | S038V4 | S075V4 | S150V4 | S300V4
Capacitance / storable energy | 235mF / 37Ws | 235mF / 37Ws | 470mF / 75Ws | 690mF / 110Ws | 1100mF / 176Ws
Minimum ballast - resistance | 100W | 100W | 56W | 22W | 15W
Recommended nominal power rating | 60 ... 100W | 60 ... 250W | 60 ... 500 W | 60 ... 1000 W | 60 ... 1000 W
Pulse power rating for 1s | 1kW | 2.5kW | 5kW | 10 kW | 42kW


Connection of the power voltage of 2 Compax3 3AC devices

Caution!

The power voltage DC of the single phase Compax3 servo axes must not be connected!

In order to improve the conditions during brake operation, the DC power voltage of 2 servo axes may be connected.

The capacity as well as the storable energy are increased; furthermore the braking energy of one servo axis may be utilized by a second servo axis, depending on the application.
It is not permitted to connect the power voltage in order to use one brake circuit for two servo axes, as this function cannot be ensured reliably.
Please connect as follows:

Servo axis 1 X2/4 to servo axis 2 X2/4

Servo axis 1 X2/5 to servo axis 2 X2/5

Note the following:
Caution! In case of non-compliance with the following instructions, the device may be destroyed!
  • You can only connect two similar servo axes (same power supply; same rated currents)
  • Connected servo axes must always be fed separately via the AC power supply.
  • If the external pre-fuse of one of the servo axes takes action, the second servo axis must also be disconnected automatically.


Motor / Motor brake (plug X3)

Compax3 plug X3

Compax3 plug X1 V4

PIN | Description
1 | U (motor)
2 | V (motor)
3 | W (motor)
4 | PE (motor)
5 | BR+ | Motor holding brake
6 | BR- | Motor holding brake
Shielding connection of the motor cable

The motor cable should be fully screened and connected to the Compax3 – housing. We offer a special shield connecting terminal as an accessory.

The shield of the motor cable must also be connected with the motor housing. The fixing (via plug or screw in the terminal box) depends on the motor type.

Connect the brake only on motors which have a holding brake! Otherwise make no brake connections at all.

Output

Motor holding brake output

Motor holding brake output | Compax3 family
Voltage range | 21 – 27VDC
Maximum output current (short circuit proof) | 1.6A

Motor cable


Resolver / Feedback (connector X13)

Compax3 plug X13

PIN X13 | Feedback /X13 High Density /Sub D (dependent on the Feedback Module)
 | Resolver (F10) | SinCos (F11) | Direct drives (F12)
1 | reserved | reserved | Sense -
2 | reserved | reserved | Sense +
3 | GND | GND | Hall1
4 | REF-Resolver+ | Vcc (+8V) | Vcc (+5V) (controlled on the encoder side) max. 200mA load
5 | +5V (for temperature sensor) |  | +5V (for temperature and hall sensors)
6 | reserved | reserved | Hall2
7 | SIN- | SIN- | SIN- / A- (Encoder)
8 | SIN+ | SIN+ | SIN+ / A+ (Encoder)
9 | reserved | reserved | Hall3
10 | Tmot | Tmot | Tmot
11 | COS- | COS- | COS- / B- (Encoder)
12 | COS+ | COS+ | COS+ / B+ (Encoder)
13 | reserved | DATAfbk | N+
14 | reserved | DATAfbk/ | N-
15 | REF-Resolver- | GND (Vcc) | GND (Vcc)
Note on F12:

+5V (Pin 4) is measured and controlled directly at the end of the line via Sense – and Sense +.

Maximum cable length: 100m

Caution! Pin 4 and Pin 5 must under no circumstances be connected!

Resolver cable can be found in the accessories chapter.

SinCos cablefinden Sie im Kapitel Zubehör.


Control voltage 24VDC / enable (plug X4)

Compax3 plug X4

PIN | Description
1 | +24V (supply)
2 | Gnd24 V
3 | Enable_in
4 | Enable_out_a
5 | Enable_out_b

Control voltage 24VDC (X4/1, X4/2)

Controller type | Compax3 family
Voltage range | 21 - 27VDC
Current drain of the device | 0.8A
Total current drain | 0.8 A + Total load of the digital outputs + current for the motor holding brake
Ripple | 0.5Vpp
Requirement according to safe extra low voltage (SELV) | yes

Hardware - enable (input X4/3 = 24VDC)

This input is used as safety interrupt for the power output stage.

Tolerance range: 18.0V - 33.6V / 720W

Safe standstill (X4/3=0V)

For implementation of the "Safe standstill" safety feature in accordance with the ”protection against unexpected start-up” described in EN1037. Please refer to the respective chapter with the circuitry examples!

The energy supply to the drive is reliably shut off, the motor has no torque.

A relay contact is located between X4/4 and X4/5 (normally closed contact)

Enable_out_a - Enable_out_b | Power output stage is
Contact opened | activated
Contact closed | disabled

Series connection of these contacts permits certain determination of whether all drives are de-energized.

Relay contact data:

Switching voltage (AC/DC): 100mV -60V

Switching current: 10mA - 0.3A

Switching power: 1mW...7W


RS232 / RS485 interface (plug X10)

Compax3 plug X10

Interface selectable by contact functions assignment of X10/1:

X10/1=0V RS232

X10/1=5V RS485

RS232
PIN X10 | RS232 (Sub D)
1 | (Enable RS232) 0V
2 | RxD
3 | TxD
4 | DTR
5 | GND
6 | DSR
7 | RTS
8 | CTS
9 | +5V
RS485 2-wire
PIN X10 | RS485 two wire (Sub D) Pin 1 and 9 jumpered externally
1 | Enable RS485 (+5V)
2 | res.
3 | TxD_RxD/
4 | res.
5 | GND
6 | res.
7 | TxD_RxD
8 | res.
9 | +5V
RS485 4-wire
PIN X10 | RS485 four wire (Sub D) Pin 1 and 9 externally jumpered
1 | Enable RS485 (+5V)
2 | RxD
3 | TxD/
4 | res.
5 | GND
6 | res.
7 | TxD
8 | RxD/
9 | +5V


Analog / Encoder (plug X11)

Compax3 plug X11

PIN X11 | Reference High Density Sub D
1 | +24V (output for encoder) max. 70mA
2 | Ain1 -: analog input - (14Bit; max. +/-10V)
3 | D/A monitor channel 1 (±10V, 8-bit resolution)
4 | D/A monitor channel 0 (±10V, 8-bit resolution)
5 | +5V (output for encoder) max. 150mA
6 | - Input: steps RS422 (5V - level) | A/ (Encoder input / simulation)
7 | + Input: steps RS422 (5V - level) | A/ (Encoder input / simulation)
8 | + Input: direction RS422 (5V - level) | B (Encoder input / simulation)
9 | Ain0 +: analog input + (14Bit; max. +/-10V)
10 | Ain1 +: analog input + (14Bit; max. +/-10V)
11 | Ain0 -: analog input - (14Bit; max. +/-10V)
12 | - Input: direction RS422 (5V - level) | B (Encoder input / simulation)
13 | reserved | N/ (encoder simulation)
14 | reserved | N/ (encoder simulation)
15 | GND


Wiring of analog interfaces

Output | Input
Analogue output | Analogue input

Ain1 (X11/10 and X11/2) has the same wiring!


Connections of the encoder interface


Profibus plug X25 with Interface C13

Compax3 plug X23

Pin X25 | Profibus (Sub D)
1 | reserved
2 | reserved
3 | Data line B
4 | RTS
5 | GND
6 | +5V
7 | reserved
8 | Data line A
9 | reserved

The assignment corresponds to Profibus standard EN 50170.

Wiring.


Function of the Bus LEDs

Function of the LEDs (via X25)
Green LED (left) | Red LED (right) | Description
alternately flashing |  | Field bus program missing
off | flashing | Device is not initialized
on | flashing | Bus operation mode (no DATA exchange)
on | off | Bus operation mode (DATA exchange)
on | on | Bus error


CANopen connector X22

Compax3 plug X23

Pin X22 | CANopen (Sub D)
1 | reserved |
2 | CAN_L | CAN Low
3 | GNDfb | Opto-isolated GND-supply
4 | reserved |
5 | SHIELD | Shield optional
6 | reserved |
7 | CAN_H | CAN High
8 | reserved |
9 | reserved |

The assignment corresponds to CANopen DS301.

At the beginning and end of the device chain a terminating resistor of 120W is required between CAN_L and CAN_H

Wiring.


Ethernet connector X24 / switch S23

Ethernet - connector

Programming interface PC « C3 powerPLmC

As a connection cable between the C3 powerPLmC and the network interface (LAN) of the PC we offer the SSK28 cable; this is a Cat.5 cable, (Cross Over).

If the connection uses a network, a cat.5 standard cable is required.

Function of the LEDs: (via X24)
LED | Off | On
Green | no physical Ethernet connection | physical Ethernet connection established
Yellow | No data exchange | Data are being transmitted and received
Run - Stop - S23 switch

Switch toggled to the left:Stops processing of the user program in the control system.

Switch toggled to the right:This command starts processing of the user program in the control system or in simulation.

Function corresponds to that available in CoDeSys with the function keys F5 (=run) and SHIFT F8 (=stop) (for more information see CoDeSys help).

When switching on the control with the switch on the left position, the starting of the IEC61131-3 program is prevented.


Digital inputs/outputs (plug X12)

Compax3 plug X12

PIN X12/ | Input/output | I/O /X12 High density/Sub D
1 | O | +24VDC output (max. 400mA)
2 | O0 | Output 0 (max. 100mA)
3 | O1 | Output 1 (max. 100mA)
4 | O2 | Output 2 (max. 100mA)
5 | O3 | Output 3 (max. 100mA)
6 | I0 | Input 0
7 | I1 | Input 1
8 | I2 | Input 2
9 | I3 | Input 3
10 | I4 | Input 4
11 | E | 24V input for the digital outputs Pins 2 to 5
12 | I5 | Input 5 or limit or direction reversal switch
13 | I6 | Input 6 or limit or direction reversal switch
14 | I7 | Input 7 or home switch
15 | O | Gnd 24 V

All inputs and outputs have 24V level.

Maximum capacitive loading of the outputs: 50nF (max. 4 Compax3 inputs)

Note:

The inputs and outputs are freely programmable using an IEC61131-3 program.

Input 7 is planned as home switch, the inputs 5 and 6 as limit switches or direction reversal switches.

If no limit switches are used and these are switched off (in the C3 ServoManager under configuration), the inputs 5 and 6 can be freely assigned.

The same applies for input 7: A machine zero mode without home switch allows to freely assign input 7.


Connection of the digital Outputs/Inputs

Wiring of digital outputs | Wiring of digital outputs
Input circuitry for digital inputs | Input circuitry for digital inputs
The circuit example is valid for all digital outputs! The outputs are short circuit proof; a short circuit generates an error. | The circuit example is valid for all digital inputs!
F1: delayed action fuse F2: quick action electronic fuse; can be reset by switching the 24VDC supply off and on again.


Installation and dimensions Compax3

In this chapter you can read about:

Installation and dimensions of Compax3 S0xx V2

Installation and dimensions Compax3 S100 V2 and S0xx V4

Installation and dimensions Compax3 S150 V2 and S150 V4

Installation and dimensions of Compax3 S300 V4


Installation and dimensions of Compax3 S0xx V2

Mounting:

3 socket head screws M5

Mounting spacing:

Device separation 15 mm

Dimensions of Compax3 S0xx V2


Installation and dimensions Compax3 S100 V2 and S0xx V4

Mounting:

3 socket head screws M5

Mounting spacing:

Device separation 15 mm

Dimensions Compax3 S038 S075 V4


Installation and dimensions Compax3 S150 V2 and S150 V4

Mounting:

4 socket head screws M5

Mounting spacing:

Device separation 15 mm

Dimensions Compax3 S150 V4


Installation and dimensions of Compax3 S300 V4

Mounting:

4 socket head screws M5

Mounting spacing:

Device separation 15 mm

Dimensions Compax3 S300

Compax3 S300 V4 is force-ventilated via a fan integrated into the heat dissipator!


Safety function – safe standstill -

In this chapter you can read about:

Safety instructions for the ”safe standstill” function

Application examples for ”safe standstill”

Compax3 is equipped with the "Safe Standstill" safety feature.

The ”protection against unexpected start-up” described in EN1037 can be implemented with this feature.

Principle:

To ensure safe protection against a motor starting up unexpectedly, the flow of current to the motor and thus to the power output stage must be prevented.

This is accomplished for Compax3 with two measures independent of each other (Channel 1 and 2), without disconnecting the drive from the power supply:

Channel 1:

Activation of the power output stage can be disabled in the Compax3 controller by means of a digital input or with a fieldbus interface (depending on the Compax3 device type) (deactivation of the energize input).

Channel 2:

The power supply for optocouplers and drivers of power output stage signals is disconnected by a safety relay activated by the enable input "ENAin"(X4/3) and equipped with force-directed contacts. This prevents control signals from being transferred to the power output stage.
The “Safe Standstill” safety function as defined by EN 954-1 Category 3 is only possible if both channels are used.
Circuit diagram illustrating working principle:

Principle of ”safe standstill”

Notes
  • In normal operation of Compax3, 24 V DC of power is supplied to the "Enable" input (X4/3). The drive is then controlled by the digital inputs/outputs or the fieldbus.

  • When used properly, the ”Safe standstill” safety function is only used when the motor is at a standstill, since it is not capable of braking a motor or bringing it to a standstill by itself.
The ”Safe Standstill” safety function is implemented in the following devices:

Compax3 technology function

Device power
  • I10T10, I11T11
  • S025V2, S063V2
  • I11T30, I20T30, I21T30
  • S100V2, S150V2
  • I11T40, I20T40, I21T40
  • S015V4, S038V4
  • I12T11, I20T11, I21T11
  • S075V4, S150V4
  • C10T11, C10T30, C10T40
  • S300V4
  • C13T11, C13T30, C13T40

and does apply only for the safety switching devices used in the application examples.

Compax3-specific Inputs and Outputs channel 1

The "Energize" input and the "Controller Feedback" output depend on the Compax3 device type:

  • Compax3 I10 T10, I11 T11, C10T11: a permanently assigned digital input and output (see in the application examples).
  • Compax3 I12 T11: a permanently assigned digital input and output (see in the application examples), or realize the ”energize” function via the RS485 – bus interface (programmable in the Compax3).
  • Compax3 T30 / T40: "Energize" and "Controller Feedback" are applied to the I/Os by way of the IEC program.
  • Compax3 with fieldbus: "Energize" and "Controller Feedback" are activated or queried by the bus (via control and status word).


Safety instructions for the ”safe standstill” function

  • Safety functions must be tested 100%.
  • Only qualified staff members are permitted to install the “Safe Standstill” feature and place it in service.
  • For all applications in which the first channel of the “Safe Standstill” is implemented by means of a PLC, care must be taken that the part of the program that is responsible for current flowing to or not flowing to the drive is programmed with the greatest possible care. The “Safe Standstill” application example of Compax3 with fieldbus should be considered.
    The designer and operator responsible for the system and machine must refer programmers who are involved to these safety-related points.
  • Terminal X4/2 (GND 24 V and at the same time the reference point for the safety relay bobbin) must be connected with the PE protective lead. This is the only way to ensure protection against incorrect operation through earth faults (EN60204-1 Section 9.4.3)!
  • All conditions necessary for CE conform operation must be observed.
  • It should be noted in connection with the “Safe Standstill” application example illustrated here that after the Emergency Power-off switch has been activated, no galvanic isolation in accordance with EN 60204-1 Section 5.5 is guaranteed. This means that the entire system must be disconnected from the mains power supply with an additional main switch or mains power contactor for repair jobs. Please note in this regard that even after the power is disconnected, dangerous electrical voltages may still be present in the Compax3 drive for about 5 minutes.
  • When using an external Emergency power-off module with adjustable delay time, (as illustrated in the “Safe Standstill” application example), it must be ensured that the delay time cannot be adjusted by persons not authorized to do so (for example by applying a lead seal).
    The adjustable delay time on the Emergency Power-off module must be set to a value greater than the duration of the braking ramp controlled by the Compax3 with maximum load and maximum speed.
    If the setting range for the specified Emergency power-off module is not sufficient, the Emergency power-off module must be replaced by another comparable module.
  • All safety-related external leads (for example the control lead for the safety relay and feedback contact) must absolutely be laid so they are protected, for example in a cable duct. Short circuits and crossed wires must be reliably excluded!
  • If there are external forces operating on the drive axes, additional measures are required (for example additional brakes). Please note in particular the effects of gravity on suspended loads!
  • If the power fails, the possibility must be considered that for the application with stop category K1, such as is described in the application example, it will no longer be possible to execute the braking ramp controlled to speed 0.
  • It is important to note that if the drive is being activated (Energize) by the RS232 (RS485) interface, it may not be possible to execute switch-off by a controlled braking ramp. For example, this is true when the set-up window of the C3 ServoManager is used. If set-up mode is turned on, the digital I/O interface and fieldbus interface are automatically disabled.


Application examples for ”safe standstill”

In this chapter you can read about:

Sample circuit for C3 powerPLmC multi-axis application

The application examples described here correspond to Stop Category 1 as defined by EN60204-1.

A Stop Category 0 in accordance with EN 60204-1 can be implemented, for example by setting the delay time on the Emergency power-off switch to 0. The Compax3 drive will then be turned off immediately in 2 channels and will not be able to generate any more torque. Please take into consideration that the motor will not brake and a coasting down of the motor may result in hazards. If this is the case, a ”Safe Standstill” in the stop category 0 is not permitted.


Sample circuit for C3 powerPLmC multi-axis application

If the Compax3 ”Safe Standstill” feature is required or used for a system or machine, the two error messages ”Motor_Stalled” and ”Tracking” (following error) must not be turned off with the ”C3_Errormask” function module.

Layout:
  • 1 Compax3 with powerPLmC
  • n Compax3 devices
  • 1 Emergency Power-off module (BH5928.47 manufactured by Dold)
  • 1 safety door monitor (BD5985N made by Dold)
    Note: With safety door monitor BD5985N, the safety door must be opened and closed again every time after turning on the 24 V power supply so that the Emergency power-off module can be acknowledged and reset. To avoid this, safety door monitors with an additional simulation entry or a corresponding reset circuit can also be used.
  • 1 Relay (K1)
  • 1 Emergency power-off switch
  • Hazardous area accessible via a safety door with safety door switch S1 and S2
  • 1 button S3

    Safe standstill with C3 powerPLmC

    Switches and buttons:

    S1:

    Closed when the safety door is closed

    S2:

    Closed when the safety door is closed

    S3:

    Activate Emergency power-off module

    *application specific variable with can be used to energize the motor independent of the safety technology.

Basic functions:
Compax3 devices disabled by:

Channel 1: Energize input (I0) to C3_1 (with powerPLmC) to "0" through open contacts of Emergency power-off module (13 -14)

Channel 2: Enable inputs of individual Compax3’s to "0" through open contacts of Emergency power-off module (57 -58)

Activate Emergency power-off module

Before the Compax3 can be placed in operation, the Emergency power-off module must be activated by a pulse to Input S33/S34.

Prerequisite:

  • S3 closed
  • Safety door closed: only in this case the safety door monitor enables the emergency power off module via two channels.
  • K1 energized
    • K1: receives current if all Compax3 devices are currentless (Output O0 = "1" if the MC_POWER components of all devices have the status ”FALSE”. ) = Channel 1 feedback
  • The feedback contact of all Compax3 devices must be closed (channel 2).

    If S33 and S34 of the Emergency power-off module are briefly connected (pulse) the contacts will be closed (between 13 and 14 and between 57 and 58)

Energize Compax3 (Motor and power output stage)
  • The Enable input is activated on all Compax3’s by the Emergency power-off module.
  • Input I0 is also activated (="1") on Compax3 C3_1, which makes it possible to activate the ENABLE inputs of the MC_Power modules with the AND modules. (If a fault is still pending on Compax3, it must previously be reset. The acknowledge/reset function depends on the type of the Compax3 device).
  • The motors are energized with current.

    Summary: Compax3 is only energized if the feedback functions are capable of functioning via two channels.

Access to the hazardous area
Activate Emergency power-off switch

The two-channel disconnecting at the emergency power-off switch deactivates the emergency power-off module – the contacts 13 – 14 will open immediately.

Channel 1:The MC_POWER modules are deactivated for all Compax3’s by Input I0 = "0" on device C3_1 (with powerPLmC) via the AND modules. Compax3 devices are guided to a standstill and the current is switched off (by means of the ramp for ”drive disable) configured in the C3 ServoManager.

Channel 1 feedback:Output O0 = "1" if the MC_POWER modules of all devices have the status ”FALSE”.

Channel 2:After the delay time set in the Emergency power-off module, (this time must be set so that all drives are stopped after it has elapsed) the contacts between 57 and 58 open, which in turn deactivates the Enable inputs of the Compax3 devices.

Channel 2 feedback:Via the series circuit of all feedback contacts, the ”Safe Standstill” status (all Compax3 devices without current) is reported.

Only if the drives are all at a standstill, the safety door may be opened and the hazardous area may be accessed.

If the safety door is opened during operation and the emergency-power-off switch was not triggered before, the Compax3 drives will also trigger the stop ramp.
Caution! The drives may still move.

If danger to life and limb of a person entering cannot be excluded, the machine must be protected by additional measures (e.g. a safety door locking).


C3 powerPLmC integrated controller

In this chapter you can read about:

Communication settings of the C3 powerPLmC

LAN - setting of the PCs

Profibus - Address with C3 powerPLmC C13

CoDeSys call

Programming based on IEC61131-3


Communication settings of the C3 powerPLmC

The LAN (Ethernet) setting (CoDeSys programming interface) of the C3 powerPLmC is made in the Compax3 ServoManager under the tree entry "C3 powerPLmC: Communication settings".

A communication between CoDeSys and C3 power PLmC is only possible with this setting and a LAN-connection.

Connection:

Standard: Ethernet connection to a network => the parameters must be predefined by the network administrator.

With Crossover (direct): Direct connection PC - C3 powerPLmC (without network)

IP address:

Unambiguous address of the C3 powerPLmC in the network.

For a cross-over connection (=direct connection between PC and C3 powerPLmC without network), a free IP address (class3) must be used (example):

192.168.xxx.yyy with xxx=1 and yyy=11

Netmask: 255.255.255.0

The cross over connection must be established with a cross over cable; this is available under the designation SSK28.

Netmask (Subnet Mask)

Specify the numeric range of the local network.

Local network addresses are derived by " ANDing" the IP address and the Netmask.

Host name:

Symbolic name which can be used instead of the IP address; this requires, however, a DNS (Domain Name Service)

- is not yet supported -

Gateway IP:

The computer that creates the connection to an additional network.

Entry is only required with a corresponding application and is not required for a direct connection via cross over.

DNS:

Address of the Domain Name Service (only when using a host name)

- is not yet supported -

Click on "terminate" in order to store the settings in the device.


LAN - setting of the PCs

During configuration of the PC a distinction is made between the direct connection PC - C3 powerPLmC (Cross Over) and the connection via a network.

Connection via a network.

The settings for the net available on the PC should only be adapted if necessary with prior consultation of the network administrator.

Direct connection PC - C3 powerPLmC (Cross Over)
Step 1

Open network connection with "Settings/system control/Network and remote connections.

Step 2

Establish new LAN connection and open with properties

The part displayed in red (framed) shows the setting of the C3 powerPLmC!

Determination of the LAN parameters of a PC in the network

Enter command IPCONFIG in DOS environment...


Profibus - Address with C3 powerPLmC C13

The setting of the Profibus address of the C3 powerPLmC C13Txx (integrated into the servo axis) is made in the Compax3 ServoManager.

The Profibus - configuration is made in the controller configuration in CoDeSys.


CoDeSys call

Here the IEC61131-3 development environment CoDeSys can be called up directly from the Compax3 ServoManager.

The C3 powerPLmC control program is programmed with CoDeSys.


Programming based on IEC61131-3

In this chapter you can read about:

Requirements

Restrictions on CoDeSys functions

System layout

CoDeSys / C3 powerPLmC target system (Target Package)

Configure Ethernet interface CoDeSys - C3 powerPLmC

PLC configuration

Task configuration

Libraries

Motion control via function modules

C3 powerPLmC as CAN Master

Application examples
Safety Instructions:
  • Before generating a boot project, (program is saved in FLASH), perform a program stop, since uncontrolled movements are possible while a boot project is being generated.
  • Attention!
    During the program test, note the motion sequences of your drive.
    Especially when working with break points, online changes, coercing variables, sequence control or debugging, it is always essential to ensure that only controlled motion sequences take place.
    These functions can change the control sequence of the program and affect behavior related to the program sequence and program execution time!
    Online change and forcing variables directly affects sequence logic.


Requirements

  • Installation of the CoDeSys programming tool.
  • Installation of necessary Target Packages (target systems):
    • Bring up the "InstallTarget" program (program group "3S Software": "CoDeSys V2.3")
    • From “Open”, select the target file; file name: "C3powerPLmC.tnf".
    • The selected target can be installed with "Install".


Restrictions on CoDeSys functions

With C3 powerPLmC as the target system, the following functions and thus the following sections of the CoDeSys description are not valid:

  • "Parameter Manager" (subsection of "Resources") and
  • "Appendix I: Target settings"
  • The function "Online: Sequence control" is not available.


System layout

Compax3 servo axes can be integrated into the C3 powerPLmC control very easily, in fact almost automatically with CANopen using the "Drive Interface".

The connected Compax3 axes are operated in the CANopen operating mode "slave with C3 powerPLmC as master" (should be set in the device configuration of the corresponding Compax3 in the CANopen wizard window).

The configuration of the Compax3 axes is made via RS232 with the aid of the C3 ServoManager.

Other CANopen stations (such as Parker I/O terminals PIO and parker Operator Panels Pop, for example) are integrated into C3 powerPLmC via a device-specific "*.eds" file.

The "*.eds" file describes all relevant properties of a CANopen bus station and is included with delivery of all CANopen bus stations.


CoDeSys / C3 powerPLmC target system (Target Package)

To create a C3 powerPLmC project, from "File:New" select the target system "CoDeSys for C3 powerPLmC" (for target setting see here).

This sets CoDeSys for C3 powerPLmC.

The values set by default can be taken over directly.

However, adjustment is possible at all times (under "Resources: Target settings").

If an old target is required, this is available under "CoDeSys for C3 powerPLmC".

Notes on memory layout:

If the error message 3803 ("Memory for global variables exhausted") is displayed during compilation, this means that the reserved data memory for the internal variables, modules and axis data structures used in the program is not sufficient. The global data memory (Global: 2nd value from the top) can be increased incrementally to correct this.

The respective hexadecimal values give the memory reservation in kilobytes, i.e. for example 16#20000 for global = 132 kByte of global program data memory reserved.

if the error message 3612 ("maximum number of modules exceeded") is displayed during compilation, the number of modules in the project exceeds the maximum number configured. The value "maximum number of modules" can be increased to correct this.

Target system settings memory layout

Next, select the module type (the default is program module PLC_PRG) and the desired programming language (for more information, see the description in CoDeSys help).


Target system setting sequence

Target system settings


Configure Ethernet interface CoDeSys - C3 powerPLmC

The connection between the programming system andC3 powerPLmC is made via Ethernet.

Connection: Network card PC - C3 powerPLmC X24 with SSK28

On the PC – page, set the IP – address in CoDeSys with the “Online: Communication parameters” menu as follows:

Sequence

The IP – address set in this manner is the address of the target system. The Gateway – function must be set to ‘local‘ and the Motorola – byte order to YES.

Note for C1xTxx devices:

The settings for Ethernet are made on the Compax3 side with the C3 ServoManager (in the tree left C3 powerPLmC: LAN setting).

Note for E2x devices:

On the device side, the settings for Ethernet are made via the C3 powerPLmC Manager.


Sequence of the Ethernet (LAN) setting

Note:

  • The address can be opened to edit by double clicking.
  • "Motorola byteorder" can be opened by double clicking and modified by double clicking.

    Ethernet Config sequence


PLC configuration

In this chapter you can read about:

CANopenMaster configuration

Integrate Compax3

Integrate PIOs

Pop Monitoring and control

Integrate any CANopen Slaves

Profibus: C3 powerPLmC as Profibus Slave

The entries in the configuration tree:

  • Ethernet and
  • VirtualServer

    are not assigned.


CANopenMaster configuration

Basic parameters

The basic parameters are set automatically.

They must not be changed.

Note on C3 powerPLmC E2x (standalone):

Assignment of the CAN busses:

upper Master: CAN1-1 / CAN1-2

lower Master: CAN2-1 / CAN2-2

If one of the two CAN busses is not used as CANopen Master, but only for the CAN data transfer on layer 2, the respective CANopen Master module can be replaced by the "CAN (Raw), Layer2" module with the aid of the context menu.

CAN parameters

Baud rate:

The baud rate must match the baud rate of the CANopen station.

The baud rate of Compax3 is set in the C3 ServoManager under configuration.

Sync telegram:

The next 3 input values will set the sync telegram.

This is not supported in the current version!

Please deactivate the Sync Telegram!

NodeID:
Note o the C3 powerPLmC C1xTxx:

The CANMaster (C3 powerPLmC) has NodeID ="1" (the same NodeID as the Compax3 into which the C3 powerPLmC is integrated).

Automatic Start

This option must be deactivated, if working which the C3 Drive Interface, as in this case the CANopen Master is started directly by the Drive Interface.

Module parameters

These parameters are used to adjust to the number of PDOs there are in the CAN bus.

The rule for this is:

  • There must be 1 RxObject for each Receive PDO (can be set under Receive PDO Mapping).
  • There must be 1 TxObject for each Transmit PDO (can be set under Transmit PDO Mapping).
  • There must be 5 RxObjects and 5 TxObjects available per Compax3 device used.

    Set these parameters according to your application.

The additional parameters (format objects and error objects) must not be adjusted!

If no sufficient number of Rxobjects was reserved, it is possible that process data received are lost in the case of a high bus load!


Integrate Compax3

Compax3 is integrated into the C3 powerPLmC via Drive Interface.

Note on C3 powerPLmC-E20 (standalone): The DriveInterface works always with CAN bus 1 (CAN 1-1 / CAN 1-2)

Note: The Drive Interface must be activated in the program (see below).

Function of the Drive Interface

The Drive Interface is responsible for the following tasks:

  • The configuration of the individual axes on the CANopen – Bus (PDO mapping and initialization of the bus).
  • Configures the interface between the PLCopen function modules and Compax3.
  • Performs implicit function calls in the runtime system to make input – and output data to and from the individual axes available cyclically or when it is changed to the C3 powerPLmC process image and thus to the function modules.
  • Adjusts the numeric format of the module parameters to Compax3 – objects and specifies standardization.

    This reduces the configuration of a multi-axis system with Compax3 on the C3 powerPLmC to the following steps:

  • Within the control configuration of the C3 powerPLmC there is an entry "Compax3_Config".
  • Under Compax3_Config, note of type "Compax3_Group" should be inserted (right click and append Compax3_Group). This represents a group of axes.
    The designation "Compax3_Group" can be renamed, in which case naming conventions for IEC61131-3 variables must be observed.

Caution! Only one Compax3 group is possible!

  • The actual Compax3 devices are also inserted under the Compax3 group. (right mouse button, insert sub-element: Compax3...); ("virtual Master": this operating mode is not yet available; if you have a corresponding application, please contact us.)
  • The axis names can be freely chosen, for exable X_Axis and must correspond to the name conventions for IEC61131-3 variables. Each axis is referenced later in the program via the name assigned here.
  • When nodes are inserted within these configuration points, the required data structures are generated automatically.

    sequence

Settings for the Compax3_Group
Agreeing on a task call

All programs that work with a Compax3_Group must be assigned to a single task!

By default, the name of this task is specified by “DriveTask”, but it can also be changed.

As an option you can, in the "LimitBusload" Checkbox, limit the maximum number of acyclic object accesses via the "C3_ReadObject2 and "C3_WriteObject" modules per task cycle in order to reduce bus load and cycle time

Settings for the axes
NodeID

The only setting for CANopen is the specification of the address for the respective axis. Addresses must be unique.

Note o the C3 powerPLmC C1xTxx!

Address 1 is reserved for the Comapx3 into which the C3 powerPLmC is integrated.

Cache parameters

A cache can be used as a fast buffer for drive parameters in order to reduce data transfer to the axes and thus shorten response times. Parameter data already transmitted must not, or only in part, be re-transmitted, which helps to increase the reaction time and to reduce the bus load.

This can entirely or at least partially eliminate transferring parameter data that has already been used.

Please note that the Drive Interface for the Cache parameter requires the lines 17 to 32 of the Compax3 recipe array (C3Array.Colxy_row17 to C3Array.Colxy_Row32) if you use T30 / T40 devices. Those may not be used in the program and not be overwritten!

Cyclic User Data Channel

cyclic data channel for the exchange of data between the programs in the C3 powerPLmC and a Compax3 T30/T40 axis.

Dynamic Range

The resolution and the range of the actual axis position as read with the module "MC_ReadActualPosition" can be set.

Node guarding:

Here you cn activate and set the Node Guarding for the Compax3 axis.

An evaluation of the node guarding sequence in the IEC61131-3 program van be made via the CiA405_Get_State module.

Note:

No input values are required under basic parameters. The value for the node number is determined automatically (does not correspond to the NodeID).

Activate Drive Interface

The Drive Interface must be activated by calling the following programs in the main program:

At the start of the program:

DriveExecuteStart (ADR(Name of the Compax3 - group))

At the end of the program:

DriveExecuteEnd (ADR(Name of the Compax3 - group))


Access to Compax3 objects

The described objects can be used in the program.

Intellisense – functions permit to enter operands: If a dot “.” is entered in the program instead of a designator, a dropdown box with all local and global variables will then appear.

When a Compax3 object group is entered, for example C3, followed by a dot, a list of available references to objects of this group appears.

Access to object C3 powerPLmC

Caution!

These are not the Compax3 objects themselves, but rather address references to them.

Access to the Compax3 objects of the individual axes is with the modules C3_ReadObject and C3_WriteObject.


Drive Interface Compax3

Drive Interface Compax3


Compax3 slave axes

In this chapter you can read about:

T11 Technology function

Technology function T30 & T40

Cyclic data channel for C3T30 and C3T40

The Compax3 slave axes are operated via the CAN bus on the C3 powerPLmC, therefore the CAN option is necessary in all axes.

Designation of the Compax3 slave axes: C3I21Txx (I21 describes the CAN Option).

The follwoing Compax3 technology functions (Txx) can be used:

  • T11: Positioning
  • T30: Motion control programmable according to IEC61131-3 or
  • T40: Electronic cam programmable according to IEC61131-3


T11 Technology function

A Compax3 slave axis C3I21T11 operated on a C3 powerPLmC must be set to the operating mode "C3 powerPLmC as master2 in the CANopen configuration.

The Compax3 slave axis C3I21T11 is programmed in the C3 powerPLmC control.


Technology function T30 & T40

A Compax3 slave axis C3I21T11 and C2I21T40 operated on a C3 powerPLmC must be set to the operating mode "Slave with C3 powerPLmC as master" in the CANopen configuration.

The Compax3 slave axis C3I21T30 and C2I21T40 can be programmed in the C3 powerPLmC control or on the slave axis. Application examples for the slave axis are program parts which need a fast detection, such as C3_Tochprobe or cam applications which can be implemented with the T40 technology function.

Communication C3 powerPLmC - Compax3 slave axis (T30, T40)

For the communication between C3 powerPLmC (Master) and Compax3 slave axis the interface module "PLmC_Interface" must always be called up in the IEC program of the slave axis.

For the exchange of data between master and slave a cyclic data channel is available.


Interface to C3 powerPLmC

In this chapter you can read about:

Interface module "PLmC_Interface"

Example: C3 powerPLmC Program & Compax3 Program


Interface module "PLmC_Interface"

Previous Topic

Next Topic

Interface module "PLmC_Interface"

The interface between a central IEC61131-3 user program on C3 powerPLmC and a local IEC61131-3 user program on a Compax3 servo axis T30 or T40 is created with the program module "PLmC_interface".

It is necessary to call up cyclically the "PLmC_interface2 module at each Compax3 servo axis (T30, T40), which is operated as a slave on a C3 powerPLmC.

The module can be found in the "C3_PLmC_interface.lib" library, which must be integrated manually via the library manager, if required.

FB name

PLmC_Interface

Interface module for the control of C3 powerPLmC
VAR_OUTPUT

O0

BOOL

Status of the digital output O0 on the C3 powerPLmC side

O1

BOOL

Status of the digital output O1 on the C3 powerPLmC side

O2

BOOL

Status of the digital output O2 on the C3 powerPLmC side

O3

BOOL

Status of the digital output O3 on the C3 powerPLmC side

LocalEnable

BOOL

Enable for the local IEC61131-3 program

LocalEnable switches to FALSE for one cycle, if a command for this axis is activated on the C3 powerPLmC.
This helps to avoid that the axis will receive different commands at a time.

Event1 ... Event8

reserved

EventParameter

reserved
Note:
  • The execution of all local motion functions should be coupled with the LocalEnable output.
  • Via the outputs O0...O3, the outputs set by C3 powerPLmC can be set out via the physical outputs with the aid of C3_Output.

Recipe array line 17... 32 assigned

Please note that the last 16 lines of the recipe array (C3Array.ColXX_Row17 to C3Array.ColXX_Row32) are reserved for the communucation with C3 powerPLmC.


Example: C3 powerPLmC Program & Compax3 Program

Previous Topic

Next Topic

Example: C3 powerPLmC Program & Compax3 Program

Task:

  • Implementation of a mark synchronization in a Compaxa3 servo axis.
  • Control of the program via the C3 powerPLmC via a user-defined control word / status word.
Main program on Compax3 (module PLC_PRG)
Cyclic call-up of the interface to powerPLmC in the PLC_PRG module

In CFC:

In ST:

Local Compax3 Program in the LocalProgram module

Program on C3 powerPLmC


Cyclic data channel for C3T30 and C3T40

An additional communication channel (besides the one established by the Drive Interface which is not freely assignable) can be established between the programs of the C3 powerPLmC and a Compax3 axis via a freely usable cyclic data channel.

To do this, the assignment of the channel is defined on the side of the C3 powerPLmC in the controller configuration for the respective axis. The assignment is always bidirectional.

The following options are available for the communication between the two programs.

2x INT:

Assignment of the cyclic channel with 2 INT variables
Mapping to Compax3 objects
C3.PLmCToC3_INT1 / C3.PLmCToC3_INT2 | from PLmC to Compax3
C3.C3ToPLmC_INT1 / C3.C3ToPLmC_INT2 | from Compax3 to PLmC
Mapping to power PLmC variables
"Axis name".PLmCToC3_INT1 | from PLmC to Compax3
"Axis name".PLmCToC3_INT2 | from PLmC to Compax3
"Axis name".C3ToPLmC_INT1 | from Compax3 to PLmC
"Axis name".C3ToPLmC_INT2 | from Compax3 to PLmC

1x DINT:

Assignment of the cyclic channel with one DINT variable
Mapping to Compax3 objects
C3.PLmCToC3_DINT | from PLmC to Compax3
C3.C3ToPLmC_DINT | from Compax3 to PLmC
Mapping to power PLmC variables
Axis name".PLmCToC3_DINT | from PLmC to Compax3
"Axis name".C3ToPLmC_DINT | from Compax3 to PLmC

1x REAL:

Assignment of the cyclic channel with one REAL variable
Mapping to Compax3 objects
C3.PLmCToC3_REAL | from PLmC to Compax3
C3.C3ToPLmC_REAL | from Compax3 to PLmC
Mapping to power PLmC variables
"Axis name".PLmCToC3_REAL | from PLmC to Compax3
"Axis name".C3ToPLmC_REAL | from Compax3 to PLmC

Note:

The use of INT or DINT variables is especially suitable for implementing a user-defined control word / status word between C3 powerPLmC IEC61131-3 program and Compax3 IEC61131-3 program.

Configuration of the data channel

Note:

If the cyclic data channel is not required, it can also be assigned to the actuel position of the axis. It is then made available to the "MC_ReadActualPosition" module. Therefore the value must not be continually read via the acyclic channel if the module is used; this reduces the bus load and the IEC cycle time.


Integrate PIOs

The Parker Input & Output terminals (PIOs) are integrated into C3 powerPLmC via CANopen. A CANopen bus coupler (PIO-337: CANopen standard or PIO-347: CANopen ECO) forms the interface from the terminals to the CANopen bus.

Input and output terminals can be operated simultaneously on a CANopen bus coupler.

Bus couplers each contain storage space for the input and output area (input process image and output process image). All input terminals on the bus coupler are stored in the input process image of the bus coupler, while all output terminals are in its output process image.

The maximum size of the process image depends on the bus coupler:

PIO-337: CANopen standard: 512 bytes each

PIO-347: CANopen ECO: 32 bytes each

The process image data must now be transferred to the control (C3 powerPLmC) via the CANopen bus. This is done via process data objects (PDOs). The PDOs are assigned by a process of "Mapping", separately for the input and output process image:

PDO-Mapping receive: C3 powerPLmC -> PIO (output terminals)

PDO-Mapping transmit: PIO -> C3 powerPLmC (input terminals)


Setting the PIOs

The following settings are required at the bus coupler:

  • Baud rate
  • Node address (Node ID)


Setting the PIO baud rate

The bus coupler supports 9 different baud rates. The setting is made via the DIP switch.

Via set module ID = 0 (all DIP switches off)

and following power on, t he bus coupler is set to configuration mode. In this state, the currently set baud rate is displayed via the upper LED group (STOP, RUN, Tx-, Rx-Overflow), while

  • STOP = switch 1,
  • RUN = switch 2,
  • Tx-Overflow = switch 3 and
  • Rx-Overflow = switch 4 .

    The currently set baud rate is displayed by slow blinking of the corresponding LEDs. Now the new baud rate can be set with the DIP switch by setting the desired DIP switches to "ON".

    The set configuration is memorized by setting DIP8 to "ON".

    After the saving, the new baud rate is displayed via a permanent illlumination of the respective LEDs. Exception: the baud rate of 1MBaud, which is displayed by flashing / illumination of all 4 LEDs.

Example:

125 kB : Tx-Overflow LED flashes / is illuminated
250 kB : STOP and RUN LED flash / are illuminated

Example: Saving the baud rate 125 kB

An exchange of data via CAN is not possible in this state.

Switch | Function | 1 MBit | 800 kB | 500 kB | 250 kB | 125 kB | 100 kB | 50 kB | 20 kB | 10 kB | displayed by the LEDs
1 (LSB) | Baud rate | 0 | 1 | 0 | 1 | 0 | 1 | 0 | 1 | 0 | STOP
2 | Baud rate | 0 | 0 | 1 | 1 | 0 | 0 | 1 | 1 | 0 | RUN
3 | Baud rate | 0 | 0 | 0 | 0 | 1 | 1 | 1 | 1 | 0 | Tx-Overflow
4 (MSB) | Baud rate | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1 | Rx-Overflow
5 |  |  |  |  |  |  |  |  |  |  |
6 |  |  |  |  |  |  |  |  |  |  |
7 |  |  |  |  |  |  |  |  |  |  |
8 | Acceptance | ´off´ -> ´on´ : Acceptance of the set configuration

Switch off the operating voltage after the completion of the baud rate settings / baud rate verification, as the set DIP value is only used as module ID for the calculation of the IDs after Power On. When the device is switched off, the desired module Id (=1 in delivered status) can now be set on the DIP switch.

Factory setting of baud rate: 125kB


Set PIO node address (module ID)

The module Id is used for the calculation of the default COB IDs (e.g. default PDOs 1...4, 1. server SDO, etc.)

Fig. 3 6: Setting the address

The binary values of the individual switches rises in the direction of the switch number
Module Id 1 => DIP1 = ON
Module ID 8 => DIP4 = ON etc.

Module IDs: 2...127, Address 1 is reserved for the Compax3 servo axis with the C3 powerPLmC.


Integration of an CANopen bus coupler:
show sequence

In CoDeSys under resources: PLC configuration the configuration tree of the of C3 powerPLmC with all interfaces is displayed in the center window .

A CANopen PIO can be appended to the CANopenMaster with an eds file:
Set cursor on CANopenMaster and open the menu with the right mouse button, then select the appropriate EDS file via "Append sub-element".

The CANopen bus coupler is created in the tree. The configuration dialogs appear on the right.

Basic parameters: are set correctly automatically. They must not be changed.

CAN parameters: The value of the NodeID is important. Generally it corresponds to the address of the CANopen bus coupler.

PDO-Mapping receive: C3 powerPLmC -> PIO (R-PDOs)

The PDOs that transfer data from the C3 powerPLmC to the PIOs are defined here.

The process image of the CANopen bus coupler is in the left window. In the right window, the PDO assignment is displayed. The PDOs that are displayed are not assigned.


PDO Mapping

Start again with F5


Process image

The process image offers digital outputs and analog 2-byte values. The assignment depends on the arrangement and the terminal types on the CAN bus coupler. The rule for this is:

The digital output terminals (digital outputs) are stored sequentially starting from the left (fieldbus coupler). For example the 8th output from the left is in byte "Output 15...8" (for more details, see the example).

The analog output terminals (2-byte analog output) are also stored sequentially beginning from the left (fieldbus coupler). For example, the 3rd output from the left is in the byte "3.2byte analog output" (for more details, see also the example).


Assign PDOs

The process image data can be assigned in any way (maximum 8-bytes per PDO) to the individual PDOs.

Additional PDOs (CANopen ECO max. 5; CANopen standard max. 32) can be added and unnecessary PDOs can be deleted.


Enable analog terminals

The analog terminals must be activated by writing an object in the bus coupler.

To do this, the value must be set to 0x01 on the "Service Data Objects" registry page under Index 0x6423 ("Analogue Input Global Interrupt Enable").

During the next start of the CANopen Bus (Project: clear all, Online: log in; Online: Start) the value is transmitted to the bus coupler.


Define symbolic names

show sequence

The values assigned to the PDOs are now entered in the configuration tree.

Double clicking on "AT" gives you the individual values of symbolic names. These are created automatically as variables.

Symbolic names can be defined for bytes, individual bits or for 2-byte values.


Define symbolic names (sequence)

Sequence define symbolic names (start again with F5)


Access to values

show sequence

Access within the program then takes place via symbolic variables that are available for selection after you enter a dot ".".

The variables can also be brought up with input help (F2) under system variables.

PDO-Mapping transmit: PIO -> C3 powerPLmC (T-PDOs)

The PDOs that transfer data from the PIOs to the C3 powerPLmC are defined here.

The process is the same as for "Receive PDO Mapping"


Variable access in the program

Start again with F5


Example of Receive PDO Mapping (PIO -> C3 powerPLmC)


Pop Monitoring and control

The settings for a Pop are made with the PopDesigner.

Step1: Select driver for the CAN

Step2: Set node address and baude rate

Function modules are available for the programmation of Pop applications with the C3 powerPLmC!
The communication with Pop is described in a separate application manuel.


Integrate any CANopen Slaves

Any CANopen modules can be integrated with the aid of the module-specific EDS file.

You will generally find help on configuring the module in the module description.


Profibus: C3 powerPLmC as Profibus Slave

In this chapter you can read about:

GSD file for the bus configuration

Process data channel

A C3 powerPLmC C13T or E2x contains a Profibus option, allowing to operate the C3 powerPLmC as Profibus slave.

After setting the Profibus address the further configuration is made at the Profibus master with the aid of the GSD file containing all Profibus relevant data.


GSD file for the bus configuration

In order to integrate the C3 powerPLmC into the bus configurator of the Profibus master, the so-called device master data file (GSD) is required.

The GSD file for C13 and E20 is: "PAR_C313.GSD(can be found on the CD)

In the GSD file a series of possible PPO modules for a different number of process data words of 2 bytes each (2 words (PZD[2] to 8 words (PZD[8]) are already configured.

Furthermore there are modules with an additional 4 or 6 word PKW channel which can be used for implementing an additional acyclic parameter channel in the user program.

Via a universal module you can generate additional kinds of PPO modules


Process data channel

122 words max. (244 bytes) can be transferred on the process data channel in both directions by C3 powerPLmC.

C3 power PLmC accepts all possible combinations and lengths.

Configuration of the process data channel

Both on the C3 powerPLmc side and on the side of the Profibus master the same configuration, i.e. assignment of the process data channel must be made.

The assignment of the process data channel on C3 powerPLmC side is made in the controller configuration.

The incoming process data are named "I-DPOutput" in the controller configuration.

The process data to be sent are named "Q - DPInput"

For process data in the format of the different IEC61131-3 data types there are so-called channels which can be entered as sub elements. /e,g, WordChannel for WORD, IntChannel for INT, DWordChannel for DWORD or RealChannel for REAL).

Each channel entered can be mapped on a global program variable. (same proceeding as with the CANopen configurator).


Task configuration

The Task inserted for the Compax3 group must be entered with the same name used in the Compax3_Group and must be of the "cyclic" type (under properties - interval, the cycle time can be configured. e.g. T#10ms for 10 ms).

A program module (e.g. PLC_PRG) must be linked to this task as an entry point, where the function DriveExecuteStart is called up at the beginning of the execution and the function DriveExecuteEnd is called up at the end of the execution. .

Additional program calls take place in PLC_PRG.

All functions accessing a Compax3 must be listed in this task.

Functions outside of Compax3 – devices, for example input – and output – add-ons, can be executed in additional tasks.

Sequence

Task interval:

When specifying the task interval (cycle time), note that system-internal tasks (communication tasks) must also run during this time in addition to the programs that are created (IEC tasks).

Note: The Trace function increases the time for communication tasks.

Task priorities

Each Task can be assigned an execution priority. (0 = highest priority, 31 = lowest priority). A high-priority task can interrupt low-priority tasks.

The task priorities 0 and 1 are reserved for system functions and should therefore not be assigned.

Caution!

Free-running tasks must be given priority 31 for additional tasks even to be processed!


Task configuration sequence

Sequence task config.


Libraries

In this chapter you can read about:

Standard libraries

Internal libraries


Standard libraries

Access to function modules is possible through input help (F2). These are created in libraries.

The following should be noted for module access:

The following are client libraries:
  • C3_PLCopenPLmC.lib: PLCopen function module.
  • C3_FunctionsPLmC.lib: C3_ .. Function modules (C3_Input, C3_Output, C3_WriteObject, R3_ReadObject).
  • C3_ObjectDirPLmC.lib: (references to Compax3 objects)
  • PLmC_CAN.lib
  • Pop_Interface.lib
  • C3_Errorlib.lib
  • Standard.lib: Standard function modules of the IEC61131-3.
  • Util.lib:
  • SysLibCom (C3 powerPLmC E20 for COM1 and COM2)
  • SysLibFile
  • SysLibRtc
  • SysLibSem
  • SysLibSocket
  • SysLibStr
  • SysTaskInfo
The following libraries assume detailed knowledge, but are generally not required:
  • SysLibTime.lib
  • SysLibCallback.lib
  • SysLibTasks.lib
  • SysLibMem.lib
  • SysLibTaskInfo.lib
  • SysLibSem.lib

Please note:

Some of the libraries must be integrated via the library manager before they can be used.


Functions and function modules of the "Standard.lib" library
Bistable function modules
  • RS

RS Flip Flop
  • SR

SR Flip Flop
  • SEMA

Software Semaphore
Numerator
  • CTD, CTU, CTUD

Counter modules
String functions
  • CONCAT, DELETE, FIND, INSERT, LEFT, LEN, MID, REPLACE, RIGHT
Timer
  • TOF

Switch-off delay
  • TON

Switch-on delay
  • TP

Pulse timer
  • RTC

Output of the continual time of day incl. date from a defined start value
Trigger
  • R_TRIG

Trigger on rising edge
  • F_TRIG

Trigger on falling edge


Functions and function modules of the "Util.lib" library (controller, signal generators, mathematical functions...)
Analog value monitoring
  • HYSTERESIS

  • LIMITALARM

Monitoring of a signal in order to keep to a lower and upper limit value
BCD conversion
  • BCD_TO_INT

Convert BCD value to integer
  • INT_TO_BCD

Convert integer to BCD value
Bit/Byte Functions
  • EXTRACT

returns Bit N to a transferred DWORD variable
  • PUTBIT

sets Bit N of a transferred DWORD variable to the transferred value
  • PACK

convert 8 bits (BOOL) to BYTE
  • UNPACK

convert BYTE to 8 bits (BOOL)
Controller
  • PD

PD Controller
  • PID

PID Controller
  • PID

PID Controller for a fixed cycle time
Function manipulation
  • CHARCURE

in order to map values to a partially linear function
  • RAMP_INT

Limit rising or falling of a fed in signal of the INT type
  • RAMP_REAL

Limit rising or falling of a fed in signal of the REAL type
Mathematical functions
  • DERIVATIVE

Differentiator
  • INTEGRAL

Integrator
  • STATISTICS_INT

Determine minimum, maximum and average value (i.e. expected value) of the signal of the INT type fed in
  • STATISTICS_REAL

Determine minimum, maximum and average value (i.e. expected value) of the signal of the INT type fed in
  • VARIANCE

Determine statistic variance of an input signal of the REAL type
Signal generators
BLINK | Generation of a digital rectangular signal with defined HI and LOW phase
GEN | Generation of periodic output signals (Sine, Cosine, Rectangle, Triangle, Saw-Tooth)


Functions for file handling "SysLibFile"

File system: in the main memory (RAM)

  • SysFileOpen

Open file for reading or writing
  • SysFileClose

Close file
  • SysFileCopy

Copy file from A to B
  • SysFileDelete

Delete file
  • SysFileRead

Reading data from a file, increases offset automatically
  • SysFileWrite

Writing data into a file, increases offset automatically
  • SysFileEOF

In order to determine if the current offset is placed at the end of the file
  • SysFileGetPos

Provides the currently set offset of the file
  • SysFileSetPos

Sets the offset of the file to a determined value
  • SysFileGetSize

Provides the size of a file
  • SysFileGetTime

Provides time of creation, the last access and the last modification
  • SysFileRename

Re-naming a file


Handling of the real-time clock (RTC) "SysLibRtc"
  • SysRtcGetTime

Provides the current time and the current date (Type DAT_TIMW / DT)
  • SysRtcSetTime

Sets the real-time clock to the transferred values
  • SysRtcCheckBattery

Checks the status of the battery of the real-time clock
  • SysRtcGetHourMode

Determine, if the clock runs in the 12 or 24h format (always 24h with C3 powerPLmC)


Task synchronization via operatiing system semaphores "SysLibSem"
  • SysSemCreate

Creating a semaphore
  • SysSemDelete

Deleting a semaphore
  • SysSemEnter

Entering a protected area
  • SysSemLeave

Leaving a protected area
  • SysSemTry

In order to verify if a semaphore is already assinged to another task


Functions for accessing Ethernet networks on TCP / UDP level with the aid of sockets "SysLibSocket"
General:
  • SysSockAccept
  • SysSockBind
  • SysSockClose
  • SysSockConnect
  • SysSockCreate
  • SysSockGetHostByName
  • SysSockGetHostName
  • SysSockGetOption
  • SysSockHtonl
  • SysSockHtons
  • SysSockInetAddr
  • SysSockInetNtoa
  • SysSockIoctl
  • SysSockListen
  • SysSockNtohl
  • SysSockNtohs
  • SysSockSelect
  • SysSockSetIPAddress
  • SysSockSetOption
  • SysSockShutdown
TCP specific:
  • SysSockRecv
  • SysSockSend
UDP specific:
  • SysSockRecvFrom
  • SysSockSendTo


Additional string functions "SysLibStr"
Comparison of 2 strings:
  • SysStrCmp
  • SysStrCmpI
  • SysStrCmpN
  • SysStrCmpNI
Additionally:
  • SysStrCpy

Copying strings
  • SysStrLen

Determine the length of a string


Measuring task cycle time and jitter "Sys TaskInfo"

Task info


Internal libraries

The modules of the following libraries are not intended for the user. They contain internal system functions:
  • C3_DriveBasic.lib
  • C3_VirtualMaster.lib
  • DSPLib.lib
  • PPCLib.lib
  • DSPLib-2.lib
  • PPCLib-2.lib


Motion control via function modules

In this chapter you can read about:

Status diagram based on PLCopen

Library constants

General rules / timing

Control functions

Reading values

Motion functions (standard)

Error handling

Process image


Status diagram based on PLCopen

This status diagram applies to each connected Compax3.

The states of each individual device are affected by the C3 powerPLmC program and can be determined with the "MC_ReadStatus" module.


Library constants

The following global constants are declared in the PLCopen function module library:

For the selection of the master signal source:
AXIS_REF_Physical | C3_AXIS_Ref | for +/-10V analog input, step / direction input 5V or Encoder A/B input 5V (depending on the configuration of the physical source under signal source)
Axis_REF_HEDA | C3_AXIS_Ref | HEDA
General constants
MC_Direction_Positive | INT | For supply of the Direction input of the MC_MoveVelocity module (for positive rotational direction)
MC_Direction_Negative | INT | For supply of the Direction input of the MC_MoveVelocity module (for negative rotational direction)
MC_Direction_Current | INT | For supply of the Direction input of the MC_MoveVelocity module (retaining the last rotational direction to be selected)
Direction_Memory | INT (Variable) | The MC_MoveVelocity modules instances store the last direction parameter in this variable. This variable can only be used by Motion Control modules and must not be overwritten!


General rules / timing

General rules

Status of the outputs

  • The outputs "Done", "InVelocity", "Error", "ErrorID" and "CommandAborted" reset with the falling edge of the "Execute" input.
  • If the "Execute" input goes back to FALSE again before the module action (for example positioning) has been completed ("pulse to Execute"), the corresponding outputs (for example "Done") will still be set for exactly ONE cycle upon termination.
  • The outputs "Done" and "Error" are never simultaneously TRUE.
  • If the instance of a function module receives a new "Execute" signal before the function ends, the module will not show any response (no "Done" and no "Command Aborted") in reference to the previous action.

Input parameters

  • Parameters are accepted with the rising edge of the "Execute" signal.
  • To be able to accept modified parameters, the module must be triggered again with an "Execute" signal.

Missing input parameters

  • If an input parameter is missing, the previous value of this instance will be used in accordance with IEC61131-3.
  • The default value is used the first time a call is made.

Position and distance

  • "Position" is a value that is defined for a reference system, i.e. a specific position value is a fixed location in the reference system.
  • "Distance" is the difference between 2 positions.

Sign

  • "Velocity", "Acceleration", "Deceleration" and "Jerk" are always positive variables.
  • "Position" and "Distance" may be positive or negative.

Error handling

  • All function modules have an "Error" output that can be activated by a module during a module sequence.
  • The ErrorID (error number) can be read by an axis error with the "MC_ReadAxisError" module.

Behavior of the "Done" - output

The "Done" output is set if the function module has been successfully executed.

If one positioning process is interrupted by a second before it is complete, the first function module will not set "Done".

Behavior of the "CommandAborted" output

"CommandAborted" is set if a positioning process is interrupted by a second positioning process, by "MC_Stop" or MC_Power.

The reset behavior of "CommandAborted" is the same as "Done".

If "CommandAborted" occurs, the other outputs will be reset.

Value range of the movement parameters

Please note that the limits are specified in revolutions.

To convert to the configured unit, multiply the min/max values by the "travel distance per motor revolution".

Linear motors

With a configured linear motor, all revolution data must be replaced by pitch.

To convert to the configured unit, the min/max values must be multiplied by the pitch length (see the technical data for the motor).


Control functions

In this chapter you can read about:

Energizing the power output stage (MC_Power)

Stop (MC_Stop)


Energizing the power output stage (MC_Power)

FB name

MC_Power

Supplies current to the power output stage
VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names
VAR_INPUT

Enable

BOOL

Activates the module; as long as Enable=True, the power output stage will be energized.
VAR_OUTPUT

Status

BOOL

Status of the power output stage (TRUE= axis energized, FALSE= axis de-energized)

Error

BOOL

Error while de-energizing power output stage

Notes:

  • If the input parameter "Enable" = TRUE, all enables of the axis will be set.
  • All enables will be reset if the input parameter
    "Enable" = FALSE, the axis decelerates with the configured error ramp to (rotational) speed = 0.
  • The controller is enabled with the MC_Power function module.
  • During automatic commutation, the output "Status" is not set to TRUE for energizing, but rather not until after automatic commutation has been successfully completed.


Stop (MC_Stop)

FB name

MC_Stop

Stops the current movement

VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names
VAR_INPUT

Execute

BOOL

Stops the movement

Deceleration

DINT

Value of deceleration (always positive) [units/s²] <Value range>

Jerk

DINT

Value of deceleration jerk [units/s³] (always positive) <Value range>
VAR_OUTPUT

Done

BOOL

Stop move

Error

BOOL

Error while stopping positioning

Note: As long as the "Execute" input is set, the axis remains in the "Stopping" status (as long the axis is energized) and is unable to execute any additional movement commands!

If the axis is switched to a de-energized state by setting the Enable signal of the "MC_Power" module to FALSE, the Stopping state will then be exited.

If the enable signal of the "MC_Power" module is set to TRUE again, the axis goes back to the "Stopping" state again if the Execute input of the "MC_Stop" module is still TRUE.

The following illustration shows an example of how the MC_Stop module interrupts and stops a movement that is in progress.

If a positioning module is interrupted by the MC_Stop module, it reports "Command Aborted" and can no longer be executed as long as the MC_Stop – module is active. If the MC_Stop module is inactive (no "Execute" signal), the function module can be executed again.

Timing Diagram:

Note:

If a positioning is to follow immediately after the stop, this can take place with the falling edge of the done output at the earliest:

Example:


Reading values

In this chapter you can read about:

Reading the current position (MC_ReadActualPosition)

Read Compax3 objects (C3_ReadObject)

Write Compax3 objects (C3_WriteObject)

Reading the device status (MC_ReadStatus)


Reading the current position (MC_ReadActualPosition)

FB name

MC_ReadActualPosition

Reading the current axis position
VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names
VAR_INPUT

Enable

BOOL

Activates the module, continuous reading of the axis position as long as Enable=TRUE
VAR_OUTPUT

Done

BOOL

Position value available

Error

BOOL

Error while reading the position

Position

REAL

Axis position

Note: -

You can read the current position of the axis with this module.
As long as the input parameter "Enable" = TRUE, the current parameter value will be supplied to the output parameter "Position"cyclically.

The status of the input parameter must be present for at least one module call.

The following illustration shows the behavior of parameters in the MC_ReadActualPosition function module.

Note!
Continuous use (enable static on TRUE) of this module can increase the bus load and the cycle time of the DriveTask, if the communiction does not take place via the cyclic but via the acyclic data channel.


Read Compax3 objects (C3_ReadObject)

FB name

C3_ReadObject

Reading obejct in the connected Compax3
VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names

Object

C3OBJECT

Object name of the Compax3 object to be read
VAR_INPUT

Execute

BOOL

Starts the read process with rising edge
VAR_OUTPUT

Done

BOOL

Compax3 object was read successfully.

Error

BOOL

Error while attempting to read the object

  • Communication timeout
  • Transmission error
  • Object read queue of the axis is full (to many object read accesses are still being processed)

Value_BOOL

BOOL

Value of the Compax3 object if it is of the specified format.

Value_INT

INT

Value of the Compax3 object if it is of the specified format.

Value_DINT

DINT

Value of the Compax3 object if it is of the specified format.

Value_WORD

WORD

Value of the Compax3 object if it is of the specified format.

Value_DWORD

DWORD

Value of the Compax3 object if it is of the specified format.

Value_REAL

REAL

Value of the Compax3 object if it is of the specified format.

Value_TIME

TIME

Value of the Compax3 object if it is of the specified format.

Note: -

After the object has been successfully read (Done=TRUE), the module makes the value of the object available on the Value_xyz output corresponding to the data type of the reference on the object input!

Example: For Object=C3.StatusPosition_Actual (Format: REAL), the value to be read is made available on the Value_REAL output.


Write Compax3 objects (C3_WriteObject)

FB name

C3_WriteObject

Writing obejct in the connected Compax3
VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names

Object

C3OBJECT

Object name of the Compax3 object to be written
VAR_INPUT

Execute

BOOL

Starts the write process with rising edge

Value_BOOL

BOOL

Value of the Compax3 object if it is of the specified format.

Value_INT

INT

Value of the Compax3 object if it is of the specified format.

Value_DINT

DINT

Value of the Compax3 object if it is of the specified format.

Value_WORD

WORD

Value of the Compax3 object if it is of the specified format.

Value_DWORD

DWORD

Value of the Compax3 object if it is of the specified format.

Value_REAL

REAL

Value of the Compax3 object if it is of the specified format.

Value_TIME

TIME

Value of the Compax3 object if it is of the specified format.
VAR_OUTPUT

Done

BOOL

Compax3 object was written successfully.

Error

BOOL

Error while attempting to write the object

  • Communication timeout
  • Transmission error
  • Object write queue of the axis is full (too many object write accesses are still being processed)

Note: -

If the edge is rising, the module retrieves the value to be written precisely from the Value_xyz input corresponding to the data type of the object to be written!

Example: For (Format: BOOL), the value to be written is used by the Value_BOOL input.

Note the following:

The object to be written must have read/write access.

Acceptance of the object (valid after:) must be observed. For "valid after: VP", the value is not accepted until after a "VP". “TRUE” must be written to the Compax3 Object "C3.ValidParameter_Global" for this purpose.


Reading the device status (MC_ReadStatus)

FB name

MC_ReadStatus

Specifies the current status according to the PLCopen status machine
VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names
VAR_INPUT

Enable

BOOL

Activates the module; continuous outputs of output parameters as long as Enable=TRUE
VAR_OUTPUT

Done

BOOL

Status values available

Error

BOOL

Error while executing module

Errorstop

BOOL

Error stop function. The motor brakes as specified by the stop ramp and is de-energized;

Stopping

BOOL

The motor is stopped;

Standstill

BOOL

The motor is stopped;

DiscreteMotion

BOOL

Individual movement;

ContinuousMotion

BOOL

Continuous positioning;

Homing

BOOL

Machine home is approached;

SynchronizedMotion

BOOL

Synchronous motion

Note: See also in the status diagram.


Motion functions (standard)

In this chapter you can read about:

Dynamic positioning

Absolute positioning (MC_MoveAbsolute)

Relative positioning (MC_MoveRelative)

Additive positioning (MC_MoveAdditive)

Continuous positioning (MC_MoveVelocity)

Homing (MC_Home)

Electronic gearbox (MC_GearIn)


Dynamic positioning

Dynamic positioning processes can be performed with the modules MC_MoveAbsolute, MC_MoveRelative and MC_MoveAdditive. The speed can be altered dynamically with MC_MoveVelocity.

In the state: ”Discrete Motion”

If another, second positioning process is activated in the "Discrete Motion" the 1st positioning process will be interrupted. The transition to the new destination occurs dynamically, i.e. without any intervening stop.

Note the following in this regard:
  • The new position / distance and the speed are taken over by the second positioning process.
  • The values for acceleration, deceleration and jerks are not taken over. The values of the original positioning process apply.
In "Continuous Motion" state

If a positioning process is activated in the "Continuous Motion" (MC_MoveAbsolute, MC_MoveRelative oder MC_MoveAdditive) or a MC_MoveVelocity the active function module will be interrupted. All input variables of the new positioning process will then be taken over.


Absolute positioning (MC_MoveAbsolute)

FB name

MC_MoveAbsolute

Absolute positioning to a specified position.
VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names
VAR_INPUT

Execute

BOOL

Starts the sequences of the module with positive edge

Position

REAL

Absolute target position of the movement to be executed (configured unit [units] ) (positive and negative direction) <Value range>

MoveVelocity

REAL

Value of maximum speed (always positive) (not necessarily reached) [units/s] <Value range>

Acceleration

DINT

Value of acceleration (always positive) [units/s²] <Value range>

Deceleration

DINT

Value of deceleration (always positive) [units/s²] <Value range>

Jerk

DINT

Value of the acceleration jerk [Units/s³] (always positive) <Value range>

JerkDecel

DINT

Value of deceleration jerk [units/s³] (always positive) <Value range>
VAR_OUTPUT

Done

BOOL

Specified setpoint position on the setpoint generator output is reached

CommandAborted

BOOL

Positioning aborted

Error

BOOL

Error while executing module

Note: -

If a SuperImposed movement is started during an absolute movement, the absolute position is not accessed, but the absolute position plus the position entered in the SuperImposed.

The same applies if a SuperImposed movement is already being executed and an absolute movement is started, then the absolute position is not accessed but the sum of both values.

After the SuperImposed movement has been finished, the absolute position is accessed with the next absolute movement.

The following illustration shows two examples of the combination of two MC_MoveAbsolute – modules.

  • The left part (a) of the time diagram shows a case in which the second function module (FB) is executed after the first function module..
    When the first function module has reached Position 60, the "Done" output gives the execution command to the second function module, which then moves to Position 100.
  • The right part (b) of the diagram shows a case in which the second function module is activated while the first function module is being executed. The first function module is automatically interrupted..
    The second function module moves directly to position 100 whether or not position 60 of the first function module has already been reached.

Jerk
The jerk (marked with ”4” in the drawing below) describes the change in acceleration (derivation of the acceleration)

The maximum change in acceleration is limited via the jerk limitation.

A motion process generally starts from a standstill, accelerates constantly at the specified acceleration to then move at the selected speed to the target position. The drive is brought to a stop before the target position with the delay that has been set in such a manner as to come to a complete stop at the target position. To reach the set acceleration and deceleration, the drive must change the acceleration (from 0 to the set value or from the set value to 0).

This change in speed is limited by the maximum jerk.

Without jerk according to VDI2143

According to VDI2143 the jerk is defined (other than here) as the jump in acceleration (infinite value of the jerk function).

This means that positionings with Compax3 are without jerk according to VDI2143, as the value of the jerk funciton is limited.

Motion sequence

1: Position

2: Speed

3: Acceleration

4: Jerk

Changes in acceleration (jerks) often have negative effects on the mechanical systems involved. There is a danger that mechanical resonance points will be excited or that impacts will be caused by existing mechanical slack points.

You can reduce these problems to a minimum by specifying the maximum jerk.


Relative positioning (MC_MoveRelative)

FB name

MC_MoveRelative

Relative positioning by a specified distance.
VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names
VAR_INPUT

Execute

BOOL

Starts the sequences of the module with positive edge

Distance

REAL

Relative distance of the movement to be executed (configured unit [units] ) <Value range>

MoveVelocity

REAL

Value of maximum speed (always positive)
(not necessarily reached) [units/s] <Value range>

Acceleration

DINT

Value of acceleration (always positive) [units/s²] <Value range>

Deceleration

DINT

Value of deceleration (always positive) [units/s²] <Value range>

Jerk

DINT

Value of the acceleration jerk [Units/s³] (always positive) <Value range>

JerkDecel

DINT

Value of deceleration jerk [units/s³] (always positive) <Value range>
VAR_OUTPUT

Done

BOOL

Specified setpoint distance on the setpoint generator output is reached

CommandAborted

BOOL

Positioning aborted

Error

BOOL

Error while executing module

Note:

In the case of dynamic positioning (module is called during a positioning process) the specified position is added to the current actual position.

The following illustration shows two examples of the combination of two MC_MoveRelative – modules.

  • The left part (a) of the time diagram shows a case in which the second function module is executed after the first function module..
    If the first function module has reached 60 units, the "Done" output gives the execution command to the second function module, which then moves an addition 40 units.
  • The right part (b) of the diagram shows a case in which the second function module is activated while the first function module is being executed. Because the second module is started during the execution of the first function module, the first function module is automatically interrupted.
    The second function module immediately moves an additional 40 units whether or not the 60 units of the first function were already reached.


Additive positioning (MC_MoveAdditive)

FB name

MC_MoveAdditive

Adds a relative distance to the target position of a positioning process in progress.
VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names
VAR_INPUT

Execute

BOOL

Starts the sequences of the module with positive edge

Distance

REAL

Relative distance <Value range>

MoveVelocity

REAL

Value of maximum speed (always positive) (not necessarily reached) [units/s] <Value range>

Acceleration

DINT

Value of acceleration (always positive) [units/s²] <Value range>

Deceleration

DINT

Value of deceleration (always positive) [units/s²] <Value range>

Jerk

DINT

Value of the acceleration jerk [Units/s³] (always positive) <Value range>

JerkDecel

DINT

Value of deceleration jerk [units/s³] (always positive) <Value range>
VAR_OUTPUT

Done

BOOL

Specified distance has been reached

CommandAborted

BOOL

Positioning aborted

Error

BOOL

Error during positioning

Note:

In the case of dynamic positioning (module is called during a positioning process) the specified position is added to the current target position.

The following illustration shows two examples of the combination of a MC_MoveAbsolute and an MC_MoveAddititve – module.

  • The left part (a) of the time diagram shows a case in which the second function module is executed after the first function module.
    After the first function module has traveled to Position 60, the "Done" output gives the execution command to the second FB, which then moves on another 40 units
  • The right part (b) of the diagram shows a case in which the second function module is activated while the first FB is being executed. Because the second module is started during the execution of the first FB, the first FB is automatically interrupted.
    The second function module adds the missing units that are still lacking for the first module and the moves an additional 40 units with the new predefined settings.


Continuous positioning (MC_MoveVelocity)

FB name

MC_MoveVelocity

Continuous controlled positioning with adjustable speed
VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names

VAR_INPUT

Execute

BOOL

Starts the sequences of the module with positive edge

MoveVelocity

REAL

Value of maximum speed (always positive) (not necessarily reached) [units/s] <Value range>

Acceleration

DINT

Value of the acceleration and deceleration (always positive) [Units/s²] <Value range>

Direction

INT

Selection: positive direction, negative direction, current direction; library constants (Library constants, Library constants)
VAR_OUTPUT

InVelocity

BOOL

Specified target speed on the setpoint output is reached

CommandAborted

BOOL

Execution interrupted

Error

BOOL

Error during positioning
Note:
  • To be able to stop the drive, the function module must be interrupted by another positioning function module or positioning must be stopped by calling the MC_Stop function module.
  • A positioning to the end limit follows.

Example

The following illustration shows two examples of the combination of two MC_MoveVelocity – modules.

  • The left part (a) of the time diagram shows a case in which the second function module is executed after the first function module.
    After the first function module has accelerated to a speed of 3000, the "InVelocity" output, AND-linked with the "Next" signal gives the execution command to the second FB, which then slows to a speed of 2000.
  • The right part (b) of the diagram shows a case in which the second FB is activated while the first function module is being executed. Because the second module is started during the execution of the first FB, the first FB is automatically interrupted.
    During the acceleration of the first module, the second module slows again similarly to a speed of 2000 without the speed of the first module having been reached.


Homing (MC_Home)

FB name

MC_Home

Predefined search for the machine reference point
VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names
VAR_INPUT

Execute

BOOL

Starts the sequences of the module with positive edge

Position

REAL

Position on the reference point (configured unit [units] ) = Machine zero Offset
VAR_OUTPUT

Done

BOOL

Referencing process completed

CommandAborted

BOOL

Referencing process aborted

Error

BOOL

Error while searching for machine reference point

Note:

This module gives the command to search for the machine reference point; not for "zero" position. The type of search function (machine reference mode) can be adjusted with the configuration or with the object "HOMING_mode" (Object 1130.4).

Objects that are connected with the machine reference point:

  • C3Plus.HOMING_speed (Object 1130.3)
  • C3Plus.HOMING_accel (Object 1130.1)
  • C3Plus.HOMING_mode (Object 1130.4)
  • C3Plus.HOMING_edge_sensor_distance (Object 1130.7)

Machine reference offset

Machine zero offset

1: MaschinezeroOffset

The machine reference offset is used to determine the actual reference point for positioning.

The rule for this is: Zero point = Machine zero + Machine zero offset

Note: If the machine zero proximity switch is at the positive end of the travel range, the machine zero offset must be = 0 or negative.

A change in the machine reference offset does not take effect until the next machine reference run.
Please note:
During homing run the software end limits are not monitored.


Electronic gearbox (MC_GearIn)

FB name

MC_GearIn

Controlled speed and position synchronicity with adjustable transmission ratio
VAR_IN_OUT

Master

INT

Constant for the master signal source (Library constants, Library constants)

Configuration of the signal sources

Slave

C3_AXIS_REF

Symbolic axis names
VAR_INPUT

Execute

BOOL

Starts the sequences of the module with positive edge

RatioNumerator

REAL

Transmission ratio of numerator

RatioDenominator

INT

Transmission ratio of denominator

Acceleration

DINT

Value of acceleration / deceleration (always positive) until the synchronism is reached [Units/s²] <Value range>
VAR_OUTPUT

InGear

BOOL

Synchronicity achieved

CommandAborted

BOOL

Command aborted

Error

BOOL

Error while executing module
Note:
  • The transmission ratio can be changed at any time with a positive edge on Execute. InGear is reset until synchronicity is achieved again.
  • For example, if speed synchronicity is not achieved because of limiting effects, the position difference that arises will be made up.
  • Acceleration / deceleration to the set transmission ratio takes place without a jerk limit.
  • If the master and slave units do not correspond, this fact must be considered for the transmission ratio.
  • Example

Structure of the "electronic cam" function

Structure image gearing

Note:

  • Direction -1 / +1: with direction reversal (under configuration of signal sources) factor -1 is applied.
  • The C3 powerPLmC controls the electronic gearbox which runs in the slave axis.


Error handling

In this chapter you can read about:

Acknowledging errors (MC_Reset)

Reading axis errors (MC_ReadAxisError)

Conversion C3ErrorID -> String (C3_GetErrorDescription)


Acknowledging errors (MC_Reset)

FB name

MC_Reset

Acknowledges errors (transition from "Errorstop" status to "Standstill" status).
VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names
VAR_INPUT

Execute

BOOL

Activates the module if there is a positive edge
VAR_OUTPUT

Done

BOOL

Error successfully acknowledged, axis is in the "Standstill" state again

Error

BOOL

Acknowledge failed /not possible

ErrorID

WORD

Error description, according to error history

Note: After the error is successfully acknowledged, the power must be supplied to the power output stage again by a rising edge on the enable input of the MC_Power power module.


Reading axis errors (MC_ReadAxisError)

FB name

MC_ReadAxisError

This function module displays axis errors.
VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names
VAR_INPUT

Enable

BOOL

Activates the module
VAR_OUTPUT

Done

BOOL

Output values available

Error

BOOL

Compax3 in error state

ErrorID

WORD

Current error description

Note: -


Conversion C3ErrorID -> String (C3_GetErrorDescription)

FB name

C3_GetErrorDescription

Conversion of a Compax3 error number into a string (e.g. for visualization)
VAR_INPUT

Enable

BOOL

Activating the module

ErrorID

DWORD

The error number to be converted into a string

Language

C3Language

Language of the output string

Permitted parameters are:

"German" for German

"English" for English
VAR_OUTPUT

Description

String (16)

STRING with 16 characters containing the textual description of ErrorID

If no adequate description for an error can be found, the text "NOT FOUND" is displayed.

If ErrorID = 0, the text "OK" is displayed
Note:

This module is not automatically loaded. They can be found in the "C3_ErrorLib.lib" library which can be loaded in the library management: right mouse button in the library window.

Example:

If Enable=TRUE and ErrorID=29456

-> Output Description =

"Drehzahl zu hoch", if Language = German

"Speed too high", if Language = English

Program example:


Process image

In this chapter you can read about:

Reading digital inputs (C3_INPUT)

Write digital outputs (C3_OUTPUT)


Reading digital inputs (C3_INPUT)

FB name

C3_INPUT

Is used for reading in the digital inputs.
VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names
VAR_INPUT

I0 ... I7

BOOL

Displays the status of the respective input.

Notes: the module should always be brought up at the beginning of the processing cycle.

Reading the Compax3 inputs


Write digital outputs (C3_OUTPUT)

FB name

C3_OUTPUT

Is used for setting the digital outputs.
VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names
VAR_OUTPUT

O0 ... O3

BOOL

Displays the status of the respective output.

Notes: the module should always be brought up at the end of the processing cycle.

Reading the Compax3 outputs


C3 powerPLmC as CAN Master

In this chapter you can read about:

CAN modules (Layer 2)

CAN CiA405 modules

The following CAN modules are available for communication with any integrated CAN station (CAN slave).

Layer 2 - modules: for any CAN station

CiA405 - modules: exclusively for CAN stations supporting CANopen

Note:

The CAN modules are not loaded automatically. They can be found in the "PLmC_CAN.lib" library which can be loaded in the library management: right mouse button in the library window.

No Compax3 modules!

These modules may not be used for Compax3 axes integrated via the "Drive Interface", as the communication there takes always place via the Drive Interface.

Exception Node guarding:

The CiA405_Get_State module for the realization of the node guarding function can also be used for a Compax3 integrated via the drive interface.


CAN modules (Layer 2)

In this chapter you can read about:

Transmit messages via the CAN bus (CAN_Transmit)

Enable in order to receive CAN data (CAN_ReceiveEnable)

Receive messages via the CAN bus (CAN_Receive)

Enable in order to receive CAN data from the system buffer (CANQ_ReceiveEnable)

CANQ_Receive

CAN Diagnosis Functions (CAN_Diagnostic)


Transmit messages via the CAN bus (CAN_Transmit)

FB name

CAN_Transmit

This module can be used to transmit messages via the CAN bus.
VAR_INPUT

Enable

BOOL

With Enable = TRUE, data will be sent via the bus upon each calling up of the module.

Bus

CAN_BUS

E20: CAN_BUS1 oder CAN_BUS2

C10/C13: CAN_BUS1

ID

WORD

11 bit CAN identifier of the message to be transmitted.

RTR

BOOL

If RTR = TRUE, a Remote Transmission Request is sent for the message (data and data length are not important in this case). If RTR = FALSE, the data are transmitted.

Data

ARRAY [1..8] of BYTE

8 byte array in which the data to be transmitted must be made available

DataLength

USINT

Length of the data, i.e. the number of the data bytes in the data array to be transmitted (the data must be left-aligned in the array).

VAR_OUTPUT

Done

BOOL

Data transferred successfully.

Error

BOOL

Error when transmitting the data
(there may be not enough CAN resources available verify number of the Tx objects in the controller configuration!)


Enable in order to receive CAN data (CAN_ReceiveEnable)

FB name

CAN_ReceiveEnable

Enable in order to receive CAN data

VAR_INPUT

Enable

BOOL

Activation of the module, i.e. enable of the reception of one or several CAN messages.
As soon as the enable input is reset to FALSE, the enable is cancelled.

Bus

CAN_BUS

E20: CAN_BUS1 oder CAN_BUS2

C10/C13: CAN_BUS1

Start_ID

WORD

First identifier to be enabled

End_ID

WORD

Last identifier to be enabled
(in order to enable a single identifier, set Start_ID = End_ID!)

Event

CAN_EVENT

Via this input you can define that the reception of an identifier will release a system event, which may trigger a task.

Valid system events are CAN_01 to CAn_30.
No event = CAN_NOEVENT (default values)
VAR_OUTPUT

Enabled

BOOL

The module has successfully enabled the queried identifiers.
Note:

Before a CAN message can be received with CAN_Receive, the reception must be enabled with this module.
Each instance can enable a single message or a defined range of messages.
In order to enable several ranges, several instances of the function module must be used.


Data type: CAN_EVENT

The "CAN_EVENT" data type is used for triggering a system event upon the receipt of a defined telegram identifier. The respective parameter is available in the "CAN-ReceiveEnable" and "CANQ_ReceiveEnable" modules. It is therefore possible to start an event task upon the receipt of a defined CAN/CANopen telegram (e.g. for an especially fast rection or event-controlled processing)

  • CAN_01
  • .....
  • CAN_30
  • CAN_NOEVENT
Generation of a task which is triggered by the "CAN_02" system event:


Receive messages via the CAN bus (CAN_Receive)

FB name

CAN_Receive

This module can be used to receive messages via the CAN bus.
VAR_INPUT

Enable

BOOL

Activation of the module, i.e. enable of data reception

Bus

CAN_BUS

E20: CAN_BUS1 oder CAN_BUS2

C10/C13: CAN_BUS1

ID

WORD

11 bit CAN identifier of the message to be received
VAR_OUTPUT

ReceiveCount

DWORD

Counter for the number of received messages. The counter is incremented by one with each newly received message. If the counter reaches the value 2^32, it will be reset to 0.

Data

ARRAY [1..8] of BYTE

8 byte array, where the last received data are available

DataLength

USINT

Length of the data received. (can be between 0 and 8 bytes). The data are always available left-aligned in the data array.

Example: If DataLength = 4, the data are available in Data[1] to Data[4]
Note:

Via this module you can receive messages via the CAN bus.
The reception of a message with a defined identifier must be enabled beforehand via the CAN_ReceiveEnable module.


Enable in order to receive CAN data from the system buffer (CANQ_ReceiveEnable)

FB name

CANQ_ReceiveEnable

Enable in order to receive CAN data and to redirect them to a queue.
VAR_INPUT

Enable

BOOL

Activation of the module, i.e. enable of the reception of a CAN message for buffered reception.
As soon as the enable input has been reset to FALSE, the enable is cancelled.

Bus

CAN_BUS

E20: CAN_BUS1 oder CAN_BUS2

C10/C13: CAN_BUS1

ID

WORD

Identifier to be enabled

Event

CAN_EVENT

Via this input you can define that the reception of an identifier will release a system event, which may trigger a task.
Valid system events are CAN_01 to CAn_30.
No event = CAN_NOEVENT (default value)
VAR_OUTPUT

Enabled

BOOL

The module has successfully enabled the queried identifier.

Error

BOOL

An error occurred when enabling the identifier

QueueHandle

DWORD

If the identifier is enabled successfully, a system buffer is reserved and a QueueHandle (identification number) is set back to this buffer.
This QueueHandle must then be transferred to the respective instance of CANQ_Receive
Note:

Before a CAN message can be recerived with CANQ_Receive, the reception with this module must be enabled.
Each instance can enable individual messages.
In order to enable several messages, several instances of the function module must be used.


CANQ_Receive

FB name

CANQ_Receive

Module for receiving a CAN-message redirected to a queue.
The reception of the message must have been enabled with CANQ_ReceiveEnable beforehand.

VAR_INPUT

QueueHandle

DWORD

QueueHandle generated by the CANQ_ReceiveEnable module (identification number)
VAR_OUTPUT

NewData

BOOL

There are data in the receive buffer

Data

ARRAY [1..8] of BYTE

8 byte array, where the received data are available

DataLength

USINT

Length of the data received. (can be between 0 and 8 bytes).
The data are always available left-aligned in the data array.

Example: If DataLength = 4, the data are available in Data[1] to Data[4]
Note:

Normally the CAN_Receive module should be used to receive data.
If, however, several messages with the same identifier might arrive within a PLC cycle and no message is to be lost, the CANQ_Receive module can be used instead. Thus all messages received are stored internally in a system buffer.
You must however ensure that enough receive objects (nRxObjects) are reserved in the controller configuration of the respective CAN master.
The module is typically called up repeatedly within a cycle until NewData = FALSE, i.e. all newly received telegrams are processed.

Example:


CAN Diagnosis Functions (CAN_Diagnostic)

FB name

CAN_Diagnostic

This module can be used for diagnostic purposes.
VAR_INPUT

Enable

BOOL

Activating the module.

Bus

CAN_BUS

E20: CAN_BUS1 oder CAN_BUS2

C10/C13: CAN_BUS1
VAR_OUTPUT

ErrorCounter

DWORD

Error counter

DataLostCounter

DWORD

Data loss counter

ArbitrationLostCounter

DWORD

Number of delays of bus access (caused by higher priority telegrams).

TxCounter

DWORD

Number of messages transmitted.

RxCounter

DWORD

Number of messages received.

SyncCounter

DWORD

Number of SYNC messages.


CAN CiA405 modules

In this chapter you can read about:

SDO modules

CiA405_Get_State

CiA405_NMT

CiA405_Recv_EMCY_Dev


Previous Topic

Next Topic

SDO modules


CiA405_SDO_Read4

FB name

CiA405_SDO_Read4

VAR_INPUT

Device

CIA405_DEVICE

Index

WORD

Index of the CANopen communication object

SubIndex

BYTE

Subindex of the CANopen communication object

Enable

BOOL

Activates the module
VAR_OUTPUT

Data

ARRAY [1.0.4] of BYTE

Data read

DataLength

USINT

Data length

Confirm

BOOL

CANopen communication object read

Error

CIA405_CANOPEN_KERNEL_ERROR

ErrorInfo

CIA405_SDO_ERROR

Note:

Only one SDO module may be active for a CANopen node (station). Another SDO module can only be activated with Confirm = TRUE. This applies for all SDO modules.

After a module has terminated its sequence with confirm = TRUE, the module must be called up again with Enable = FALSE, in order to release internally assigned system ressources!

Additional CIA405_SDO_Read modules with the same layout and function but with a larger data width are:
  • CIA405_SDO_READ7: Data: ARRAY [1.0.7] of BYTE
  • CIA405_SDO_READ14: Data: ARRAY [1.0.14] of BYTE
  • CIA405_SDO_READ21: Data: ARRAY [1.0.21] of BYTE
  • CIA405_SDO_READ28: Data: ARRAY [1.0.28] of BYTE
Timing:

1: Module activated

2: Command executed

3: if Enable = FALSE, then aklso confirm=FALSE (4)


CiA405_SDO_Error (Abort Code): UDINT

Previous Topic

Next Topic

CiA405_SDO_Error (Abort Code): UDINT

In the case of an incorrect SDO transmission, the error cause is returned via the "abort code".

Abort Code | Description
0x0503 0000 | ” Toggle Bit” was not alternated
0x0504 0000 | SDO protocol ”time out”
0x0504 0001 | Client/server command designator invalid or unknown
0x0504 0002 | Unknown block size (block mode only)
0x0504 0003 | Unknown block number (block mode only)
0x0504 0004 | CRC error (block mode only)
0x0504 0005 | Outside of memory
0x0601 0000 | Access to this object is not supported
0x0601 0001 | Attempted read access to a write only object
0x0601 0002 | Attempted write access to a read only object
0x0602 0000 | The object does not exist in the object directory
0x0604 0041 | The object cannot be ”mapped” in a PDO
0x0604 0042 | The size and number of the ”mapped” objects exceeds the maximum PDO length
0x0604 0043 | General parameter incompatibility
0x0604 0047 | General incompatibility in the device
0x0606 0000 | Access infringement due to a hardware error
0x0607 0010 | Data type does not fit, length of the service parameter does not fit
0x0607 0012 | Data type does not fit, length of the service parameter too large
0x0607 0013 | Data type does not fit, length of the service parameter too small
0x0609 0011 | Subindex does not exist
0x0609 0030 | Outside parameter value range (only for write access operations)
0x0609 0031 | Parameter value too large
0x0609 0032 | Parameter value too small
0x0609 0036 | Maximum value smaller than minimum value
0x0800 0000 | General error
0x0800 0020 | Date cannot be transmitted or saved
0x0800 0021 | Date cannot be transmitted or saved due to local device management
0x0800 0022 | Date cannot be transmitted or stored due to device status
0x0800 0023 | Dynamic generation of the object directory is impossible or no object directory exists (the object directory is created from a file and an error occurs due to a defective file)


Data type: CIA405_CANOPEN_KERNEL_ERROR : WORD

Previous Topic

Next Topic

Data type: CIA405_CANOPEN_KERNEL_ERROR : WORD

Internal error of the CANopen stack. The following errors are possible:

(* 0 | = | No Error *)
(* 1 | = | Other error - see further error registers *)
(* 2 | = | Data overflow - e.g. buffer is too small for received SDO *)
(* 3 | = | Time out *)
(* 4 | = | SDO does not exist *)
(* 5 | = | Could not send request on SDO *)
(* 16#10 | = | CAN Bus off *)
(* 16#11 | = | CAN Error Passive *)
(* 16#12 | = | Could not create format object *)
(* 16#13 | = | NodeID not found*)
(* 16#14 | = | CAN Net not found *)
(* 16#15 | = | Could not read Device type (object 0x1000) *)
(* 16#16 | = | Error while reading device type : Unexpected response *)
(* 16#17 | = | Could not send reset node telegram *)
(* 16#18 | = | Could not send start node telegram *)
(* 16#19 | = | Could not send stop node telegram *)
(* 16#1A | = | EMCY identifier of node to be guarded must not be 0 *)
(* 16#1B | = | Could not send RTR for transmit PDOs *)
(* 16#1F | = | Unknown CANopen Kernel error *)


Data type: CIA405_DEVICE : BYTE (0..127)

Previous Topic

Next Topic

Data type: CIA405_DEVICE : BYTE (0..127)

CANopen node address (Node ID)

Timing:

1: Module activated

2: Command executed

3: if Enable = FALSE, then aklso confirm=FALSE (4)


CiA405_SDO_Write4

FB name

CiA405_SDO_Write4

VAR_INPUT

Device

CIA405_DEVICE

Index

WORD

Index of the CANopen communication object

SubIndex

BYTE

Subindex of the CANopen communication object

Enable

BOOL

Activates the module

Data

ARRAY [1.0.4] of BYTE

Data to be sent

DataLength

USINT

VAR_OUTPUT

Confirm

BOOL

CANopen object changed

Error

CIA405_CANOPEN_KERNEL_ERROR

ErrorInfo

CIA405_SDO_ERROR

Note:

Only one SDO module may be active for a CANopen node (station). Another SDO module can only be activated with Confirm = TRUE. This applies for all SDO modules.

After a module has terminated its sequence with confirm = TRUE, the module must be called up again with Enable = FALSE, in order to release internally assigned system ressources!

Additional CIA405_SDO_Write modules with the same layout and function but with a larger data width are:
  • CIA405_SDO_WRITE7: Data: ARRAY [1.0.7] of BYTE
  • CIA405_SDO_WRITE14: Data: ARRAY [1.0.14] of BYTE
  • CIA405_SDO_WRITE21: Data: ARRAY [1.0.21] of BYTE
  • CIA405_SDO_WRITE28: Data: ARRAY [1.0.28] of BYTE
Timing:

1: Module activated

2: Command executed

3: if Enable = FALSE, then aklso confirm=FALSE (4)


Conversion function for CiA405-SDO-Read4 & CiA405-SDO-Write4

Previous Topic

Next Topic

Conversion function for CiA405-SDO-Read4 & CiA405-SDO-Write4

For an easier handling of the CIA405-SDO_READ4 and CIA405_SDO_WRITE4 modules there is a series of conversion functions available in order to execute an automatic conversion of the parameters in a byte array (when writing via SDO) or a conversion of a byte array in a parameter (when reading via SDO).

The following functions are implemented:
Conversion of received data:
  • BYTEARRAY_TO_INTEGER16
  • BYTEARRAY_TO_INTEGER32
  • BYTEARRAY_TO_INTEGER8
  • BYTEARRAY_TO_REAL32
  • BYTEARRAY_TO_UNSIGNED16
  • BYTEARRAY_TO_UNSIGNED32
  • BYTEARRAY_TO_UNSIGNED8
Conversion of data to be sent:
  • INTEGER16_TO_BYTEARRAY
  • INTEGER32_TO_BYTEARRAY
  • INTEGER8_TO_BYTEARRAY
  • REAL32_TO_BYTEARRAY
  • UNSIGNED16_TO_BYTEARRAY
  • UNSIGNED32_TO_BYTEARRAY
  • UNSIGNED8_TO_BYTEARRAY


CiA405_Get_State

The CiA405_Get_State module for the realization of the node guarding function can also be used for a Compax3 integrated via the drive interface.

FB name

CiA405_Get_State

Query of the CANopen status
VAR_INPUT

Device

CIA405_DEVICE

Enable

BOOL

Activates the module
VAR_OUTPUT

Confirm

BOOL

Updated status available at the state output

State

CIA405_STATE

If a node is no longer available at the bus (nodeguarding error), the output State will take on the value NOT_AVAIL.
Note:


Data type: CIA405_STATE
Implemented states:
  • RESET_COMM,
  • PRE_OPERATIONAL,
  • STOPPED,
  • OPERATIONAL,
  • UNKNOWN,
  • NOT_AVAIL


Node guarding

Example:

Life Time Factor = 2 => Life Time = 2 * Guard Time

The master sends a request to the CAnopen device to be monitored periodically with the Guard Time (typical value e.g. 500msec). The device will thereupon answer with its current CANopen communication status (operational, preoperational,...). This status can be queried via the state output of the function module CiA405_Get_State.

If the CANopen master does not receive an answer from the device (e.g. due to a bus system failure) during the Life Time, a so-called node guarding event is generated, which can be queried by changing the state output to the value "NOT_AVAIL".

While the plant is in operation, the failed device can be reactivated for the bus with the CIA405_NMT module via the NMT command "RESET_NODE" after correction of the error; a complete mapping is being automatically executed.

Compax3 devices integrated via the Drive Interface can only be reactivated for the bus by a new start of the controller.


CiA405_NMT

FB name

CiA405_NMT

Changing the CANopen status via NMT
VAR_INPUT

Device

CIA405_DEVICE

Address "0" is used to address all CANopen nodes (Broadcast).

State

CIA405_TRANSITION_STATE

Enable

BOOL

Activates the module
VAR_OUTPUT

Confirm

BOOL

NMT - command transferred
(bei RESET_NODE: new mapping executed)

Error

CIA405_CANOPEN_KERNEL_ERROR

Note:
If the NMT command "ResetNode" is executed, the mapping configured in the CANopen Master is additionally transmitted after the reset of the node.


Data type: CiA405_TRANSITION_STATE
I mplemented transitions:
  • START_REMOTE_NODE,
  • ENTER_PRE_OPERATIONAL,
  • RESET_NODE and new Mapping


CiA405_Recv_EMCY_Dev

FB name

CiA405_Recv_EMCY_Dev

Verifies if a certain device has sent an Emergency object.
VAR_INPUT

Device

CIA405_DEVICE

Enable

BOOL

Activates the module
VAR_OUTPUT

Confirm

BOOL

no error

Error

CIA405_CANOPEN_KERNEL_ERROR

ErrorInfo

CIA405_EMCY_ERROR

Note:

Timing Diagram


Data type: CIA405_EMCY_ERROR

Contents of an emergency error telegram.

Contents of the data structure:

TYPE CIA405_EMCY_ERROR :

STRUCT

EMCY_ERROR_CODE : WORD;

ERROR_REGISTER : BYTE;

ERROR_FIELD : ARRAY[1..5] OF BYTE;

END_STRUCT

END_TYPE


Application examples

Two drives are controlled from the C3 powerPLmC. These consist of the components:

  • X_Axis: Compax3 with C3 powerPLmC, designation C10T11.
  • Y_Axis: Compax3 with CAN – interface, designation I21T11.

    The following functions must be performed:

  • After the power supply is turned on, current is supplied to the axes and they can be moved.
  • After that, the machine zero point is approached.
  • Once it is reached, the axes are ready for operation.
  • Each axis moves to two absolute positions one after the other, independently of the state of the other axes.
  • The subsequent positioning process is started when both axes have reached their previous destination.
  • After this is completed, the cycle is repeated.
  • In the event of a malfunction, it can be reset with a QUIT – input on the corresponding axis.
  • The actual position of the axes is displayed. However, it is only read each 15th time instead of in each cycle to reduce the bus load.

You will find the example with a description of the program on the CD (project: "Beispiel_01.pro")!

Further application examples can be found on the C3 powerPLmC CD:
Application | Description | CD directory under applications
PLmCAppl_A0005 | OPC Client / Server | OPCServerClient
PLmCAppl_A0007 | POP_Interface | PLmC with POP
PLmCAppl_A0008 | CoDeSys Project – Templates for PlmC with Compax3, PIOs, Pop | ProjectTemplates
PLmCAppl_A0009 | Time functions. Real-time clock of the PLmC | TimeFunctions
PLmCAppl_A0010 | Treating files Writing and reading files from the IEC program | HandlingFiles


C3T30 integrated servo axis

In this chapter you can read about:

Setting up Compax3

Motion control

Communication

Compax3 - Objects

Status values

Error


Setting up Compax3

In this chapter you can read about:

Configuration

Optimization

Configuring the master signal sources


Configuration

In this chapter you can read about:

Selection of the supply voltage used

Motor Selection

Optimize motor reference point and switching frequency of the motor current

Braking Resistor

General Drive

Defining the reference system

Defining jerk / ramps

Monitoring / Limit Settings

Encoder Output

Recipe table

Configuration name / comments

Caution!

De-energize the motor before downloading the configuration software.

N.B.!

Incorrect configuration settings entail danger when energizing the motor. Therefore take special safety precautions to protect the travel range of the system.

Mechanical limit values!

Observe the limit values of the mechanical components!

Ignoring the limit values can lead to destruction of the mechanical components.

Configuration sequence:

Installation of the C3 ServoManager

The Compax3 ServoManager can be installed directly from the Compax3 CD. Click on the appropriate hyperlink or start the installation program "C3Mgr_Setup_V.... .exe" and follow the instructions.

PC minimum requirements

For successful installation, your PC must meet the following minimum requirements:

  • Windows NT 4.0 (Intel) with Service Pack 6, Windows 2000 (Service Pack 4 recommended) or Windows XP.
  • Administrator authorisation* on the system
  • Microsoft Internet Explorer 4.01 (SP2) or higher
  • Pentium-PC (600 MHz or faster is recommended)
  • 128 MB RAM (256 MB recommended)
  • Super VGA-Monitor (with a resolution of at least 800 x 600, setting: small fonts)

PC minimum requirements

For successful installation, your PC must meet the following minimum requirements:

  • Windows NT 4.0 (Intel) with Service Pack 6, Windows 2000 (Service Pack 4 recommended) or Windows XP.
  • Administrator authorisation* on the system
  • Microsoft Internet Explorer 4.01 (SP2) or higher
  • Pentium-PC (600 MHz or faster is recommended)
  • 128 MB RAM (256 MB recommended)
  • Super VGA-Monitor (with a resolution of at least 800 x 600, setting: small fonts)
  • Required HD capacity
    • CD installation: 350MB before installation, 200MB after completion of the installation

Connection between PC and Compax3

Your PC is connnected (SSK1) with Compax3 over an RS232 cable (COM 1/2 interface on the PC based on X10 Compax3).

Start the Compax3 ServoManager and make the setting for the selected interface in the menu Options: Port (RS232) COM 1 or COM 2.

Device Selection

In the menu tree under device selection you can read the device type of the connected device (Online Device Identification) or select a device type (Device Selection Wizard).

Configuration

Then you can double click on "Configuration" to start the configuration wizard. The wizard will lead you through all input windows of the configuration.

Input quantities will be described in the following chapters, in the same order in which you are queried about them by the configuration wizard.


Selection of the supply voltage used

Please select the mains voltage for the operation of Compax3.

This influences the choice of motors available.


Motor Selection

The selection of motors can be broken down into:

  • Motors that were purchased in Europe and
  • Motors that were purchased in the USA.
  • You will find non-standard motors under "Additional motors" and
  • Under "User-defined motors" you can select motors set up with the C3 MotorManager.

For motors with holding brake SMHA or MHA brake delay times can be entered. See brake delay times.

Please note the following equivalence that applies regarding terms to linear motors:

  • Rotary motors / linear motors
  • Rotations º Pitch
  • rotational speed º speed
  • torque º force
  • moment of inertia º load

Notes on direct drives (Linear- and Torque - motors)


Optimize motor reference point and switching frequency of the motor current

Optimization of the motor reference point

The motor reference point is defined by the reference current and the reference (rotational) speed.

Standard settings are:

  • Reference current = nominal current
  • Reference (rotational) speed = nominal (rotational) speed

    These settings are suitable for most cases.

    The motors can, however, be operated with different reference points for special applications.

  • By reducing the reference (rotational) speed, the reference current can be increased. This results in more torque with a reduced speed.
  • For applications where the reference current is only required cyclically with long enough breaks in between,you may use a reference current higher than I0. The limit value is however reference current = max. 1.33*I0. The reference (rotational) speed must also be reduced.

    The possible settings or limits result from the respective motor characteristics.

    Caution!

    Wrong reference values (too high) can cause the motor to switch off during operation (because of too high temperature) or even cause damage to the motor.

Optimization of the switching frequency

The switching frequency of the power output stage is preset to optimize the operation of most motors.

It may, however, be useful to increase the switching frequency especially with direct drives in order to reduce the noise of the motors. Please note that the power output stage must be operated with reduced nominal currents in the case of increased switching frequencies.
The switching frequency may only be increased.

Caution!

By increasing the motor current switching frequency, the nominal current and the peak current are reduced.
This must already be observed in the planning stage of the plant!

The preset motor current switching frequency depends on the performance variant of the Compax3 device.

The respective Compax3 devices can be set as follows:

Resulting nominal and peak currents depending on the switching frequency

Compax3 S0xx V2 at 1*230VAC/240VAC
Switching frequency* |  | S025 V2 | S063 V2
16kHz | Inominal | 2.5Aeff | 6.3Aeff
 | Ipeak (<5s) | 5.5Aeff | 12.6Aeff
32kHz | Inominal | 2.5Aeff | 5.5Aeff
 | Ipeak (<5s) | 5.5Aeff | 12.6Aeff
Compax3 S1xx V2 at 3*230VAC/240VAC
Switching frequency* |  | S100 V2 | S150 V2
8kHz | Inominal | - | 15Aeff
 | Ipeak (<5s) | - | 30Aeff
16kHz | Inominal | 10Aeff | 12.5Aeff
 | Ipeak (<5s) | 20Aeff | 25Aeff
32kHz | Inominal | 8Aeff | 10Aeff
 | Ipeak (<5s) | 16Aeff | 20Aeff
Compax3 S0xx V4 at 3*400VAC
Switching frequency* |  | S015 V4 | S038 V4 | S075 V4 | S150 V4 | S300 V4
8kHz | Inominal | - | - | - | 15Aeff | 30Aeff
 | Ipeak (<5s) | - | - | - | 30Aeff | 60Aeff
16kHz | Inominal | 1.5Aeff | 3.8Aeff | 7.5Aeff | 10.0Aeff | 26Aeff
 | Ipeak (<5s) | 4.5Aeff | 9.0Aeff | 15.0Aeff | 20.0Aeff | 52Aeff
32kHz | Inominal | 1.5Aeff | 2.5Aeff | 3.7Aeff | 5.0Aeff | 14Aeff
 | Ipeak (<5s) | 3.0Aeff | 5.0Aeff | 10.0Aeff | 10.0Aeff | 28Aeff
Compax3 S0xx V4 at 3*480VAC
Switching frequency* |  | S015 V4 | S038 V4 | S075 V4 | S150 V4 | S300 V4
8kHz | Inominal | - | - | - | 13.9Aeff | 30Aeff
 | Ipeak (<5s) | - | - | - | 30Aeff | 60Aeff
16kHz | Inominal | 1.5Aeff | 3.8Aeff | 6.5Aeff | 8.0Aeff | 21.5Aeff
 | Ipeak (<5s) | 4.5Aeff | 7.5Aeff | 15.0Aeff | 16.0Aeff | 43Aeff
32kHz | Inominal | 1.0Aeff | 2.0Aeff | 2.7Aeff | 3.5Aeff | 10Aeff
 | Ipeak (<5s) | 2.0Aeff | 4.0Aeff | 8.0Aeff | 7.0Aeff | 20Aeff

The values marked with grey are the pre-set values (standard values)!

*corresponds to the frequency of the motor current


Braking Resistor

If the regenerative braking power that is fed back exceeds the storable energy of the servo controller, an error will be generated. To ensure safe operation, it is then necessary to either

  • reduce the accelerations resp. the decelerations,
  • or es you will need an external braking resistor.

    Please select the connected braking resistor or enter the characteristic values of your braking resistor directly.

Please note that with resistance values greater than specified, the power output from the servo drive can no longer be dissipated in the braking resistor.


General Drive

External moment of inertia / load

The external moment of inertia is required for adjusting the servo controller. The more accurately the moment of inertia of the system is known, the better is the stability and the shorter is the settle-down time of the control loop.

It is important to specify the minimum and maximum moment of inertia for best possible behavior under varying load.

Minimum moment of inertia / minimum load

Maximum moment of inertia / maximum load

Enter minimum = maximum moment of inertia when the load does not vary.


Defining the reference system

The reference system for positioning is defined by:

  • a unit,
  • the travel distance per motor revolution,
  • a machine zero point with true zero,
  • positive and negative end limits.


Measure reference

In this chapter you can read about:

Unit of Travel

Travel distance per motor revolution

Reset mode


Unit of Travel

Unit of Travel

You can select from among the following for the unit:

  • mm,
  • increments or
  • angle degree.

    The unit of measure is always [mm] for linear motors.


Travel distance per motor revolution

Travel distance per motor revolution / pitch

The measure reference to the motor is created with the value:

"travel distance per motor revolution / pitch" in the selected unit.

Travel distance per motor revolution

Input as numerator and denominator

You can enter the "travel distance per motor revolution" as a fraction (numerator divided by denominator). This is useful in the case of continuous operation mode or in reset mode if the value cannot be specified as a rational number. This makes it possible to avoid long-term drifts.

Example 1:

Rotary table control

Travel distance per motor revolution example

Unit: Degrees

Gear transmission ratio 70:4 => 4 load revolutions = 70 motor revolutions

Travel distance per motor revolution = 4/70 * 360° = 20.571 428 5 ...° (number cannot be represented exactly)

Instead of this number, you have the option of entering it exactly as a numerator and denominator:

Travel distance per motor revolution = 144/7

This will not result in any drift in continuous operation mode or in reset mode, even with relatively long motion in one direction.

Example 2:

Conveyor belt

Travel path per motor revolution example 2

Unit: mm

Gear transmission ratio 7:4 => 4 load revolutions = 7 motor revolutions

Number of pinions: 12

Tooth separation: 10mm

Travel path per motor revolution = 4/7 * 12 * 10mm = 68.571 428 5 ... mm (this number cannot be expressed exactly)

Instead of this number, you have the option of entering it exactly as a numerator and denominator:

Travel distance per motor revolution = 480/7 mm

For "travel distance per motor revolution" that can be represented exactly, enter 1 as the denominator.

Travel distance per motor revolution / pitch
Numerator
Unit: Unit of Travel | Range: depending on the chosen unit |  | Standard value: depending on the chosen unit
Resolution: 0.000 000 1 (7 decimal places)
Unit of Travel |  | Division |  | Standard value
Increments* |  | 10 ... 1 000 000 |  | 1024
mm |  | 0,010 000 0 ... 2000,000 000 0 |  | 1,000 000 0
Degrees |  | 0,010 000 0 ... 720,000 000 0 |  | 360,000 000 0
Denominator
Unit: - | Range: 1 ... 1 000 000 | Standard value: 1
Integer value

*When choosing the ”Increments” unit , this applies only to position values; speed, acceleration and jerk are specified in this case in revolutions/s, revolutions/s2 and revolutions/s3 (resp. pitch/s, pitch/s2, pitch/s3).

Invert Motor Rotation/Direction Sense
Unit: - | Range: no/yes | Standard value: no
Reverse direction inverts the sense of rotation, i.e. the direction of movement of the motor is reversed in the case of equal setpoint.


Reset mode

Reset mode

Reset mode is available for applications in which the positioning range repeats; some examples are: Rotary table applications, belt conveyor, ... .

After the reset travel distance (can be specified exactly as numerator and denominator) the position values in Compax3 are reset to 0.

Example:

Conveyor belt (from the "Conveyor belt" example) with reset path

A reset path of 300 mm can be entered directly with numerator = 300 mm and denominator = 1.

Reset mode is not possible for linear motors.

Reset Distance
Numerator
Unit: Unit of Travel | Range: depending on the chosen unit | Standard value: depending on the chosen unit
Unit of Travel | Division | Standard value
Increments | 10 ... 1 000 000 | 0
mm | 1 ... 2000 | 0
Degrees | 1 ... 720 | 0
Denominator
Unit: - | Range: 1 ... 1 000 000 | Standard value: 0
Integer value
Turn off reset mode

Reset mode is turned off for numerator = 0 and denominator = 0.


Machine Zero

In this chapter you can read about:

SinCos Multiturn encoder

Multiturn Emulation

Machine zero modes overview

Homing modes with home switch (on X12/14)

Machine zero modes without home switch

Adjusting the machine zero proximity switch

Machine zero speed and acceleration

The Compax3 machine zero modes are adapted to the CANopen profile for Motion Control CiADS402.

Position reference point

Essentially, you can select between operation with or without machine reference.

The reference point for positioning is determined by using the machine reference and the machine reference offset.

Machine reference run

In a homing run the drive moves to the position value 0 immediately after finding the home switch. The position value 0 is defined via the homing offset.

A machine reference run is required each time after turning on the system for operation with machine reference.
Please note:
During homing run the software end limits are not monitored.


SinCos Multiturn encoder

Using a SinCos Multiturn absolute value encoder (Motor - Option A7) as feedback system, the absolute position can be read in when switching on the Compax3. A machine zero run after switch-on is then not necessary.

In this case the reference only needs to be established once

  • at initial commissioning time
  • after an exchange of motor / feedback system
  • after a mechanical modification and
  • after replacing the device (Compax3)
  • after a configuration download

    by carrying out a machine zero run.

    The homing mode 35 "home at the current position" is appropriate for this, because it is therewith possible to operate without proximity switch, but any other machine zero run mode is possible too - if the hardware prerequisites are fulfilled.

    When you have once re-established the reference, reset the homing mode to "without homing run".


Multiturn Emulation

You can simulate the function of a SinCos Multiturn by the aid of a Multiturn emulation. A resolver or a SinCos Singleturn is sufficient as a feedback signal from the motor.

It differs from the physical SinCos Multiturn in the way that it may not be moved by more than half a turn in currentless state – unless the absolute position is lost.

Besides that, the Multiturn emulation offers the same function as the physical SinCos Multiturn.

You can switch on the Multiturn emulation directly in the wizard.

You can assign the maximum permissible motor angle by which the motor may move in powerless state via the Multiturn validity window (1 ... 180°). If Compax3 states after switching on that this value is exceeded, this is indicated via a status. The status can be read in the IEC61131-3 program in object 3310.1 ”C3.Multiturnemulation_Status” ("0": angle in the window; "-1": angle was outside the window). Compax3 restores nevertheless the absolute position, which is, however, not correct if the motor was moved by more than half a turn while currentless.

For a unique machine zero run the same conditions apply as for the use of an absolute encoder (SinCos Multiturn).


Machine zero modes overview
Selection of the machine zero modes (MN-M)
Machine zero initiator on X12/14: MN-M 3 ... 14, 19 ... 30 | Without motor reference point MN-M 19 ...30 | without direction reversal switches MN-M 19, 20 MN-M 21, 22
 |  | Search for Home in opposite direction MN-M 23, 24, 25, 26 MN-M 27, 28, 29, 30
 | With motor reference point MN-M 3 ... 14 | without direction reversal switches MN-M 3, 4 MN-M 5, 6
 |  | Search for Home in opposite direction MN-M 7, 8, 9, 10 MN-M 11,12,13, 14,
Without machine zero initiator on X12/14: MN-M 1, 2, 17, 18, 33 .. 35, 128, 129, 130 ... 133 | Without motor reference point MN-M 17, 18, 35, 128, 129 | MN-M 35: at the current Position MN-M 128, 129: while moving to block
 |  | Use of HW travel limit switch as Home switch MN-M 17, 18
 | With motor reference point | Only motor reference MN-M 33, 34 MN-M 130, 131
 | MN-M 1, 2, 33, 34, 130 ... 133 | Use of HW travel limit switch as Home switch MN-M 1, 2 MN-M 132, 133

Definition of terms / explanations:

Motor zero point

Zero pulse of the feedback

Motor feedback systems such as resolvers or SinCos give one pulse per motor revolution.

Some motor feedback systems of direct drives do also have a zero pulse, which is generated once or in defined intervals.

By interpreting the motor zero point (generally in connection with the machine zero initiator) the machine zero can be defined more exactly.

Machine zero initiator:

For creating the mechanical reference

Has a defined position within or on the edge of the travel range.

Direction reversal switches:

Initiators on the edge of the travel range, which are used only with a machine zero run in order to detect the end of the travel range.

In some cases, the function ” direction reversal via current” is also possible, then you will need no initiator, Compax3 detects the end of the travel range as a result of a rise in current. Please observe the respective notes.

During operation, the direction reversal switches are often used as limit switches.
Example axis with the initiator signals

1: | Direction reversal / limit switch on the end of the travel range ( change the assignment of the direction reversal/limit switch inputs to travel range side can be changed).
2: | Machine zero initiator (can, in this example, be released to 2 sides)
3: | Direction reversal/limit switch on the positive end of the travel range. ( assignment of the direction reversal/limit switches inputs on the side of the travel range can be changed).
4: | Positive direction of movement
5: | Signals of the motor zero point (zero pulse of the motor feedback)
6: | Signal of the machine zero initiator (without inversion of the initiator logic).
7: | Signal of the direction reversal resp. end switch on the positive end of the travel range (without inversion of the initiator logic).
8: | Signal of the direction reversal / resp. end switch on the negative end of the travel range (without inversion of the initiator logic).
9: | Signal of the machine zero initiator (with inversion of the initiator logic).
10: | Signal of the direction reversal / resp. end switch on the positive end of the travel range (with inversion of the initiator logic).
11: | Signal of the direction reversal / resp. end switch on the negative end of the travel range (with inversion of the initiator logic).
12: | Logic state of the home switch (independent of the inversion)
13: | Logic state of the direction reversal resp. end switch on the positive end of the travel range (independent of the inversion)
14: | Logic state of the direction reversal resp. end switch on the negative end of the travel range (independent of the inversion)

The following principle images of the individual machine zero modes always refer to the logic state (12, 13, 14) of the switches.


Homing modes with home switch (on X12/14)

In this chapter you can read about:

Debouncing the machine zero input (X12/14)

Without motor reference point

With motor reference point


Debouncing the machine zero input (X12/14)

Previous Topic

Next Topic

Debouncing the machine zero input (X12/14)

A majority gate is used for debouncing.

The signal is sampled every 0.5ms
The debounce time determines the number of scans the majority gate will perform.
If the level of more than half of the signals was changed, the internal status will change.

The debounce time can be set in the configuration wizard within the range of 0 ... 20ms.

The value 0 deactivates the debouncing.


Without motor reference point

Previous Topic

Next Topic

Without motor reference point


Without direction reversal switches

Previous Topic

Next Topic

Without direction reversal switches


MN-M 19.20: MN-Initiator = 1 on the positive side

Previous Topic

Next Topic

MN-M 19.20: MN-Initiator = 1 on the positive side

The MN initiator can be positioned at any location within the travel range. The travel range is then divided into 2 contiguous ranges: one range with deactivated MN initiator (left of the MN initiator) and one range with activated MN initiator (right of the MN initiator).

When the MN initiator is inactive (signal = 0) the search for the machine reference is in the positive travel direction.

Without motor zero point, without direction reversal switches

MN-M 19:The negative edge of the MN proximity switch is used directly as MN (home) (the motor zero point remains without consideration).

MN-M 20:The positive edge of the MN proximity switch is used directly as MN (home) (the motor zero point remains without consideration).

1: logic state


MN-M 21.22: MN proximity switch = 1 on the negative side

Previous Topic

Next Topic

MN-M 21.22: MN proximity switch = 1 on the negative side

The MN initiator can be positioned at any location within the travel range. The travel range is then divided into 2 contiguous ranges: one range with deactivated MN initiator (positive part of the travel range) and one range with activated MN initiator (negative part of the travel range).

When the MN initiator is inactive (signal = 0) the search for the machine reference is in the negative travel direction.

Without motor zero point, without direction reversal switches

MN-M 21:The negative edge of the MN proximity switch is used directly as MN (home) (the motor zero point remains without consideration).

MN-M 22:The positive edge of the MN proximity switch is used directly as MN (home) (the motor zero point remains without consideration).

1: logic state


With direction reversal switches

Previous Topic

Next Topic

With direction reversal switches

Machine zero modes with a home switch which is activated in the middle of the travel range and can be deactivated to both sides.

The assignment of the direction reversal switches can be interchanged.

Function Home in opposite direction when Current (Torque) limit is reached

If no direction reversal switches are available, the reversal of direction can also be performed during the machine zero run via the function ”direction reversal via current”.

Here the drive runs towards the mechanical limit mounted at the end of the travel range.

The current rises. When the adjustable current limit is reached, the drive is decelerated and changes the direction of movement.

Caution!

Wrong settings can cause hazard for man and machine.

It is therefore essential to respect the following:

  • Choose a low machine zero speed.
  • Set the machine zero acceleration to a high value, so that the drive changes direction quickly, the value must, however, not be so high that the current limit threshold is already reached by accelerating or decelerating (without mechanical limitation).
  • The mechanical limitation as well as the load drain must be set so that they can absorb the resulting kinetic energy.


MN-M 23..0.26: Direction reversal switches on the positive side

Previous Topic

Next Topic

MN-M 23..0.26: Direction reversal switches on the positive side

Without motor zero point, with direction reversal switches

1: Logic state of the home switch

2: Logic state of the direction reversal switch


MN-M 27..0.30: With direction reversal switches on the negative side

Previous Topic

Next Topic

MN-M 27..0.30: With direction reversal switches on the negative side

Without motor zero point, with direction reversal switches

1: Logic state of the home switch

2: Logic state of the direction reversal switch


With motor reference point

Previous Topic

Next Topic

With motor reference point


MN-M 3.4: MN-Initiator = 1 on the positive side

Previous Topic

Next Topic

MN-M 3.4: MN-Initiator = 1 on the positive side

The MN initiator can be positioned at any location within the travel range. The travel range is then divided into 2 contiguous ranges: one range with deactivated MN initiator (left of the MN initiator) and one range with activated MN initiator (right of the MN initiator).

When the MN initiator is inactive (signal = 0) the search for the machine reference is in the positive travel direction.

With motor zero point, without direction reversal switches

MN-M 3:The 1st motor zero point with MN proximity switch = "1" is used as MN.

MN-M 4:The 1st motor zero point with MN proximity switch = "1" is used as MN.

1: Motor zero point

2: Logic state of the home switch


MN-M 5.6: MN proximity switch = 1 on the negative side

Previous Topic

Next Topic

MN-M 5.6: MN proximity switch = 1 on the negative side

The MN initiator can be positioned at any location within the travel range. The travel range is then divided into 2 contiguous ranges: one range with deactivated MN initiator (positive part of the travel range) and one range with activated MN initiator (negative part of the travel range).

When the MN initiator is inactive (signal = 0) the search for the machine reference is in the negative travel direction.

With motor zero point, without direction reversal switches

MN-M 5:The 1st motor zero point with MN proximity switch = "0" is used as MN.

MN-M 6:The 1st motor zero point with MN proximity switch = "1" is used as MN.

1: Motor zero point

2: Logic state of the home switch


MN-M 7..0.10: Direction reversal switches on the positive side

Previous Topic

Next Topic

MN-M 7...10: Direction reversal switches on the positive side

With motor zero point, with direction reversal switches

Machine zero modes with a home switch which is activated in the middle of the travel range and can be deactivated to both sides.

1: Motor zero point

2: Logic state of the home switch

3: Logic state of the direction reversal switch


MN-M 11...14: With direction reversal switches on the negative side

Previous Topic

Next Topic

MN-M 11..0.14: With direction reversal switches on the negative side

With motor zero point, with direction reversal switches

Machine zero modes with a home switch which is activated in the middle of the travel range and can be deactivated to both sides.

1: Motor zero point

2: Logic state of the home switch

3: Logic state of the direction reversal switch


Machine zero modes without home switch


MN-M 35: MN at the current position

Previous Topic

Next Topic

MN-M 35: MN at the current position

The current position when the MN run is activated is used as an MN.


MN-M 128/129: current increase while moving to block

Previous Topic

Next Topic

MN-M 128/129: current increase while moving to block

Without an MN initiator, an end of travel region (block) is used as an MN.

The increase in the current is evaluated for this purpose (adjustable up to 100% of the reference current), if the motor is pressing against the end of the travel region. If the limit is exceeded, the MN is set. Following error is deactivated during the MN run.

Please observe:

The homing offset must be set so that the home (reference point) for positioning lies witihn the travel range.

MN-M 128:Travel in the positive direction to the end of the travel region

MN-M 129:Travel in the negative direction to the end of the travel region

Caution!

Wrong settings can cause hazard for man and machine.

It is therefore essential to respect the following:

  • Choose a low machine zero speed.
  • Set the machine zero acceleration to a high value, so that the drive changes direction quickly, the value must, however, not be so high that the current limit threshold is already reached by accelerating or decelerating (without mechanical limitation).
  • The mechanical limitation as well as the load drain must be set so that they can absorb the resulting kinetic energy.


MN-M 17.18: Limit switch as machine zero

Previous Topic

Next Topic

MN-M 17.18: Limit switch as machine zero

1: Logic state of the direction reversal switch

Function Home in opposite direction when Current (Torque) limit is reached

If no direction reversal switches are available, the reversal of direction can also be performed during the machine zero run via the function ”direction reversal via current”.

Here the drive runs towards the mechanical limit mounted at the end of the travel range.

The current rises. When the adjustable current limit is reached, the drive is decelerated and changes the direction of movement.

Caution!

Wrong settings can cause hazard for man and machine.

It is therefore essential to respect the following:

  • Choose a low machine zero speed.
  • Set the machine zero acceleration to a high value, so that the drive changes direction quickly, the value must, however, not be so high that the current limit threshold is already reached by accelerating or decelerating (without mechanical limitation).
  • The mechanical limitation as well as the load drain must be set so that they can absorb the resulting kinetic energy.


Machine zero only from motor reference

Previous Topic

Next Topic

Machine zero only from motor reference


MN-M 33,34: MN at motor zero point

Previous Topic

Next Topic

MN-M 33,34: MN at motor zero point

The motor reference point is now evaluated (no MN initiator):

Without home switch

MN-M 33:For a MN run, starting from the current position, the next motor zero point in the negative travel direction is taken as the MN.

MN-M 34:For a MN run, starting from the current position, the next motor zero point in the positive travel direction is taken as the MN.

1: Motor zero point


MN-M 130, 131: Determine absolute position via distance coding

Previous Topic

Next Topic

MN-M 130, 131: Acquire absolute position via distance coding

Only for motor feedback with distance coding (the absolute position can be determined via the distance value).

Compax3 determines the absolute position from the distance of two signals and then stops the movement (does not automatically move to position 0).

MN-M 130, 131

1: Signals of the distance coding


MN-M 1.2: Limit switch as machine zero

Previous Topic

Next Topic

MN-M 1.2: Limit switch as machine zero
End switch on the negative side

1: Motor zero point

2: Logic state of the home switch

End switch on the positive side:

1: Motor zero point

2: Logic state of the home switch


MN-M 132, 133: Determine absolute position via distance coding with direction reversal switches

Previous Topic

Next Topic

MN-M 132, 133: Acquire absolute position via distance coding with direction reversal switches

Only for motor feedback with distance coding (the absolute position can be determined via the distance value).

Compax3 determines the absolute position from the distance of two signals and then stops the movement (does not automatically move to position 0).

MN-M 1302, 133

1: Signals of the distance coding

2: Logic state of the direction reversal switches


Adjusting the machine zero proximity switch

This is helpful in some cases with homing modes that work with the home switch and motor reference point.

If the motor reference point happens to coincide with the position of the MN initiator, there is a possibility that small movements in the motor position will cause the machine reference point to shift by one motor revolution (to the next motor reference point).

1: Motor zero point

2: Logic state of the home switch

A solution to this problem is to move the MN initiator by means of software. This is done using the value initiator adjustment.

Initiator adjustment
Unit: Motor angle in degrees | Range: -360 ... 360 | Standard value: 0
Move the machine reference initiator using software


Machine zero speed and acceleration

With these values you can define the motion profile of the machine zero run.


Previous Topic

Next Topic

Travel Limit Settings


Software end limits

The travel range is defined via the negative and positive end limits.

Travel Limit Settings

1: negative end limit

2: positive end limit

Software end limit in absolute operating mode

The positioning is restricted to the range between the travel limits.

A positioning order aiming at a target outside the travel range is not executed.

Behaviour of software end limits

1: negative end limit

2: positive end limit

The reference is the position reference point that was defined with the machine reference and the machine reference offset.

Software end limits in reset mode

The reset mode does not support software end limits

Software end limit in continuous mode

Each individual positioning is confined within the travel limits.

A positioning order aiming at a target outside the software end limits is not executed.

The reference is the respective current position.

Error when disregarding the software end limits

A software end limit error is triggered, if the position value exceeds an end limit.
For this, the position setpoint value is evaluated in energized state; in currentless state, the actual position value is evaluated.

Hysteresis in disabled state:

If the axis stands currentless at an end limit, another error may be reported due to position jitter after acknowledging the end limit error. To avoid this, a hysteresis surrounding the end limits was integrated (size corresponds to the size of the positioning window).
Only if the distance between axis and the end limits was larger than the positioning window, another end limit error will be detected

Error codes of the end limit errors:

0x7323 | Error when disregarding the positive software end limit.
0x7324 | Error when disregarding the negative software end limit.

Activating / deactivating the end limit error:

In the C3 ServoManager under configuration: End limits, the error can be (de)activated.

For IEC-programmable devices with the "C3_ErrorMask" module.

Behavior after the system is turned on

The end limits are not active after switching on. The end limits do not refer to the position reference point until after a machine reference run.

During homing run the end limits are not monitored.

With a Multiturn encoder or with active Multiturn emulation, the limit is valid immediately after switching on.

Behavior outside the travel range

1. If the software end limit errors are deactivated, all movements are possible.
2. if the software end limit errors are activated:

After disregarding the software end limits, an error is triggered. First of all, this error must be acknowledged.

Then a direction block is activated: only motion commands in the direction of the travel range are executed. These will not trigger another error.

Motion commands inciting a movement in the opposite direction of the travel range are blocked and will trigger another error.

Software end limits behavior outside the travel range

1: negative end limit

2: positive end limit

Behavior outside the travel range I12
Behavior with software end limits of a referenced axis

Position within
target outside

Position outside
target outside and aiming in the opposite direction of the travel range

Position outside
target within and aiming in the direction of the travel range

JOG +/-
  • Positioning up to the end limits
  • No Error
  • No positioning
  • No Error
  • Positioning

MC_MoveAbsolute, MC_MoveRelative, MC_MoveAdditive,
MC_MoveSuperImposed
  • No positioning
  • Error
  • No positioning
  • Error
  • Positioning

MC_GearIn,
MC_Cam...
C3_Cam...
  • Positioning up to the end limits, from these on braking with the error ramp.
    The end limit is exceeded
  • Error
  • No positioning
  • Error
  • No positioning
  • Error

MC_MoveVelocity
  • Positioning up to the end limits
  • Error
  • No positioning
  • Error
  • Positioning

MC_Home
  • No monitoring of the software end limits

    The software end limit error can be deactivated in general via the configuration or separately for each end limit via the module C3_Error_Mask


Hardware end limits

Hardware end limits are realized with the aid of end switches.

These are connected to X12/12 (input 5) and X12/13 (input 6) and can be (de)activated separately in the C3 ServoManager under Configuration: End limits.

After a limit switch has been detected, the drive decelerates with the ramp values set for errors (error code 0x54A0 at X12/12 active, 0x54A1 at X12/13 active).

Please make sure that after the detection of the end switch there is enough travel path left up to the limit stop.

Behavior of hardware end limits

1: Limit switch E5 (X12/12)

2: Limit switch E6 (X12/13)

3: Limit switch position E5 (X12/12)

4: Limit switch position E6 (X12/13)

Assignment of the end switches can be exchanged!

Please note:

The limit switches must be positioned so that they cannot be released towards the side to be limited.

Behavior in the case of an active limit switch

The drive can then be moved out of the end switch range with a normal positioning.

The direction of the movement is verified!

Only the direction towards the travel range is allowed.

Limit switch / direction reversal switch

Limit switches functioning as direction reversal switches during homing run, will not trigger a limit switch error.

Hiding the limit switch error

(De)activate limite switch errors

The end limit error can be deactivated in general via the configuration or separately for each limit switch via the module C3_Error_Mask


Debouncing the limit switches

Previous Topic

Next Topic

Debouncing the limit switches

A majority gate is used for debouncing.

The signal is sampled every 0.5ms
The debounce time determines the number of scans the majority gate will perform.
If the level of more than half of the signals was changed, the internal status will change.

The debounce time can be set in the configuration wizard within the range of 0 ... 20ms.

The value 0 deactivates the debouncing.


Exchange assignment direction reversal / limit switches

If this function is not activated, the direction reversal / end switches are assigned as follows:

Direction reversal / limit switch on E5 (X12/12): negative side of the travel range

Direction reversal / limit switch on E6 (X12/13): Direction reversal / limit switch on E6 (X12/13):

Exchange assignment of direction reversal / limit switch is activated

If this function is activated, the direction reversal / limit switches are assigned as follows:

Direction reversal / limit switch on E5 (X12/12): positive side of the travel range

Direction reversal / limit switch on E6 (X12/13): negative side of the travel range


Change initiator logic

The initiator logic of the limit switches (this does also apply for the direction reversal switches) and the machine zero initiator can be changed separately.

  • Limit switch E5 low active
  • Limit switch E6 low active
  • Home switch E7 low active

    In the basic settings the inversion is deactivated, so that the signals are ”high active”.

    With this setting the inputs I5 to I7 can even be switched within their logic, if they are not used as direction reversal/limit switches or machine zero.


Defining jerk / ramps

In this chapter you can read about:

Ramp upon error and de-energize


Ramp upon error and de-energize

Ramp (delay) upon error and "De-energize"

Deceleration on error / deenergize I20

3: Deceleration upon error and upon deactivation of MC_Power


Monitoring / Limit Settings

In this chapter you can read about:

Current (Torque) Limit

Positioning window - Position reached

Following error limit

Maximum operating speed


Current (Torque) Limit

The current required by the speed controller is limited to the current limit.


Positioning window - Position reached

Position reached indicates that the target position is located within the position window.

In addition to the position window, a position window time is supported. If the actual position goes inside the position window, the position window time is started. If the actual position is still inside the position window after the position window time, "Position reached" is set.

If the actual position leaves the position window within the position window time, the position window time is started again.

When the actual position leaves the position window with Position reached = "1", Position reached is immediately reset to "0".

Position monitoring is active even if the position leaves the position window because of measures taken externally.

In Position Window (+/-)

1: Positioning window

2: positioning window time

POS: Setpoint position reached (== object 420.6 C3.PositioningAccuracy_PositionReached)


Following error limit

The following error is a dynamic error.

The dynamic difference between the setpoint position and the actual position during a positioning is called the following error. Do not confuse this with the static difference which is always 0; the target position is always reached exactly.

The change of position over time can be specified exactly using the parameters jerk, acceleration and speed. The integrated Setpoint value generator calculates the course of the target position. Because of the delay in the feedback loop, the actual position does not follow the setpoint position exactly. This difference is referred to as the following error.

Disadvantages caused by a following error

In joint operation of several servo controllers (e.g. master controller and slave controller), following errors lead to problems due to the dynamic position differences, and a large following error can lead to positioning overshoot.

Error message

If the following error exceeds the specified following error limit, the ”following error time” then expires. If the following error is even greater than the following error limit at the end of the following error time, an error is reported.

If the following error falls short of the following error limit, a new following error time is then started.

Minimizing the following error

The following error can be minimized with the help of the extended (advanced) controller parameters, in particular with the Feedforward parameters (feedforward of rotation speed, acceleration, current and jerk).

Tracking error limit I20

1: Tracking error limit

2: Tracking error time

ERROR:Error output of positioning modules

QUIT:Ackn with MC_Reset module


Maximum operating speed

The speed limitation is derived from the maximum operating speed. In order to ensure control margins, the speed is limited to a higher value.

The speed setpoint value is actively limited to 1.1 times the given value.

If the speed actual value exceeds the preset maximum speed by 21% (=”switching off limit speed”), error 0x7310 is triggered.


Encoder Output

You can make use of a permanently integrated encoder simulation feature to make the actual position value available to additional servo drives or other automation components.

Caution!

The encoder simulation is not possible at the same time as the encoder input resp. the step/direction input.

In both cases the same interface is used.

Simulated Encoder Output Resolution
Unit: Increments per revolution / pitch | Range: 4 - 16384 |  | Standard value: 1024
Adjustable in powers of two (2n): 1, 2, 4, 8, 16, 32, 64, 128, 256, 512, 1024, 2048, 4096, 8192, 16384 Limit frequency: 620kHz i. e.
Increments per revolution |  | Max. speed
1024 |  | 36000 min-1
4096 |  | 9000 min-1
16384 |  | 2250 min-1


Encoder bypass with Feedback module F12 (for direct drives)

If an encoder is used as feedback (with option F12), the encoder signals can be placed directly (Bypass) to the encoder interface (X11: same assignment as encoder simulation) for further use.

The advantage is that the limit frequency of the encoder simulation is avoided.


Recipe table

If you would like to work with the Recipe table,(e.g. for memorizing variable machine data) you can make preassignments in it with Compax3 ServoManager.

Note:

The recipe array can also be loaded separately into the device (>button on the right side).


Configuration name / comments

Here you can name the current configuration as well as write a comment.


Optimization

In this chapter you can read about:

Optimization

Control Loop Dynamics

Input simulation

Calibration of the analog input

Turning the motor holding brake on and off

The controller optimization of the Compax3 is carried out in 2 steps:

  • Via the standard settings (stiffness, damping, rotation speed controller and rotation speed filter), with the help of which many applications can be optimized in a simple manner.
  • With advanced settings for users familiar with control loops.


Optimization

In this chapter you can read about:

Commissioning mode

Several optimization aids are available:

  • Status Display
  • Oscilloscope function with export features
  • Calibration functions
  • Error history


Commissioning mode

Setup mode can be activated in the ServoManager under the menu item "Optimization".

The following functions are possible:

  • Machine reference run
  • Manual+ / Manual-
  • Activation / deactivation of the motor holding brake.
  • Acknowledging errors
  • Defining and activating a test movement
  • Activating the digital outputs.

In setup mode, access via interface and via digital inputs is deactivated.

Control word / Commissioning mode

The commissioning mode functions have priority over the bus commands for the control word.

Status word / Commissioning mode

The status word can also be updated in commissioning mode.


Control Loop Dynamics

In this chapter you can read about:

Velocity loop stiffness

Velocity loop damping

Velocity Filter

Advanced control parameters


Velocity loop stiffness
The stiffness is proportional to the control loop speed.

Nominal value: 100%

On increasing stiffness:

Control action becomes faster. The control loop oscillates above a critical threshold value. Set the stiffness with an adequate safety margin with respect to the oscillation threshold value.

On decreasing stiffness:

Control action becomes slower. This increases the following error. Current limiting will be reached later.

1: Commanded value

2: Actual value

3: Stiffness

2100.2: Velocity loop stiffness
Unit: % | Range: 10 ... 100 000 | Standard value: 100%
The stiffness is proportional to the control loop speed.


Velocity loop damping
The damping influences the Setpoint value overshoot magnitude and the decay time constant of control loop oscillation.

Nominal value: 100%

On increasing the damping:

Overshoot decreases. High frequency oscillation of the servo drive takes place as from a certain threshold value.

On decreasing the damping:

The Setpoint value overshoot of the actual value increases, and the actual value oscillates for a longer time above and below the Setpoint value. As from a certain threshold value the servo drive oscillates continuously.

Influence of the damping

1: Commanded value

2: Actual value

3: Damping

2100.3: Velocity loop damping
Unit: % | Range: 0 ... 500 | Standard value: 100%
The damping influences the Setpoint value overshoot magnitude and the decay time constant of control loop oscillation.


Velocity Filter

Can be used to improve (filter) the rotation speed signal. The greater the value, the stronger becomes the filter effect. However, the rotation speed delay increases with this value, so that the maximum possible control loop dynamic range becomes smaller with values which are too large.

  • Set the value to 0 when using motors with SinCos.
  • In the case of large load inertia in relation to the moment of inertia of the motor, a large value can achieve further improvement in the attainable stiffness.
2100.5: Velocity Filter
Unit: % | Range: 0 ... 550 | Standard value: 100%
This is used to improve signals (filtering) of the speed control signal


Advanced control parameters
Controller structure:

The status values are divided into 2 groups (user levels):

standard: here you can find all important status values

advanced: advanced status values, require a better knowledge

Switching of the user level

The user level can be changed in the optimization window (left hand side lower part under selection (TAB) "optimization") with the following button.

2100.8: Current Loop Bandwidth
Unit: % | Range: 10 ... 200 | Standard value: 50%

2100.9: Current Loop Damping
Unit: % | Range: 0 ... 500 | Standard value: 100%

2100.7: Velocity Loop - "D" Term
Unit: % | Range: 0 ... 4 000 000 | Standard value: 0

2100.6: Actual Acceleration Filter
Unit: % | Range: 0 ... 550 | Standard value: 100

2100.4: Moment of inertia
Unit: % | Range: 10 ... 500 | Standard value: 100%


Forward control measures
Feedforward of rotation speed, acceleration and current

Advantages:

  • Minimizes following error
  • Improves the transient response
  • Gives greater dynamic range with lower maximum current

Principle:

A positioning is calculated in the Setpoint value plate and specified as the Setpoint value for the position controller. This provides the Setpoint value plate with the preliminary information on changes in speed, acceleration and current required for positioning. Switching this information to the controller then makes it possible to reduce tracking errors to a minimum. The transient response of the controller is also improved and the drive dynamics are increased.

The stability of the control loop is unaffected by the forward control.


Positioning without forward control:

Previous Topic

Next Topic

Positioning without forward control:

Positioning without forward control:

without forward control


Velocity feedforward

Previous Topic

Next Topic

Velocity feedforward

2010.1: Velocity feedforward

Unit: % | Range: 0 ... 500 | Standard value: 100%
Effect of the rotation speed forward control

1: Rotation speed setpoint value

2: Rotation actual speed value

3: Motor current

4: Pos. error


Acceleration feedforward

Previous Topic

Next Topic

Acceleration feedforward

2010.2: Acceleration feedforward

Unit: % | Range: 0 ... 500 | Standard value: 100%
Additional effect of forward acceleration control

1: Rotation speed setpoint value

2: Rotation actual speed value

3: Motor current

4: Pos. error


Current feedforward

Previous Topic

Next Topic

Current feedforward

2010.4: Current feedforward

Unit: % | Range: 0 ... 500 | Standard value: 0%
Additional effect of current feedforward

1: Rotation speed setpoint value

2: Rotation actual speed value

3: Motor current

4: Pos. error


Jerk feedforward

Previous Topic

Next Topic

Jerk feedforward

2010.5: Jerk feedforward

Unit: % | Range: 0 ... 500 | Standard value: 0%


Input simulation

In this chapter you can read about:

Calling up the input simulation

Functionality

Function

The input simulation is used for the performance of tests without the complete input/output hardware being necessary.

The digital inputs (standard and inputs of M10/M12 option) as well as the analog inputs are supported.

The following operating modes are available for digital inputs:

  • The physical inputs are deactivated, the digital inputs are only influenced via the input simulation.
  • The digital inputs and the physical inputs are logically or-linked.
    This necessitates very careful action, as the required function is, above all with low-active signals, no longer available.

    The pre-setting of an analog input value is always made in addition to the physical analog input.

    the function of the inputs depends on the Compax3 device type; please refer to the respective online help or the manual.

The input simulation is only possible while the connection with Compax3 is active!


Calling up the input simulation

Open the optimization window (double klick in the C3 ServoManager tree entry: Optimization).

Activate the Tab ”Setup” in the right lower window.

Clicking on the following button will open a menu; please select the input simulation.


Functionality

Window Compax3 InputSimulator:

1st series: Standard inputs E7 ... E0 = ”0” button not pressed; = ”1” switch pressed

2nd series:Optional digital inputs (M10 / M12)

Green field: port 4 is defined as input

Red field: port 4 is defined as output

the least significant input is always on the right side

3rd series:if the button ”deactivating physical inputs” is pressed, all physical, digital inputs are deactivated; only the input simulation is active.

If both sources (physical and simulated inputs) are active, they are or-linked!
Caution!

Please consider the effects of the or-linking; above all on low-active functions.

4th series: Simulation of the analog inputs 0 and 1 in 100mV – steps.

The set value is added to the value on the physical input.

After the input simulation has been called up, all simulated inputs are on ”0”.
When the input simulation is left, the physical inputs become valid.


Calibration of the analog input

In this chapter you can read about:

Offset alignment

Gain alignment


Offset alignment

Performing an offset alignment when working with the ±10V analog interface in the optimization window under optimization: Analog Input.

Enter the offset value at 0V input voltage under ”701: Offset”

The currently entered value is shown in the status value "analogue input" (optimizing window at the top right) (unit: 1 º 10V). Enter this value directly with the same sign as offset value.

The status value "analogue input" shows the corrected value.


Gain alignment

Performing an offset alignment when working with the ±10V analog interface in the optimization window under optimization: Analog Input: 702: Gain.

A gain factor of 1 has been entered as default value.

The currently entered value is shown in the status value ”analogue input” (optimising window at the top right).

The status value "analogue input" shows the corrected value.


Turning the motor holding brake on and off

Compax3 controls the holding brake of the motor and the power output stage. The time behavior can be set.

Application:

For an axis to which torque is applied in the stationary state (e.g. for a z-axis) the drive can be switched on and off in a manner such that no load movement takes place. The drive thereby remains energized during the holding brake response time. This is adjustable.

The power output stage current is de-energized by:
  • Error or
  • by deactivating the MC_Power module
  • the ServoManager

Thereafter the motor is braked to zero rotation speed on the set ramp.

When zero speed is reached, the motor is de-energized with the delay "brake closing delay time".

Turning the motor holding brake on and off

1: Motor powered

2: Motor de-energized

3: Brake open

4: Engage the brake

5: brake closing delay time

The power output stage is enabled by:
  • Quit (acknowledge) (after error) with the MC_Reset module
  • by activating the MC_Power module
  • the ServoManager

The motor is energized with the delay "delay time for brake release".

Turning the motor holding brake on and off

1: Motor powered

2: Motor de-energized

3: Brake open

4: Engage the brake

5: Delay time for brake release


Configuring the master signal sources

In this chapter you can read about:

Physical source

Internal virtual master

HEDA Master signal source

Under the tree entry ”Signal source” of the C3 ServoManager you can configure 3 signal sources for Master – Slave applications.

The master signal source can then be selected in the IEC program with the aid of the C3_MasterControl module via the input ”Master”.

3 signal sources are available:

  • Physical source
    • analog value above +/-10V
    • Encoder signal A/B (5V)
    • Step/Direction signal (5V)
  • Internal virtual Master (IEC-Programm)
  • HEDA

    the "use as current signal source" CheckBox can be found in the signal source configuration wizards.

    This CheckBox is only important for Compax3 Firmware versions < V2.05.

    Use this to set the signal source for the CoDeSys program.


Physical source

In this chapter you can read about:

Encoder A/B 5V or step/direction as signal source

+/-10V Master speed


Encoder A/B 5V or step/direction as signal source

Caution!

The encoder simulation is not possible at the same time as the encoder input resp. the step/direction input.

In both cases the same interface is used.

The dimensional reference to the master is established via the following settings:

  • Travel path per motor revolution master axis numerator
    With denominator = 1 the value can be entered directly.
    Long-term drift can be avoided by entering non-integral values integrally as a fraction with numerator and denominator.
  • Travel distance per motor revolution master axis denominator
Increments per revolution of master axis
  • Increments per revolution of the master axis

If required the direction of rotation of the master axis read in can be changed.


Example: Electronic gearbox with position detection via encoder

Reference to master axis

The reference to the master axis is established via the increments per revolution and the travel path per revolution of the master axis (corresponds to the circumference of the measuring wheel).

The rule for this is:

MasterPos = | Master_I | * | Travel Distance per Master Axis revolution (M_Units/rev) | (1)
 | I_M |  | Travel Distance per Master Axis revolution - Denominator

MasterPos: Master position

Master_I: master increments read in

I_M: Increments per revolution of the master axis

External signal source

Encoder with 1024 increments per master revolution and a circumference of the measuring wheel of 40mm.

Settings:

Travel path per revolution of the master axis numerator = 40

Travel path per revolution of the master axis denominator = 1

Increments per revolution of the master axis = 1024

Configuration wizard:

Reference system of Slave axis: Unit of measure [mm]

Travel path per revolution numerator = 1

Travel path per revolution denominator = 1

Gearing:

Gearing numerator = 2

Gearing denominator = 1

This results in the following interrelations:

If the measuring wheel moves by 40mm (1 master revolution), the slave axis will move by 80mm.

Slave unit = MasterPos *

Gearing numerator

(2)

Gearing denominator

(1) set into (2) and with numerical values results with 1024 increments read in (=1 Master revolution):

Slave unit = 1024 * | 1 | * | 40mm | * | 2 | = 80mm
 | 1024 |  | 1 |  | 1

Master - Position = +40mm => Slave - Position = +80mm

Structure:
Master | Z1 | MasterPos | Gearing numerator | Slave - | N2 | Slave_U | Gearboxes | Load
 | N1 |  | Gearing denominator | Units | Z2 | to motor |  |

detailed structure

with:

MD = | Z1 | * | Travel Distance per Master Axis revolution (M_Units/rev) | Entry in the ”configuration of the signal source” wizard
 | N1 |  | Travel Distance per Master Axis revolution - Denominator

SD = | Z2 | * | Travel path per revolution slave axis numerator | Entry in the ”configuration of the signal source” wizard
 | N2 |  | Travel path per revolution slave axis denominator

MD: | Feed of the master axis
SD: | Feed of the slave axis


+/-10V Master speed

The velocity of the master is read in via the analog channel 0 (X11/9 and X11/11).

From this value a position is internally derived.

The reference to the master is established with the velocity at 10V.

If required the direction of rotation of the master axis read in can be changed.


Time frame signal source master

Averaging and a following filter (interpolation) can help to avoid steps caused by discrete signals.

If the external signal is analog, there is no need to enter a value here (Value = 0).

For discrete signals e.g. from a PLC, the scanning time (or cylce time) of the signal source is entered.

time frame predefined setpoint value

This function is only available if the analog interface +/-10V is used!


Internal virtual master

In this chapter you can read about:

The reset distance of the virtual master is only used for resetting the displayed value (Object680.2).

The travel per motor revolution of the master axis (numerator/denominator) is set to 1 for a virtual master.

If required the direction of rotation of the master axis read in can be changed.


HEDA Master signal source

Please choose if the virtual master of the HEDA master is transmitted via the HEDA.

If yes, the input ”travel per revolution” is not necessary, as a positioning signal is already present.

The dimensional reference to the master is established via the following settings:

  • Travel path per motor revolution master axis numerator
    With denominator = 1 the value can be entered directly.
    Long-term drift can be avoided by entering non-integral values integrally as a fraction with numerator and denominator.
  • Travel distance per motor revolution master axis denominator

If required the direction of rotation of the master axis read in can be changed.


Motion control

In this chapter you can read about:

Programming based on IEC61131-3

Status diagrams

Control functions

Reading values

Motion functions (standard)

Superimposed motion

Electronic gearbox (MC_GearIn)

Cam

Cam switching mechanism

Error handling

Process image

Interface to C3 powerPLmC

IEC examples


Programming based on IEC61131-3

In this chapter you can read about:

Requirements

CoDeSys / Compax3 target system (Target Package)

Languages supported

Function range supported

Data types supported

Retain Variables

Recipe table with 9 columns and 32 lines

Maximum program size

Cycle time

Access to the Compax3 object directory

Compilation, debugging and down/upload of IEC61131 programs

General rules / timing

Library constants


CoDeSys / Compax3 target system (Target Package)

Caution! New target system files (targets) for T30 and T40!

Beginning with Compax3 software version V2.0, two new Compax3 targets are included with delivery (containing module and object descriptions).

  • CoDeSys for C3 T30: for Compax3 T30 (beginning with Compax3 software version V2.0)
  • CoDeSys for C3 T40: for Compax3 T40 (beginning with Compax3 software version V2.0)

    The old target is still available for programs that were created earlier (created with Compax3 software version < V2.0).

  • CoDeSys for Compax3: for Compax3 T30

    This programs are thus still capable of running.

    When migrating to a new target, you must be certain that the module and object names have been changed.

    Edit the appropriate parts of the IEC program accordingly.


Program development and test

Program development

CoDeSys is the development environment for control systems which will help you develop Compax3 IEC61131 programs. CoDeSys is called up from the Compax3 ServoManager (under ”programming: IEC61131-3 development environment")

The IEC program can be integrated into the C3 ServoManager project or exported again from the project as required.

When CoDeSys is brought up, the IEC program stored in the project is opened. If the project does not contains an IEC program, a selection dialog appears.

Download to Compax3

After the IEC61131 program has been developed and compiled with CoDeSys, it is downloaded to Compax3 by means of the ServoManager (in ”Download: IEC61131-3").

Program test

For testing your program directly with Compax3, you may use the Compax3 IEC61131-3 debugger (the debug functions of CoDeSys are not supported in conjunction with Compax3). The debugger is called up from the ServoManager (under Programming: IEC61131-3 debugger). It automatically accesses the last IEC61131-3 program in the ServoManager to be loaded into Compax3 with "Download: IEC61131-3" and makes its modules and variables available in the project tree.

The data from Compax3 are read via the instruction ”log in”. Please note in this regard that the interface to Compax3 can only be assigned once: Online functions in the ServoManager such as Upload, Download, Status display in the Optimization window or oscilloscope functions are not possible simultaneously. These functions interrupt the connection between debugger and Compax3 automatically.


Recipe management

The recipe management function in CoDeSys is not supported in conjunction with Compax3. Please use the recipe table available in Compax3 (also see in the configuration wizard).


Languages supported

  • IL (Instruction List)
  • ST (Structured Text)
  • FBD (Function block diagram)
  • CFC (continuous function chart editor)
  • LD (Ladder diagram)


Function range supported

In this chapter you can read about:

Operators supported

Standard functions supported

Standard function modules supported


Operators supported
IL | FBP / CFC / SFC | ST
LD(N) |  |
ST(N) |  |
R |  |
S |  |
AND(N) | AND | AND(N)
OR(N) | OR | OR(N)
XOR(N) | XOR | XOR(N)
NOT | NOT | NOT
ADD | ADD | +
SUB | SUB | -
MUL | MUL | *
DIV | DIV | /
GT | GT | >
GE | GE | >=
EQ | EQ | =
NE | NE | <>
LE | LE | <=
LT | LT | <
RET | RET | RETURN
 | MOVE |
 |  | :=
CAL(C/N) |  |
JMP(C/N) |  |
 |  | CASE
 |  | DO
 |  | ELSE
 |  | ELSIF
 |  | END_CASE
 |  | END_FOR
 |  | END_IF
 |  | END_REPEAT
 |  | END_WHILE
 |  | EXIT
 |  | FOR
 |  | IF
 |  | REPEAT
 |  | THEN
 |  | TO
 |  | UNTIL
 |  | WHILE


Standard functions supported
Bit manipulation functions

SHL, SHR, ROL, ROR

Numeric functions

ABS, SQRT, SIN, COS

Functions for type conversion
Type conversions x_TO_y | X=Source data type, Y=Target data type
TRUNC |
Functions for selection
MIN | Not for BOOL /WORD / DWORD
MAX | Not for BOOL /WORD / DWORD
LIMIT | Not for BOOL /WORD / DWORD
SEL | Not for BOOL /WORD / DWORD


Standard function modules supported
FlipFlops

RS, SR,

Trigger

R_TRIG, F_TRIG,

Numerator

CTU, CTD, CTUD,

Timer

TON, TOF, TP,

max. 8 pcs., time resolution 0.5ms
(the number of timers required is displayed in the CoDeSys output window during compilation)


Data types supported

The following data types are available for IEC61131-3 programming:
Name | Division | Format
BOOL | Status values: TRUE or FALSE | Logical variable.
INT | -32768...32767 | 16-bit integer: Fixed point number without places after the decimal
DINT | -2147483648...2147483647 | 32-bit integer: Fixed point number without places after the decimal
REAL |  | 32-bit floating point: 16 bits before the decimal and 16 bits after the decimal
WORD | 0...65535 | 16-bit bit sequence (no range of values)
DWORD | 0...4294967295 | 32-bit bit sequence (no range of values)
TIME | 0...4194,3035s | 32 Bit - Format (resolution: 0.5 ms)
ENUM | User-defined type of enumeration (local enumerations are not supported)

Altogether 500 16-bit variables are available. These include BOOL, INT, and WORD.

Altogether 150 32-bit variables are available. These include DINT,DWORD,TIME,REAL.

The number of the required variables is displayed in the CoDeSys output window during compilation.


Retain Variables

6 retain variables (variables that are safe from power failure) are available

  • 3x16-bit retain-variables
  • 3x32-bit retain-variables


Recipe table with 9 columns and 32 lines

An array, i.e. a table with 9 columns and 32 rows, is available to store values.
This table is freely assignable and can be used for example to store position sets or for recipe management.
In addition, this table can be used to exchange data with an external control system or a POP, for example.

The layout of the table is as follows:
Column 1 Type: REAL Objects O1901 | Column 2 Type: REAL Objects O1902 | Column 3 Type: INT Objects O1903 | Column 4 Type: INT Objects O1904 | Column 5 Type: INT Objects O1905 | Column 6 Type: DINT Objects O1906 | Column 7 Type: DINT Objects O1907 | Column 8 Type: DINT Objects O1908 | Column 9 Type: DINT Objects O1909
Row 1 "C3Array_Col1_Row1" (1901.1) | Row 1 "C3Array_Col2_Row1" (1902.1) | Row 1 "C3Array_Col3_Row1" (1903.1) | Row 1 "C3Array_Col4_Row1" (1904.1) | Row1 "C3Array_Col5_Row1" (1905.1) | Row 1 "C3Array_Col6_Row1" (1906.1) | Row 1 "C3Array_Col7_Row1" (1907.1) | Row 1 "C3Array_Col8_Row1" (1908.1) | Row 1 "C3Array_Col9_Row1" (1909.1)
... | ... | ... | ... | ... | ... | ... | ... | ...
... | ... | ... | ... | ... | ... | ... | ... | ...
... | ... | ... | ... | ... | ... | ... | ... | ...
Row 32 "C3Array_Col1_Row32" (1901.32) | Row 32 "C3Array_Col2_Row32" (1902.32) | Row 32 "C3Array_Col3_Row32" (1903.32) | Row 32 "C3Array_Col4_Row32" (1904.32) | Row 32 "C3Array_Col5_Row32" (1905.32) | Row 32 "C3Array_Col6_Row32" (1906.32) | Row 32 "C3Array_Col7_Row32" (1907.32) | Row 32 "C3Array_Col8_Row32" (1908.32) | Row 32 "C3Array_Col9_Row32" (1909.32)

In addition to direct access to every individual field in the table, direct access is also possible through pointer addressing.
To do this, the table pointer "C3ArrayPointer_Row" (Object 1900.1) must be set to the desired rows.
This makes access to Columns 1 through 9 of the referenced rows possible through "C3Array_Indirect_Col1" to "C3Array_Indirect_Col9" (objects 1910.1 to 1910.9).


Maximum program size

Up to 5000 (IL) instructions are possible (please note that function modules that are integrated also require program memory).

The number of instructions generated is displayed in the CoDeSys output window by the Compax3 compiler during interpretation.


Cycle time

Minimal cycle time: 1ms.

The cycle time can be adjusted with the Compax3 ServoManager when downloading IEC61131-3 programs.

It is possible to optimize later in the optimization display of the Compax3 Servomanager. The cycle time is displayed there in increments of 500 µs (2 = 1 ms; 3 = 1.5 ms; etc.).

The IEC61131-3 program is stopped cycle time of 0.


Access to the Compax3 object directory

All Compax3 objects are encapsulated in the "C3" program module.

Access to Compax3 Objects in CoDeSys:

Access to Compax3 objects

Compax3 objects are divided into groups:

C3. | Compax3 - Objects
C3Array. | Recipe List
C3Pop. | Objects for the Parker Operator Panel Pop.
C3Cam. | Objects for T40 cam control.
C3Plus. | Additional objects that are generally not required.
C3Scope. | Objects for programming the oscilloscope functions.

The object name reveals the group assignment.


Compilation, debugging and down/upload of IEC61131 programs

  • Translating IEC61131-3 programs in CoDeSys
  • Downloading or uploading of IEC61131-3 programs with the Compax3 ServoManager.
  • The debugger is called up from the C3 ServoManager under ”Programming: IEC61131-3 debugger” called up.

Note:

Before compiling you have to enter for which Compax3 versions the compilation is to be executed.
Please note that when selecting ”all versions” not all functions are available, only the minimal range of functions is supported.

Only if the latest firmware version was selected (and the corresponding firmware is loaded in the target Compax3) all functions described here are supported.


Library constants

The following global constants are declared in the PLCopen function module library:

Name | Type | Description
For power supply of the axis inputs/outputs of modules:
Axis_Ref_LocalAxis | INT | Local axis (physically present axis)
Axis_Ref_Virtual | INT | virtual Master (only with T40)
AXIS_REF_LocalCam | INT | Local Cam axis (physically present axis)

For the selection of the master signal source:
AXIS_REF_Physical | INT | for +/-10V analog input, step / direction input 5V or Encoder A/B input 5V (depending on the configuration of the physical source under signal source)
Axis_Ref_Virtual | INT | virtual Master
Axis_Ref_HEDA | INT | HEDA
Axis_Ref_ActualPosition | INT | reserved (actual position value)
Axis_Ref_ReferencePosition | INT | reserved (position Setpoint value)
General constants
MC_Direction_Positive | INT | For supply of the Direction input of the MC_MoveVelocity module (for positive rotational direction)
MC_Direction_Negative | INT | For supply of the Direction input of the MC_MoveVelocity module (for negative rotational direction)
MC_Direction_Current | INT | For supply of the Direction input of the MC_MoveVelocity module (retaining the last rotational direction to be selected)
Direction_Memory | INT (Variable) | The MC_MoveVelocity modules instances store the last direction parameter in this variable. This variable can only be used by Motion Control modules and must not be overwritten!
OutputSelect_C3Output | INT | for the C3_OutputSelect module: Assignment of the source for the respective output to module "C3_Output".
OutputSelect_FastCam | INT | for the C3_OutputSelect module: Assignment of the source for the respective output to the respective fast cam.


Previous Topic

Next Topic

Status diagrams


Compax3 – status diagram

Status diagram T40

  • C3 Ixx T30 Functions: Transitions and states as continuous line, text not in italics
  • C3 Ixx T40 Functions: complete status diagram, all functions
  • Special T40 functions are displayed in italics and in dashed line
  • MC_Power.Enable = FALSE changes to "not powered" from any state (apart from ErrorStop).


Virtual Master

The IEC program can be created for 2 axes:

  • The Slave axis (the present Compax3)
  • A virtual Master whose position value can be used as a master position.

    The axis can be selected with the "Axis" input.

    The rule for this is:

  • Axis = AXIS_REF_LocalAxis: Slave axis
  • Axis = AXIS_REF_Virtual: virtual Master
Status diagram of the virtual master

Status diagram virtual master

Create a program for the virtual axis.

The virtual axis supports the function modules listed in the status diagram.

To do so, the input/output variable ”Axis” is assigned to the constant ”AXIS_REF_Virtual”.

The position value of the virtual axis can be used as master signal source.

Note:

Please note that the virtual axis is only available for function modules listed in the status diagram.


Control functions

In this chapter you can read about:

Energizing the power output stage (MC_Power)

Stop (MC_Stop)

Opening the brake (C3_OpenBrake)


Opening the brake (C3_OpenBrake)

FB name

C3_OpenBrake

Opening the motor holding brake – works only with no current (standstill - not powered)

VAR_INPUT

OpenBrake

BOOL

"TRUE" opens the motor holding brake

When current is being supplied to the drive, the input has no function.


Reading values

In this chapter you can read about:

Reading the current position (MC_ReadActualPosition)

Read access to the (C3_ReadArray) array

Reading the device status (MC_ReadStatus)


Reading the current position (MC_ReadActualPosition)

FB name

MC_ReadActualPosition

Reading the current axis position
VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names
VAR_INPUT

Enable

BOOL

Activates the module, continuous reading of the axis position as long as Enable=TRUE
VAR_OUTPUT

Done

BOOL

Position value available

Error

BOOL

Error while reading the position

Position

REAL

Axis position

Note: -

You can read the current position of the axis with this module.
As long as the input parameter "Enable" = TRUE, the current parameter value will be supplied to the output parameter "Position"cyclically.

The status of the input parameter must be present for at least one module call.

The following illustration shows the behavior of parameters in the MC_ReadActualPosition function module.


Read access to the (C3_ReadArray) array

FB name

C3_ReadArray

This module is used for simplified read access to the array (recipe table).
VAR_INPUT

Enable

BOOL

The desired rows can be read with the Enable input (after selecting "Row").

Row

INT

The desired row in the table must be created at the end of the Row module input.
this input works with object 1900.1; please take this into consideration, if you directly access the object 1900.1 in addition.
VAR_OUTPUT

Error

BOOL

Error as an output indicates that an error was encountered while reading the array
(a row that does not exist selected on the Row input).

Col1 – Col9

REAL
INT
DINT

The individual columns of the array can be accessed through outputs Col1 through Col9.

Notes: Rows will be read cyclically as long as Enable = TRUE.


Motion functions (standard)

In this chapter you can read about:

Absolute positioning (MC_MoveAbsolute)

Relative positioning (MC_MoveRelative)

Additive positioning (MC_MoveAdditive)

Continuous positioning (MC_MoveVelocity)

Manual operation (C3_Jog)

Homing (MC_Home)

Current setting operation (C3_Current)


Manual operation (C3_Jog)

FB name

C3_Jog

Traveling along the axis in manual mode (in the "standstill" state)
VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names

(Axis_Ref_LocalAxis oder Axis_Ref_Virtual)
VAR_INPUT

JogForward

BOOL

JogForward = TRUE makes the axis move in positive direction.

JogBackward

BOOL

JogBackward = TRUE makes the axis move in negative direction. <Value range>

MoveVelocity

REAL

Speed value [Units/s] <Value range>

Acceleration

DINT

Value of the acceleration [Units/s²] <Value range>

Deceleration

DINT

Value of deceleration with stop [Units/s²] <Value range>

Jerk

DINT

Value of the acceleration and deceleration jerk [Units/s³] <Value range>
VAR_OUTPUT

Busy

BOOL

Module is active (manual operation in progress)

Error

BOOL

Error during manual operation or faulty parameter when starting manual operation
Note:
  • The axis must be in the "standstill" state in order to start manual operation (Jogging Mode).
  • Start: When starting manual operation, the output ”Busy” is set to TRUE.
  • Stop: The axis is brought to a standstill if the respective input (JogForward or JogBackward) is set to FALSE again
  • As soon as manual operation is stopped, the output ”Busy” is set to FALSE. Further commands can only be executed after this feedback.

Example: Manual movement via digital inputs.


Current setting operation (C3_Current)

FB name

C3_Current

Current control. Speed and position controllers are switched off.
The system controls to the specified current.

The current setting can be made with the module input or with an analog input.
VAR_IN_OUT

Axis

C3_AXIS_REF

Symbolic axis names
VAR_INPUT

Execute

BOOL

Starts the sequences of the module with positive edge

Current

INT

Current to be set in [mA]

Mode

INT

0 = The current read during Execute on the Current input is set.

3 = After Execute, the Current input is read again in each cycle and the corresponding current is set (Execute must be permanently present for this mode).
VAR_OUTPUT

InCurrent

BOOL

Specified current set

CommandAborted

BOOL

Command aborted

Error

BOOL

Error

Note:

  • The power supply current (optimization parameter) is set to 100% to operate C3_Current.
  • The status ”current control” must be aborted with MC_Stop before new positionings are possible.


Previous Topic

Next Topic

Superimposed motion


Dynamic positioning

Dynamic positioning processes can be performed with the modules MC_MoveAbsolute, MC_MoveRelative and MC_MoveAdditive. The speed can be altered dynamically with MC_MoveVelocity.

In the state: ”Discrete Motion”

If another, second positioning process is activated in the "Discrete Motion" the 1st positioning process will be interrupted. The transition to the new destination occurs dynamically, i.e. without any intervening stop.

Note the following in this regard:
  • The new position / distance and the speed are taken over by the second positioning process.
  • The values for acceleration, deceleration and jerks are not taken over. The values of the original positioning process apply.
In "Continuous Motion" state

If a positioning process is activated in the "Continuous Motion" (MC_MoveAbsolute, MC_MoveRelative oder MC_MoveAdditive) or a MC_MoveVelocity the active function module will be interrupted. All input variables of the new positioning process will then be taken over.

Superimposed positioning

Please note also the difference to superimposed positioning with MC_MoveSuperImposed.

Here, the movement of the active function module is executed until the end.


Superimposed positioning (MC_MoveSuperImposed)

FB name

MC_MoveSuperImposed

Superimposing of an active positioning with an additional relative distance.

The positioning process that is currently underway is not interrupted by MC_MoveSuperImposed; it is superimposed instead
VAR_IN_OUT

Axis

INT

Axis ID; constant: AXIS_REF_LocalAxis
VAR_INPUT

Execute

BOOL

Starts the sequences of the module with positive edge

Distance

REAL

Additional distance for superimposed positioning (configured unit [units]) (positive and negative direction) <Value range>

MoveVelocity

REAL

Value of the max. speed difference to the speed of the actual positioning (always positive) (is not necessarily reached) [Units/s] <Value range>

Acceleration

DINT

Value of acceleration (always positive) [units/s²] <Value range>

Deceleration

DINT

Value of deceleration (always positive) [units/s²] <Value range>

Jerk

DINT

Value of the acceleration jerk [Units/s³] (always positive) <Value range>

JerkDecel

DINT

Value of deceleration jerk [units/s³] (always positive) <Value range>
VAR_OUTPUT

Done

BOOL

Additional distance was added to the current positioning

Busy

BOOL

Superimposed motion is performed

CommandAborted

BOOL

Positioning aborted

Error

BOOL

Error while executing module
Note:
  • The values Distance, Velocity, Acceleration, Deceleration, Jerk JerkDecel are no absolute values, they are added to the current movement.
  • A stop of the axis will interrupt the current as well as the superimposed movement.
  • In the PLCopen state "Standstill" the MC_MoveSuperImposed module acts like the MC_MoveRelative module.
  • MC_MoveSuperImposed does not interrupt an active command.
  • ”Position reached” (Object 420.6) is not influenced by the additional movement triggered by MC_MoveSuperImposed.
  • This module cannot be operated with C3_ShiftPosition and MC_Phasing at a time.
  • The position of the module in the structure image.


Zero point shift caused by superimposed positioning (C3_ShiftPosition)

FB name

C3_ShiftPosition

Subordination of a relative distance, which causes a shift of the reference point, i.e. the system zero point (home) shifts by this relative distance. The drive performs a physical movement which is, however, not displayed.

The positioning being executed at that time is not interrupted by C3_ShiftPosition.
Application: Slave reg synchronization.
VAR_IN_OUT

Axis

INT

Axis ID; constant: AXIS_REF_LocalAxis
VAR_INPUT

Execute

BOOL

Starts the sequences of the module with positive edge

Distance

REAL

Distance of the offset (configured unit [units] ) (positive and negative direction) <Value range>

MoveVelocity

REAL

Value of the maximum speed difference (always positive) (not necessarily reached) [units/s] <Value range>

Acceleration

DINT

Value of acceleration (always positive) [units/s²] <Value range>

Deceleration

DINT

Value of deceleration (always positive) [units/s²] <Value range>

Jerk

DINT

Value of the acceleration jerk [Units/s³] (always positive) <Value range>

JerkDecel

DINT

Value of deceleration jerk [units/s³] (always positive) <Value range>
VAR_OUTPUT

Done

BOOL

Relative distance was reached

Busy

BOOL

Shift is being executed

CommandAborted

BOOL

Positioning aborted

Error

BOOL

Error while executing module
Note:
  • The values Distance, Velocity, Acceleration, Deceleration, Jerk JerkDecel are no absolute values, they are added to the current movement.
  • In the PLCopen "Standstill" state, the axis performs a relative movement, during which the axis moves, but the displayed position is not changed.
  • In the PLCopen "Discrete Motion" state, the speed and the position of the active movement are superimposed, but the displayed speed and position are not changed.
  • In the case of a stop command on the axis, the current movement is interrupted as well as the shift.
  • C3_ShiftPosition does not interrupt any active command.
  • This module cannot be operated with MC_MoveSuperImposed and MC_Phasing at a time.
  • The position of the module in the structure image.


Electronic gearbox (MC_GearIn)

FB name

MC_GearIn

Controlled speed and position synchronicity with adjustable transmission ratio
VAR_IN_OUT

Master

INT

Constant for the master signal source (Library constants, Library constants)

Configuration of the signal sources

Slave

C3_AXIS_REF

Symbolic axis names
VAR_INPUT

Execute

BOOL

Starts the sequences of the module with positive edge

RatioNumerator

REAL

Transmission ratio of numerator

RatioDenominator

INT

Transmission ratio of denominator

Acceleration

DINT

Value of acceleration / deceleration (always positive) until the synchronism is reached [Units/s²] <Value range>
VAR_OUTPUT

InGear

BOOL

Synchronicity achieved

CommandAborted

BOOL

Command aborted

Error

BOOL

Error while executing module
Note:
  • The transmission ratio can be changed at any time with a positive edge on Execute. InGear is reset until synchronicity is achieved again.
  • For example, if speed synchronicity is not achieved because of limiting effects, the position difference that arises will be made up.
  • Acceleration / deceleration to the set transmission ratio takes place without a jerk limit.
  • If the master and slave units do not correspond, this fact must be considered for the transmission ratio.
  • Example


Cam

In this chapter you can read about:

Overview

Basics

Generating cams

Cam function structure

Master signal source

Control of the cam generator (C3_CamTableSelect)

Alignment of the slave axis

10 Steps for cam generation

Cam applications


Overview

T40 Functions: Cam

General
  • Cam control function
  • Programmable based on IEC61131-3
  • Position of selected master signal source via:
    • Encoder, Step / direction
      or +/-1 0V analog
    • HEDA
    • Virtual Master

Cam memory
  • 10.000 interpolation points
    (master / slave in 24 bit format)
    saved failure save.
  • Distance of interpolation points can be adapted to curve (non equidistant interpolation points)
  • Linear interpolation between points

Linking curve segments
  • Up to 20 cam segments can be produced.
  • Virtually random cam links (forwards and backwards)
  • Freely programmable, event-triggered curve branching.
  • Scalable cam segments and complete cam profiles

Coupling and decoupling functions
  • With the aid of a quadratic function.
  • By means of a change-over function
  • Without overspeeding by coupling over several master cycles.
  • Virtually free set-up of the coupling and decoupling movement
  • master-guided coupling movement.
  • Random standstill position

Mark synchronization
  • Master or slave oriented (simultaneous, cam-independent).
  • highly precise mark recognition (accuracy < 1 µs)

Cam generation with renowned Nolte tool.
  • Standard or extended range of functions
  • evaluation of the motion profiles.


Basics

In this chapter you can read about:

Cam types

Cam parameters / terms

Basic procedure


Cam types

There are two principal curve types:

Closed curve

The start and end positions of the Slave are identical. I.e. the Slave moves always within the same position range.

ST: | Slave clock distance
MT: | Master clock distance

Open curve

The start and the end position of the Slave are not identical. I.e. the Slave moves in one direction, as at the end of the curve the actual position of the Slave is compared to the start position of the curve.

ST: | Slave clock distance
MT: | Master clock distance


Cam parameters / terms
Example:

ST: | Slave clock distance
MT: | Master clock distance
ME: | Coupling position
MS: | Synchronous position
MA: | Decoupling position
MB: | Braking position
S0: | Standstill position of the Slave

Master clock distance (MT)

The Master clock distance is the distance which the master runs, i.e. after which the cycle is repeated. This distance is stated in the physical unit of the Master.

After this distance, the curve is repeated.

Slave clock distance (ST)

The Slave clock distance is the distance which the Slave runs, stated in the physical unit of the Slave.

Coupling position (ME)

Master position, where the coupling sequence starts.

Synchronous position (MS)

The coupling sequence is finished, if the master has reached the synchronous position MS, i.e. at the master position MS the slave is synchronous to the curve (MS > MT possible).

Decoupling position (MA)

Via the decoupling position MA the decoupling sequence can be started in a defined fashion from a certain master position (MA) on (dependent on the decoupling operating mode selected).

Braking position (MB)

At this master position, the slave comes to a standstill after decoupling (MB > MT possible).

Standstill position Slave (S0)

Target position of the slave axis after decoupling.

Back stop

The back stop can be enabled if required (IEC module: C3_MasterControl).

It ensures that a backwards movement of the master will not incite an axis movement of the slave.

Example:

1: Master signal after back stop

2: Master signal before back stop

3: Backwards movement of the master

4: Forwards movement of the master corresponding to the backwards movement.

Note:

The negative distance difference caused by the backwards movement of the master (3) must be traveled in positive direction (4), before it can be effective as a movement.


Basic procedure

When implementing a standard cam application, the following steps are necessary:

  • Create curve and load into Compax3.
  • Setting the master position detection
  • Establish relationship between master position read in and curve.
  • Select curve.
  • Start curve operation in a defined fashion.
  • Establish relationship with slave position (coupling).
  • Finish curve operation in a defined fashion (decoupling).


Generating cams

In this chapter you can read about:

Introduction to the CamDesigner (example)

Cam functions of the Compax3 ServoManager / motion laws

The curve creation software "C3 CamDesigner" is a separate program and must therefore be installed separately.

You will find the program on the Compax3 CD.


Introduction to the CamDesigner (example)

Prerequisite:

Compax3 is configured

Compax3 ServoManager is installed (can be found on the Compax3 CD).

C3 CamDesigner is installed (can be found on the Compax3 CD).

Settings:
  • Travel distance per motor revolution = 360°
  • Reset distance = 360°

    In the ”Configuration” wizard in the ”reference system” window

  • Travel path per revolution of the physical source: Numerator = 360, Denominator = 1

    in the ”signal sources” wizard windows: ”Physical source”

  • Signal source: Encoder Tracking; 5V

Procedure:

Starting the CamDesigner: Nagivation tree of the Compax3 ServoManager under ”cam”: ”Modify cam with CamDesigner”

The transfer window from Compax3 ServoManager to CamDesigner will open:

Cam transfer window

Here you can enter:

  • Axis name
  • Number of interpolation points to be calculated per curve,
  • Signal source ”Encoder A/B 5V” and
  • "Dwell-to-dwell motion law".

    Do not change the default settings:

  • 180 points and
  • the ”modified sine line according to Neklutin” (russian mathematician)

    At first the display is empty; the motion sequence can be entered.

    This is made via the menu: File: New sequence.

    In the dialog box you can select the the axis name of your choice, here ”axis”

    The display looks as follows:

    CamDesigner input display

Now the curve can be created:

The BASIC version of the CamDesigner offers three tools:

  • Drawing -> Dwell
  • Drawing -> straight line
  • Drawing -> point

    With the aid of these tools the known sections of a motion sequence, in general dwells or sections with constant speed, are entered. Please select a tool.

    Now you can position the respective section per mouse click or enter it with the keyboard. Click into the ”enter” field. In the dialog box you can make the following entries depending on the tool selected:

  • Tool dwell:
    • a. Path coordinate 0 Degrees
    • b. Clock angle beginning 0 Degrees
    • c. Clock angle end 30 Degrees
  • Tool dwell:
    • a. Path coordinate 150 Degrees
    • b. Clock angle beginning 110 Degrees
    • c. Clock angle end 120 Degrees
  • Tool straight line:
    • a. Path coordinate beginning 110 Degrees
    • b. Clock angle beginning 190 Degrees
    • c. Path coordinate end 30 Degrees
    • d. Clock angle end 270 Degrees
  • Tool interpolation point:
    • a. Path coordinate 0 Degrees
    • b. Clock angle 3600 Degrees
  • and as an option
    • c. speed 0 rad/s
    • d. Acceleration 0 rad/s2

      The display looks as follows

      The dashed sections are now calculated by the CamDesigner.

      The transitions from dwell to motion are always calculated via a polynomial 5th order (in the BASIC version).

      For the transitions dwell-to-dwell, the preselected motion law is used. This can also be changed retrospectively in the header data (menu: edit: Header data). The header data mask also states the cycle time (cycles per minute).

      The result is displayed via the ”show motion diagram”

      Displayed are the sequences for position, speed and acceleration, in physical units and with respect to the cycle time entered.

      This window can be left via the X Icon.

      If necessary, you can make modifications (motion laws, cycle time, etc.)

      After the optimization the curve progression you can leave the CamDesigner via ”file”: "Exit"

      The following dialog queries if the Cam Download is to take place immediately. The download can also be executed later via ”Download”: ”Cam – curve data”.


Cam functions of the Compax3 ServoManager / motion laws

In this chapter you can read about:

Description of the cam wizard

Motion laws:


Description of the cam wizard

  1. Name of the cam project being used in the CamDesigner.
  2. Reset distance (=clock distance) of the master = length of the X axis in the CamDesigner.
    The entry fields are inactive, if motion sequences were already created in the CamDesigner.
    The values can, however, be modified in the header data of the CamDesinger.
    ATTENTION:
    Cam interpolation points may need to be adapted or deleted, if they are redundant due to a smaller clock distance!.
    Decimal numbers must be converted into integers as numerator and denominator values. Please note, that max. 3 decimal places are considered for numerator/denominator. (see on page 3)
  3. If the master clock distance has more than 3 decimal places, a drift is created.
    If the Compax3 ServoManager states this, you can avoid this drift by using an alternative master clock distance.
    Use another unit for the alternative master clock distance, instead of [mm] or [degrees] rather use [product cycles] or [%], so that you have an integer.
    This unit is then valid for all master-related values (ME, MS, status values, ...) as well as for the curve.
    Create the curve for this alternative master clock distance and you will get ad drift free curve operation.
    the input field will become inactive, if motion sequences were already created in the CamDesigner. The alternative clock distance can also be manipulated in the header data mask of the CamDesigner.
    Example:
    Master: Direct-driven indexing table with 7 work stations;
    Path/revolution = 360°
    Reset distance = 360°
    Slave: One of the work stations
    Path/revolution = 360/7° master degree; cannot be displayed as clock resp. master reset distance (drift)!
    Better: alternative clock distance e.g. 360 slave degrees.
  4. Selection of the signal source which is used as default value for the master source (Input AXIS_REF_Local_Cam on the IEC block C3_MasterControl). An entry is required.
    You can choose between configured signal sources.
    The source can be changed afterwards with the input master of the IEC block C3_MasterControl.
  5. The maximum speed is used as axis dimensioning for the display of the motion profile as well as a limit value for the motion sequence..
    At +/-10V as signal source, the value 10V is used (the entry field is deactivated).
    This value can also be manipulated in the header data mask of the CamDesigner.
    Please note: The value is converted into steps/min by the CamDesigner; therefore a slight difference in this value caused by rounding is possible after the return from the CamDesigner.
  6. If the licence file is installed: Switching between Advanced and Basic version of the CamDesigner.
  7. Interpolation point reduction
    deactivated: The curve is stored in equidistant interpolation points (corresponding to the stated number of interpolation points)
    Activation: The equidistant interpolation points are reduced (resulting in the creation of not equidistant interpolation points).
    The interpolation points are removed so that the resulting error is smaller than the interpolation tolerance stated (linear interpolation is respected).
  8. Interpolation tolerance (see 7).
  9. Maximum number of interpolation points per curve. Value range 18..3600.
    Without activated interpolation point reduction, a curve has this number of interpolation points.
    If the reduction is activated, the actual number of interpolation points may (depending on the tolerance selected) be smaller. Please respect that this value also constitutes the "basic grid" for the interpolation point reduction.
    The number of interpolation points can also be manipulated in the header data mask of the CamDesigner.
  10. Here the dwell-to-dwell interpolation method is selected. The following motion laws are possible in the BasicVersion of the CamDesigner:
    • 3 Sloping Sine Line according to Helling-Bestehorn
    • 4 5th order polynomial
    • 5 Modified acceleration trapezoid
    • 6 Modified Sine Line according to Neklutin
    • 7 Simple sine (disadavantageous jerk)
    • 11 11th order polynomial
    • 12 Squared parabola (disadvantageous jerk)
    • 28 8th order polynomial (disadvantgeous jerk)
    • 30 low-noise cosine combination
    • 31 3th order polynomial (disadvantgeous jerk)
    • 32 4th order polynomial
    • 33 6th order polynomial (disadvantgeous jerk)
    • 34 7th order polynomial
    • 38 mirrored sine
    • 47 harmonic combination

      For all other interpolations, the 5th order polynomial is used in the basic version. In the "Advanced Version", all methods of interpolation (also in combination) are possible in general. A detailed description of the methods not mentioned here, can be found in the CamDesinger help.
      The dwell-to-dwell motion law can also be specified in the header data mask of the CamDesigner.

  11. if the option "always calculate motion diagrams" is activated, the CamDesigner will calculate the interpolated motion sequence and the acceleration sequence after each change.
    This option can also be de-/activated in the header data mask of the CamDesigner.
  12. Modular grid for graphic cam input.
    These values determine to which master/slave grid the curve elements placed with the aid of the mouse are brought ("catched"). The grid of the master (x)-axis must be smaller than the configured clock distance.
    These values can also be de-/activated in the input mask of the CamDesigner for curve points.
  13. Here are displayed status resp. error messages and notes.
  14. Starting the CamDesigner.
    This must be installed from the Compax3 CD before.
    After the return from the CamDesigner it is necessary to perform a curve data download in order to load the changes into Compax3 (even if the curves themselves were not modified).
  15. Cancel. Closing gehe window, the changes are discarded.


Motion laws:
Definition of the term range expansion:

Range expansion is a technique to reduce the dynamic loads in curve and servo drives within motion sections.

This is also called prolongation of travel time.

In general the range expansion is used for motion sections, which run from a dwell or a reversal to another dwell or reversal. It can, however, be expanded to general motion sections.

When using the range expansion you profit from the fact that the values of the path function grow slowly together with the clock angle at the ends of a jerk-free motion section. This means that a relatively long time passes before a definite travel path is built up.

Secondly you profit from the fact that the path end positions of motion sections must only be respected to a certain degree, but not up to the 8th decimal place.

Procedure:
  • Determination of the clock angle range phi_original_nutz actually used in the motion section with the original length phi_original.
  • Calculation of the new usable length:

    phi_new_total = phi_original / phi_original_use

    For asymmetric motion law sectors, the clock angle shifts of the left and right limit position are different!

    1: phi_original_use

    2: phi_original = phi_new_use

    3: Phi_new_total

    4: End position

    5: Tolerance

Example:

In a motion section above 100mm travel path at a clock angle of 120° the modified sine line is used. The end positions do, however, not need to be respected with 0mm tolerance, but only with 0.1 mm tolerance.

The travel path table for the motion section states that 0.1mm travel path can be reached after a clock angle of about 5.3°. 99.9mm travel path are reached after a clock angle of about 114.7°.

Motion diagram table:

phi s

[Degrees] [mm]

______________________

0.000 0.000

0.500 0.000

1.000 0.001

1.500 0.002

2.000 0.005

2.500 0.010

3.000 0.018

3.500 0.029

4.000 0.043

4.500 0.060

5.000 0.083

5.500 0.110

6.000 0.142

6.500 0.180

7.000 0.224

...

113.000 99.776

113.500 99.820

114.000 99.858

114.500 99.890

115.000 99.917

115.500 99.940

Between 0.1 mm travel path and 99.9 mm travel path (i.e. between the two tolerated limit positions) lies a clock angle of 109.4 degrees (instead of the theoretical 120 degrees at zero tolerance).

The entire motion sector with the length of up to now 120 degrees can now be temporally expanded so that the clock angle of 109.4 degrees becomes 120 degrees. This means that the PhiFactor F is 120/109.4.

The expanded clock ange range for the motion section is

phi_new_total = 120 · F = 120 · 120 / 109.4 = 131.6 degrees clock angle

The maximum speed in the section is reduced by 9% by profiting from the 0.1 mm tolerance, the acceleration is reduced by 17% and the dynamic drive torque by 24%!

The description of the majority of the motion laws on the following pages state the information on the range expansion on the lower left side:

f = 0.0001 means that the supposed tolerance is 0.0001 of the section travel path (path = 100 mm per tolerance = 0.01 mm). z(f=0.0001) is the position in the normalized motion law, where the function value f=0.0001 is reached.

FactorPhi is the temporal factor by which the sector clock angle can be expanded until the tolerance limits are reached.

Cv,0.0001, Ca,0.0001 und Cmdyn,0.0001 sare the dynamic characteristic values for speed, acceleration and dynamic drive torque after the range expansion related to the original clock angle.

Besides the tolerance limit of 0.0001 (of the section travel path) the tolerance limits of 0.0003, 0.001, 0.005 and 0.02 are also run through.


Motion law 3 / Sloping Sine Line according to Helling-Bestehorn

Previous Topic

Next Topic

Motion law 3 / Sloping Sine Line according to Helling-Bestehorn
Cycloidal Motion

Denominations generally used:

  • Sloping sine line
  • Sine Line according to Helling-Bestehorn
  • Bestehorn sinuoids
  • Higher Sinuids
  • Lopsided sine line
  • Sine square (with reference to the speed curve)

    Parameters:

  • Travel path resp. amplitude
  • Clock angle j
  • Reversal point parameter I


Motion law 4 / Polynomial 5th order R-R (Polynomial 3-4-5)

Previous Topic

Next Topic

Motion law 4 / Polynomial 5th order R-R (Polynomial 3-4-5)
Polynomial 5th Order

Denominations generally used:

  • Polynomial 5th order
  • Polynomial 5th order
  • Polynomials 3-4-5

    Parameters:

  • Travel path resp. amplitude
  • Clock angle j
  • Reversal point parameter I

    The 5th order polynomial is, together with the cycloidal motion a favored motion law for motion tasks where no particular dynamic problems are noted. It has good but not very good properties for all criteria.


Motion law 5 / Modified acceleration trapezoid

Previous Topic

Next Topic

Motion law 5 / Modified acceleration trapezoid
Modified Trapezoidal

Parameters:

  • Travel path resp. amplitude
  • Clock angle j
  • Reversal point parameter I


Motion law 6 / Modified sine line according to Neklutin

Previous Topic

Next Topic

Motion law 6 / Modified sine line according to Neklutin
Modified Sine

Parameters:

  • Travel path resp. amplitude
  • Clock angle j
  • Reversal point parameter I

    The modified sine line is, together with the 5th order polynomial a favored motion law for motion tasks where no particular dynamic problems are noted. It has good but not very good properties for all criteria.


Motion law 7 / Simple sine

Previous Topic

Next Topic

Motion law 7 / Simple sine
Simple Sine

Parameters:

  • Travel path resp. amplitude
  • Clock angle j
  • Reversal point parameter I

    The simple sine should not be used as dwell-to-dwell motion law, as this will generate jerks!


Motion law 11 / Polynomial 11th order

Previous Topic

Next Topic

Motion law 11 / Polynomial 11th order
Polynomial 11th Order

Parameters:

  • Travel path resp. amplitude
  • Clock angle j
  • Reversal point parameter I


Motion law 12 / squared parabola

Previous Topic

Next Topic

Motion law 12 / squared parabola
Squared Parabola

Denominations:

  • Squared Parabola
  • Velocity ramp in triangular operation (electrical engineering)

    Parameters:

  • Travel path resp. amplitude
  • Clock angle j
  • Reversal point parameter I

    The squared parbola is jerk-generating and should not be used for motions which shall run smoothly!


Motion law 28 / Polynomial 8th order

Previous Topic

Next Topic

Motion law 28 / Polynomial 8th order
Polynomial 8th Order

Parameters:

  • Travel path resp. amplitude
  • Clock angle j
  • Reversal point parameter I


Motion law 30 / Low-noise cosine combination

Previous Topic

Next Topic

Motion law 30 / Low-noise cosine combination
Low-noise Cosine Combination

Parameters:

  • Travel path resp. amplitude
  • Clock angle j
  • normalized position ) of the acceleration maximum
  • normalized inflection point parameter lambda

    the low-noise cosine combination has balanced characteristic values and is particularly suited for high-speed mechanisms because of the continuity of the jerk function.


Motion law 31 / Polynomial 3th order

Previous Topic

Next Topic

Motion law 31 / Polynomial 3th order
Polynomial 3rd Order

Parameters:

  • Travel path resp. amplitude
  • Clock angle j
  • Reversal point parameter I


Motion law 32 / Polynomial 4th order

Previous Topic

Next Topic

Motion law 32 / Polynomial 4th order
Polynomial 4th Order

Parameters:

  • Travel path resp. amplitude
  • Clock angle j
  • Reversal point parameter I


Motion law 33 / Polynomial 6th order

Previous Topic

Next Topic

Motion law 33 / Polynomial 6th order
Polynomial 6th Order

Parameters:

  • Travel path resp. amplitude
  • Clock angle j
  • Reversal point parameter I


Motion law 34 / Polynomial 7th order

Previous Topic

Next Topic

Motion law 34 / Polynomial 7th order
Polynomial 7th Order

Parameters:

  • Travel path resp. amplitude
  • Clock angle j
  • Reversal point parameter I

    The polynomial 7th order is an extremely harmonic motion law. The high values for velocity, acceleration and driving torque can be reducted with the method of range expansion for this polynomial more than for the other motion laws.


Motion law 38 / Mirrored sine

Previous Topic

Next Topic

Motion law 38 / Mirrored sine
Mirrored Sine

Parameters:

  • Travel path resp. amplitude
  • Clock angle j
  • Reversal point parameter I


Motion law 47 / double harmonic

Previous Topic

Next Topic

Motion law 47 / double harmonic
Double Harmonic

Parameters:

  • Travel path resp. amplitude
  • Clock angle j
  • Reversal point parameter I

    Further laws can be found in the Advanced version of the CamDesigner Help!


Cam function structure

In this chapter you can read about:

Function modules of the cam

Signal image

Cam reference systems


Function modules of the cam

T40 function modules

Functions of the individual modules:
Master Position:
  • Detection of the master position
  • Alignment / adjustment of the master position signal

    For this the following IEC modules are available

  • C3_MasterControl:
    • Select source
    • activate detection
    • activate master back stop (only rising master signals are accepted)
  • C3_SetMaster: Define start position for the master signal.
  • C3_MasterConfig: Define master reset distance (independent of the curve reseet distance).
  • MC_Phasing: Additional master distance which is added to the master signal and which causes a slave movement.
Cam: Curve generation and control
  • Selection of the curve
  • Settings: run through curve once or cyclically
  • Enable the master signal to the curve
  • Definition of the master reference: relative or absolute.
  • Specification of the master and slave segment distance.
  • Specification of another MasterOffset with absolute reference or a starting delay with relative reference.

    This is made via the ”C3_CamTableSelect2 IEC module.

Setpoint generator: Coupling and decoupling curves
  • Enable the curve slave position.
  • Alignment / adjustment of the curve slave position to the actual slave position.

    For this the following IEC modules are available

  • MC_CamIn: Coupling with relative slave reference.
  • C3_CamIn: Coupling with absolute slave reference with coupling function, master coupling position and master synchronous position
  • C3_CamOut: Decoupling with absolute slave reference with coupling function, master decoupling position, master braking position and slave standstill position.


Signal image

Displayed are 2 different signal plans, which differ in their master reference:

  • absolute master reference
  • relative master reference

    Displayed are:

  • the master signal processing,
  • the function of the individual IEC function modules as well as
  • the status objects made available for the commissioning or processing.

Symbols

Please make yourself familiar with the symbols of the signal image .

Abbreviations:

RV: | Reset distance of the virtual master (from C3 ServoManager wizard ”signal source”)
RM Cam: | Reset distance of the master from curve
RS: | Reset distance of the slave (from C3 ServoManger Wizard ”configuration: Reference system)
MD: | Feed of the master axis
SD: | Feed of the slave axis


Signal image with absolute master reference

Note:

Direction -1 / +1: with direction reversal (under configuration of signal sources) factor -1 is applied.


Signal image with relative master reference

Note:

Direction -1 / +1: with direction reversal (under configuration of signal sources) factor -1 is applied.


Symbols of the signal image

Symbol | Description
Point of addition | Point of addition: d = a + b + c
Point of multiplication | Point of multiplication: c = a * b
Comparison function | Comparison: If b >= a, then output active
 | Integrator Output signal = ò(Input signal)*dt The output signal is the integral (sum over time) of the input signal ”Start value=0” will set the output to 0; this is triggered by activating ”Execute” of an IEC module.
 | Differentiator Output signal = d(input signal)/dt The output signal is the derivation (gradient) of the input signal
Cam | non-linear curve function Slave / Master Slave-Position = f (Master-Position)
controlloop | Closed control loop Input: Setpoint Position Output: Actual position
Reset function | Reset function Output signal is reset to 0 after value ”R”. Value R can be taken in the signal image.
setpointgenerator | Command value generator Generates the desired setpoint process (e.g. when coupling into a curve)
 | IEC function module with module name and input values
BackStop | Back stop Prevents a declining master signal (Function of C3_MasterControl)
Sampling-holding-function | Sampling-holding-function (SH: Sample & Hold) The input value of the SH member is written to the output with trigger signal t.


Cam reference systems

In this chapter you can read about:

Relative master reference without offset

Relative master reference with 180° offset

Absolute master reference without offset

Absolute master reference with 180° offset

Relative slave reference

Absolute slave reference

For a cam application it is necessary to adapt the curve values (positions) to the master and slave positions.

There are different possibilites to do this:

  • relative master reference
    • without offset
    • with offset
  • absolute master reference
    • without offset
    • with offset
  • Relative slave reference
  • Absolute slave reference


Relative master reference without offset

Master Cam input: Master signal at the beginning of the curve

Master signal: Master signal of the detection

Slave: Signal at the end of the curve


Relative master reference with 180° offset

Master Cam input: Master signal at the beginning of the curve

Master signal: Master signal of the detection

Slave: Signal at the end of the curve


Absolute master reference without offset

Master Cam input: Master signal at the beginning of the curve

Master signal: Master signal of the detection

Slave: Signal at the end of the curve


Absolute master reference with 180° offset

Master Cam input: Master signal at the beginning of the curve

Master signal: Master signal of the detection

Slave: Signal at the end of the curve


Relative slave reference

Relative slave reference can be established with MC_CamIn.

Master Cam input: Master signal at the beginning of the curve

Master signal: Master signal of the detection


Absolute slave reference

Absolute reference can be established by coupling in with a coupling movement (Mode 1 or 2)

Master Cam input: Master signal at the beginning of the curve

Master signal: Master signal of the detection


Master signal source

In this chapter you can read about:

Setting the position of the selected master source (C3_SetMaster)

Recording the position of the selected master source (C3_MasterControl)

C3_MasterConfig

Master signal phase shift (MC_Phasing)


Setting the position of the selected master source (C3_SetMaster)

FB name

C3_SetMaster

Setting the master position
VAR_IN_OUT

Slave

INT

Axis ID; constant: AXIS_REF_LocalAxis
VAR_INPUT

Execute

BOOL

Start setting sequence

Value

REAL

Start value
VAR_OUTPUT

Done

BOOL

Setting sequence finished successfully

Error

BOOL

Setting the master failed

Note:

  • Setting the value is possible:
    • without having selected a curve
    • during master position acquisition.
  • The SetMaster function can only be executed, if the axis is not synchronized (not in ”Synchronized Motion”)
  • SetMaster interrupts the connection with the curve generator (see in signal image).
  • If the ”Value” is greater than the current reset distance, the value is allowed for in the reset distance.

tTiming for Execute / Done:

tTiming Execute / Done

"Done" comes immediately after the execution of the module.


Recording the position of the selected master source (C3_MasterControl)

FB name

C3_MasterControl

Start and Stop of the master detection
VAR_IN_OUT

Slave

INT

Axis ID; constant: AXIS_REF_LocalAxis
VAR_INPUT

Enable

BOOL

Starting the module.
Acquisition is started or stopped in accordance with the Mode

StartMode

INT

Selection of the Start mode
1: Start of the detection with rising edge of the enable
2: Fast start after external event (Impulse). Defined by ”StartSource” and ”StartMask”, , does start within 0.5ms.

StartSource

DWORD

Specification of an object (see example) for starting the detection.
Only relevant with StartMode 2.

StartMask

WORD

Binary mask for and-linking the source in order to select a bit from the source object.
Only relevant with StartMode 2.

StopMode

INT

Selection of the Stop mode
1: Stops the acquisition with falling edge of the Enable
2: Stops the detection at the end of the master clock distance. Defined via the curve or via C3_MasterConfig.

Periodic

BOOL

False: run trough once
True: cyclic run

BackStop

BOOL

False: Backstop not active
True: Back stop active

Master

INT

Axis - ID of the master source (Library constants, Library constants)

AXIS_REF_HEDA: HEDA
AXIS_REF_Physical: +/-10V, step/direction/ Encoder
AXIS_REF_Virtual: virtual Master
VAR_OUTPUT

status

BOOL

Shows that the master position acquisition is running

EndOfProfile

BOOL

Impulse at the end of the configured master cycle

Busy

BOOL

Waiting for an external event

Error

BOOL

Command was aborted; error when starting the detection
Note:
  • With the transition Enable low to high the StartMode is evaluated.
  • With the transition Enable high to low the StopMode is evaluated.
  • Only one module controlling the detection is allowed in the project.
  • Enable and StartSource must have different sources.

    Acquisition of the master position

Example 1:

  • Enable of the master position acquisition with input I0.
  • Start of the detection with an external event = rising edge at the I1 input.
    Input I1 is selected via the object "C3.DigitalInput_Value”.
    The input I1 is placed on Bit 1 (counting from 0), as a result the input "StartMask” receives the value 2.
  • Detection runs in single mode.

    Start of the acquisition of the master position

Example 2:

  • StopMode=2: Acquisition stops at the end of the master clock distance
  • If "Enable" is deactivated within the master clock distance and is re-activated before the end of the master clock distance, the acquisition will continue undisturbed.

    Start of the acquisition of the master position


Cam operation with STOP or Error

The master position and the curve are not influenced by a STOP or an error of the axis.

The detection and the curve generation continue; this means that the curve output is also available in the case of an error.


C3_MasterConfig

FB name

C3_MasterConfig

Configure reset distance of the position of selected master
(does not influence the curve, only in the display object)
VAR_IN_OUT

Slave

INT

Axis ID; constant: AXIS_REF_LocalAxis
VAR_INPUT

Execute

BOOL

Start configuration

Numerator

DINT

Numerator of the reset distance to master position acquisition

Denominator

DINT

Numerator of the reset distance for the position of selected master source
(automatically 1 with alternative master clock distance)

The reset distance is disabled with:

Numerator = 0 and Denominator = 1

thus the display is no longer reset
VAR_OUTPUT

Done

BOOL

Configuration finished successfully.

Error

BOOL

Configuration of the master failed
Note:
  • The module can only be executed if the position of the selected master source acquisition is not running, i.e. was not started via C3_MasterControl
  • Write Flash is not executed, the changed values of the reset distance are lost when switching off.
  • The reset distance defined via the module deactivates the previously valid reset distance of the curve, see in signal image.
  • For linked curves the sum of all master segments (Numerator / Denominator) is entered as reset distance.

    tTiming for Execute / Done:

    tTiming Execute / Done

    "Done" comes immediately after the execution of the module.


Master signal phase shift (MC_Phasing)

FB name

MC_Phasing

A phase equalization between Master and Slave can be performed with a position offset.

Only the Master signal in the Slave is affected in this case. The Master itself remains unaffected.
PhaseShift influences the master signal before the curve; the slave moves by the resulting distance after the curve.

Calling MC_Phasing a second time causes an additional offset of the Master signal by the value specified in PhaseShift
VAR_IN_OUT

Master

INT

Axis ID; constant: AXIS_REF_LocalCam

Slave

INT

Axis ID; constant: AXIS_REF_LocalAxis
VAR_INPUT

Execute

BOOL

Starts the sequences of the module with positive edge

PhaseShift

REAL

Relatice distance added to the master signal (configured unit [units]) (positive and negative direction) <Value range>

MoveVelocity

REAL

Speed when changing the master signal (always positive) (is not necessarily reached) [Units/s] <Value range>

Acceleration

DINT

Acceleration when changing the master signal (always positive) [Units/s²] <Value range>

Deceleration

DINT

Deceleration when changing the master signal (always positive) [Units/s²] <Value range>

Jerk

DINT

Acceleration jerk [Units/s³] when changing the master signal (always positive) <Value range>

JerkDecel

DINT

Deceleration jerk [Units/s³] when changing the master signal (always positive) <Value range>
VAR_OUTPUT

Done

BOOL

Phase offset achieved

CommandAborted

BOOL

Command aborted

Error

BOOL

Error while executing module
Note:
  • The values PhaseShift, Velocity, Acceleration, Deceleration, Jerk JerkDecel are no absolute values, they are added to the current movement of the master signal.
  • MC_Phasing is not stopped by a stop of the axis.
  • This module cannot be operated with C3_ShiftPosition and MC_MoveSuperImposed at a time.
  • This function is only possible in cam operation.


Control of the cam generator (C3_CamTableSelect)

FB name

C3_CamTableSelect

Control of the curve generator
VAR_IN_OUT

Master

INT

Axis ID; constant: AXIS_REF_LocalCam

Slave

INT

Axis ID; constant: AXIS_REF_LocalAxis

VAR_INPUT

Execute

BOOL

Curve selection with positive edge

CamTable

INT

Curve number (beginning with 1)

Periodic

BOOL

=FALSE: run through curve oncy
=TRUE: run through curve cyclically

MasterAbsolute

BOOL

Select master reference of the curve
FASLE = relative
TRUE = absolute

Mastercycle

REAL

Value of the master segment distance [physical units] 3 decimal places are considered.

Slavecycle

REAL

Value of the slave segment distance [physical units] 3 decimal places are considered.

MasterOffset

REAL

Absolute mode:
Offset at the start of the master position aquisition
relative mode:
Start delay, the master position acquisition starts if the master signal reaches this value, see in the signal image.

If the input is open the curve starts with Execute (without delay)

LastSegment

BOOL

Resets the display, see in structure.
VAR_OUTPUT

Done

BOOL

Change of curves finished

Busy

BOOL

Waiting for change of cams

EndOfSegment

BOOL

Impulse at the end of a curve even if no Execute is present

Error

BOOL

Command aborted
Error in cam selection or master connection
Note:
  • If the inputs ”Mastercycle” and ”Slavecycle” are not assigned, the master cycle is accepted by the configuration and the highest feed of the selected curve is taken as slave cycle ((see curve types).
  • If the MasterAbsolute input stands on TRUE (absolute), the switch to the curve genertor is closed with the CamTableSelect and the curve adapts to the master position detection.
    The MasterOffset functions as Offset for the master position acquisition;
    Input not assigned means MasterOffset = 0.
  • If the MasterAbsolute input stands on FALSE (relative), the switch to the curve generator is closed with the CamTableSelect and the curve does not adapt but begins on the master side at 0.
    The MasterOffset works as start delay; the curve starts only when the master has traveled further than this value in the positive direction.
  • If the curve runs in single mode, only direct coupling with MC_CamIn is sensible.
  • If the curve runs in single mode and the master runs periodically, it is only sensible to have the curve run relative to the master.
  • After running through the curve in single mode, the drive changes from the ”Synchronized Motion” state back to the ”Standstill” state, i.e. after a SingleStart a positioning is possible.
  • An Execute during a curve cycle leads to a curve change at the end of the curve cycle. The ”MasterAbsolute” and "MasterOffset" inputs are not evaluated.
    Please note: If an Execute signal follows an Execute (by bouncing), another change of curve is already triggered.
  • With relative master reference (MasterAbsoute=FALSE) with start delay, the change of curve is already executed (Done=TRUE), if the master signal has not yet reached the Masteroffset (start delay).

Example / Timing diagram


Alignment of the slave axis


Start cam / coupling

In this chapter you can read about:

Starting a selected curve (MC_CamIn)

Starting a selected curve with coupling movement (C3_CamIn)


Starting a selected curve (MC_CamIn)

FB name

MC_CamIn

Synchronization of the axis with the output of the curve generator without coupling movement
VAR_IN_OUT

Master

INT

Axis ID; constant: AXIS_REF_LocalCam

Slave

INT

Axis ID; constant: AXIS_REF_LocalAxis
VAR_INPUT

Execute

BOOL

Curve start with positive edge
VAR_OUTPUT

InSync

BOOL

Synchronous operation active

CommandAborted

BOOL

Command aborted

Error

BOOL

Command aborted
Error in the cam operation

EndOfProfile

BOOL

End of a cam cycle.
A pulse with the length of an IEC cycle indicates the end of each cam cycle.
Suitable for setting up a loop counter.
Note:
  • Curve alignment:
    • Execute is followed by immediate coupling; the current curve setpoint value is adapted to the current slave setpoint value. This adapts the curve to the current position.
    • In order to avoid velocity jumps, the master should be at a standstill or the curve should have an initial gradient (slope) of 0.
  • MC_CamIn can also be started by a C3_CamTableSelect, if the curve setpoint value does not jump after the start of the C3_CamTableSelect Example 6: Operation with cam segments and standstill area.

Direct coupling with MC_CamIn

Coupling with MC_CamIn

Sa: current slave position

MT: Master clock distance

ST: Slave clock distance


Starting a selected curve with coupling movement (C3_CamIn)

In this chapter you can read about:

Quadratic coupling (CouplingMode = 1)

Direct coupling (CouplingMode = 0)

Change-over (CouplingMode = 2)

FB name

C3_CamIn

Synchronization of the axis to the output of the curve generator with adjustable coupling movement
VAR_IN_OUT

Master

INT

Axis ID; constant: AXIS_REF_LocalCam

Slave

INT

Axis ID; constant: AXIS_REF_LocalAxis
VAR_INPUT

Execute

BOOL

Curve start with positive edge

CouplingMode

INT

0 = coupling without coupling movement, after the master having traveled over the coupling position (ME) in positive direction.
1 = coupling via quadratic function;
the master coupling position (ME) is calculated.
2 = couling via changeover function.

CouplingPosition

REAL

Master coupling position (ME) in master units
(is taken into consideration with CouplingMode = 0 and 2
with CouplingMode = 1, the coupling position is calculated)
Value range: 0 ... MT

SyncPosition

REAL

Master synchronous position (MS) in master units
(not relevant with CouplingMode = 0)
Value range:
CouplingMode 1: 0 ... MT
CouplingMode 2: 0 ... n*MT
VAR_OUTPUT

InSync

BOOL

Synchronous operation active

CommandAborted

BOOL

Command aborted

Error

BOOL

Command aborted
Error in the cam operation

EndOfProfile

BOOL

End of a slave cam cycle.
A pulse with the length of a IEC cycle indicates the end of each master cam cycle .
Suitable for setting up a loop counter.
Note:
  • Master coupling position (ME) and master synchronized position (MS):
    • With CouplingMode = 0: ME is taken into consideration, MS not relevant.
    • With CouplingMode = 1: ME is calculated internally, MS is taken into consideration.
    • With CouplingMode = 2: ME is taken into consideration, MS is taken into consideration.
  • With CouplingMode =1 the curve must be constantly rising at the Master synchronous position (MS).
  • If the master runs backwards after the beginning of the coupling movement, the slave will be at its original position after reaching the coupling position.
  • With changeover, the coupling function depends on the current curve.
  • The relevant master position for coupling position and synchronized position is object 3030.24.
  • Before C3_CamIn is executed, a curve must be selected with C3_CamTableSelect.

Example with CouplingMode = 1 and C3_CamTableSelect: Periodic = TRUE.


Quadratic coupling (CouplingMode = 1)

Previous Topic

Next Topic

Quadratic coupling (CouplingMode = 1)

The quadratic coupling results in a quadratic position course of the slave axis without velocity superelevation via the function:

The synchronous position with master reference (MS) is ideally stated within the hind range of the master clock distance, so that the coupling movement takes place within one single cycle.

For this, the start position (activating the coupling sequence with C3_CamIn: Execute) must also be near the curve zero point.

The master-related coupling position (ME) is calculated from the slope of the curve in the synchronization point and the actual slave position (Sa) so that it results in a quadratic position course.

For this, there must be a positive slope (gradient) at the synchronization position.

The master speed must be positive, i.e. the master position must be rising.

Coupling via a slave clock distance

Quadratic coupling function during 1 cycle

SS: Slave synchronization position

Sa: current slave position before start of curve

ME: Master coupling position calculated from MS, slope in MS/SS and Sa

MS: Master synchronous position

MT: Master clock distance

ST: Slave clock distance

e(M): quadratic coupling function

1: gradient triangle: determines the duration of the coupling sequence (the steeper, the faster is the coupling sequence)

Coupling over several slave clock distances

If the curve has a very flat slope in the synchronization point (MS/SS), or if the current Slave Sa is behind the Slave synchronzation position, the coupling sequence takes place over several master cycles.

Quadratic coupling function during several cycles

SS: Slave synchronization position

Sa: current slave position before start of curve

ME: Master coupling position calculated from MS, slope in MS/SS and Sa

MS: Master synchronous position

MT: Master clock distance

ST: Slave clock distance

e(M): quadratic coupling function

1: The slave setpoint value is reset at this position in the display.


Direct coupling (CouplingMode = 0)

Previous Topic

Next Topic

Direct coupling (CouplingMode = 0)

Coupling with C3_CamIn CouplingMode = 0

Sa: current slave position

MT: Master clock distance

ST: Slave clock distance

After Execute of C3_CamIn the slave will only couple in from the master coupling position ME.

In order to avoid velocity jumps, the curve should have an initial gradient (slope) of 0.


Change-over (CouplingMode = 2)

Previous Topic

Next Topic

Change-over (CouplingMode = 2)

When using the change-over-function, the curve setpoint value is permanently displayed during coupling, while the current slave position is permanently hidden. Overspeeding and pull-out movement are possible.

By specifying the master-related coupling and synchronization position in master units, the coupling curve is mapped to a range of any length of the curve. This means that it is no longer fixedly coupled to the curve cycle.

Algorithm of the change-over function

The normalized coupling function begins at the value 0 and end at the value 1 and rises continually in between. It is a 5th order function.

The coupling curve does not produce a direct slave setpoint value but produces a factor KE for the weighting of the current curve setpoint value resp. the current slave position Sa (position at the start of the coupling sequence).

The course of the coupling curve depends on the slave position Sa and the course of the curve in synchronized operation.

The master speed must be positive, i.e. the master position must be rising.

The weighting is made according to the following function:

coupling curve = SK * KE + S0 * (1 – KE)

with:

S0 = standstill position

SK = current curve setpoint value

KA = control variable between 0 ... 1.0 (between ME and MS)

Example: Change-over function over a curve cycle

Coupling with the changeover function within a curve cycle

SS: Slave synchronization position

Sa: current slave position before start of curve

ME: Master coupling position = 30°

MS: Master synchronized position = 340°

MT: Master clock distance = 360°

ST: Slave clock distance

The slope (speed) of the coupling sequence shows a clear overspeeding in comparison with the synchronized run.

Example: Change-over function over several curve cycles

Coupling with the changeover function during several curve cycles

SS: Slave synchronization position

Sa: current slave position before start of curve

ME: Master coupling position = 60°

MS: Master synchronized position = 700°

MT: Master clock distance = 360°

ST: Slave clock distance

1: The slave setpoint value is reset at this position in the display.

Change-over function KE:


Exiting the active curve with coupling movement (C3_CamOut)

In this chapter you can read about:

Direct decoupling (CouplingMode = 0)

Quadratic decoupling (CouplingMode = 1)

Decoupling with change-over function (CouplingMode = 2)

FB name

C3_CamOut

Decouple the active curve with adjustable coupling movement
VAR_IN_OUT

Master

INT

Axis ID; constant: AXIS_REF_LocalCam

Slave

INT

Axis ID; constant: AXIS_REF_LocalAxis
VAR_INPUT

Execute

BOOL

Activate the decoupling process with a positive edge

DecouplingMode

INT

0 = decoupling without coupling movement, after the master having traveled over the decoupling position MA in positive direction.
(MB and S0 not relevant)
1 = decoupling via quadratic function;
the master braking position (MB) is calculated
2 = decoupling via changeover function

DecouplingPosition

REAL

Master decoupling position in Master units (MA)
Value range: 0 ... MT

BrakingPosition

REAL

Master braking position in master units (MB)
(is taken into consideration with CouplingMode = 2
with CouplingMode = 1, the braking position is calculated).
MB must be > than MA.
Value range: 0 ... n*MT

StandstillPosition

REAL

Slave standstill position in Slave units (S0)
VAR_OUTPUT

Done

BOOL

Decoupling complete

InSync

BOOL

Wait for decoupling position

Error

BOOL

Command aborted
Error in the cam operation

EndOfProfile

BOOL

End of the curve cycle.

Note:

  • Master decoupling position (MA) and Master braking position (MB)
    • With DecouplingMode 0: MA is taken into consideration, MB not relevant.
    • With DecouplingMode 1: MA is taken into consideration; MB is calculated.
    • With DecouplingMode 2: MA is taken into consideration; MB is taken into consideration.
  • The Slave standstill position is not taken into consideration with DecouplingMode = 0.
  • With DecouplingMode =1 the curve must be constantly rising at the Master decoupling position (MA).
  • if the master runs backwards after the beginning of the decoupling movement, the curve is accessed again after reaching the decoupling position.
  • With changeover, the decoupling function depends on the current curve.
  • The relevant master position for ecoupling position and braking position is object 3030.24.

    Example with DecouplingMode = 1 and C3_CamTableSelect: Periodic = TRUE.


Direct decoupling (CouplingMode = 0)

With direct decoupling, the curve operation is immediately terminated with the Execute.

In order to avoid speed jumps, the master should be at a standstill during direct decoupling or should be decoupled at a point, where the slope iss 0 (constant slave position).


Quadratic decoupling (CouplingMode = 1)

The quadratic decoupling results in a quadratic position course of the slave axis without velocity superelevation via the function:

The braking position (MB) is calculated from the slope of the curve at the decoupliing point and the standstill position (S0) so that a quadratic position course is the result.

If the standstill position is smaller than the slave position at the beginning of the decoupling, the decoupling movement will only be terminated in the following cycle.

For this, there must be a positive slope (gradient) at the decoupling position.

The master speed must be positive, i.e. the master position must be rising.

Decoupling over several master clock distances

If the slope (gradient) of the curve in the decoupling point is very flat, the decoupling sequence will take several master clock distances.

Decoupling by means of a quadratic function

S0: Slave standstill position

Sa: Slave position at the master decoupling position

MA: Master decoupling position

MB: Master braking position

MT: Master clock distance

ST: Slave clock distance

a(M): quadratic decoupling function

1: gradient triangle: determines the duration of the decoupling sequence (the steeper, the faster is the coupling sequence)


Decoupling with change-over function (CouplingMode = 2)

The standstill position is continually displayed during decoupling, while the curve is continually hidden.

Overspeeding and pull-out movement are possible.

By the specification of the master-related decoupling and braking position in master units, the decoupling curve is mapped on any length of the curve.

Algorithm of the change-over function

The normalized coupling function corresponds to the coupling function, but it is run trough in inverse direction during decoupling. It provides factor KA, which is used for the weighting.

The course of the decoupling curve depends on the standstill position and the course of the curve in synchronized operation.

The weighting is made according to the following function:

decoupling curve = SK * KA + S0 * (1 – KA)

with:

S0 = standstill position

SK = current curve setpoint value

KA = control variable between 1.0 ... 0 (between MA and MB)

Example: Decoupling with the changeover-function

Decoupling via changeover function

S0: Slave standstill position

MA: Master decoupling position = 60°

MB: Master braking position 680°

MT: Master clock distance = 360°

ST: Slave clock distance


10 Steps for cam generation

In this chapter you can read about:

Step 1: C3 ServoManager

Step 2: Connect motor.

Step 3: Supply & I/O wiring

Step 4: RS232 connection & C3 ServoManager

Step 5: Set Compax3 device type

Step 6: Configuration

Step 7: Selecting Master signal source

Step 8: Generating the cam

Step 9: Create IEC program

Step 10: Starting and monitoring cam
Example:
  • Electronic Cam with 2 standstill areas,
  • Master signal is the internal virtual master.
Step 1: C3 ServoManager
  • Install Compax3 ServoManager (Compax3-CD 840-100005) on your PC (it is recommended to un-install all previous versions beforehand).
  • Install CamDesigner (Compax3-CD 840-100005).
  • You need a RS232 cable (SSK1/xx) for the connection PC - Compax3 X10.
Step 2: Connect motor.
  • Motor cable to Compax3 X3
  • Feedback cable to Compax3 X13.
Step 3: Supply & I/O wiring
  • AC supply (1 or 3 phase) to X1
  • DC supply to X4
  • Device enable by 24VDC on X4/Pin3
  • The following digital inputs must be assigned:

    Input 0 - Pin X12/6

    24V = Enable of the power output stage

    Input 1 - Pin X12/7

    24V = Start machine zero

    Input 2 - Pin X12/8

    24V = Start virtual master
    0V = Stop virtual master

    Input 4 - Pin X12/10

    24V = select and start curve

    Input 5 - Pin X12/12

    24V = curve coupling

    Input 6 - Pin X12/13

    24V = curve decoupling

    Input 7 - Pin X12/14

    24V = Reset (ackn.)

Step 4: RS232 connection & C3 ServoManager
  • Establish RS232 connection (cable SSk1/xx) between PC and C3 X10.
  • Start C3 ServoManager
Step 5: Set Compax3 device type
  • Compax3 device selection wizard, select type

    or

  • Type online identification
Step 6: Configuration

Start configuration in the C3 ServoManager and configure Compax3.

  • Set motor
  • Braking Resistor
  • External moment of inertia
  • Distance / Travel Parameters
    • Unit: Degrees
    • Travel distance per motor revolution numerator = 360°
    • Travel distance per revolution – Denominator = 1
    • Reset distance numerator = 360°
    • Reset distance denominator = 1
  • Machine zero = mode 34
  • Limit switch
  • Jerk / Ramps
  • Monitoring / Limits: Following error to 5°
  • Encoder Output
  • Recipe List
Step 7: Selecting Master signal source
  • Open entry of signal source (left side of the tree)
  • Select master signal source: virtual Master
  • Enter units and reset distance (360°)
  • Rs485 settings
load configuration into Compax3.
Step 8: Generating the cam

Call up/process curve with the aid of the CamEditor

  • Enter axis name
  • Select signal source of virtual master
  • Enter number of interpolation points: 360
  • Enter motion law: dwell-to-dwell: ”Modified Sine Line according to Neklutin”
  • Start CamDesigner
  • Under Menu File: New sequence. Select axis name
  • Add 2 standstill areas: 0/360; 0/310; 50/360 (Path coordinate/clock angle)
  • View path-time-diagram and optimize curve if needs be
  • End CamDesigner via Menu:File:End
  • Download of the curve into Compax3
Step 9: Create IEC program
  • Start IEC development environment (in the tree on the left side under Programming: IEC61131-3 development environment
  • File, enter new project name
  • Set target system: CoDeSys for C3 T40
  • Open program example "cd\exambles\10StepsToCam" in CFC.
  • Save project
  • Project translate everything
  • Download of the IEC program into Compax3 (in the C3 ServoManager in the tree on the left side under Download: IEC61131-3)
Step 10: Starting and monitoring cam
Input 0 - Pin X12/6 | 24V = energize Compax3
Input 1 - Pin X12/7 | 24V = Starting the homing run
Input 2 - Pin X12/8 | 24V = Start virtual master 0V = Stop virtual master
Input 4 - Pin X12/10 | 24V = select and start curve
Input 5 - Pin X12/12 | 24V = curve coupling
Input 6 - Pin X12/13 | 24V = curve decoupling
Input 7 - Pin X12/14 | 24V = Reset (ackn.)

Control status values in the IEC61131-3 - Debugger or in the oscilloscope (optimization window) (e. g. C3Cam.STATUSMASTER_Position, ...)


Cam applications

In this chapter you can read about:

example 1: Single start of a closed cam

example 2: Change between single start of an open cam and POSA

example 3: Single Start for run through curve 5 times

example 4: Composing curves

example 5: Cyclic operation with event-triggered change of curve

example 6: Operation with curve segments and standstill area

example 7: Curve operation with slave reg synchronization

example 8: Curve operation with master reg synchronization

Example case of damage

Application note: Drift

You will find the applications described below as CoDeSys project on the Compax3 CD in the ”Examples” file.


Example 1: Single start of a closed cam
Task:
  • Closed cam (forwards and backwards) with standstill area at the beginning and at the end.
  • Digital input starts run through curve once.
  • Connection to virtual master.

Corresponding files:

CamExample01.C3P (Compax3 project on the Compax3 CD:\Examples\Example1)

CamExample01.pro (CoDeSys project on the Compax3 CD:\Examples\Example1)

Control interface:

Input | Function
I0 | Energize axis, homing, curve generator, starting and coupling axis
I1 | Enable master detection
I2 | Starting detection in single mode
I3 | Start of the virtual master
I4 | Free
I5 | Free
I6 | Free
I7 | Free

Solution:

  • The curve is activated after the homing run (Home.Done to CTS1).
  • After that the axis is synchronized via CS1.Done at CI1. Now the master detection can be started.
  • Input I1 enables the master acquisition, which will wait for the external event (Input I2)
    In order to do this, the C3_MasterControl module: is assigned to following value: ADR(C3.DigitalInput_Value).
    In order to select the 3rd bit from this value the input StartMask receives the value 4.
  • The master acquisition runs in Single Mode and the curve generator (C3_CamTableSelect) in the Periodic, this means that the switch between the curve generator and detection is always closed, see in the signal image. With the external event (input I2) a curve cycle is run through.
Signal image:

example 1: Signals


Example 2: Change between single start of an open cam and POSA
Task:
  • Open curve with standstill range at the beginnning and at the end
  • Digital input starts run through curve once
  • Digital input starts positioning movement on slave cycle
  • Connection to encoder

Corresponding files:

CamExample02.C3P (Compax3 project on the Compax3 CD:\Examples\Example2)

CamExample02.pro (CoDeSys project on the Compax3 CD:\Examples\Example2)

Control interface:

Input | Function
I0 | Energize axis, homing, curve generator, starting and coupling axis
I1 | Starting detection in single mode
I2 | Start of the absolute movement
I3 | Free
I4 | Free
I5 | Free
I6 | Free
I7 | Free

Solution:

Explanation:
  • The repeated turning up of the single start during the run through curve must not disturb the operation.
  • Single start during positioning must not disturb, curve must not start:
    This is prevented by the fact that the enable of the master position detection is only started, if the drive is in the "Synchronized Motion" state.
  • Master detection is started with an external event (input I2).
    In order to do this the C3_MasterControl module: is assigned to following value: ADR(C3.DigitalInput_Value).
    In order to select the 3rd bit from this value the input StartMask receives the value 4.
  • The axis is coupled after Homing (MC_CamIn), then the curve generator (C3_CamTableSelect) starts, after that the master position acquisition is started via the external input (C3_MasterControl).
    As the output Home.Done is permanently present, this output must be put to CI1 with an edge module. This ensures that CI1 (MC_CamIn) can be activated again.
  • The absolute movement is not executed in the "Synchronized Motion " status (MC_MoveAbsolut reports an error), so this is automatically blocked.


Example 3: Single Start for run through curve 5 times
Task:
  • Open curve without standstill area
  • Coupling / decoupling with change-over function
  • Digital input for the start of 5 curve cycles (incl coupling and decoupling cycle)

Corresponding files:

CamExample03.C3P (Compax3 project on the Compax3 CD:\Examples\Example3)

CamExample03.pro (CoDeSys project on the Compax3 CD:\Examples\Example3)

Control interface:

Input | Function
I0 | Energize axis, Homing
I1 | Enable and start of the master position detection
I2 | Start of the curve cycle
I3 | Free
I4 | Free
I5 | Free
I6 | Free
I7 | Start of the virtual master

Solution:

Explanation:
  • Coupling from 0 on (CamIn.CouplingPosition = 0), decoupling on 360° (CamOut.StandstillPosition = 360°).
  • The curve generator (C3_CamTableSelect) is started in relative Mode with the Input I2.
  • with MasterOffset = 0, the next zero crossing is waited for if the master is already running.
  • The busy output of CTS1 starts the coupling sequence before the selected curve is active. Only if the master position has exceeded the value 0 (CTS1.MasterOffset = 0, CTS1.MasterAbsolute = TRUE), the curve starts to run and CTS1.Done will become TRUE.
  • After the 3rd impulse "EndOfSegment" of the C3_CamTableSelect module, the 4th curve is already running. The change of cam to the single mode is then triggered with the counter module. This will become active at the end of the 4th curve, so that the curve is run through 5 times.
  • If the change to the 5th curve cycle has been executed, the Done output will come to this module (CTS2), which will trigger the decoupling sequence.


Example 4: Composing curves
  • 3 curves (ramp-up curve, straight line, ramp-down curve) with the same master clock distance
  • digital input for single start of a curve sequence, after that standstill until the repeated start of the 3-curve sequence.

Corresponding files:

CamExample04.C3P (Compax3 project on the Compax3 CD:\Examples\Example4)

CamExample04.pro (CoDeSys project on the Compax3 CD:\Examples\Example4)

Control interface:

Input | Function
I0 | Energize axis, Homing
I1 | Enable and start of the master position detection
I2 | Coupling and curve start
I3 | Free
I4 | Free
I5 | Free
I6 | Free
I7 | Start of the virtual master

Solution:

Explanation:
  • The entire curve line is 720° long, the reset distance in the slave axis configuration stands on 720° (Configuration: Reference system).
  • The change of cams is triggered with the Done of the curve activated before (CTS1 ... CTS3). The Done output follows, if the change into the respective curve has been executed.
  • The axis is synchronized with input I2 (CamIn) and at the same time the curve generator (CTS1) is started.1
    This ensures that no increments are lost with running master.
Design of a curve:

Position Reset Distance Slave: Reset distance slave

Position Reset Distance Master: Reset distance Master = time axis in the Cam Designer


Example 5: Cyclic operation with event-triggered change of curve
  • 2 curves with the same clock distances: S-curve without standstill area and straight line
  • digital input for quadratic coupling and decoupling
  • digital input for switching of curve
  • Master reference must be kept with exactly the same increments during the change
  • The master position acquisition must continue in decoupled state

Corresponding files:

CamExample05.C3P (Compax3 project on the Compax3 CD:\Examples\Example5)

CamExample05.pro (CoDeSys project on the Compax3 CD:\Examples\Example5)

Control interface:

Input | Function
I0 | Energize axis, Homing
I1 | Enable and start of the master position detection
I2 | Selection of cam
I3 | Coupling / Decoupling
I4 | Free
I5 | Free
I6 | Free
I7 | Start of the virtual master

Solution:

Explanations:
  • Via Input I2 either curve 1 (CTS1) or curve 2 (CTS2) is activated, both in the absolute mode (MasterAbsolute=TRUE).
  • The detection starts with I1 (MasterControl).
  • Coupling in takes place with rising edge of I3, decoupling takes place with falling edge of I3.


Example 6: Operation with curve segments and standstill area
  • Via a master cycle, a slave feed with following standstill is to take place from a master position of 30° on; from a master position of 230° on, the slave is to return. This sequence is to be repeated cyclically.

Corresponding files:

CamExample06.C3P (Compax3 project on the Compax3 CD:\Examples\Example6)

CamExample06.pro (CoDeSys project on the Compax3 CD:\Examples\Example6)

Control interface:

Input | Function
I0 | Energize axis, Homing
I1 | Enable and start of the master position detection
I2 | Start of the curve cycle
I3 | Free
I4 | Free
I5 | Free
I6 | Free
I7 | Start of the virtual master

Solution:

Boundary conditions:
  • After the coupling of the axis, the curve generator (CST1) is started in relative mode with an offset of 30°.
    The start of the curve takes only place, if a master position of 30° is reached.
  • The feed takes place via 100 master degrees (C3_CamTableSelect module): Mastercycle = 100).
  • With the falling edge of EndofSegment of the CamTableSelect module (CTS1), the next movement will be triggered via CamIn2.
  • CamIn2 will start via "InSynch" the 2nd C3_CamTableSelect (CTS2), whose curve will reset the slave to its previous position via the master position range between 100° and 230°.
  • The sequence can be repeated with "EndofSegment" of this module.
Special feature:
  • In this example, the curve shall be run through entirely, therefore MC_CamIn is started before C3_CamTableSelect. This is only possible with MC_CamIn.
Signal image:

example 6: Signals


Example 7: Curve operation with slave reg synchronization

The slave position in the curve mode is to be corrected in dependance of a registration mark: Slave-oriented reg synchronization.

Corresponding files:

Slave_Markenkorrektur_Example.C3P (Compax3 Project auf Compax3 CD:\Examples\Example7)

Slave_Markenkorrektur_Example.pro (CoDeSys Project on the Compax3 CD:\Examples\Example7)

Control interface:

Input | Function
I0 | Energize axis, homing, select curve, starting and coupling axis (static)
I1 | Enable and start of the master position acquisition (static)
I2 | Start virtual master
I3 | Reg enable (static)
I4 | Reg input (edge)
I5 | Free
I6 | Free
I7 | Free

Solution:

Boundary conditions:
  • Setpoint position of the registration mark: 90°
  • Ignore zone of the reg detection: 180° - 360°
curve


Example 8: Curve operation with master reg synchronization

The master position in the curve mode is to be corrected in dependance of a registration mark: Master oriented reg synchronization.

Corresponding files:

Master_Markenkorrektur.C3P (Compax3 Project auf Compax3 CD:\Examples\Example8)

Master_Markenkorrektur.pro (CoDeSys Project on the Compax3 CD:\Examples\Example8)

Control interface:

Input | Function
I0 | Energize axis, homing, select curve, starting and coupling axis (static)
I1 | Enable master acquisition (static)
I2 | Start virtual master
I3 | Reg enable (static)
I4 | Reg input (edge)
I5 | Free
I6 | Free
I7 | Free

Solution:

master oriented reg synchronization

Boundary conditions:
  • Setpoint position of the registration mark: 90°.
  • Slave standstill at 180°.
  • The object C3Cam.StatusMaster_PositionCamUnits (o3030.24) is used as source for the C3_Touchprobe module and is set against the reg setpoint position.
  • The adjustment movement is made via MC_Phasing (see the signal image of the cam).
curve


Example case of damage

The axis should work in curve mode.
The master should be stopped in the case of an axis error. After the elimination and acknowledgement of the error, the axis shall synchronize and normal operation shall be resumed.

Corresponding files:

CamExampleHav.C3P (Compax3 Project on the Compax3 CD:\Examples\Examples_Haverie)

CamExampleHav.pro (CoDeSys Project on the Compax3 CD:\Examples\Examples_Haverie)

Control interface:

Input | Function
I0 | Energize axis
I1 | Enable and start of the master position detection
I2 | Start of the curve cycle
I3 | Coupling / Decoupling
I4 | Free
I5 | Clear Error
I6 | Homing
I7 | Start of the virtual master

Solution:

Boundary conditions:
  • The ReadStatus module helps detect, if the axis is in the error state.
    An error will trigger the stop of the virtual axis, the curve cycle will stop, the curve generator (C3_CamTableSelect) will continue.
  • After the stop of the master, the axis will also be at a standstill.
  • The error is acknowledged via input I5; the axis will be energized again (see also the "AND" module at the input of MC_Power).
  • If the axis is energized again and input I5 is present, the axis is moved to the current position of the curve output (MC_moveAbsolute) and at the end of the movement it is coupled again with MC_CamIn.
  • The output "InSync" of the MC_CamIn (camin2) will re-start the virtual master and the cycle is continued.


Application note: Drift

Correct scaling of the reference values helps prevent drift.

For this, it is necessary to consider the conversions of the position signal:

Master / Slave / Load revolution: Master / Slave / Load revolutions:

Master / Slave units: Master / Slave - revolutions

Gear box: Gearboxes

The rule for this is:

Z1 | = | Travel distance per revolution master axis numerator
N1 |  | Travel distance per motor revolution master axis denominator

(configured in the Compax3 ServoManager under "signal source")

Z2 | = | Travel distance per revolution slave axis numerator
N2 |  | Travel distance per revolution – Slave axis Denominator

(configured in the Compax3 ServoManager under "configuration")

Z3 | = transmission ratio | Motor
N3 |  | Load

MT: Master clock distance

"Position Reset" Distance - Master Axis (M_Units)

"Position Reset" Distance - Master Axis (Denominator)

MT is rounded to 3 decimal places.

ST: Slave clock distance

Numerical Example:

Product: 314,871 long

14 products are to be transported per load revolution via a curve.

Gearbox: Motor/Load = 6949673 / 43890 => i = 158.3429...

1. Variant (with drift)

Load revolutions = (number of the products) * (length of a product) * (reciprocal of the travel path per motor revolution slave axis) * (gearbox load / motor)

Load revolutions = 14 * 314.871mm * | N2 | * | 43890
 | Z2 |  | 6949673

14 * 314,871mm * | 43890 | = | Z2 | = | 193475634,66
 | 6949673 |  | N2 |  | 6949673

This factor can not be expressed exactly in Compax3; the max. entry allowed in the Compax3 ServoManager:

1934756

69496

which causes drift.

2. Variant (without drift)

Slave clock distance = 1 product cycle

For this, the curve is created scaled to 1.

Load revolutions = 14 * 1mm * | N2 | * | 43890
 | Z2 |  | 6949673

14 * 1mm * | 43890 | = | Z2 | = | 614460
 | 6949673 |  | N2 |  | 6949673

This factor for the path per motor revolution can be expressed, no drift is generated!


Cam switching mechanism

In this chapter you can read about:

Cam switching mechanism function overview

Redirect the fast cams directly to the physical output (C3_OutputSelect)

Objects of the cam switching mechanism

Behavior of the switch-on/switch-off anticipation

Hysteresis

CoDeSys-Project for the configuration of the cams

Example: Working with fast cams


Cam switching mechanism function overview

In this chapter you can read about:

Example of cam function

Examples of a cam cycle

Up to 36 cams can be programmed. They are divided into 2 cam types:

Serial cams
  • 32 serial cams (Cam 0 ... 31) of which a cam is brought up once every 0.5 ms.
    Thecycle timeof the cams is: ((Highest active serial cam +1) * 0.5ms..
    Example: if cam 17 is the highest cam enabled, this results in a cycle time of: 18 * 0.5ms = 9ms
  • If no fast cams are used, the cycle time of the serial cams can be reduced up to 125µs:
    The setting is made via object 3701.6. It applies:
    Cycle time = number of the serial cams *0.5ms / O3701.6 with the value range O3701.6 = 1, 2, 3, 4.
Fast cams
  • 4 fast cams with a cycle time of 500µs (125µs per cam).
  • When using fast cams, there is a cycle time of 0.5ms per cam for serial cams.
  • With the aid of the module C3_OutputSelect the fast cams can be put directly and without delay to the digital outputs A0 ... A3, independent of the cycle time of the IEC program.
Cam functions
  • Switching-on and switching-off position of each cam individually.
  • Cams with compensation for dead time, with switching-on and switching-off anticipation for each cam.
  • Individually adjustable cam source.
  • Enable for each individual cam.
  • Adjustable switching hysteresis for actual position value as a cam source.
  • The outputs of the cams are objects.


Example of cam function
Example of cam function (without switching-on and switching-off anticipation)

The cam outputs are positioned on objects and can be used for other purposes in the IEC program.


Examples of a cam cycle
Example 1: Working cycles for:
  • 3 fast cams and
  • 3 serial cams

    Example of cam cycle

    1: Serial cams

    2: Fast cams

Example 2: Working cycles for:
  • no fast cams,
  • 8 serial cams and
  • reduced cycle time (object O3701.6 = 3)

    Example of cam cycle

Example 3: Working cycles for 3 fast and 3 serial cams
  • no fast cams,
  • 8 serial cams and
  • reduced cycle time (object O3701.6 = 4)

    Example of cam cycle


Redirect the fast cams directly to the physical output (C3_OutputSelect)

FB name

C3_OutputSelect

Select source for digital outputs
VAR_INPUT

Execute

BOOL

Activates the module with a rising edge

O0

INT

Constant for source for the digital output 0

O1

INT

Constant for source for the digital output 1

O2

INT

Constant for source for the digital output 2

O3

INT

Constant for source for the digital output 3
VAR_OUTPUT

Done

BOOL

Source selection executed
Note:
  • The source selection for the outputs is executed with a rising edge of Execute.
  • Application for fast cams:
    the fast cams are put directly and without delay to the digital outputs, independent of the cycle time of the IEC program.
  • OutputSelect_C3Output allows to access the respective output directly via the IEC program (e.g. with the aid of C3_Output).
  • OutputSelect_FastCamSwitch puts the respective fast can to the output, i.e. the cam 0 would be put to O0, cam 1 would be put to O1etc.

Example:

  • Source: output 0: C3_Output
  • Source: output 1: Fast cam 1
  • Source: output 2: Fast cam 2
  • Source: output 3: C3_Output


Objects of the cam switching mechanism

Object designations | Unit | Objects for serial cams |  | Objects for fast cams |  | Valid after:
Source ="1": Actual position ="2": Setpoint position ="3": virtual Master ="5": Master position (3030.1) |  | Cam 0: ... Cam 31: | O3730.1 ... O3761.1 | Cam 0: ... Cam 3: | O3710.1 ... O3713.1 | VP*
Switching-on position | defined unit for positions | Cam 0: ... Cam 31: | O3730.2 ... O3761.2 | Cam 0: ... Cam 3: | O3710.2 ... O3713.2 | VP*
Switching-on position | defined unit for positions | Cam 0: ... Cam 31: | O3730.3 ... O3761.3 | Cam 0: ... Cam 3: | O3710.3 ... O3713.3 | VP*
Switch-on anticipation | 1 º 500ms | Cam 0: ... Cam 31: | O3730.4 ... O3761.4 | Cam 0: ... Cam 3: | O3710.4 ... O3713.4 | Immediately
Switch-off anticipation | 1 º 500ms | Cam 0: ... Cam 31: | O3730.5 ... O3761.5 | Cam 0: ... Cam 3: | O3710.5 ... O3713.5 | Immediately
Output |  | Cam 0: ... Cam 15 Cam 16 ... Cam 31: | O3701.3 Bit 0 ... O3701.3 Bit15 O3701.5 Bit 0 ... O3701.5 Bit15 | Cam 0: ... Cam 3: | O3700.3 Bit 0 ... O3700.3 Bit 3 | VP*
Enable |  | Cam 0: ... Cam 15 Cam 16 ... Cam 31: | O3701.2 Bit 0 ... O3701.2 Bit15 O3701.4 Bit 0 ... O3701.4 Bit15 | Cam 0: ... Cam 3: | O3700.2 Bit 0 ... O3700.2 Bit 3 | VP*
Hysteresis | defined unit for positions | the same for all cams: O3705.1 |  |  |  | VP*

The exact description of the objects can be found in the Object directory.

The command VP (set objects to valid) can be executed as

  • global VP – for all objects or
  • selective VP – only objects of the cam switching mechanism -

  • Global VP: Write into object 210.11 with value <> 0
  • Selective VP: Write into object 210.9 with value <> 0 (C3Plus.ValidParameter_CamControlledSwitches:=True)

    The selective VP is executed faster and constitutes a smaller temporal strain!

Scheme of the object assignment example of the serial cam 0


Behavior of the switch-on/switch-off anticipation

The switching-on and switching-off behavior of the actuating elements (delayed switching, reaction time) can be compensated via a reaction time (switching-on/off anticipation) that can be parametered for each individual cam.

Compax3 will calculate a corrected switching-on/ or –off position by multiplying the reaction time with the current speed, so that the actuating element will switch at the actual switching position due to its delay; the actuating element delay is compensated.


Behavior depending on the travel direction

tOn: | Switch-on anticipation
tOff: | Switch-off anticipation

For the switching behavior depending on the position applies therefore:


Example: switching behavior at positive speed (speed>0)

SwitchOn: | Switching-on position
SwitchOn*: | corrected switching-on position
SwitchOff: | Switching-on position
SwitchOff*: | corrected switching-off position
Pos_tOn: | position difference calculated from the switch-on anticipation
Pos_tOff: | position difference calculated from the switch-off anticipation


Example: switching behavior at negative speed (speed<0)

SwitchOn: | Switching-on position
SwitchOn*: | corrected switching-on position
SwitchOff: | Switching-on position
SwitchOff*: | corrected switching-off position
Pos_tOn: | position difference calculated from the switch-on anticipation
Pos_tOff: | position difference calculated from the switch-off anticipation

N.B.!

The switching-on resp. switching-off anticipation are exchanged with negative speed, as the cam

  • switches on at the switching-off position

    and

  • switches off at the switching-on position!


Switching behavior with reset operation

When leaving the positioning area, the positions are corrected accordingly.

The switching-off position may be smaller than the switching-on position:

SwitchOn: | Switching-on position
SwitchOn*: | corrected switching-on position
SwitchOff: | Switching-on position
SwitchOff*: | corrected switching-off position
tOn: | Switch-on anticipation
tOff: | Switch-off anticipation

Note:

With reset mode of the selected source, the switching position is limited to the area:

0 <= switching position < reset distance

That means that values < 0 will become 0, values > than the reset distance will be come the reset distance-1LSB.


Switch-on anticipation is corrected via reset distance

SwitchOn: | Switching-on position
SwitchOn*: | corrected switching-on position
SwitchOff: | Switching-on position
SwitchOff*: | corrected switching-off position
tOn: | Switch-on anticipation
tOff: | Switch-off anticipation

For cam_1 and _2


Note: No switching operation with overlapping cams

If it occurs that for example the switching-off position is < the switching-on position due to a movement caused by the reaction time compensation, no switching will take place. This case must be eliminated by choosing appropriate cam positions.

SwitchOn: | Switching-on position
SwitchOn*: | corrected switching-on position
SwitchOff: | Switching-on position
SwitchOff*: | corrected switching-off position
Pos_tOn: | position difference calculated from the switch-on anticipation
Pos_tOff: | position difference calculated from the switch-off anticipation

Please observe:

The position difference for the compensation of the switching delay rises with the speed.


Hysteresis

In order to avoid jitter of cams at the limits of the switching area (only relevant as source of cam with actual values) a switching hysteresis (the same for all cams) can be defined.

SwitchOn: | Switching-on position
SwitchOn*: | switching-on position corrected by the hysteresis
SwitchOff: | Switching-on position
SwitchOff*: | switching-off position corrected by the hysteresis

The hysteresis is preset as a position value.

Please observe:

The hysteresis influences the switching-on and switching-off anticipation
You should therefore set this value at the lowest possible level.


CoDeSys-Project for the configuration of the cams

You will find a CoDeSys project for the configuration of the cams with the following functions on the Compax3 CD under ..\Examples\CamSwitch\CamSwitch_Template.pro:

Configuration of the cam switching mechanism via IEC61131-3 in ST (structured text):

1.) Initializing some "example cams" (Module "Init_Cam_Switch")
  • Configuration of sequential cams,
  • Configuration of fast cams,
  • Configuration of the hystereses,
  • Activation of (fast) cams,
  • Resetting outputs,
  • Triggering selective VP

Global variables determine, which functions are used or are relevant:

CAMsourceActual - True: Actual position is used as master source

CAMfast - True: fast cams are being used

CAMnumber_per_cycle - 1..4: Number of cams implemented/500µs)

2.) Use of the cams in the IEC (Module "PLC_PRG")
  • Execute module "Init_Cam_Switch" once,
  • logic query with cams,
  • logic combination with cams,
  • Output of cams via digital outputs,
  • Deactivating individual cams,
  • Manupulating deactivated cams


Example: Working with fast cams

Setting 2 fast cams to the Compax3 outputs O2 and O3.

Related programs:

  • ..\Examples\CamSwitch\2_schnelle_Nocken.C3P
  • \Examples\CamSwitch\2_schnelle_Nocken.pro

Assignment:

O0 = 1: Drive energized

O1 = 1: Machine zero approached

O2 = 1 fast cam 2 (170° ... 190°)

O3 = 1 fast cam 3 (290° ... 310°)

I0: Energize Drive

I1: Start searching machine zero

I2: Start of a 360° positioning (reset distance = 360°)

Solution:

Example of cam CFC (fast cams)

ST Part

Example of cam CFC (fast cams)

Note:
  • With C3_OutputSelect the outputs O2 and O3 are assigned to the fast cams. Compax3 puts automatically the fast cams 2 and 3 to the outputs O2 and O3.
  • The cam objects are set once after switching-on.


Error handling

In this chapter you can read about:

Acknowledging errors (MC_Reset)

Reading axis errors (MC_ReadAxisError)

Switching off error messages (C3_ErrorMask)


Switching off error messages (C3_ErrorMask)

FB name

C3_ErrorMask

This module is used to switch off error messages
VAR_INPUT

Execute

BOOL

The selected error mask is activated

Disable_PLC

BOOL

TRUE is used to switch off error 0x6281.

Disable_HEDA

BOOL

TRUE is used to switch off HEDA errors.

Disable_Fieldbus

BOOL

TRUE is used to switch off the errors 0x8120 and 0x8121.

Disable_MotorStalled

BOOL

TRUE is used to switch off error 0x7121.

Disable_Tracking

BOOL

TRUE is used to switch off error 0x7320.

Disable_IOShortCircut

BOOL

TRUE is used to switch off error 0x5380.

Disable_IOAddSupply

BOOL

TRUE is used to switch off error 0x5117.

Disable_BusVoltageLow

BOOL

TRUE is used to switch off error 0x3222.

Disable_E5LimitSwitch

BOOL

TRUE is used to switch off error 0x54A0.

Disable_E6LimitSwitch

BOOL

TRUE is used to switch off error 0x54A1.

Disable_SoftwareLimit_Pos

BOOL

TRUE is used to switch off error 0x7323.

Disable_SoftwareLimit_Neg

BOOL

TRUE is used to switch off error 0x7324.

Error list

Notes:

  • The setting of the error mask is made internally with a C3 object. If the objects are saved permanently, the setting is memorized after Power off.
Please note:
  • With open inputs, the respective error is active, therefore you should assign the error messages you wish to eliminate with TRUE.
  • The module will overwrite the settings made via the C3 ServoManager.

Mask Compax3 error


Process image

In this chapter you can read about:

Reading digital inputs (C3_Input)

Write digital outputs (C3_Output)

Reading/writing optional inputs/outputs

Memorizing the signals with the trigger event (C3_TouchProbe)


Reading digital inputs (C3_Input)

FB name

C3_Input

Used to generate a process image of the digital inputs.
VAR_INPUT

I0 ... I7

BOOL

Displays the status of the respective input.

Notes: the module should always be brought up at the beginning of the processing cycle.

Reading the Compax3 inputs


Write digital outputs (C3_Output)

FB name

C3_Output

Used to generate a process image of the digital outputs.
VAR_OUTPUT

O0 ... O3

BOOL

Displays the status of the respective output.

Notes: the module should always be brought up at the end of the processing cycle.


Reading/writing optional inputs/outputs


C3_IOAddition_0

FB name

C3_IOAddition_0

Is used to create a process image of the optional digital inputs/outputs.
VAR_INPUT

I0 ... I3

BOOL

Displays the status of the respective input.

O0 ... O3

BOOL

Displays the status of the respective output.

Please note that the group of 4 may be assigned as inputs or outputs. You may only use either inputs or outputs exclusively.

Notes: The module should always be brought up at the beginning (inputs) or end (outputs) of the processing cycle.

Compax3 optional inputs/outputs


C3_IOAddition_1

FB name

C3_IOAddition_1

Is used to create a process image of the optional digital inputs/outputs.
VAR_INPUT

I4 ... I7

BOOL

Displays the status of the respective input.

O4 ... O7

BOOL

Displays the status of the respective output.

Please note that the group of 4 may be assigned as inputs or outputs. You may only use either inputs or outputs exclusively.

Notes: the module should always be brought up at the beginning of the processing cycle.

Compax3 optional inputs/outputs


C3_IOAddition_2

FB name

C3_IOAddition_2

Is used to create a process image of the optional digital inputs/outputs.
VAR_INPUT

I8 ... I11

BOOL

Displays the status of the respective input.

O8 ... O11

BOOL

Displays the status of the respective output.

Please note that the group of 4 may be assigned as inputs or outputs. You may only use either inputs or outputs exclusively.

Notes: the module should always be brought up at the beginning of the processing cycle.

Compax3 optional inputs/outputs


Memorizing the signals with the trigger event (C3_TouchProbe)

FB name

C3_TouchProbe

Memorizing signals / objects with the trigger event
- replaces the MC_TouchProbe module -
VAR_IN_OUT

Axis

INT

Axis ID (Library constants)
VAR_INPUT

Execute

BOOL

Activates the module if there is a rising edge

SignalSource

Pointer

Selects the signal to be scanned.
The ADR()-operator must always be used.
The signal scanned must be in the REAL or the INT format.

FallingEdge

BOOL

If TRUE, it is triggered in the falling edge.
The logical status after a possible input inversion is respected.

TriggerInput

INT

Selects the trigger input.

TouchProbeInputx constant

ExpectedValue

REAL

Value at which the trigger event is expected.

Tolerance

REAL

Tolerance interval around ExpectedValue, where the trigger event is accepted (always positive) (with reference to the signal source).

StartIgnore

REAL

The beginning of the range in which the trigger event will be ignored (with reference to the signal source).

StopIgnore

REAL

The end of the range in which the trigger event will be ignored (with reference to the signal source).

EnableIgnoreZone

BOOL

Activate IgnoreZone.

Abort

BOOL

Deactivate module.
VAR_OUTPUT

Done

BOOL

Trigger event occurred within the tolerance interval and the signal was detected.

RecordedSignal_ Real

REAL

Value scanned at the time of the trigger event, if the source is available in the coDeSys "REAL format.
Please respect the format information

RecordedSignal_ INT

INT

Value scanned at the time of the trigger event, if the source is available in the CoDeSys "INT" format.

Busy

BOOL

Module active and no scanning signal occurred outside the IgnoreZone.

Error

BOOL

Error while executing module.
Note:
  • Temporal precision of signal recording: < 1 µs
  • TriggerInput Trigger-input:
    via the constants "TouchProbeInput0" ... "TouchProbeInput7" (X12/6 - X12/14) the trigger signal input is selected.
  • Attention!
    Max. one entity of the module can be active as the hardware resources are only available once!
    Several entities being activated one after the other are permitted.

Example: Scanning the actual current, triggered via Input I0

1: Area, where an error is generated.

2: Signal

  • If the trigger signal is emitted outside the permissible value range and outside the range between SgartIgnore and StopIgnore, the module will report an error.
  • The module does only read in a position if this position is within a permissible value range between (ExpectedValue - Tolerance) and (ExpectedValue + Tolerance)
  • Within this range, the signals are read in with a temporal exactitude of <1µs (determined by linear interpolation) and accepted with the TriggerInput signal.
  • Further examples with C3_Touchprobe (example 7 und example 8).


Interface to C3 powerPLmC

In this chapter you can read about:

Interface module "PLmC_Interface"

Cyclic data channel for C3T30 and C3T40

Example: C3 powerPLmC Program & Compax3 Program


Interface module "PLmC_Interface"

The interface between a central IEC61131-3 user program on C3 powerPLmC and a local IEC61131-3 user program on a Compax3 servo axis T30 or T40 is created with the program module "PLmC_interface".

It is necessary to call up cyclically the "PLmC_interface2 module at each Compax3 servo axis (T30, T40), which is operated as a slave on a C3 powerPLmC.

The module can be found in the "C3_PLmC_interface.lib" library, which must be integrated manually via the library manager, if required.

FB name

PLmC_Interface

Interface module for the control of C3 powerPLmC
VAR_OUTPUT

O0

BOOL

Status of the digital output O0 on the C3 powerPLmC side

O1

BOOL

Status of the digital output O1 on the C3 powerPLmC side

O2

BOOL

Status of the digital output O2 on the C3 powerPLmC side

O3

BOOL

Status of the digital output O3 on the C3 powerPLmC side

LocalEnable

BOOL

Enable for the local IEC61131-3 program

LocalEnable switches to FALSE for one cycle, if a command for this axis is activated on the C3 powerPLmC.
This helps to avoid that the axis will receive different commands at a time.

Event1 ... Event8

reserved

EventParameter

reserved
Note:
  • The execution of all local motion functions should be coupled with the LocalEnable output.
  • Via the outputs O0...O3, the outputs set by C3 powerPLmC can be set out via the physical outputs with the aid of C3_Output.

Recipe array line 17... 32 assigned

Please note that the last 16 lines of the recipe array (C3Array.ColXX_Row17 to C3Array.ColXX_Row32) are reserved for the communucation with C3 powerPLmC.


Example: C3 powerPLmC Program & Compax3 Program

Task:

  • Implementation of a mark synchronization in a Compaxa3 servo axis.
  • Control of the program via the C3 powerPLmC via a user-defined control word / status word.
Main program on Compax3 (module PLC_PRG)
Cyclic call-up of the interface to powerPLmC in the PLC_PRG module

In CFC:

In ST:

Local Compax3 Program in the LocalProgram module

Program on C3 powerPLmC


IEC examples

In this chapter you can read about:

Example in CFC: Using Compax3-specific function modules and Compax3 objects

Example in CFC: positioning 1

Example in CFC: positioning 2

Example in CFC: Positioning with set selection

Example in CFC: cycle mode

Example in ST: Cycle mode with a Move module


Example in CFC: Using Compax3-specific function modules and Compax3 objects

  • Read in the process image of the digital inputs with the InputStatus module.
  • Generate a process image of the digital outputs with the OutputStatus module.
  • Digital input I0, used for counting an external event. The event is only detected as an event if
    • The I0 input is at TRUE for at least 0.5 seconds and
    • The voltage on analog input 0 exceeds the threshold value of 3.5 volts.
  • When 5 of these events have been counted, the digital output is set to O0. At the same time, the program prevents additional events on the I0 from being counted. The counter state can be reset again with Input I1 as soon as it reaches a value of 5.

    Example C3 FBs and Objects


Example in CFC: Positioning 1

  • Input I7 enables the power output stage
  • Input I0 starts an absolute positioning process with fixed parameters
  • Input I6 is used to stop the movement
  • After positioning is complete, there will be a return to Position 0 as soon as Input I1 has been activated


Example in CFC: Positioning 2

  • Input I7 enables the power output stage
  • Input I0 starts an absolute positioning process
  • If an event (I1) occurs during the positioning, the target position will be moved back by 20 ("MoveAdditive")
  • If an event occurs while positioning is not in progress, it has no effect


Example in CFC: Positioning with set selection

  • Input I7 enables the power output stage
  • The position, speed and ramps can be stored in the array (table) (for example input with the Compax3 ServoManager)
  • The desired set can be selected with inputs I1 through I5 (binary coded)
  • Input I0 starts the positioning (absolute positioning)
  • Positioning that is in progress can be stopped with Input I6


Example in CFC: Cycle mode

Example a: Cycle mode
  • Input I7 enables the power output stage
  • Input I0 starts cyclical positioning. During this process, two positions are approached in alternation.
  • Input I6 stops cycle mode


Example in ST: Cycle mode with a Move module

Input I2 enables the power output stage.

  • Input I0 starts cycle mode. Two positions are approached alternately.
  • There is a pause of 1 second after the first position is reached.
  • There is a pause of 1.5 seconds after the second position is reached.
  • Input I1 stops cycle mode.


Communication

In this chapter you can read about:

RS232 & RS485 – interface record

Here you will find the description of the fieldbus interfaces, which can be configured in the Compax3 ServoManager under the tree entry "communication".


RS232 & RS485 – interface record

In this chapter you can read about:

RS485 setting values

ASCII - record

Binary record

You can communicate with Compax3 in order to read or write objects via plug X10 on the front plate either with RS232 or with RS485.

As a rule 2 records are possible:

  • ASCII record simple communication with Compax3
  • Binary record: fast and secure communication with Compax3 by the aid of block securing.

Switching between the ASCII and the binary record via automatic record detection.

interface - settings

Wiring

RS232: SSK1

RS485: as SSK27 / RS485 is activated via +5V at X10/1.


RS485 setting values

If ”Master=Pop” was selected, only the settings compatible with the Pops (Parker Operator Panels) made by Parker are possible.

Please note that the connected Pop has the same RS485 setting values.

You can test this with the "PopDesigner" software.

"Master=General" makes all Compax3 settings possible.

Multicast Address

You can use this address to allow the master to access multiple devices simultaneously.

Device Address

The device address of the connected Compax3 can be set here.

Baud rate

Adjust the transfer speed (baud rate) to the master.

Connection Type

Choose between two-wire and four-wire - RS485.

Protocol

Adjust the protocol settings to the settings of your master.


ASCII - record

The general layout of a command string for Compax3 is as follows:

[Adr] command CR

Adr | RS232: no address RS485: Compax3 address in the range 0 ... 99 Address settings can be made in the C3 ServoManager under "RS485 settings"
Command | valid Compax3 command
CR | End sign (carriage return)

Command

A command consists of the representable ASCII characters (0x21 .. 0x7E). Small letters are converted automatically into capitals and blanks (0x20) are deleted, if they are not placed between two quotation marks.

Separator between places before and after the decimal is the decimal point (0x2E).

A numeric value can be given in the Hex-format if it is preceded by the ”$” sign. Values can be requested in the Hex-format if the CR is preceded additionally by the ”$” sign.

Answer strings

All commands requesting a numeric value from Compax3 are acknowledged with the respective numeric value in the ASCII format followed by a CR without preceding command repetition and following statement of unit. The length of these answer strings differs depending on the value.

Commands requesting an Info-string (e.g. software version), are only acknowledged with the respective ASCII character sequence followed by a CR, without preceding command repetition. The length of these answer strings is here constant.

Commands transferring a value to Compax3 or triggering a function in Compax3 are acknowledged by:

>CR

if the value can be accepted resp. if the function can be executed at that point in time.

If this is ot the case or if the command syntax was invalid, the command is acknowledged with

!xxxxCR

The 4 digit error number xxxx is given in the HEX - format; you will find the meaning in the appendix.

RS485 answer string

When using RS485, each answer string is preceded by a *" (ASCII - character: 0x2A).

Compax3 commands

Read object

RS232: O [$] Index , [$] Subindex [$]

RS485: Address O [$] Index , [$] Subindex [$]

The optional ”$” after the subindex stands for ”hex-output” which means that an object value can also be requested in hex;

e.g. "O $0192,2$":

Write object

RS232: O [$] Index , [$] Subindex = [$] Value [ ; Value2 ; Value3 ; ...]

RS485: Address O [$] Index , [$] Subindex = [$] Value [ ; Value2 ; Value3 ; ...]

The optional “$” preceding Index, Subindex and value stands for “Hex-input” which means that Index, Subindex and the value to be transferred can also be entered in hex (e.g. O $0192,2=$C8).


Binary record

The binary record with block securing is based on 5 different telegrams:

  • 2 request telegrams which the control sends to Compax3 and
  • 3 response telegrams which Compax3 returns to the control.
Telegram layout
Basic structure:
Start code | address | Number of data bytes - 1 | Data |  |  |  | block securing
SZ | O | L | D0 | D1 | ... | Dn |  | Crc(Hi) | Crc(Lo)
The start code defines the frame type and is composed as follows:
Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Frame type | Frame identification |  |  |  | PLC |  | Gateway | address
RdObj Read object | 1 | 0 | 1 | 0 | x | 1 | x | x
WrObj Write object | 1 | 1 | 0 | 0 | x | 1 | x | x
Rsp Answer | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 1
Ack Positive command acknowledgement | 0 | 0 | 0 | 0 | 0 | 1 | 1 | 0
Nak Negative command acknowledgement | 0 | 0 | 0 | 0 | 0 | 1 | 1 | 1

Bits 7, 6, 5 and 4 of the start code form the telegram identification; Bit 2 is always ”1”.

Bits 3, 1 and 0 have different meanings for the request and response telegrams.

The address is only necessary for RS484.

Request telegrams

-> Compax3
  • the address bit (Bit 0 = 1 ) shows if the start code is followed by an address
    (only for RS485; for RS232 Bit 0 = 0)
  • the gateway bit (Bit 1 = 1) shows if the message is to be passed on.
    (Please set Bit 1 = 0, as this function is not yet available)
  • the PLC bit (Bit 3 = 0 ) allows access to objects in the PLC format (U16, U32, IEEE Floating Point). For information into which PLC format the objects are converted, please refer to the object description.

Response telegram

Compax3 ->
  • Bits 0 and 1 are used to identify the response
  • Bit 3 is always 0

    The maximum number of data bytes in the request telegram is 256, in the response telegram 253.

    The block securing (CRC16) is made via the CCITT table algorithm for all characters.

    After receiving the start code, the timeout monitoring is activated in order to avoid that Compax3 waits in vain for further codes (e.g. connection interrupted) The timeout period between 2 codes received is fixed to 5ms (5 times the code time at 9600Baud)

Write object – WrObj telegram
SZ | Adr | L | D0 | D1 | D2 | D3 ... Dn | Crc(Hi) | Crc(Lo)
0xCX |  | n | Index(Hi) | Index(Lo) | Subindex | Value | 0x.. | 0x..

Describing an object by a value.

Positive acknowledgement – Ack-telegram
SZ | L | D0 | D1 | Crc(Hi) | Crc(Lo)
0x06 | 1 | 0 | 0 | 0x.. | 0x..

Answer from Compax3 if a writing process was successful, i.e. the function could be executed and is completed in itself.

Negative acknowledgement – Nak - telegram
SZ | L | D0 | D1 | Crc(Hi) | Crc(Lo)
0x07 | 1 | F-No.(Hi) | F-No.(Lo) | 0x.. | 0x..

Answer from Compax3 if access to the object was denied (e.g. function cannot be executed at that point in time or object has no reading access). The error no. is coded according to the DriveCom profile resp. the CiA Device Profile DSP 402.

Read object – RdObj - telegram
SZ | Adr | L | D0 | D1 | D2 | D3 | D4 | D5 | ... | Dn | Crc(Hi) | Crc(Lo)
0xAX |  | n | Index1(Hi) | Index1(Lo) | Subindex1 | Index2(Hi) | Index2(Lo) | Subindex2 | ... | ... | 0x.. | 0x..

Reading one or several objects

Answer – Rsp - telegram
SZ | L | D0 ... Dx-1 | Dx ... Dy-1 | Dy-D.. | D ... D.. | D ... Dn | Crc(Hi) | Crc(Lo)
0x05 | n | Value1 | Value 2 | Value 3 | Value .. | Value n | 0x.. | 0x..

Answer from Compax3 if the object can be read.

If the object has no reading access, Compax3 answers with the Nak – telegram.

Example:

Reading object "StatusPositionActual" (o680.5):

Request: A5 03 02 02 A8 05 E1 46

Response: 05 05 FF FF FF FF FE 2D 07 B4

Writing into an Array (o1901.1 = 2350)

Request: C5 02 08 07 6D 01 00 09 2E 00 00 00 95 D5

Response: 06 01 00 00 BA 87

Block securing:

Checksum calculation for the CCITT table algorithm

The block securing for all codes is performed via the following function and the corresponding table:

The ”CRC16” variable is set to ”0” before sending a telegram.

Function call:

CRC16 = UpdateCRC16(CRC16, Character);

This function is called up for each Byte (Character) of the telegram.

The result forms the last two bytes of the telegram

Compax3 checks the CRC value on receipt and reports CRC error in the case of a deviation.

Function

const unsigned int _P CRC16_table[256] = {

0x0000, 0x1021, 0x2042, 0x3063, 0x4084, 0x50a5, 0x60c6, 0x70e7,

0x8108, 0x9129, 0xa14a, 0xb16b, 0xc18c, 0xd1ad, 0xe1ce, 0xf1ef,

0x1231, 0x0210, 0x3273, 0x2252, 0x52b5, 0x4294, 0x72f7, 0x62d6,

0x9339, 0x8318, 0xb37b, 0xa35a, 0xd3bd, 0xc39c, 0xf3ff, 0xe3de,

0x2462, 0x3443, 0x0420, 0x1401, 0x64e6, 0x74c7, 0x44a4, 0x5485,

0xa56a, 0xb54b, 0x8528, 0x9509, 0xe5ee, 0xf5cf, 0xc5ac, 0xd58d,

0x3653, 0x2672, 0x1611, 0x0630, 0x76d7, 0x66f6, 0x5695, 0x46b4,

0xb75b, 0xa77a, 0x9719, 0x8738, 0xf7df, 0xe7fe, 0xd79d, 0xc7bc,

0x48c4, 0x58e5, 0x6886, 0x78a7, 0x0840, 0x1861, 0x2802, 0x3823,

0xc9cc, 0xd9ed, 0xe98e, 0xf9af, 0x8948, 0x9969, 0xa90a, 0xb92b,

0x5af5, 0x4ad4, 0x7ab7, 0x6a96, 0x1a71, 0x0a50, 0x3a33, 0x2a12,

0xdbfd, 0xcbdc, 0xfbbf, 0xeb9e, 0x9b79, 0x8b58, 0xbb3b, 0xab1a,

0x6ca6, 0x7c87, 0x4ce4, 0x5cc5, 0x2c22, 0x3c03, 0x0c60, 0x1c41,

0xedae, 0xfd8f, 0xcdec, 0xddcd, 0xad2a, 0xbd0b, 0x8d68, 0x9d49,

0x7e97, 0x6eb6, 0x5ed5, 0x4ef4, 0x3e13, 0x2e32, 0x1e51, 0x0e70,

0xff9f, 0xefbe, 0xdfdd, 0xcffc, 0xbf1b, 0xaf3a, 0x9f59, 0x8f78,

0x9188, 0x81a9, 0xb1ca, 0xa1eb, 0xd10c, 0xc12d, 0xf14e, 0xe16f,

0x1080, 0x00a1, 0x30c2, 0x20e3, 0x5004, 0x4025, 0x7046, 0x6067,

0x83b9, 0x9398, 0xa3fb, 0xb3da, 0xc33d, 0xd31c, 0xe37f, 0xf35e,

0x02b1, 0x1290, 0x22f3, 0x32d2, 0x4235, 0x5214, 0x6277, 0x7256,

0xb5ea, 0xa5cb, 0x95a8, 0x8589, 0xf56e, 0xe54f, 0xd52c, 0xc50d,

0x34e2, 0x24c3, 0x14a0, 0x0481, 0x7466, 0x6447, 0x5424, 0x4405,

0xa7db, 0xb7fa, 0x8799, 0x97b8, 0xe75f, 0xf77e, 0xc71d, 0xd73c,

0x26d3, 0x36f2, 0x0691, 0x16b0, 0x6657, 0x7676, 0x4615, 0x5634,

0xd94c, 0xc96d, 0xf90e, 0xe92f, 0x99c8, 0x89e9, 0xb98a, 0xa9ab,

0x5844, 0x4865, 0x7806, 0x6827, 0x18c0, 0x08e1, 0x3882, 0x28a3,

0xcb7d, 0xdb5c, 0xeb3f, 0xfb1e, 0x8bf9, 0x9bd8, 0xabbb, 0xbb9a,

0x4a75, 0x5a54, 0x6a37, 0x7a16, 0x0af1, 0x1ad0, 0x2ab3, 0x3a92,

0xfd2e, 0xed0f, 0xdd6c, 0xcd4d, 0xbdaa, 0xad8b, 0x9de8, 0x8dc9,

0x7c26, 0x6c07, 0x5c64, 0x4c45, 0x3ca2, 0x2c83, 0x1ce0, 0x0cc1,

0xef1f, 0xff3e, 0xcf5d, 0xdf7c, 0xaf9b, 0xbfba, 0x8fd9, 0x9ff8,

0x6e17, 0x7e36, 0x4e55, 0x5e74, 0x2e93, 0x3eb2, 0x0ed1, 0x1ef0

};

unsigned int UpdateCRC16(unsigned int crc,unsigned char value) {

unsigned int crc16;

crc16 = (CRC16_table[(crc >> 8) & 0x00FF] ^ (crc << 8)

^ (unsigned int)(value));

return crc16;

}

You will find this function on the Compax3 CD under RS232_485\Function UpdateCRC16.txt!


Compax3 - Objects

In this chapter you can read about:

Object overview sorted by object name (C1xT40)

C1xT40 Objects sorted by object name

Compax3 objects are encapsulated in the "C3, C3Array, ..." modules in the IEC61131-3 programming environment.

Enter the object names before the "." and the corresponding list of objects will appear.

Objects that are not described here are reserved objects!

Set objects to valid

Please note that certain objects are not valid (read by Compax3) immediately after a change. This is described in the heading "Valid after".

These objects are converted to internal variables the Compax3 "VP" command (write in object 210.10 with value <> 0).

Save objects permanently

It should also be noted that modified objects are not permanently stored, i.e. the changes are lost after the power (24 VDC) is turned off.

The object ”Save objects permanently” (write in object 20.11 with value <> 0)" can be used to save objects in a flash memory so they are retained even if the power fails.


Object overview sorted by object name (C1xT40)

No. | Object name | Object | Format |  | Access |  | Valid beginning
634.4 | C3.AnalogOutput0_DemandValue | Setpoint for analog output 0 |  | I16 |  | Read/write |  | Immediately
635.4 | C3.AnalogOutput1_DemandValue | Setpoint for analog output 1 |  | I16 |  | Read/write |  | Immediately
2100.8 | C3.ControllerTuning_CurrentBandwidth | Current Loop Bandwidth |  | U16 |  | Read/write |  | VP
2100.9 | C3.ControllerTuning_CurrentDamping | Current Loop Damping |  | U16 |  | Read/write |  | VP
2100.3 | C3.ControllerTuning_Damping | Damping (rotation speed controller) |  | U16 |  | Read/write |  | VP
2100.6 | C3.ControllerTuning_FilterAccel | Actual Acceleration Filter |  | U16 |  | Read/write |  | VP
2100.11 | C3.ControllerTuning_FilterAccel2 | Filter actual acceleration 2 |  | U16 |  | Read/write |  | VP
2100.5 | C3.ControllerTuning_FilterSpeed | Velocity Filter |  | U16 |  | Read/write |  | VP
2100.10 | C3.ControllerTuning_FilterSpeed2 | Filter actual velocity 2 |  | U16 |  | Read/write |  | VP
2100.4 | C3.ControllerTuning_Inertia | Moment of inertia |  | U16 |  | Read/write |  | VP
2100.7 | C3.ControllerTuning_SpeedDFactor | Velocity Loop - "D" Term |  | U16 |  | Read/write |  | VP
2100.2 | C3.ControllerTuning_Stiffness | Stiffness (speed controller) |  | U16 |  | Read/write |  | VP
990.1 | C3.Delay_MasterDelay | Setpoint delay for bus master |  | I16 |  | Read/write |  | Immediately
120.2 | C3.DigitalInput_Value | Status of digital inputs |  | V2 |  | Read only |  | -
121.2 | C3.DigitalInputAddition_Value | Input word of I/O option |  | V2 |  | Read only |  | -
133.4 | C3.DigitalOutputAddition_Enable | Activate input/output option M10/M12 |  | V2 |  | Read/write |  | Immediately
133.2 | C3.DigitalOutputAddition_Error | Error in I/O option |  | V2 |  | Read only |  | -
133.3 | C3.DigitalOutputAddition_Value | Output word for I/O option |  | V2 |  | Read/write |  | Immediately
2020.1 | C3.ExternalSignal_Position | Position from external signal source |  | C4_3 |  | Read only |  | -
2020.2 | C3.ExternalSignal_Speed | Speed from external signal source |  | C4_3 |  | Read only |  | -
2010.2 | C3.FeedForward_Accel | Acceleration feedforward |  | U16 |  | Read/write |  | VP
2010.4 | C3.FeedForward_Current | Current feedforward |  | U16 |  | Read/write |  | VP
2010.5 | C3.FeedForward_Jerk | Jerk feedforward |  | U16 |  | Read/write |  | VP
2010.1 | C3.FeedForward_Speed | Velocity feedforward |  | U16 |  | Read/write |  | VP
2010.18 | C3.FeedForward_Voltage | Voltage feedforward |  | U16 |  | Read/write |  | VP
1141.7 | C3.GEAR_actual_masterposition | Position input value for Gearing |  | C4_3 |  | Read only |  | -
402.4 | C3.Limit_CurrentNegative | Maximum permissible negative current |  | I16 |  | Read/write |  | VP
402.3 | C3.Limit_CurrentPositive | Maximum permissible positive current |  | I16 |  | Read/write |  | VP
402.2 | C3.Limit_SpeedNegative | Maximum permissible negative speed |  | I16 |  | Read/write |  | VP
402.1 | C3.Limit_SpeedPositive | Maximum permissible positive speed |  | I16 |  | Read/write |  | VP
410.3 | C3.LimitPosition_Negative | Negative SW travel limit |  | C4_3 |  | Read/write |  | Immediately
410.2 | C3.LimitPosition_Positive | Positive Travel Limit |  | C4_3 |  | Read/write |  | Immediately
3310.1 | C3.Multiturnemulation_Status | Status of the Multiturn emulation |  | I16 |  | Read only |  | -
20.10 | C3.ObjectDir_ReadObjects | Read objects from Flash |  | I16 |  | Read/write |  | Immediately
20.11 | C3.ObjectDir_WriteObjects | Save objects permanently |  | I16 |  | Read/write |  | Immediately
420.3 | C3.PositioningAccuracy_FollowingErrorTimeout | Following Error Time |  | U16 |  | Read/write |  | Immediately
420.2 | C3.PositioningAccuracy_FollowingErrorWindow | Following error limit |  | C4_3 |  | Read/write |  | VP
420.6 | C3.PositioningAccuracy_PositionReached | Position reached |  | I32 |  | Read only |  | -
420.1 | C3.PositioningAccuracy_Window | Positioning window for position reached |  | C4_3 |  | Read/write |  | VP
420.7 | C3.PositioningAccuracy_WindowTime | In Position Window Time |  | U16 |  | Read/write |  | Immediately
2120.7 | C3.SpeedObserver_DisturbanceAdditionEnable | Switch to enable disturbance compensation |  | BOOL |  | Read/write |  | VP
2120.5 | C3.SpeedObserver_DisturbanceFilter | Time constant disturbance filter |  | U32 |  | Read/write |  | VP
2120.1 | C3.SpeedObserver_TimeConstant | Rapidity of the speed monitor |  | U32 |  | Read/write |  | VP
682.5 | C3.StatusAccel_Actual | Status of actual acceleration unfiltered |  | I32 |  | Read only |  | -
682.6 | C3.StatusAccel_ActualFilter | Status of filtered actual acceleration |  | I32 |  | Read only |  | -
682.4 | C3.StatusAccel_DemandValue | Status demand acceleration |  | I32 |  | Read only |  | -
682.7 | C3.StatusAccel_FeedForwardAccel | Status acceleration feed forward |  | C4_3 |  | Read only |  | -
688.2 | C3.StatusCurrent_Actual | Status of actual current RMS (torque producing) |  | E2_6 |  | Read only |  | -
688.8 | C3.StatusCurrent_ControlDeviationIq | Status of control deviation of current control RMS |  | C4_3 |  | Read only |  | -
688.14 | C3.StatusCurrent_FeedForwordCurrentJerk | Status of current rms and jerk feedforward |  | C4_3 |  | Read only |  | -
688.9 | C3.StatusCurrent_PhaseU | Status of current phase U |  | C4_3 |  | Read only |  | -
688.10 | C3.StatusCurrent_PhaseV | Status of current phase V |  | C4_3 |  | Read only |  | -
688.1 | C3.StatusCurrent_Reference | Status of setpoint current RMS (torque forming) |  | E2_6 |  | Read only |  | -
688.13 | C3.StatusCurrent_ReferenceJerk | Status of demand jerk setpoint generator |  | C4_3 |  | Read only |  | -
688.11 | C3.StatusCurrent_ReferenceVoltageUq | Status of current control control signal |  | C4_3 |  | Read only |  | -
683.1 | C3.StatusDevice_ActualCurrent | Status of actual current value |  | E2_6 |  | Read only |  | -
683.2 | C3.StatusDevice_ActualDeviceLoad | Status of device utilization |  | E2_6 |  | Read only |  | -
683.3 | C3.StatusDevice_ActualMotorLoad | Status of long-term motor load |  | E2_6 |  | Read only |  | -
683.4 | C3.StatusDevice_DynamicMotorLoad | Status of short-term motor load |  | E2_6 |  | Read only |  | -
683.5 | C3.StatusDevice_ObservedDisturbance | Status of observed disturbance |  | C4_3 |  | Read only |  | -
692.4 | C3.StatusFeedback_EncoderCosine | Status of analog input cosine |  | I32 |  | Read only |  | -
692.3 | C3.StatusFeedback_EncoderSine | Status of analog input sine |  | I32 |  | Read only |  | -
692.2 | C3.StatusFeedback_FeedbackCosineDSP | Status of cosine in signal processing |  | I32 |  | Read only |  | -
692.1 | C3.StatusFeedback_FeedbackSineDSP | Status of sine in signal processing |  | I32 |  | Read only |  | -
692.5 | C3.StatusFeedback_FeedbackVoltage[Vpp] | Status of feedback level |  | C4_3 |  | Read only |  | -
689.1 | C3.StatusHeda_RxPD | Receive string |  | OS |  | Read only |  | -
689.2 | C3.StatusHeda_TxPD | Sendestring |  | OS |  | Read only |  | -
680.5 | C3.StatusPosition_Actual | Status actual position |  | C4_3 |  | Read only |  | -
680.13 | C3.StatusPosition_ActualValueController | Status actual position without absolute reference |  | C4_3 |  | Read only |  | -
680.4 | C3.StatusPosition_DemandValue | Status demand position |  | C4_3 |  | Read only |  | -
680.2 | C3.StatusPosition_DemandValue2 | Status demand position virtual master |  | Y4 |  | Read only |  | -
680.12 | C3.StatusPosition_DemandValueController | Status demand position without absolute reference |  | C4_3 |  | Read only |  | -
680.11 | C3.StatusPosition_EncoderInput24V | Status of encoder input 0 (24V) |  | C4_3 |  | Read only |  | -
680.10 | C3.StatusPosition_EncoderInput5V | Status of encoder input 0 (5V) |  | C4_3 |  | Read only |  | -
680.6 | C3.StatusPosition_FollowingError | Status of following error |  | C4_3 |  | Read only |  | -
681.5 | C3.StatusSpeed_Actual | Status actual speed unfiltered |  | C4_3 |  | Read only |  | -
681.9 | C3.StatusSpeed_ActualFiltered | Status actual speed filtered |  | C4_3 |  | Read only |  | -
681.12 | C3.StatusSpeed_ActualScaled | Filtered actual speed |  | C4_3 |  | Read only |  | -
681.13 | C3.StatusSpeed_DemandScaled | Setpoint speed of the setpoint generator |  | C4_3 |  | Read only |  | -
681.10 | C3.StatusSpeed_DemandSpeedController | Status demand speed controller input |  | C4_3 |  | Read only |  | -
681.4 | C3.StatusSpeed_DemandValue | Status demand speed of setpoint generator |  | C4_3 |  | Read only |  | -
681.2 | C3.StatusSpeed_DemandValue2 | Status demand speed virtual master |  | Y4 |  | Read only |  | -
681.6 | C3.StatusSpeed_Error | Status control deviation of speed |  | C4_3 |  | Read only |  | -
681.11 | C3.StatusSpeed_FeedForwardSpeed | Status speed feed forward |  | C4_3 |  | Read only |  | -
684.2 | C3.StatusTemperature_Motor | Status of motor temperature |  | U16 |  | Read only |  | -
684.1 | C3.StatusTemperature_PowerStage | Status of power output stage temperature |  | U16 |  | Read only |  | -
685.3 | C3.StatusVoltage_AnalogInput0 | Status of analog input 0 |  | Y2 |  | Read only |  | -
685.4 | C3.StatusVoltage_AnalogInput1 | Status of analog input 1 |  | Y2 |  | Read only |  | -
685.1 | C3.StatusVoltage_AuxiliaryVoltage | Status of auxiliary voltage |  | E2_6 |  | Read only |  | -
685.2 | C3.StatusVoltage_BusVoltage | Status DC bus voltage |  | E2_6 |  | Read only |  | -
210.10 | C3.ValidParameter_Global | Set objects to valid |  | U16 |  | Read/write |  | Immediately
1901.1 | C3Array.Col01_Row01 | Variable Column 1 Row 1 |  | Y4 |  | Read/write |  | Immediately
1901.2 | C3Array.Col01_Row02 | Variable Column 1 Row 2 |  | Y4 |  | Read/write |  | Immediately
1901.3 | C3Array.Col01_Row03 | Variable Column 1 Row 3 |  | Y4 |  | Read/write |  | Immediately
1901.4 | C3Array.Col01_Row04 | Variable Column 1 Row 4 |  | Y4 |  | Read/write |  | Immediately
1901.5 | C3Array.Col01_Row05 | Variable Column 1 Row 5 |  | Y4 |  | Read/write |  | Immediately
1902.1 | C3Array.Col02_Row01 | Variable Column 2 Row 1 |  | Y2 |  | Read/write |  | Immediately
1902.2 | C3Array.Col02_Row02 | Variable Column 2 Row 2 |  | Y2 |  | Read/write |  | Immediately
1902.3 | C3Array.Col02_Row03 | Variable Column 2 Row 3 |  | Y2 |  | Read/write |  | Immediately
1902.4 | C3Array.Col02_Row04 | Variable Column 2 Row 4 |  | Y2 |  | Read/write |  | Immediately
1902.5 | C3Array.Col02_Row05 | Variable Column 2 Row 5 |  | Y2 |  | Read/write |  | Immediately
1903.1 | C3Array.Col03_Row01 | Variable Column 3 Row 1 |  | I16 |  | Read/write |  | Immediately
1903.2 | C3Array.Col03_Row02 | Variable Column 3 Row 2 |  | I16 |  | Read/write |  | Immediately
1903.3 | C3Array.Col03_Row03 | Variable Column 3 Row 3 |  | I16 |  | Read/write |  | Immediately
1903.4 | C3Array.Col03_Row04 | Variable Column 3 Row 4 |  | I16 |  | Read/write |  | Immediately
1903.5 | C3Array.Col03_Row05 | Variable Column 3 Row 5 |  | I16 |  | Read/write |  | Immediately
1904.1 | C3Array.Col04_Row01 | Variable Column 4 Row 1 |  | I16 |  | Read/write |  | Immediately
1904.2 | C3Array.Col04_Row02 | Variable Column 4 Row 2 |  | I16 |  | Read/write |  | Immediately
1904.3 | C3Array.Col04_Row03 | Variable Column 4 Row 3 |  | I16 |  | Read/write |  | Immediately
1904.4 | C3Array.Col04_Row04 | Variable Column 4 Row 4 |  | I16 |  | Read/write |  | Immediately
1904.5 | C3Array.Col04_Row05 | Variable Column 4 Row 5 |  | I16 |  | Read/write |  | Immediately
1905.1 | C3Array.Col05_Row01 | Variable Column 5 Row 1 |  | I16 |  | Read/write |  | Immediately
1905.2 | C3Array.Col05_Row02 | Variable Column 5 Row 2 |  | I16 |  | Read/write |  | Immediately
1905.3 | C3Array.Col05_Row03 | Variable Column 5 Row 3 |  | I16 |  | Read/write |  | Immediately
1905.4 | C3Array.Col05_Row04 | Variable Column 5 Row 4 |  | I16 |  | Read/write |  | Immediately
1905.5 | C3Array.Col05_Row05 | Variable Column 5 Row 5 |  | I16 |  | Read/write |  | Immediately
1906.1 | C3Array.Col06_Row01 | Variable Column 6 Row 1 |  | I32 |  | Read/write |  | Immediately
1906.2 | C3Array.Col06_Row02 | Variable Column 6 Row 2 |  | I32 |  | Read/write |  | Immediately
1906.3 | C3Array.Col06_Row03 | Variable Column 6 Row 3 |  | I32 |  | Read/write |  | Immediately
1906.4 | C3Array.Col06_Row04 | Variable Column 6 Row 4 |  | I32 |  | Read/write |  | Immediately
1906.5 | C3Array.Col06_Row05 | Variable Column 6 Row 5 |  | I32 |  | Read/write |  | Immediately
1907.1 | C3Array.Col07_Row01 | Variable Column 7 Row 1 |  | I32 |  | Read/write |  | Immediately
1907.2 | C3Array.Col07_Row02 | Variable Column 7 Row 2 |  | I32 |  | Read/write |  | Immediately
1907.3 | C3Array.Col07_Row03 | Variable Column 7 Row 3 |  | I32 |  | Read/write |  | Immediately
1907.4 | C3Array.Col07_Row04 | Variable Column 7 Row 4 |  | I32 |  | Read/write |  | Immediately
1907.5 | C3Array.Col07_Row05 | Variable Column 7 Row 5 |  | I32 |  | Read/write |  | Immediately
1908.1 | C3Array.Col08_Row01 | Variable Column 8 Row 1 |  | I32 |  | Read/write |  | Immediately
1908.2 | C3Array.Col08_Row02 | Variable Column 8 Row 2 |  | I32 |  | Read/write |  | Immediately
1908.3 | C3Array.Col08_Row03 | Variable Column 8 Row 3 |  | I32 |  | Read/write |  | Immediately
1908.4 | C3Array.Col08_Row04 | Variable Column 8 Row 4 |  | I32 |  | Read/write |  | Immediately
1908.5 | C3Array.Col08_Row05 | Variable Column 8 Row 5 |  | I32 |  | Read/write |  | Immediately
1909.1 | C3Array.Col09_Row01 | Variable Column 9 Row 1 |  | I32 |  | Read/write |  | Immediately
1909.2 | C3Array.Col09_Row02 | Variable Column 9 Row 2 |  | I32 |  | Read/write |  | Immediately
1909.3 | C3Array.Col09_Row03 | Variable Column 9 Row 3 |  | I32 |  | Read/write |  | Immediately
1909.4 | C3Array.Col09_Row04 | Variable Column 9 Row 4 |  | I32 |  | Read/write |  | Immediately
1909.5 | C3Array.Col09_Row05 | Variable Column 9 Row 5 |  | I32 |  | Read/write |  | Immediately
1910.1 | C3Array.Indirect_Col01 | Indirect table access Column 1 |  | Y4 |  | Read/write |  | Immediately
1910.2 | C3Array.Indirect_Col02 | Indirect table access Column 2 |  | Y2 |  | Read/write |  | Immediately
1910.3 | C3Array.Indirect_Col03 | Indirect table access Column 3 |  | I16 |  | Read/write |  | Immediately
1910.4 | C3Array.Indirect_Col04 | Indirect table access Column 4 |  | I16 |  | Read/write |  | Immediately
1910.5 | C3Array.Indirect_Col05 | Indirect table access Column 5 |  | I16 |  | Read/write |  | Immediately
1910.6 | C3Array.Indirect_Col06 | Indirect table access Column 6 |  | I32 |  | Read/write |  | Immediately
1910.7 | C3Array.Indirect_Col07 | Indirect table access Column 7 |  | I32 |  | Read/write |  | Immediately
1910.8 | C3Array.Indirect_Col08 | Indirect table access Column 8 |  | I32 |  | Read/write |  | Immediately
1910.9 | C3Array.Indirect_Col09 | Indirect table access Column 9 |  | I32 |  | Read/write |  | Immediately
1900.1 | C3Array.Pointer_Row | Pointer to table row |  | U16 |  | Read/write |  | Immediately
3730.3 | C3Cam.ControlledSwitch00_PositionOff | switch-off position of cam |  | C4_3 |  | Read/write |  | VP
3730.2 | C3Cam.ControlledSwitch00_PositionOn | switch-on position of cam |  | C4_3 |  | Read/write |  | VP
3730.1 | C3Cam.ControlledSwitch00_Source | source of cam |  | I16 |  | Read/write |  | VP
3730.5 | C3Cam.ControlledSwitch00_TimeOff | switch-off anticipation of cam |  | I16 |  | Read/write |  | Immediately
3730.4 | C3Cam.ControlledSwitch00_TimeOn | switch-on anticipation of cam |  | I16 |  | Read/write |  | Immediately
3701.2 | C3Cam.ControlledSwitches_Enable0 | enable of cam group 0 |  | U16 |  | Read/write |  | Immediately
3701.4 | C3Cam.ControlledSwitches_Enable1 | enable of cam group 1 |  | U16 |  | Read/write |  | Immediately
3701.6 | C3Cam.ControlledSwitches_NumberPerCycle | Number of cams in one cycle |  | U16 |  | Read/write |  | Immediately
3701.3 | C3Cam.ControlledSwitches_Output0 | output of cam group 0 |  | U16 |  | Read/write |  | Immediately
3701.5 | C3Cam.ControlledSwitches_Output1 | output of cam group 1 |  | U16 |  | Read/write |  | Immediately
3700.2 | C3Cam.ControlledSwitchesFast_Enable | enable fast cams |  | U16 |  | Read/write |  | Immediately
3700.3 | C3Cam.ControlledSwitchesFast_Output | output for fast cams |  | U16 |  | Read/write |  | Immediately
3705.1 | C3Cam.ControlledSwitchesHysteresis_ActualPosition | hysteresis for cam switching mechanism |  | C4_3 |  | Read/write |  | VP
3710.3 | C3Cam.ControlledSwitchFast0_PositionOff | switch-off position for fast cam |  | C4_3 |  | Read/write |  | VP
3710.2 | C3Cam.ControlledSwitchFast0_PositionOn | switch-on position for fast cam |  | C4_3 |  | Read/write |  | VP
3710.1 | C3Cam.ControlledSwitchFast0_Source | source of fast cam |  | I16 |  | Read/write |  | VP
3710.5 | C3Cam.ControlledSwitchFast0_TimeOff | switch-off anticipation of fast cam |  | I16 |  | Read/write |  | Immediately
3710.4 | C3Cam.ControlledSwitchFast0_TimeOn | switch-on anticipation of fast cam |  | I16 |  | Read/write |  | Immediately
3022.1 | C3Cam.Manipulation_OffsetMasterposition | Master position offset |  | C4_3 |  | Read/write |  | Immediately
3022.6 | C3Cam.Manipulation_OffsetMasterposition_Units | Offset Master position |  | C4_3 |  | Read/write |  | Immediately
3022.3 | C3Cam.Manipulation_ScalefactorMasterGlobal | Global scaling factor for the master speed |  | C4_3 |  | Read/write |  | Immediately
3021.2 | C3Cam.SignalSource_Position | Status of position of selected master signal source |  | C4_3 |  | Read only |  | -
3031.4 | C3Cam.StatusData_ActualCurve | Current curve number |  | I16 |  | Read only |  | -
3030.12 | C3Cam.StatusMaster_PhasingSum | Added up position sum of the master-side phasing |  | C4_3 |  | Read only |  | -
3030.1 | C3Cam.StatusMaster_Position | Reset master position |  | C4_3 |  | Read only |  | -
3030.24 | C3Cam.StatusMaster_PositionCamUnits | Master position at the beginning of the curve |  | C4_3 |  | Read only |  | -
3030.22 | C3Cam.StatusMaster_SpeedUnits | Master speed [Units/s] |  | C4_3 |  | Read only |  | -
3032.24 | C3Cam.StatusOutput_CurvePositionUnits | End of curve |  | C4_3 |  | Read only |  | -
3032.1 | C3Cam.StatusOutput_Position | Slave position |  | C4_3 |  | Read only |  | -
2190.2 | C3Plus.AutoCommutationControl_InitialCurrent | Start current of automatic commutation |  | U32 |  | Read/write |  | VP
550.1 | C3Plus.ErrorHistory_LastError | Current error (n) |  | U16 |  | Read only |  | -
1141.8 | C3Plus.GEAR_actual_master_speed | Master speed for Gearing |  | C4_3 |  | Read only |  | -
900.12 | C3Plus.HEDA_CRC_ErrorCounter | Error counter CRC (HEDA) |  | U32 |  | Read/write |  | Immediately
3920.1 | C3Plus.HEDA_SignalProcessing_Input | Process input signal Slave |  | C4_3 |  | Read/write |  | Immediately
900.1 | C3Plus.HEDA_State | Status HEDA |  | I16 |  | Read/write |  | Immediately
900.13 | C3Plus.HEDA_SyncErrorCounter | Error counter Sync (HEDA) |  | U32 |  | Read/write |  | Immediately
1130.1 | C3Plus.HOMING_accel | Acceleration / deceleration MN run |  | U32 |  | Read/write |  | Immediately
1130.7 | C3Plus.HOMING_edge_sensor_distance | Initiator adjustment |  | C4_3 |  | Read/write |  | Immediately
1130.2 | C3Plus.HOMING_jerk | Jerk for homing |  | U32 |  | Read/write |  | Immediately
1130.4 | C3Plus.HOMING_mode | Adjusting the homing mode |  | U16 |  | Read/write |  | Immediately
1130.3 | C3Plus.HOMING_speed | Speed for homing |  | C4_3 |  | Read/write |  | Immediately
50.3 | C3Plus.PLC_ActualCycleTime | Status of cycle time of the control program |  | U16 |  | Read only |  | -
50.4 | C3Plus.PLC_ActualCycleTimeMax | Status of maximum cycle time |  | U16 |  | Read/write |  | Immediately
50.1 | C3Plus.PLC_DemandCycleTime | Cycle time specification |  | U16 |  | Read/write |  | Immediately
2200.2 | C3Plus.PositionController_ActualValue | Position actual value (sequentially) |  | C4_3 |  | Read only |  | -
2200.1 | C3Plus.PositionController_DemandValue | Position setpoint value (sequentially) |  | C4_3 |  | Read only |  | -
2000.2 | C3Plus.ProfilGenerators_PG2Position | Position value of the setpoint encoder of the virtual axis |  | C4_3 |  | Read only |  | -
2000.5 | C3Plus.ProfilGenerators_PG2Speed | Speed of the virtual axis |  | I32 |  | Read only |  | -
2000.1 | C3Plus.ProfilGenerators_SG1Position | Position value of the setpoint encoder |  | C4_3 |  | Read only |  | -
2000.4 | C3Plus.ProfilGenerators_SG1Speed | Speed of the setpoint encoder |  | I32 |  | Read only |  | -
210.9 | C3Plus.ValidParameter_CamControlledSwitches | Set cam switching mechanism parameters to valid |  | U16 |  | Read/write |  | Immediately


C1xT40 Objects sorted by object name

In this chapter you can read about:

Object: setpoint for analog output 0

Object: setpoint for analog output 1

Object: bandwidth of the current controller

Object: damping factor of the current controller

Object: damping (rotation speed controller)

Object: Filter actual acceleration

Object: Filter actual acceleration 2

Object: Filter actual velocity

Object: Filter actual velocity 2

Object: moment of inertia

Object: D-component of the rotation speed controller

Object: stiffness (speed controller)

Object: Setpoint delay for bus master

Object: Status of digital inputs

Object: input word of I/O option

Object: activating input/output option M10/M12

Object: error in I/O option

Object: output word for I/O option

Object: position from external signal source

Object: speed from external signal source

Object: acceleration forward control

Object: current feedforward

Object: jerk feedforward

Object: rotation speed forward control

Object: Voltage feedforward

Object: Position input value for Gearing

Object: maximum permissible negative current

Object: maximum permissible positive current

Object: maximum permissible negative speed

Object: maximum permissible positive speed

Object: negative end limit

Object: positive end limit

Object: Status of Multiturn emulation

Object: reading objects from Flash

Object: saving objects permanently

Object: following error time

Object: following error limit

Object: position reached

Object: positioning window for position reached

Object: position window time

Object: Switch to enable disturbance compensation

Object: Time constant disturbance filter

Object: Rapidity of the speed monitor

Object: Status of actual acceleration unfiltered

Object: Status of filtered actual acceleration

Object: Status demand acceleration

Object: Status acceleration feed forward

Object: Status of actual current RMS (torque producing)

Object: Status of control deviation of current control RMS

Object: Status of current rms and jerk feedforward

Object: Status of current phase U

Object: Status of current phase V

Object: Status of setpoint current RMS (torque forming)

Object: Status of demand jerk setpoint generator

Object: Status of current control control signal

Object: Status of actual current value

Object: Status of device utilization

Object: Status of long-term motor load

Object: Status of short-term motor load

Object: Status of observed disturbance

Object: Status of analog input cosine

Object: Status of analog input sine

Object: Status of cosine in signal processing

Object: Status of sine in signal processing

Object: Status of feedback level

Object: Receive string

Object: Sendestring

Object: Status actual position

Object: Status actual position without absolute reference

Object: Status demand position

Object: Status demand position virtual master

Object: Status demand position without absolute reference

Object: Status of encoder input 0 (24V)0

Object: Status of encoder input 0 (5V)0

Object: Status of following error

Object: Status actual speed unfiltered

Object: Status actual speed filtered

Object: Filtered actual speed

Object: Setpoint speed of the setpoint generator

Object: Status demand speed controller input

Object: Status demand speed of setpoint generator

Object: Status demand speed virtual master

Object: Status control deviation of speed

Object: Status speed feed forward

Object: Status of motor temperature

Object: Status of power output stage temperature

Object: Status of analog input 0

Object: Status of analog input 1

Object: Status of auxiliary voltage

Object: Status DC bus voltage

Object: setting objects to valid

Object: variable Column 1 Row 1

Object: variable Column 2 Row 1

Object: variable Column 3 Row 1

Object: variable Column 4 Row 1

Object: variable Column 5 Row 1

Object: variable Column 6 Row 1

Object: variable Column 7 Row 1

Object: variable Column 8 Row 1

Object: variable Column 9 Row 1

Object: indirect table access Column 1

Object: indirect table access Column 2

Object: indirect table access Column 3

Object: indirect table access Column 4

Object: indirect table access Column 5

Object: indirect table access Column 6

Object: indirect table access Column 7

Object: indirect table access Column 8

Object: indirect table access Column 9

Object: pointer to table row

Object: switch-off position of cam

Object: switch-on position of cam

Object: source of cam

Object: switch-off anticipation of cam

Object: switch-on anticipation of cam

Object: enable of cam group 0

Object: enable of cam group 1

Object: Number of cams in one cycle

Object: output of cam group 0

Object: output of cam group 1

Object: enable fast cams

Object: output for fast cams

Object: hysteresis for cam switching mechanism

Object: switch-off position for fast cam

Object: switch-on position for fast cam

Object: source of fast cam

Object: switch-off anticipation of fast cam

Object: switch-on anticipation of fast cam

Object: Master position offset

Object: Offset Master position

Object: Global scaling factor for the master speed

Object: Status of position of selected master signal source

Object: Current curve number

Object: Added up position sum of the master-side phasing

Object: Reset master position

Object: Master position at the beginning of the curve

Object: Master speed [Units/s]

Object: End of curve

Object: Slave position

Object: Start current of automatic commutation

Object: current error (n)

Object: Master speed for Gearing

Object: Error counter CRC (HEDA)

Object: Process input signal Slave

Object: Status HEDA

Object: Error counter Sync (HEDA)

Object: Acceleration / deceleration MN (homing) run

Object: initiator adjustment

Object: jerk for homing

Object: adjusting the homing mode

Object: speed for homing

Object: Status of cycle time of the control program

Object: Status of maximum cycle time

Object: cycle time specification

Object: Position actual value (sequentially)

Object: Position setpoint value (sequentially)

Object: Position value of the setpoint encoder of the virtual axis

Object: Speed of the virtual axis

Object: Position value of the setpoint encoder

Object: Speed of the setpoint encoder

Object: Set cam switching mechanism parameters to valid


Object: Setpoint for analog output 0

Object name | C3.AnalogOutput0_DemandValue
Object No. | 634.4 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Setpoint for analog output 0 (DA0 - X11/4); can be used as a DA monitor. This output must be previously activated to be able to access it. You can do this in the ServoManager in the optimization window in the partial window at the bottom left under DA monitor. Convert the signal source to IEC61131.


Object: Setpoint for analog output 1

Object name | C3.AnalogOutput1_DemandValue
Object No. | 635.4 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Setpoint for analog output 1 (DA1 - X11/3); can be used as DA monitor. This output must be previously activated to be able to access it. You can do this in the ServoManager in the optimization window in the partial window at the bottom left under DA monitor. Convert the signal source to IEC61131.


Object: Current Loop Bandwidth

Object name | C3.ControllerTuning_CurrentBandwidth
Object No. | 2100.8 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 10 % | Maximum value | 200 %
Remark: |


Object: Current Loop Damping

Object name | C3.ControllerTuning_CurrentDamping
Object No. | 2100.9 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 0 % | Maximum value | 500 %
Remark: |


Object: Damping (rotation speed controller)

Object name | C3.ControllerTuning_Damping
Object No. | 2100.3 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 0 % | Maximum value | 500 %
Remark: |


Object: Actual Acceleration Filter

Object name | C3.ControllerTuning_FilterAccel
Object No. | 2100.6 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 0 % | Maximum value | 554 %
Remark: |


Object: Filter actual acceleration 2

Object name | C3.ControllerTuning_FilterAccel2
Object No. | 2100.11 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | us |  |
Minimum value | 63 us | Maximum value | 8300000 us
Remark: | Works in line with actual acceleration filter Default value 0us The filter is deactivated for values from 0 to 62us.


Object: Velocity Filter

Object name | C3.ControllerTuning_FilterSpeed
Object No. | 2100.5 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 0 % | Maximum value | 554 %
Remark: |


Object: Filter actual velocity 2

Object name | C3.ControllerTuning_FilterSpeed2
Object No. | 2100.10 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | us |  |
Minimum value | 63 us | Maximum value | 8300000 us
Remark: | Works in line with actual velocity filter Default value 0us The filter is deactivated for values from 0 to 62us.


Object: Moment of inertia

Object name | C3.ControllerTuning_Inertia
Object No. | 2100.4 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 10 % | Maximum value | 500 %
Remark: |


Object: Velocity Loop - "D" Term

Object name | C3.ControllerTuning_SpeedDFactor
Object No. | 2100.7 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 0 % | Maximum value | 2000000 %
Remark: | Velocity Loop - "D" Term


Object: Stiffness (speed controller)

Object name | C3.ControllerTuning_Stiffness
Object No. | 2100.2 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 10 % | Maximum value | 100000 %
Remark: |


Object: Setpoint delay for bus master

Object name | C3.Delay_MasterDelay
Object No. | 990.1 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | no | CodeSys format: |
Unit of Travel | 500us |  |
Minimum value | 0 500us | Maximum value | 19 500us
Remark: | Setpoint delay for bus master. If several axes are to run synchronous to the setpoint value, there is a position offset when accelerating and braking caused by the bus delay time. This object can be used to delay the setpoint value on the master between the setpoint generator and the controller, so that the same delay time as on the slaves is effective on the master. For following axes, the object should always be on 0. For a HEDA master it should be on 2 (=1ms).


Object: Status of digital inputs

Object name | C3.DigitalInput_Value
Object No. | 120.2 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | WORD
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Status of the dig. inputs (multiple word) Bit 0: I0 (right) Bit 1: I1 ...


Object: Input word of I/O option

Object name | C3.DigitalInputAddition_Value
Object No. | 121.2 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | WORD
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Input word for I/O option M10 or M12


Object: Activate input/output option M10/M12

Object name | C3.DigitalOutputAddition_Enable
Object No. | 133.4 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | WORD
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Activation of output groups M10 and M12 Bit0=0 lower 4 bits inputs (plug X22/2 - /5) Bit0=1 lower 4 bits outputs (plug X22/2 - /5) Bit1=0 middle 4 bits inputs (plug X22/6 - /9) Bit1=1 middle 4 bits outputs (plug X22/6 - /9) Bit2=0 upper 4 bits inputs (plug X22/10, /12, /13, /14) Bit2=1 upper 4 bits outputs (plug X22/10, /12, /13, /14)


Object: Error in I/O option

Object name | C3.DigitalOutputAddition_Error
Object No. | 133.2 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | WORD
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Error of I/O option M10 or M12: Bit0=1 lower 4 bits error (plug X22/2 - /5) Bit1=1 middle 4 bits error (plug X22/6 - /9) Bit2=1 upper 4 bits error (plug X22/10, /12, /13, /14) Error means output overloaded Bit3=1 24-V under-voltage


Object: Output word for I/O option

Object name | C3.DigitalOutputAddition_Value
Object No. | 133.3 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | WORD
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Output word for I/O option M10 or M12


Object: Position from external signal source

Object name | C3.ExternalSignal_Position
Object No. | 2020.1 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | rounds |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Position value of the external signal source The following inputs can be used as external signal source (depending on the configuration of the device): - +-10V - RS422 Step/direction - RS422 A/B Encoder - Digital value


Object: Speed from external signal source

Object name | C3.ExternalSignal_Speed
Object No. | 2020.2 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit/s |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Speed value of the external signal source The following inputs can be used as external signal source (depending on the configuration of the device): - +-10V - RS422 Step/direction - RS422 A/B Encoder


Object: Acceleration feedforward

Object name | C3.FeedForward_Accel
Object No. | 2010.2 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 0 % | Maximum value | 500 %
Remark: | Default 100%


Object: Current feedforward

Object name | C3.FeedForward_Current
Object No. | 2010.4 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 0 % | Maximum value | 500 %
Remark: | Default 0%


Object: Jerk feedforward

Object name | C3.FeedForward_Jerk
Object No. | 2010.5 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 0 % | Maximum value | 500 %
Remark: | Default 0%


Object: Velocity feedforward

Object name | C3.FeedForward_Speed
Object No. | 2010.1 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 0 % | Maximum value | 500 %
Remark: | Default 100%


Object: Voltage feedforward

Object name | C3.FeedForward_Voltage
Object No. | 2010.18 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 0 % | Maximum value | 500 %
Remark: |


Object: Position input value for Gearing

Object name | C3.GEAR_actual_masterposition
Object No. | 1141.7 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: |
Unit of Travel | rounds |  |
Minimum value | Unit | Maximum value | Unit
Remark: | in Units


Object: Maximum permissible negative current

Object name | C3.Limit_CurrentNegative
Object No. | 402.4 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 0 A | Maximum value | -500 A
Remark: | Negative current limit 100% correspond to the rated motor current


Object: Maximum permissible positive current

Object name | C3.Limit_CurrentPositive
Object No. | 402.3 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 0 A | Maximum value | 500 A
Remark: | Positive current limit 100% correspond to the rated motor current


Object: Maximum permissible negative speed

Object name | C3.Limit_SpeedNegative
Object No. | 402.2 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 0 rounds/s | Maximum value | -1000 rounds/s
Remark: | Negative speed limit 100% correspond to the motor reference speed


Object: Maximum permissible positive speed

Object name | C3.Limit_SpeedPositive
Object No. | 402.1 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 0 rounds/s | Maximum value | 2000 rounds/s
Remark: | Positive speed limit 100% correspond to the motor reference speed


Object: Negative SW travel limit

Object name | C3.LimitPosition_Negative
Object No. | 410.3 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit |  |
Minimum value | -4000000 rounds | Maximum value | 4000000 rounds
Remark: |


Object: Positive Travel Limit

Object name | C3.LimitPosition_Positive
Object No. | 410.2 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit |  |
Minimum value | -4000000 rounds | Maximum value | 4000000 rounds
Remark: |


Object: Status of the Multiturn emulation

Object name | C3.Multiturnemulation_Status
Object No. | 3310.1 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | BOOL
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | 0: angle was within the window; -1: angle was outside the window. The position will be restored at any rate, even if the angle was not within the window! If the window size is zero, there is no reconstruction of the absolute position, i.e. the status is not processed (value 0) – the Multiturn emulation is switched off.


Object: Read objects from Flash

Object name | C3.ObjectDir_ReadObjects
Object No. | 20.10 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | BOOL
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Read objects from Flash by writing a value <> 0 to this object The function does not work in curve mode.


Object: Save objects permanently

Object name | C3.ObjectDir_WriteObjects
Object No. | 20.11 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | BOOL
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Save objects permanently by writing a value <> 0 for this object. Please note the following: - This command lasts about ca. 1.5s, which increases the cycle time of the control system briefly. - Perform this command only when needed. The write cycles of the memory module are limited (up to 100,000). The function does not work in curve mode.


Object: Following Error Time

Object name | C3.PositioningAccuracy_FollowingErrorTimeout
Object No. | 420.3 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | TIME
Unit of Travel | ms |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | If the following error limit for this time is exceeded, this will lead to the following error event.


Object: Following error limit

Object name | C3.PositioningAccuracy_FollowingErrorWindow
Object No. | 420.2 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit |  |
Minimum value | 0 n/a | Maximum value | 4000000 n/a
Remark: |


Object: Position reached

Object name | C3.PositioningAccuracy_PositionReached
Object No. | 420.6 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | BOOL
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Position reached "1" = Position has been within the ”Window” positioning window at least since the time "Position window time"


Object: Positioning window for position reached

Object name | C3.PositioningAccuracy_Window
Object No. | 420.1 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit |  |
Minimum value | 0 rounds | Maximum value | 4000000 rounds
Remark: |


Object: In Position Window Time

Object name | C3.PositioningAccuracy_WindowTime
Object No. | 420.7 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | TIME
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Time for position reached in 500µs; 1 = 500µs


Object: Switch to enable disturbance compensation

Object name | C3.SpeedObserver_DisturbanceAdditionEnable
Object No. | 2120.7 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | no | CodeSys format: | BOOL
Unit of Travel | n/a |  |
Minimum value | -1 n/a | Maximum value | -- n/a
Remark: | Switch to enable disturbance compensation Default is deactivated Works only with active monitor For values unequal zero the the observed disturbance is fed in after the speed controller and the velocity loop ”I” term is deactivated.


Object: Time constant disturbance filter

Object name | C3.SpeedObserver_DisturbanceFilter
Object No. | 2120.5 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | no | CodeSys format: | DINT
Unit of Travel | us |  |
Minimum value | 63 us | Maximum value | 8300000 us
Remark: | Time constant of the observed disturbance filter The filter is deactivated for values from 0 to 62us. Default value 1000us


Object: Rapidity of the speed monitor

Object name | C3.SpeedObserver_TimeConstant
Object No. | 2120.1 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | no | CodeSys format: | DINT
Unit of Travel | us |  |
Minimum value | 125 us | Maximum value | 1000000 us
Remark: | Default value 1000us for values of 0 to 124 us the monitor is deactivated. Activated from 125us on


Object: Status of actual acceleration unfiltered

Object name | C3.StatusAccel_Actual
Object No. | 682.5 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | DINT
Unit of Travel | Unit/s² |  |
Minimum value | -1000000 unit/s² | Maximum value | 1000000 unit/s²
Remark: | Please note that this signal is often rather noisy.


Object: Status of filtered actual acceleration

Object name | C3.StatusAccel_ActualFilter
Object No. | 682.6 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | DINT
Unit of Travel | Unit/s² |  |
Minimum value | -1000000 unit/s² | Maximum value | 1000000 unit/s²
Remark: | Signal is smoothed by acceleration filter 1 and 2 resp. by the rotational speed monitor and acceleration filter 2. Signal is the source of the D-component in the (rotational) speed controller


Object: Status demand acceleration

Object name | C3.StatusAccel_DemandValue
Object No. | 682.4 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | DINT
Unit of Travel | Unit/s² |  |
Minimum value | -1000000 unit/s² | Maximum value | 1000000 unit/s²
Remark: | Setpoint acceleration setpoint generator Stated in user units Output value of the fine interpolator


Object: Status acceleration feed forward

Object name | C3.StatusAccel_FeedForwardAccel
Object No. | 682.7 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: | REAL
Unit of Travel | Unit/s |  |
Minimum value | 0 unit/s | Maximum value | -- unit/s
Remark: | Given in user units (rotational speed format)


Object: Status of actual current RMS (torque producing)

Object name | C3.StatusCurrent_Actual
Object No. | 688.2 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | mA |  |
Minimum value | -353553 mA | Maximum value | 353553 mA
Remark: | Actual current RM (torque producing) ,actual value after filter


Object: Status of control deviation of current control RMS

Object name | C3.StatusCurrent_ControlDeviationIq
Object No. | 688.8 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: | REAL
Unit of Travel | mA |  |
Minimum value | -353553 mA | Maximum value | 353553 mA
Remark: | Control deviation of current RMS (torque producing)


Object: Status of current rms and jerk feedforward

Object name | C3.StatusCurrent_FeedForwordCurrentJerk
Object No. | 688.14 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: | REAL
Unit of Travel | mA |  |
Minimum value | -353553 mA | Maximum value | 353553 mA
Remark: | Current & jerk feedforward RMS Stated in amperes RMS after filter


Object: Status of current phase U

Object name | C3.StatusCurrent_PhaseU
Object No. | 688.9 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: | REAL
Unit of Travel | mA |  |
Minimum value | -500000 mA | Maximum value | 500000 mA
Remark: | Phase current U, Output as peak value Actual value after oversampling


Object: Status of current phase V

Object name | C3.StatusCurrent_PhaseV
Object No. | 688.10 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: | REAL
Unit of Travel | mA |  |
Minimum value | -500000 mA | Maximum value | 500000 mA
Remark: | Phase current V, Output as peak value Actual value after oversampling


Object: Status of setpoint current RMS (torque forming)

Object name | C3.StatusCurrent_Reference
Object No. | 688.1 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | mA |  |
Minimum value | -353553 mA | Maximum value | 353553 mA
Remark: | Setpoint motor current RMS. ( torque-producing ) Cross-flow setpoint value including current and jerk feedforward


Object: Status of demand jerk setpoint generator

Object name | C3.StatusCurrent_ReferenceJerk
Object No. | 688.13 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit/s³ |  |
Minimum value | 0 unit/s³ | Maximum value | -- unit/s³
Remark: | Jerk setpoint generator value Stated in user units Output value of the fine interpolator


Object: Status of current control control signal

Object name | C3.StatusCurrent_ReferenceVoltageUq
Object No. | 688.11 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: | REAL
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | 0.577 n/a
Remark: | Control signal of current controller (torque forming) 0.577 correspond to full range (Terminal voltage=DC bus voltage)


Object: Status of actual current value

Object name | C3.StatusDevice_ActualCurrent
Object No. | 683.1 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | % |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Actual current value (actual torque value) The reference is the rated motor current


Object: Status of device utilization

Object name | C3.StatusDevice_ActualDeviceLoad
Object No. | 683.2 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | % |  |
Minimum value | 0 % | Maximum value | -- %
Remark: | Device utilization Stated in % of the nominal device current


Object: Status of long-term motor load

Object name | C3.StatusDevice_ActualMotorLoad
Object No. | 683.3 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | % |  |
Minimum value | 0 % | Maximum value | 105 %
Remark: | Motor load, Stated in & of the motor pulse current. Effective motor load with reference to the nominal motor current resp. if a motor reference point is selected, with reference to the motor reference current. For the monitoring the thermal time constant Tau is required. 1.05*I can be set permanently. Error object 500.1 Bit 13, Error Code 2311


Object: Status of short-term motor load

Object name | C3.StatusDevice_DynamicMotorLoad
Object No. | 683.4 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | % |  |
Minimum value | 0 % | Maximum value | 115 %
Remark: | Motor pulse utilization, Stated in & of the motor pulse current. Dynamic motor load with reference to the nominal motor current resp., in the case of a selected motor reference point, with reference to the motor reference current. For the monitoring the impulse current and the impulse current time are required in order to calculate a time constant. 1.15*I can be set permanently. Error object 500.6 Bit 6, Error Code 7180


Object: Status of observed disturbance

Object name | C3.StatusDevice_ObservedDisturbance
Object No. | 683.5 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | % |  |
Minimum value | -2000 % | Maximum value | 2000 %
Remark: | Load moment resp. load force detected by the (rotational) speed monitor. Unit is % of Mnominal resp. of Fnominal (100% = Moment resp. force given the configured nominal resp. reference current)


Object: Status of analog input cosine

Object name | C3.StatusFeedback_EncoderCosine
Object No. | 692.4 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: |
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | 1 n/a
Remark: | Cosine trace of encoder, für F11 and F12 devices


Object: Status of analog input sine

Object name | C3.StatusFeedback_EncoderSine
Object No. | 692.3 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: |
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | 1 n/a
Remark: | Sine track of encoder, für F11 and F12 devices (0.5 = 2.5V)


Object: Status of cosine in signal processing

Object name | C3.StatusFeedback_FeedbackCosineDSP
Object No. | 692.2 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: |
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | 1 n/a
Remark: | Cosine trace of resolver, for F10 devices The value 1 corresponds to 2.5 Volts The amplitude must be <1 and > 0.1 at the resolver; otherwise a level error is reported.


Object: Status of sine in signal processing

Object name | C3.StatusFeedback_FeedbackSineDSP
Object No. | 692.1 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: |
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | 1 n/a
Remark: | Sinus track resolver, für F10 devices The value 1 corresponds to 2.5 Volts The amplitude must be <1 and > 0.1 at the resolver; otherwise a level error is reported.


Object: Status of feedback level

Object name | C3.StatusFeedback_FeedbackVoltage[Vpp]
Object No. | 692.5 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: |
Unit of Travel | V |  |
Minimum value | 0 V | Maximum value | -- V
Remark: | Feedback level, for F11 and F12 devices, display in Vpp (=sqrt(sin²+cos²))


Object: Receive string

Object name | C3.StatusHeda_RxPD
Object No. | 689.1 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: |
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: |


Object: Sendestring

Object name | C3.StatusHeda_TxPD
Object No. | 689.2 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: |
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: |


Object: Status actual position

Object name | C3.StatusPosition_Actual
Object No. | 680.5 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Stated in user units, reset position


Object: Status actual position without absolute reference

Object name | C3.StatusPosition_ActualValueController
Object No. | 680.13 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: | REAL
Unit of Travel | Unit |  |
Minimum value | 0 unit | Maximum value | -- unit
Remark: | Stated in user units, continuous position


Object: Status demand position

Object name | C3.StatusPosition_DemandValue
Object No. | 680.4 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Stated in user units, reset position


Object: Status demand position virtual master

Object name | C3.StatusPosition_DemandValue2
Object No. | 680.2 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | The position setpoint value of the virtual axis (virtual Master / profile transmitter 2)


Object: Status demand position without absolute reference

Object name | C3.StatusPosition_DemandValueController
Object No. | 680.12 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: | REAL
Unit of Travel | Unit |  |
Minimum value | 0 unit | Maximum value | -- unit
Remark: | Stated in user units, continuous position


Object: Status of encoder input 0 (24V)

Object name | C3.StatusPosition_EncoderInput24V
Object No. | 680.11 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | rounds |  |
Minimum value | 0 rounds | Maximum value | -- rounds
Remark: | Encoder input 1 (24V), counter state in turns of the encoder


Object: Status of encoder input 0 (5V)

Object name | C3.StatusPosition_EncoderInput5V
Object No. | 680.10 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | rounds |  |
Minimum value | 0 rounds | Maximum value | -- rounds
Remark: | Encoder input 0 (5V), counter state in turns of the encoder


Object: Status of following error

Object name | C3.StatusPosition_FollowingError
Object No. | 680.6 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Stated in user units, difference between target and actual value of position


Object: Status actual speed unfiltered

Object name | C3.StatusSpeed_Actual
Object No. | 681.5 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit/s |  |
Minimum value | -8388608 unit/s | Maximum value | 8388607.999999 unit/s
Remark: |


Object: Status actual speed filtered

Object name | C3.StatusSpeed_ActualFiltered
Object No. | 681.9 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit/s |  |
Minimum value | -8388608 unit/s | Maximum value | 8388607.999999 unit/s
Remark: |


Object: Filtered actual speed

Object name | C3.StatusSpeed_ActualScaled
Object No. | 681.12 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | % |  |
Minimum value | % | Maximum value | %
Remark: | with reference to the nominal speed in %


Object: Setpoint speed of the setpoint generator

Object name | C3.StatusSpeed_DemandScaled
Object No. | 681.13 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | % |  |
Minimum value | % | Maximum value | %
Remark: | with reference to the nominal speed in %


Object: Status demand speed controller input

Object name | C3.StatusSpeed_DemandSpeedController
Object No. | 681.10 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: | REAL
Unit of Travel | Unit/s |  |
Minimum value | 0 unit/s | Maximum value | -- unit/s
Remark: | Speed setpoint value on the controller input including feed forward


Object: Status demand speed of setpoint generator

Object name | C3.StatusSpeed_DemandValue
Object No. | 681.4 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit/s |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Setpoint value according to the fine interpolator


Object: Status demand speed virtual master

Object name | C3.StatusSpeed_DemandValue2
Object No. | 681.2 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit/s |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | The setpoint speed value of the virtual axis (virtual Master / profile transmitter 2)


Object: Status control deviation of speed

Object name | C3.StatusSpeed_Error
Object No. | 681.6 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit/s |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Difference between speed Setpoint value and filtered actual value


Object: Status speed feed forward

Object name | C3.StatusSpeed_FeedForwardSpeed
Object No. | 681.11 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: | REAL
Unit of Travel | Unit/s |  |
Minimum value | 0 unit/s | Maximum value | -- unit/s
Remark: |


Object: Status of motor temperature

Object name | C3.StatusTemperature_Motor
Object No. | 684.2 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | C |  |
Minimum value | 0 C | Maximum value | -- C
Remark: | Motor Temperature measured via the sensor in the motor, correct display only with KTY84


Object: Status of power output stage temperature

Object name | C3.StatusTemperature_PowerStage
Object No. | 684.1 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | C |  |
Minimum value | 0 C | Maximum value | -- C
Remark: | Power Stage Temperature


Object: Status of analog input 0

Object name | C3.StatusVoltage_AnalogInput0
Object No. | 685.3 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | V |  |
Minimum value | -10 V | Maximum value | 10 V
Remark: | Analog input 0 Analog input on plug X11/9 and X11/11 Indication of the voltage measured on the input in volts


Object: Status of analog input 1

Object name | C3.StatusVoltage_AnalogInput1
Object No. | 685.4 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | V |  |
Minimum value | -10 V | Maximum value | 10 V
Remark: | Analog input 1 Analog input on plug X11/10 and X11/2 Indication of the voltage measured on the input in volts


Object: Status of auxiliary voltage

Object name | C3.StatusVoltage_AuxiliaryVoltage
Object No. | 685.1 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | V |  |
Minimum value | 0 V | Maximum value | -- V
Remark: | Control Voltage


Object: Status DC bus voltage

Object name | C3.StatusVoltage_BusVoltage
Object No. | 685.2 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | V |  |
Minimum value | 0 V | Maximum value | -- V
Remark: | unfiltered signal


Object: Set objects to valid

Object name | C3.ValidParameter_Global
Object No. | 210.10 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | BOOL
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Set all objects or parameters to valid This is automatically performed after the power is turned on. "VP" command is activated by writing a value <> 0; Command is performed if 0 is read.


Object: Variable Column 1 Row 1

Object name

C3Array.Col01_Row01

Object No.

1901.1

HEDA-channel

yes

Access:

Read/write

Valid after:

Immediately

CodeSys object:

yes

CodeSys format:

REAL

Unit of Travel

n/a

Minimum value

0 n/a

Maximum value

-- n/a

Remark:

The column consists of 32 variables that are freely available.

In addition to access via IEC61131-3, the array can also be written with the aid of the ServoManager.

For variable access applies: Variable of column y and of line x = O190y.x; y = 1 ... 9; x = 1 ... 32

Access via Profibus:

The first 5 rows of the recipe table have 2 PNU numbers and can be placed in the process data channel.

PNU numbers column y

1. Line = 130 and 34y.1; 2. Line = 131 and 34y.2

3. Line = 132 and 34y.3; 4. Line = 133 and 34y.4

5. Line = 134 and 34y.5; 6. Line = 34y.6

...

32. Line = 34y.32

The second PNU number develops as follows:

1. Column: 130 ... 134; 2. Column: 135 ... 139

3. Column: 140 ... 144; 4. Column: 145 ... 149

5. Column: 150 ... 154; 6. Column: 155 ... 159

7. Column: 160 ... 164; 8. Column: 165 ... 169

9. Column: 170 ... 174

Access via CANopen:

The first 5 rows of the recipe table can be placed in a PDO.

CAN numbber column y

1. Line = 0x230y.1; 2. Line = 0x230y.2

3. Line = 0x230y.3; 4. Line = 0x230y.4

5. Line = 0x230y.5; 6. Line = 0x230y.6

...

32. Line = 0x230y.32

scalable through object 201.1: NormFactorY4_Array_Col1 (for bus applications)


Object: Variable Column 2 Row 1

Object name | C3Array.Col02_Row01
Object No. | 1902.1 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | See object O1901.1 scalable through object 200.5: NormFactorY2_Array_Col2


Object: Variable Column 3 Row 1

Object name | C3Array.Col03_Row01
Object No. | 1903.1 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | See object O1901.1


Object: Variable Column 4 Row 1

Object name | C3Array.Col04_Row01
Object No. | 1904.1 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | See object O1901.1


Object: Variable Column 5 Row 1

Object name | C3Array.Col05_Row01
Object No. | 1905.1 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | See object O1901.1


Object: Variable Column 6 Row 1

Object name | C3Array.Col06_Row01
Object No. | 1906.1 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | DINT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | See object O1901.1


Object: Variable Column 7 Row 1

Object name | C3Array.Col07_Row01
Object No. | 1907.1 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | DINT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | See object O1901.1


Object: Variable Column 8 Row 1

Object name | C3Array.Col08_Row01
Object No. | 1908.1 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | DINT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | See object O1901.1


Object: Variable Column 9 Row 1

Object name | C3Array.Col09_Row01
Object No. | 1909.1 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | DINT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | See object O1901.1


Object: Indirect table access Column 1

Object name | C3Array.Indirect_Col01
Object No. | 1910.1 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Access to Column 1; row defined by C3_object "pointer to table row"


Object: Indirect table access Column 2

Object name | C3Array.Indirect_Col02
Object No. | 1910.2 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Access to Column 2; row defined by C3_object "pointer to table row"


Object: Indirect table access Column 3

Object name | C3Array.Indirect_Col03
Object No. | 1910.3 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Access to Column 3; row defined by C3_object "pointer to table row"


Object: Indirect table access Column 4

Object name | C3Array.Indirect_Col04
Object No. | 1910.4 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Access to Column 4; row defined by C3_object "pointer to table row"


Object: Indirect table access Column 5

Object name | C3Array.Indirect_Col05
Object No. | 1910.5 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Access to Column 5; row defined by C3_object "pointer to table row"


Object: Indirect table access Column 6

Object name | C3Array.Indirect_Col06
Object No. | 1910.6 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | DINT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Access to Column 6; row defined by C3_object "pointer to table row"


Object: Indirect table access Column 7

Object name | C3Array.Indirect_Col07
Object No. | 1910.7 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | DINT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Access to Column 7; row defined by C3_object "pointer to table row"


Object: Indirect table access Column 8

Object name | C3Array.Indirect_Col08
Object No. | 1910.8 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | DINT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Access to Column 8; row defined by C3_object "pointer to table row"


Object: Indirect table access Column 9

Object name | C3Array.Indirect_Col09
Object No. | 1910.9 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | DINT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Access to Column 9; row defined by C3_object "pointer to table row"


Object: Pointer to table row

Object name | C3Array.Pointer_Row
Object No. | 1900.1 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Compax3 IxxT30 / IxxT40: Please note that the C3_READARRAY module also writes into this object.


Object: switch-off position of cam

Object name | C3Cam.ControlledSwitch00_PositionOff
Object No. | 3730.3 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit |  |
Minimum value | 0 unit | Maximum value | -- unit
Remark: | Switch-off position of Cam 0 Switch-off position of additional cams: 3730...3761 up to 32 cams (cam 0...31) Profibus: 509.1...509.32 CANopen: 0x2409.1...0x2409.32


Object: switch-on position of cam

Object name | C3Cam.ControlledSwitch00_PositionOn
Object No. | 3730.2 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit |  |
Minimum value | 0 unit | Maximum value | -- unit
Remark: | Switch-on position of Cam 0 Switch-on position of additional cams: 3730...3761 up to 32 cams (cam 0...31) Profibus: 508.1...508.32 CANopen: 0x2408.1...0x2408.32


Object: source of cam

Object name | C3Cam.ControlledSwitch00_Source
Object No. | 3730.1 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Source of cam 0 Source of additional cams: 3730...3761 up to 32 cams (cam 0...31) Profibus: 507.1...507.32 CANopen: 0x2407.1...0x2407.32 Sources: 1: Position actual value 2: Position target value 3: virtual axis (virtual Master) other values are not permitted


Object: switch-off anticipation of cam

Object name | C3Cam.ControlledSwitch00_TimeOff
Object No. | 3730.5 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | TIME
Unit of Travel | 500us |  |
Minimum value | 0 500us | Maximum value | -- 500us
Remark: | Switch-off anticipation of Cam 0 Switch-off anticipation of additional cams: 3730...3761 up to 32 cams (cam 0...31) Profibus: 511.1...511.32 CANopen: 0x240B.1...0x240B.32


Object: switch-on anticipation of cam

Object name | C3Cam.ControlledSwitch00_TimeOn
Object No. | 3730.4 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | TIME
Unit of Travel | 500us |  |
Minimum value | 0 500us | Maximum value | -- 500us
Remark: | Switch-on anticipation of Cam 0 Switch-on anticipation of additional cams: 3730...3761 up to 32 cams (cam 0...31) Profibus: 510.1...510.32 CANopen: 0x240A.1...0x240A.32


Object: enable of cam group 0

Object name | C3Cam.ControlledSwitches_Enable0
Object No. | 3701.2 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | WORD
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Enable word for cam 0...15 Bit 0: Cam 0 Bit 1: Cam 1 ...


Object: enable of cam group 1

Object name | C3Cam.ControlledSwitches_Enable1
Object No. | 3701.4 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | WORD
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Enable word for cam 16..0.31 Bit 0: Cam 16 Bit 1: Cam 17 ...


Object: Number of cams in one cycle

Object name | C3Cam.ControlledSwitches_NumberPerCycle
Object No. | 3701.6 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | 4 n/a
Remark: | Number of cams that are processed in one Compax cycle Only if no fast cams are used. The rule for this is: Cycle time = Number of serial cams * 0.5 ms / O3701.6 Range of values: 1,2,3,4 (Standard value = 1)


Object: output of cam group 0

Object name | C3Cam.ControlledSwitches_Output0
Object No. | 3701.3 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | WORD
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Output word for cam 0..0.15 Bit 0: Cam 0 Bit 1: Cam 1 ...


Object: output of cam group 1

Object name | C3Cam.ControlledSwitches_Output1
Object No. | 3701.5 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | WORD
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Output word for cam 16...31 Bit 0: Cam 16 Bit 1: Cam 17 ...


Object: enable fast cams

Object name | C3Cam.ControlledSwitchesFast_Enable
Object No. | 3700.2 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | WORD
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Enable of fast cams 0...3 Bit 0: Cam 0 Bit 1: Cam 1 ...


Object: output for fast cams

Object name | C3Cam.ControlledSwitchesFast_Output
Object No. | 3700.3 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | WORD
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Output word of fast cam Bit 0: Cam 0 Bit 1: Cam 1 ...


Object: hysteresis for cam switching mechanism

Object name

C3Cam.ControlledSwitchesHysteresis_ActualPosition

Object No.

3705.1

HEDA-channel

no

Access:

Read/write

Valid after:

VP

CodeSys object:

yes

CodeSys format:

REAL

Unit of Travel

Unit

Minimum value

-4000000 unit

Maximum value

4000000 unit

Remark:

The switch-on and switch-off positions of all cams with the actual position value as a source shift by Hysteresis/2:

Switch-on_position_actual=switch-on_position_setpoint+/-Hysteresis/2

Switch-off_position_actual=switch-on_position_setpoint+/-Hysteresis/2

(pos. movement/ neg. movement)

This makes it possible to avoid jittering of the cam caused by moving the drive around the switching point.

The following types of behavior apply to the entire range:

* If the switching range set by parameters is less than the hysteresis, the cam will always be deactivated (regardless of compensation for dead time).

* If the switching range set by parameters is greater than the reset travel distance, the cam will always be activated (regardless of compensation for dead time).

* If the resulting switching range is less than the hysteresis, the cam will always be deactivated.

* If the resulting switching range is greater than the reset travel distance, the cam will always be activated.


Object: switch-off position for fast cam

Object name | C3Cam.ControlledSwitchFast0_PositionOff
Object No. | 3710.3 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit |  |
Minimum value | 0 unit | Maximum value | -- unit
Remark: | Switch-off position of fast Cam 0 Switch-off position of additional fast cams 3710.3...37130.3 up to 4 fast cams (Cam 0...3) Profibus: 504.1...504.4 CANopen: 0x2404.1...0x2404.4


Object: switch-on position for fast cam

Object name | C3Cam.ControlledSwitchFast0_PositionOn
Object No. | 3710.2 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit |  |
Minimum value | 0 unit | Maximum value | -- unit
Remark: | Switch-on position for fast Cam 0 Switch-on position of additional fast cams 3710.2...37130.2 up to 4 fast cams (Cam 0...3) Profibus: 503.1...503.4 CANopen: 0x2403.1...0x2403.4


Object: source of fast cam

Object name | C3Cam.ControlledSwitchFast0_Source
Object No. | 3710.1 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Source of fast Cam 0 Source of additional fast cams 3710.1...3713.1 up to 4 fast cams (fast Cam 0...3) Profibus: 502.1...502.4 CANopen: 0x2402.1...0x2402.4 Source of the cam 1: Position actual value 2: Position target value 3: virtual axis (virtual Master) other values are not permitted


Object: switch-off anticipation of fast cam

Object name | C3Cam.ControlledSwitchFast0_TimeOff
Object No. | 3710.5 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | TIME
Unit of Travel | 500us |  |
Minimum value | 0 500us | Maximum value | -- 500us
Remark: | Switch-off anticipation of fast Cam 0 Switch-off position of additional fast cams 3710.5...37130.5 up to 4 fast cams (Cam 0...3) Profibus: 506.1...506.4 CANopen: 0x2406.1...0x2406.4


Object: switch-on anticipation of fast cam

Object name | C3Cam.ControlledSwitchFast0_TimeOn
Object No. | 3710.4 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | TIME
Unit of Travel | 500us |  |
Minimum value | 0 500us | Maximum value | -- 500us
Remark: | Switch-on anticipation of fast Cam 0 Switch-on anticipation of additional fast cams 3710.4...3713.4 up to 4 fast cams (Cam 0...3) Profibus: 505.1...505.4 CANopen: 0x2405.1...0x2405.4


Object: Master position offset

Object name | C3Cam.Manipulation_OffsetMasterposition
Object No. | 3022.1 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | rounds |  |
Minimum value | -8388608 rounds | Maximum value | 8388607.999999 rounds
Remark: |


Object: Offset Master position

Object name | C3Cam.Manipulation_OffsetMasterposition_Units
Object No. | 3022.6 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Offset for the master position in Units


Object: Global scaling factor for the master speed

Object name | C3Cam.Manipulation_ScalefactorMasterGlobal
Object No. | 3022.3 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Caution! A drift is generated with a continuous application, if no 2^n number is used for this factor of if no corrective measures, such as mark correction are taken! The value is accepted with SetMaster and at the end of the curve (end of segment detection)


Object: Status of position of selected master signal source

Object name | C3Cam.SignalSource_Position
Object No. | 3021.2 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | rounds |  |
Minimum value | 0 unit | Maximum value | -- unit
Remark: |


Object: Current curve number

Object name | C3Cam.StatusData_ActualCurve
Object No. | 3031.4 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: |


Object: Added up position sum of the master-side phasing

Object name | C3Cam.StatusMaster_PhasingSum
Object No. | 3030.12 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | rounds |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | iis reset to zero by a new start of a curve (C3.CamTableSelect) is not influenced by a change of curve


Object: Reset master position

Object name | C3Cam.StatusMaster_Position
Object No. | 3030.1 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Munit |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | [Master units]


Object: Master position at the beginning of the curve

Object name | C3Cam.StatusMaster_PositionCamUnits
Object No. | 3030.24 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Munit |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | [Master units]


Object: Master speed [Units/s]

Object name | C3Cam.StatusMaster_SpeedUnits
Object No. | 3030.22 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Munit/s |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: |


Object: End of curve

Object name | C3Cam.StatusOutput_CurvePositionUnits
Object No. | 3032.24 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | [Slave units] in other cases as 3032.12


Object: Slave position

Object name | C3Cam.StatusOutput_Position
Object No. | 3032.1 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit |  |
Minimum value | 0 unit | Maximum value | -- unit
Remark: | reset position after cam table [Units]


Object: Start current of automatic commutation

Object name | C3Plus.AutoCommutationControl_InitialCurrent
Object No. | 2190.2 | HEDA-channel | no
Access: | Read/write | Valid after: | VP
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | % |  |
Minimum value | 1 /oo | Maximum value | 500 /oo
Remark: | Starting current automatic commutation [ /oo IN] This value must be set so that the commutation research needs approx. 3-5 s. If it takes longer or error 73AB (automatic commutation: timeout) reduce value, if it takes a shorter time or error 73A6 (automatic commutation: more than 60° electric movement) the value must be increased.


Object: Current error (n)

Object name | C3Plus.ErrorHistory_LastError
Object No. | 550.1 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Last entry in the error history Entry of errors that occurred with the corresponding error number for each one Acknowledgement by Ackn or Power on will be written with a 1.


Object: Master speed for Gearing

Object name | C3Plus.GEAR_actual_master_speed
Object No. | 1141.8 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: |
Unit of Travel | Munit/s |  |
Minimum value | Unit/s | Maximum value | Unit/s
Remark: | in Units/s


Object: Error counter CRC (HEDA)

Object name | C3Plus.HEDA_CRC_ErrorCounter
Object No. | 900.12 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | no | CodeSys format: |
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: |


Object: Process input signal Slave

Object name | C3Plus.HEDA_SignalProcessing_Input
Object No. | 3920.1 | HEDA-channel | yes
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: |


Object: Status HEDA

Object name | C3Plus.HEDA_State
Object No. | 900.1 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | 0=not Init 1=Init (Hardware initialized) 2=Sync (Synchronization with the Master) 3=Com (Exchange of data with other devices) 4=wait Master (Device is waiting for Master) 5=off (Off, device does not communicate) In order to trigger a new initialization, o900.1 must be written with value 0!


Object: Error counter Sync (HEDA)

Object name | C3Plus.HEDA_SyncErrorCounter
Object No. | 900.13 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | no | CodeSys format: |
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: |


Object: Acceleration / deceleration MN run

Object name | C3Plus.HOMING_accel
Object No. | 1130.1 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | DINT
Unit of Travel | Unit/s² |  |
Minimum value | 0.24 rounds/s² | Maximum value | 1000000 rounds/s²
Remark: | If 0 is specified, the minimum value is used automatically. MN: Machine zero


Object: Initiator adjustment

Object name | C3Plus.HOMING_edge_sensor_distance
Object No. | 1130.7 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel |  |  |
Minimum value | -1000000 | Maximum value | 1000000
Remark: | Virtual displacement of the initiator


Object: Jerk for homing

Object name | C3Plus.HOMING_jerk
Object No. | 1130.2 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | DINT
Unit of Travel | Unit/s³ |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | If 0 is specified, the minimum value is used automatically.


Object: Adjusting the homing mode

Object name | C3Plus.HOMING_mode
Object No. | 1130.4 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | n/a |  |
Minimum value | -127 n/a | Maximum value | 128 n/a
Remark: | Mode according to CANopen definition. 1...35 If 130 is entered, the homing run will be determined by the control word. Zero means no homing selected. New (manufacturer-specific) modes beginning with V01.09.00: 128: move to block in positive direction, after that approach position 129: move to block in negative direction, after that approach position


Object: Speed for homing

Object name | C3Plus.HOMING_speed
Object No. | 1130.3 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | Unit/s |  |
Minimum value | 0 rounds/s | Maximum value | 2000 rounds/s
Remark: |


Object: Status of cycle time of the control program

Object name | C3Plus.PLC_ActualCycleTime
Object No. | 50.3 | HEDA-channel | no
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | 500us |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Current cycle time [unit: 1=500µs] of the control program


Object: Status of maximum cycle time

Object name | C3Plus.PLC_ActualCycleTimeMax
Object No. | 50.4 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | 500us |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Maximum cycle time [unit: 1=500µs] Very large values may occur here with the command "Save objects permanently". Then the control program will no longer be executed for the execution time (about 1.5 sec)


Object: Cycle time specification

Object name | C3Plus.PLC_DemandCycleTime
Object No. | 50.1 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | INT
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Specification of the cycle time [500µs]. If the cycle time cannot be maintained, an error will be triggered. If 0 is specified, execution of the control program will be terminated.


Object: Position actual value (sequentially)

Object name | C3Plus.PositionController_ActualValue
Object No. | 2200.2 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: | REAL
Unit of Travel | rounds |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Large continuous position actual value in rotations is not reset and is suitable for the transmisison of synchronization tasks


Object: Position setpoint value (sequentially)

Object name | C3Plus.PositionController_DemandValue
Object No. | 2200.1 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: | DWORD
Unit of Travel | rounds |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Large continuous position setpoint value in rotations is not reset and is suitable for the transmisison of synchronization tasks


Object: Position value of the setpoint encoder of the virtual axis

Object name | C3Plus.ProfilGenerators_PG2Position
Object No. | 2000.2 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | rounds |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Is not reset Value range -2^23 ... +2^23-1 Suitable as process signal for HEDA coupling


Object: Speed of the virtual axis

Object name | C3Plus.ProfilGenerators_PG2Speed
Object No. | 2000.5 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: | REAL
Unit of Travel | rounds/s |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: |


Object: Position value of the setpoint encoder

Object name | C3Plus.ProfilGenerators_SG1Position
Object No. | 2000.1 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | yes | CodeSys format: | REAL
Unit of Travel | rounds |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Is not reset Value range -2^23 ... +2^23-1 Suitable as process signal for HEDA coupling Undelayed position value of the SG1. Object 990.1 (MasterDelay) does not influence this signal.


Object: Speed of the setpoint encoder

Object name | C3Plus.ProfilGenerators_SG1Speed
Object No. | 2000.4 | HEDA-channel | yes
Access: | Read only | Valid after: | -
CodeSys object: | no | CodeSys format: | REAL
Unit of Travel | rounds/s |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: |


Object: Set cam switching mechanism parameters to valid

Object name | C3Plus.ValidParameter_CamControlledSwitches
Object No. | 210.9 | HEDA-channel | no
Access: | Read/write | Valid after: | Immediately
CodeSys object: | yes | CodeSys format: | BOOL
Unit of Travel | n/a |  |
Minimum value | 0 n/a | Maximum value | -- n/a
Remark: | Is automatically executed at Power On and with ValidParameter_global (210.10). Is activated by writing a value<> (TRUE in IEC).


Status values

In this chapter you can read about:

Drive

Motor

Position

Speeds

Superimposed motion

Current

Inputs

Cam

Virtual Master

IEC61131-3

Feedback

Gearing

HEDA

A list of the status values supports you in optimization and commissioning.

Open the optimization function in the C3 ServoManager (double-click on optimization in the tree)

You will find the available status values in the lower right part of the window under selection (TAB) ”Status values”

You can pull them into the oscilloscope (upper part of the left side) or into the status display (upper part of the right side) by the aid of the mouse (drag and drop).

The status values are divided into 2 groups (user levels):

standard: here you can find all important status values

advanced: advanced status values, require a better knowledge

Switching of the user level

The user level can be changed in the optimization window (left hand side lower part under selection (TAB) "optimization") with the following button.

D/A-Monitor

A part of the status values can be output via the D/A monitor channel 0 (X11/4) and channel 1 (X11/3).

The reference for the output voltage can be entered individually in the reference unit of the D/A monitor.

Hint

The unit of measurement of the D/A monitor values differs from the unit of measurement of the status values.


Drive

Status DC bus voltage |  |  | Object 685.2
available | in all Compax3 device types
Object name | C3.StatusVoltage_BusVoltage
User level | standard | D/A monitor output | possible
Remark: | unfiltered signal
Status of device utilization |  |  | Object 683.2
available | in all Compax3 device types
Object name | C3.StatusDevice_ActualDeviceLoad
User level | standard | D/A monitor output | not possible
Remark: | Device utilization Stated in % of the nominal device current
Status of power output stage temperature |  |  | Object 684.1
available | in all Compax3 device types
Object name | C3.StatusTemperature_PowerStage
User level | standard | D/A monitor output | not possible
Remark: | Power Stage Temperature
Status of auxiliary voltage |  |  | Object 685.1
available | in all Compax3 device types
Object name | C3.StatusVoltage_AuxiliaryVoltage
User level | standard | D/A monitor output | not possible
Remark: | Control Voltage


Motor

Status of short-term motor load |  |  | Object 683.4
available | in all Compax3 device types
Object name | C3.StatusDevice_DynamicMotorLoad
User level | standard | D/A monitor output | not possible
Remark: | Motor pulse utilization, Stated in & of the motor pulse current. Dynamic motor load with reference to the nominal motor current resp., in the case of a selected motor reference point, with reference to the motor reference current. For the monitoring the impulse current and the impulse current time are required in order to calculate a time constant. 1.15*I can be set permanently. Error object 500.6 Bit 6, Error Code 7180
Status of long-term motor load |  |  | Object 683.3
available | in all Compax3 device types
Object name | C3.StatusDevice_ActualMotorLoad
User level | standard | D/A monitor output | not possible
Remark: | Motor load, Stated in & of the motor pulse current. Effective motor load with reference to the nominal motor current resp. if a motor reference point is selected, with reference to the motor reference current. For the monitoring the thermal time constant Tau is required. 1.05*I can be set permanently. Error object 500.1 Bit 13, Error Code 2311
Status of motor temperature |  |  | Object 684.2
available | in all Compax3 device types
Object name | C3.StatusTemperature_Motor
User level | standard | D/A monitor output | not possible
Remark: | Motor Temperature measured via the sensor in the motor, correct display only with KTY84


Position

Status actual position |  |  | Object 680.5
available | I10T10
Object name | C3.StatusPosition_Actual
User level | advanced | D/A monitor output | not possible
Remark: | Stated in user units, reset position
Status actual position |  |  | Object 680.5
available | in all Compax3 device types exept I10T10
Object name | C3.StatusPosition_Actual
User level | standard | D/A monitor output | possible
Remark: | Stated in user units, reset position
Status of following error |  |  | Object 680.6
available | I10T10
Object name | C3.StatusPosition_FollowingError
User level | advanced | D/A monitor output | not possible
Remark: | Stated in user units, difference between target and actual value of position
Status of following error |  |  | Object 680.6
available | in all Compax3 device types exept I10T10
Object name | C3.StatusPosition_FollowingError
User level | standard | D/A monitor output | possible
Remark: | Stated in user units, difference between target and actual value of position
Status demand position |  |  | Object 680.4
available | in all Compax3 device types exept I10T10
Object name | C3.StatusPosition_DemandValue
User level | standard | D/A monitor output | possible
Remark: | Stated in user units, reset position
Status demand position |  |  | Object 680.4
available | I10T10
Object name | C3.StatusPosition_DemandValue
User level | advanced | D/A monitor output | not possible
Remark: | Stated in user units, reset position
Status actual position without absolute reference |  |  | Object 680.13
available | in all Compax3 device types
Object name | C3.StatusPosition_ActualValueController
User level | advanced | D/A monitor output | possible
Remark: | Stated in user units, continuous position
Status demand position without absolute reference |  |  | Object 680.12
available | in all Compax3 device types exept I10T10
Object name | C3.StatusPosition_DemandValueController
User level | advanced | D/A monitor output | possible
Remark: | Stated in user units, continuous position


Speeds

Filtered actual speed |  |  | Object 681.12
available | in all Compax3 device types
Object name | C3.StatusSpeed_ActualScaled
User level | advanced | D/A monitor output | not possible
Remark: | with reference to the nominal speed in %
Status of observed disturbance |  |  | Object 683.5
available | in all Compax3 device types
Object name | C3.StatusDevice_ObservedDisturbance
User level | advanced | D/A monitor output | possible
Remark: | Load moment resp. load force detected by the (rotational) speed monitor. Unit is % of Mnominal resp. of Fnominal (100% = Moment resp. force given the configured nominal resp. reference current)
Status acceleration feed forward |  |  | Object 682.7
available | in all Compax3 device types exept I10T10
Object name | C3.StatusAccel_FeedForwardAccel
User level | advanced | D/A monitor output | not possible
Remark: | Given in user units (rotational speed format)
Status of filtered actual acceleration |  |  | Object 682.6
available | in all Compax3 device types
Object name | C3.StatusAccel_ActualFilter
User level | advanced | D/A monitor output | possible
Remark: | Signal is smoothed by acceleration filter 1 and 2 resp. by the rotational speed monitor and acceleration filter 2. Signal is the source of the D-component in the (rotational) speed controller
Status of actual acceleration unfiltered |  |  | Object 682.5
available | in all Compax3 device types
Object name | C3.StatusAccel_Actual
User level | advanced | D/A monitor output | possible
Remark: | Please note that this signal is often rather noisy.
Setpoint speed of the setpoint generator |  |  | Object 681.13
available | in all Compax3 device types
Object name | C3.StatusSpeed_DemandScaled
User level | advanced | D/A monitor output | not possible
Remark: | with reference to the nominal speed in %
Status demand speed controller input |  |  | Object 681.10
available | in all Compax3 device types
Object name | C3.StatusSpeed_DemandSpeedController
User level | standard | D/A monitor output | possible
Remark: | Speed setpoint value on the controller input including feed forward
Status actual speed filtered |  |  | Object 681.9
available | in all Compax3 device types
Object name | C3.StatusSpeed_ActualFiltered
User level | standard | D/A monitor output | possible
Remark: |
Status control deviation of speed |  |  | Object 681.6
available | in all Compax3 device types
Object name | C3.StatusSpeed_Error
User level | standard | D/A monitor output | possible
Remark: | Difference between speed Setpoint value and filtered actual value
Status demand speed of setpoint generator |  |  | Object 681.4
available | in all Compax3 device types
Object name | C3.StatusSpeed_DemandValue
User level | standard | D/A monitor output | possible
Remark: | Setpoint value according to the fine interpolator
Status actual speed unfiltered |  |  | Object 681.5
available | in all Compax3 device types
Object name | C3.StatusSpeed_Actual
User level | advanced | D/A monitor output | possible
Remark: |
Status demand acceleration |  |  | Object 682.4
available | in all Compax3 device types
Object name | C3.StatusAccel_DemandValue
User level | advanced | D/A monitor output | not possible
Remark: | Setpoint acceleration setpoint generator Stated in user units Output value of the fine interpolator
Status speed feed forward |  |  | Object 681.11
available | in all Compax3 device types exept I10T10
Object name | C3.StatusSpeed_FeedForwardSpeed
User level | advanced | D/A monitor output | not possible
Remark: |


Superimposed motion

Speed of a superimposed motion |  |  | Object 681.3
available | IxxT30, IxxT40
Object name | C3.StatusSpeed_DemandValue3
User level | standard | D/A monitor output | not possible
Remark: | Speed of a superimposed motion, caused by MC_Phasing, MC_SuperImposed or C3_ShiftPosition.


Current

Status of control deviation of current control RMS |  |  | Object 688.8
available | in all Compax3 device types
Object name | C3.StatusCurrent_ControlDeviationIq
User level | advanced | D/A monitor output | possible
Remark: | Control deviation of current RMS (torque producing)
Status of actual current RMS (torque producing) |  |  | Object 688.2
available | in all Compax3 device types
Object name | C3.StatusCurrent_Actual
User level | standard | D/A monitor output | possible
Remark: | Actual current RM (torque producing) ,actual value after filter
Status of current phase U |  |  | Object 688.9
available | in all Compax3 device types
Object name | C3.StatusCurrent_PhaseU
User level | advanced | D/A monitor output | not possible
Remark: | Phase current U, Output as peak value Actual value after oversampling
Status of current phase V |  |  | Object 688.10
available | in all Compax3 device types
Object name | C3.StatusCurrent_PhaseV
User level | advanced | D/A monitor output | not possible
Remark: | Phase current V, Output as peak value Actual value after oversampling
Status of current control control signal |  |  | Object 688.11
available | in all Compax3 device types
Object name | C3.StatusCurrent_ReferenceVoltageUq
User level | advanced | D/A monitor output | not possible
Remark: | Control signal of current controller (torque forming) 0.577 correspond to full range (Terminal voltage=DC bus voltage)
Status of demand jerk setpoint generator |  |  | Object 688.13
available | in all Compax3 device types exept I10T10
Object name | C3.StatusCurrent_ReferenceJerk
User level | advanced | D/A monitor output | not possible
Remark: | Jerk setpoint generator value Stated in user units Output value of the fine interpolator
Status of current rms and jerk feedforward |  |  | Object 688.14
available | in all Compax3 device types
Object name | C3.StatusCurrent_FeedForwordCurrentJerk
User level | advanced | D/A monitor output | not possible
Remark: | Current & jerk feedforward RMS Stated in amperes RMS after filter
Status of setpoint current RMS (torque forming) |  |  | Object 688.1
available | in all Compax3 device types
Object name | C3.StatusCurrent_Reference
User level | standard | D/A monitor output | possible
Remark: | Setpoint motor current RMS. ( torque-producing ) Cross-flow setpoint value including current and jerk feedforward


Inputs

Status of analog input 1 |  |  | Object 685.4
available | in all Compax3 device types
Object name | C3.StatusVoltage_AnalogInput1
User level | standard | D/A monitor output | possible
Remark: | Analog input 1 Analog input on plug X11/10 and X11/2 Indication of the voltage measured on the input in volts
Status of analog input 0 |  |  | Object 685.3
available | in all Compax3 device types
Object name | C3.StatusVoltage_AnalogInput0
User level | standard | D/A monitor output | possible
Remark: | Analog input 0 Analog input on plug X11/9 and X11/11 Indication of the voltage measured on the input in volts
Status of encoder input 0 (24V) |  |  | Object 680.11
available | in all Compax3 device types
Object name | C3.StatusPosition_EncoderInput24V
User level | standard | D/A monitor output | not possible
Remark: | Encoder input 1 (24V), counter state in turns of the encoder
Status of encoder input 0 (5V) |  |  | Object 680.10
available | in all Compax3 device types
Object name | C3.StatusPosition_EncoderInput5V
User level | standard | D/A monitor output | not possible
Remark: | Encoder input 0 (5V), counter state in turns of the encoder


Cam

End of curve |  |  | Object 3032.24
available | I11T40, I20T40, I21T40
Object name | C3Cam.StatusOutput_CurvePositionUnits
User level | standard | D/A monitor output | not possible
Remark: | [Slave units] in other cases as 3032.12
Master position at the beginning of the curve |  |  | Object 3030.24
available | I11T40, I20T40, I21T40
Object name | C3Cam.StatusMaster_PositionCamUnits
User level | standard | D/A monitor output | not possible
Remark: | [Master units]
Current curve number |  |  | Object 3031.4
available | I11T40, I20T40, I21T40
Object name | C3Cam.StatusData_ActualCurve
User level | standard | D/A monitor output | not possible
Remark: |
Status of position of selected master signal source |  |  | Object 3021.2
available | I11T40, I20T40, I21T40
Object name | C3Cam.SignalSource_Position
User level | standard | D/A monitor output | possible
Remark: |
Master speed [Units/s] |  |  | Object 3030.22
available | I11T40, I20T40, I21T40
Object name | C3Cam.StatusMaster_SpeedUnits
User level | standard | D/A monitor output | not possible
Remark: |
Slave position |  |  | Object 3032.1
available | I11T40, I20T40, I21T40
Object name | C3Cam.StatusOutput_Position
User level | standard | D/A monitor output | possible
Remark: | reset position after cam table [Units]
Reset master position |  |  | Object 3030.1
available | I11T40, I20T40, I21T40
Object name | C3Cam.StatusMaster_Position
User level | standard | D/A monitor output | possible
Remark: | [Master units]


Virtual Master

Status demand position virtual master |  |  | Object 680.2
available | I11T40, I20T40, I21T40
Object name | C3.StatusPosition_DemandValue2
User level | standard | D/A monitor output | not possible
Remark: | The position setpoint value of the virtual axis (virtual Master / profile transmitter 2)
Status demand speed virtual master |  |  | Object 681.2
available | I11T40, I20T40, I21T40
Object name | C3.StatusSpeed_DemandValue2
User level | standard | D/A monitor output | not possible
Remark: | The setpoint speed value of the virtual axis (virtual Master / profile transmitter 2)


IEC61131-3

Status of maximum cycle time |  |  | Object 50.4
available | IxxT30, IxxT40
Object name | C3Plus.PLC_ActualCycleTimeMax
User level | standard | D/A monitor output | not possible
Remark: | Maximum cycle time [unit: 1=500µs] Very large values may occur here with the command "Save objects permanently". Then the control program will no longer be executed for the execution time (about 1.5 sec)
Setpoint for analog output 0 |  |  | Object 634.4
available | IxxT30, IxxT40
Object name | C3.AnalogOutput0_DemandValue
User level | advanced | D/A monitor output | possible
Remark: | Setpoint for analog output 0 (DA0 - X11/4); can be used as a DA monitor. This output must be previously activated to be able to access it. You can do this in the ServoManager in the optimization window in the partial window at the bottom left under DA monitor. Convert the signal source to IEC61131.
Setpoint for analog output 1 |  |  | Object 635.4
available | IxxT30, IxxT40
Object name | C3.AnalogOutput1_DemandValue
User level | advanced | D/A monitor output | possible
Remark: | Setpoint for analog output 1 (DA1 - X11/3); can be used as DA monitor. This output must be previously activated to be able to access it. You can do this in the ServoManager in the optimization window in the partial window at the bottom left under DA monitor. Convert the signal source to IEC61131.
Status of cycle time of the control program |  |  | Object 50.3
available | IxxT30, IxxT40
Object name | C3Plus.PLC_ActualCycleTime
User level | standard | D/A monitor output | not possible
Remark: | Current cycle time [unit: 1=500µs] of the control program


Feedback

Status of analog input sine |  |  | Object 692.3
available | in all Compax3 device types
Object name | C3.StatusFeedback_EncoderSine
User level | advanced | D/A monitor output | not possible
Remark: | Sine track of encoder, für F11 and F12 devices (0.5 = 2.5V)
Status of analog input cosine |  |  | Object 692.4
available | in all Compax3 device types
Object name | C3.StatusFeedback_EncoderCosine
User level | advanced | D/A monitor output | not possible
Remark: | Cosine trace of encoder, für F11 and F12 devices
Status of cosine in signal processing |  |  | Object 692.2
available | in all Compax3 device types
Object name | C3.StatusFeedback_FeedbackCosineDSP
User level | advanced | D/A monitor output | not possible
Remark: | Cosine trace of resolver, for F10 devices The value 1 corresponds to 2.5 Volts The amplitude must be <1 and > 0.1 at the resolver; otherwise a level error is reported.
Status of sine in signal processing |  |  | Object 692.1
available | in all Compax3 device types
Object name | C3.StatusFeedback_FeedbackSineDSP
User level | advanced | D/A monitor output | not possible
Remark: | Sinus track resolver, für F10 devices The value 1 corresponds to 2.5 Volts The amplitude must be <1 and > 0.1 at the resolver; otherwise a level error is reported.
Hall sensor 3 |  |  | Object 691.6
available | in all Compax3 device types
Object name | C3.StatusHallcommutation_Bit3
User level | advanced | D/A monitor output | not possible
Remark: |
Hall sensor 2 |  |  | Object 691.5
available | in all Compax3 device types
Object name | C3.StatusHallcommutation_Bit2
User level | advanced | D/A monitor output | not possible
Remark: |
Hall sensor 1 |  |  | Object 691.4
available | in all Compax3 device types
Object name | C3.StatusHallcommutation_Bit1
User level | advanced | D/A monitor output | not possible
Remark: |
Status of feedback level |  |  | Object 692.5
available | in all Compax3 device types
Object name | C3.StatusFeedback_FeedbackVoltage[Vpp]
User level | advanced | D/A monitor output | not possible
Remark: | Feedback level, for F11 and F12 devices, display in Vpp (=sqrt(sin²+cos²))


Gearing

Position input value for Gearing |  |  | Object 1141.7
available | I12T11, I20T11, I21T11, IxxT30, IxxT40
Object name | C3.GEAR_actual_masterposition
User level | standard | D/A monitor output | not possible
Remark: | in Units
Master speed for Gearing |  |  | Object 1141.8
available | I12T11, I20T11, I21T11, IxxT30, IxxT40
Object name | C3Plus.GEAR_actual_master_speed
User level | standard | D/A monitor output | not possible
Remark: | in Units/s


HEDA

Error counter Sync (HEDA) |  |  | Object 900.13
available | I11T40, I20T40, I21T40
Object name | C3Plus.HEDA_SyncErrorCounter
User level | standard | D/A monitor output | not possible
Remark: |
Status HEDA |  |  | Object 900.1
available | I11T40, I20T40, I21T40
Object name | C3Plus.HEDA_State
User level | standard | D/A monitor output | not possible
Remark: | 0=not Init 1=Init (Hardware initialized) 2=Sync (Synchronization with the Master) 3=Com (Exchange of data with other devices) 4=wait Master (Device is waiting for Master) 5=off (Off, device does not communicate) In order to trigger a new initialization, o900.1 must be written with value 0!
Sendestring |  |  | Object 689.2
available | I11T40, I20T40, I21T40
Object name | C3.StatusHeda_TxPD
User level | standard | D/A monitor output | not possible
Remark: |
Receive string |  |  | Object 689.1
available | I11T40, I20T40, I21T40
Object name | C3.StatusHeda_RxPD
User level | standard | D/A monitor output | not possible
Remark: |
Process input signal Slave |  |  | Object 3920.1
available | I11T40, I20T40, I21T40
Object name | C3Plus.HEDA_SignalProcessing_Input
User level | standard | D/A monitor output | not possible
Remark: |
Error counter CRC (HEDA) |  |  | Object 900.12
available | I11T40, I20T40, I21T40
Object name | C3Plus.HEDA_CRC_ErrorCounter
User level | standard | D/A monitor output | not possible
Remark: |


Error

All errors lead to error status.

Reaction 2: Downramp with switch to currentless then apply brake and then de-energize.

Reaction 5: switch-off of the current immediately (without ramp), application of the brake.

Caution! A Z-axis may drop down due to the brake delay times

Most pending errors can be acknowledged with Quit!
The following errors must be acknowledged with Power on:
0x7381, 0x7382, 0x7391, 0x7392, 0x73A0

The errors as well as the error history can be viewed in the C3 ServoManager under optimization (at the top right of the optimization window).


Error list

2311h
8977d

Error code (hex): | 0x2311
Error: | Effective motor current monitor
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: |
Note: | Adjustable monitoring (with motor parameters: thermal time constant and reference current) The current value can be read with the "Motor load" status display. An error message is generated for a motor load of 105%.

2312h
8978d

Error code (hex): | 0x2312
Error: | Effective drive current monitor
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: |
Note: | Adjustable monitoring (dependant on device parameters) The current value can be read with object 683.2 or the "Device utilization" status display.

2320h
8992d

Error code (hex): | 0x2320
Error: | Overcurrent (power stage)
Error reaction: | Reaction 5: switch-off of the current immediately (without ramp), application of the brake.
Measure: | Check motor cable
Note: | Error cause is a hardware signal

2331h
9009d

Error code (hex): | 0x2331
Error: | Earth fault phase 1
Error reaction: | none
Measure: |
Note: | not implemented

3210h
12816d

Error code (hex): | 0x3210
Error: | High Voltage DC exceeds limit
Error reaction: | Reaction 5: switch-off of the current immediately (without ramp), application of the brake.
Measure: | Limit value is normalized on object 236.45. Normalization factor 1000V
Note: | The voltage on the output bus has exceeded the maximum permissible value

3222h
12834d

Error code (hex): | 0x3222
Error: | High voltage DC too low (<70V)
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: |
Note: | Measurement via PAP

4210h
16912d

Error code (hex): | 0x4210
Error: | Power output stage / device temperature > 85 C
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: |
Note: | Measurement via PAP; source from power stage

4310h
17168d

Error code (hex): | 0x4310
Error: | Motor temp.
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: |
Note: | Source is motor temperature signal

5111h
20753d

Error code (hex): | 0x5111
Error: | Auxiliary Voltage 15V faulty
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: |
Note: | Measurement via PAP

5112h
20754d

Error code (hex): | 0x5112
Error: | Overvoltage on 24V Control (X4/1 pin)
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: |
Note: | Measurement via PAP

5116h
20758d

Error code (hex): | 0x5116
Error: | Undervoltage on 24V Control (X4/1 pin)
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: |
Note: | Measurement via PAP

5117h
20759d

Error code (hex): | 0x5117
Error: | Undervoltage - Additional I/O option
Error reaction: | none
Measure: |
Note: | Used for M expansion with I/O if the external power supply is missing

5380h
21376d

Error code (hex): | 0x5380
Error: | Short Circuit on Digital Output
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: |
Note: | Applies to the 4 on-board outputs

5420h
21536d

Error code (hex): | 0x5420
Error: | Braking Resistor overloaded (Peak Current)
Error reaction: | Reaction 5: switch-off of the current immediately (without ramp), application of the brake.
Measure: |
Note: | Setting via tool input

5421h
21537d

Error code (hex): | 0x5421
Error: | Braking Resistor overloaded (Continuous Current)
Error reaction: | Reaction 5: switch-off of the current immediately (without ramp), application of the brake.
Measure: |
Note: | Setting via tool input

5480h
21632d

Error code (hex): | 0x5480
Error: | Short Circuit - Motor Brake
Error reaction: | none
Measure: |
Note: | Diagnostic lines from power stage interface

5481h
21633d

Error code (hex): | 0x5481
Error: | Open Circuit - Motor Brake
Error reaction: | none
Measure: |
Note: | Diagnostic lines from power stage interface

5491h
21649d

Error code (hex): | 0x5491
Error: | Disable pow.st.
Error reaction: | Reaction 5: switch-off of the current immediately (without ramp), application of the brake.
Measure: |
Note: | Hardware input (safe standstill)

54A0h
21664d

Error code (hex): | 0x54A0
Error: | Limit switch I5 (X12/12) activated
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Move axis into the travel range. The error may occur if E5 is designed as a freely assignable input and for example C3_ErrorMask is used in the IEC-program.
Note: | Limit switch on input 5 is active. Is only set with rising edge.

54A1h
21665d

Error code (hex): | 0x54A1
Error: | Limit switch I6 (X12/13) activated
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Move axis into the tavel range. The error may occur if E6 is designed as a freely assignable input and for example C3_ErrorMask is used in the IEC program.
Note: | Limit switch on input 6 is active. Is only set with rising edge.

6011h
24593d

Error code (hex): | 0x6011
Error: | Runtime overflow 31.25us
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: |
Note: |

6012h
24594d

Error code (hex): | 0x6012
Error: | Runtime overflow 500us
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: |
Note: | Runtime monitoring. Internal error

6280h
25216d

Error code (hex): | 0x6280
Error: | IEC61131-3 Division by zero
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Debug IEC program
Note: | Division by zero occurred in the IEC program. Execution is aborted at this point and the cycle is restarted after the selected cycle time.

6281h
25217d

Error code (hex): | 0x6281
Error: | IEC61131-3 Cycle time exceeded
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Optimize program (runtime), increase target cycle time, suppress time-intensive processes (for example saving objects in Flash)
Note: | Preset nominal cycle time could not be kept. Execution is aborted and the cycle is restarted after the selected cycle time.

6282h
25218d

Error code (hex): | 0x6282
Error: | IEC61131-3 program stack overflow
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Reduce nesting depth in function and subprogram calls
Note: | Stack overflow in IEC runtime. Execution is aborted at this point and the cycle is restarted after the selected cycle time.

6283h
25219d

Error code (hex): | 0x6283
Error: | IEC61131-3 FB overflow
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Reduce the number of or the nesting depth of function module instances
Note: | Stack overflow in the IEC runtime caused by too many function module entities. Execution is aborted at this point and the cycle is restarted after the selected cycle time.

6284h
25220d

Error code (hex): | 0x6284
Error: | IEC61131-3 illegal instruction
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Recompile the program / download and verify the compiler version
Note: | Invalid opcode in the IEC program Execution is aborted at this point and the cycle is restarted after the selected cycle time.

7121h
28961d

Error code (hex): | 0x7121
Error: | Motor stalled
Error reaction: | Reaction 5: switch-off of the current immediately (without ramp), application of the brake.
Measure: |
Note: | Speed controller signal at limit for specific time

7180h
29056d

Error code (hex): | 0x7180
Error: | Motor Peak Current monitor
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: |
Note: | Adjustable monitoring (with motor parameters: pulse current time and pulse current) The current value can be read with the "Motor impulse utilization" status display. An error message is generated for a motor impulse utilization of 115%.

7310h
29456d

Error code (hex): | 0x7310
Error: | Speed too high
Error reaction: | Reaction 5: switch-off of the current immediately (without ramp), application of the brake.
Measure: |
Note: | Speed too high

7320h
29472d

Error code (hex): | 0x7320
Error: | Pos. error
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Optimize controller adjustment (increase stiffness),increase tracking error window and / or tracking error time
Note: | Monitoring of tracking error window incl. time

7323h
29475d

Error code (hex): | 0x7323
Error: | Target position beyond positive end limit
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Software end limits exceeded. After that only movements towards the travel range are permitted. Cam, Gear, Current are blocked. Only effective, if home is reached (axis is referenced).
Note: | Software end limits exceeded. After that only movements towards the travel range are permitted. Cam, Gear, Current are blocked. Only effective, if home is reached (axis is referenced).

7324h
29476d

Error code (hex): | 0x7324
Error: | Target position beyond negative end limit
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Software end limits exceeded. After that only movements towards the travel range are permitted. Cam, Gear, Current are blocked. Only effective, if home is reached (axis is referenced).
Note: | Software end limits exceeded. After that only movements towards the travel range are permitted. Cam, Gear, Current are blocked. Only effective, if home is reached (axis is referenced).

7381h
29569d

Error code (hex): | 0x7381
Error: | Resolver output level too high
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Check feedback cable or feedback Note: The feedback excitation voltage is deactivated for level errors!
Note: | Level limit exceeded, can only be reset by powering on the device again.

7382h
29570d

Error code (hex): | 0x7382
Error: | Resolver output level too low
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Check feedback cable or feedback Note: The feedback excitation voltage is deactivated for level errors!
Note: | Level has fallen below limit, can only be reset by powering on the device again.

7391h
29585d

Error code (hex): | 0x7391
Error: | Feedback level exceeds limit
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Check feedback cable (shield, abort, short-circuit) or feedback Note: The feedback power supply voltage is deactivated for F11!
Note: | SinCos feedback/Encoder: Level of the Sine/Cosine trace too high; can only be reset by powering on the device again. The limit for Firmware >V2.x.x is at the physical limit 2.5Vss.

7392h
29586d

Error code (hex): | 0x7392
Error: | Feedback level too low
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Check feedback cable (shield, abort, short-circuit) or feedback Note: The feedback power supply voltage is deactivated for F11!
Note: | SinCos feedback/Encoder: Level of Sine/Cosine or A/B trace too low, can only be reset by powering on the device again The limit for Firmware >V2.x.x is at 0.4Vss. With RS422 feedback one or both traces are missing.

73A0h
29600d

Error code (hex): | 0x73A0
Error: | Hall commutation: invalid combination of hall signals
Error reaction: | Reaction 5: switch-off of the current immediately (without ramp), application of the brake.
Measure: | Check hall wiring and hall sensors for functionality. Eliminate any (EMC) malfunctions in hall signals.
Note: | A hall combination that is not permitted with correct wiring was recorded during hall commutating. Can only be reset by PowerOn.

73A1h
29601d

Error code (hex): | 0x73A1
Error: | Hall commutation: invalid correction value fine angle
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Configure hall direction correctly (check with Motormanager). (EMC) Eliminate disturbance on hall signals. Check hall wiring and verify function of hall sensors.
Note: | The difference between rough and fine commutation detected is higher than the maximum value 30 electric. Can be acknowledged by PowerOn.

73A5h
29605d

Error code (hex): | 0x73A5
Error: | Automatic commutation: no standstill of drive on start
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Check the signal quality of the feedback (noise), bring the drive to a standstill
Note: | (Filtered) speed of the motor within 10 s after the start of automatic commutation not zero

73A6h
29606d

Error code (hex): | 0x73A6
Error: | Automatic commutation: More than 60° el. movement
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Malfunction (motion caused by external source) of the motor during automatic commutation, starting current too great, incorrect parameter for commutation direction (use MotorManager to determine the values). Check feedback resolution and/or number of feedback or motor poles.
Note: | The motor has moved more than permitted during automatic commutation.

73A7h
29607d

Error code (hex): | 0x73A7
Error: | Automatic commutation: More than 5° el. movement during phase 2
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Eliminate external influence on the motor or device current is too small resp. friction is too great.
Note: | Motor is not following controlled movement. In this case, the motor should stand still.

73A8h
29608d

Error code (hex): | 0x73A8
Error: | Automatic commutation: No standstill during phase 3
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Eliminate external influence on the motor. Check feedback.
Note: | The motor is not following controlled movement (here: Motor does not stop)

73A9h
29609d

Error code (hex): | 0x73A9
Error: | Automatic commutation: Timeout during phase 3
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Increase the starting current and eliminate very high direction dependence or friction if any. Check feedback resolution and/or number of feedback or motor poles.
Note: | The maximum time for automatic commutation has been exceeded.

73AAh
29610d

Error code (hex): | 0x73AA
Error: | Automatic commutation: Too many trials during phase 3
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Increase the starting current or eliminate external influence on the motor. Check feedback resolution and/or number of feedback or motor poles.
Note: | The motor is not following assigned controlled movement.

73ABh
29611d

Error code (hex): | 0x73AB
Error: | Automatic commutation: Timeout
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Increase automatic commutation starting current, eliminate motor block, check parameters for motor current (too small, device extremely under-dimensioned), current controller unstable.
Note: | It was not possible to successfully complete automatic commutation within 30 s.

73ACh
29612d

Error code (hex): | 0x73AC
Error: | Automatic commutation: No motor connected
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Connect motor resp. check wiring
Note: | Current controller setting full voltage without current flowing.

73B0h
29616d

Error code (hex): | 0x73B0
Error: | Distance coding: invalid reference mark position
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Checking and correcting the feedback sensor adjustment as well as the feedback wiring
Note: | The position of the reference mark (middle of mark) with reference to the fine interpolation (Sine and Cosine) is not in the range –89.9..179.9 .

7480h
29824d

Error code (hex): | 0x7480
Error: | Cam generator: invalid segment in linking table
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Check segment entries of the linking table and/or verify the contents of the curve header / memory.
Note: | The segment entered into the linking table row (linking direction taken into consideration) currently processed or one of the following rows up to the next end segment, is not available in the curve memory (> number of curves in the header or not set in the flash).

7481h
29825d

Error code (hex): | 0x7481
Error: | Cam generator: invalid master segment distance
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Verify master segment distances and/or master segment factors in the linking table.
Note: | The master segment distance assigned to the currently processed linking table row or to the following linking table row up to the next end segment (linking direction taken into consideration) is permitted (segment distance or factor <=0).

7482h
29826d

Error code (hex): | 0x7482
Error: | Cam generator: cam point not found
Error reaction: | none
Measure: | Verify configuration of the master channel (normalization), verify master segment distance and/or factor (too small?), if needs be, reduce number of interpolation points of the curve.
Note: | The curve point belonging to the current relative master position in the current segment could not be found, as the scanning area is too small.

7483h
29827d

Error code (hex): | 0x7483
Error: | Cam generator: cam data error
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Verify normalized master positions in the flash.
Note: | The difference between the master positions of two successive curve points in the flash is smaller or equal to zero.

7484h
29828d

Error code (hex): | 0x7484
Error: | Cam generator: cam point of coupling segment not found
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | as 7482 but with coupling segment
Note: | as 7482 but with coupling segment

7485h
29829d

Error code (hex): | 0x7485
Error: | Cam generator: cam data coupling segment error
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | as 7483 but with coupling segment
Note: | as 7483 but with coupling segment

7486h
29830d

Error code (hex): | 0x7486
Error: | Cam generator: multiple segment change
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Verify configuration of the master channel (normalization), verify master segment distance and/or factor (too small?).
Note: | The current configuration demands that more than one change of segment would be necessary in 500us. This is however not possible..

7487h
29831d

Error code (hex): | 0x7487
Error: | Cam generator: maximum allowable master or slave speed value exceeded
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Master and slave normalization, verify master and slave factors as well as master or slave segment distances, reduce master velocity.
Note: | The master speed / slave speed exceeds 2^23.

7488h
29832d

Error code (hex): | 0x7488
Error: | Cam generator: maximum allowable internal speed value exceeded
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Verify or modify configuration.
Note: | Value range overflow in curve operation. The selected configuration is not possible.

7590h
30096d

Error code (hex): | 0x7590
Error: | HEDA synchronization error
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Check HEDA cable. Are the terminating connectors correctly fixed? Is the red HEDA-LED off on all devices? Is there a Master and are all of ist transmit slots active?
Note: | HEDA connection is interrupted. No valid telegrams could be detected.

7591h
30097d

Error code (hex): | 0x7591
Error: | HEDA communication error
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Check HEDA cable. Are the terminating connectors correctly fixed? Could double assignments in a transmit slot lead to collisions? Watch HEDA-LED!
Note: | HEDA-CRC-Error. Error within a telegram.

7594h
30100d

Error code (hex): | 0x7594
Error: | HEDA receiver overrun
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: |
Note: | HEDA

8110h
33040d

Error code (hex): | 0x8110
Error: | Overrun
Error reaction: | none
Measure: |
Note: | Field bus error: adjustable response (none, response 2)

8120h
33056d

Error code (hex): | 0x8120
Error: | CRC error or passive mode (CAN)
Error reaction: | none
Measure: |
Note: | Field bus error: adjustable response (none, response 2)

8121h
33057d

Error code (hex): | 0x8121
Error: | Bus off (CAN)
Error reaction: | none
Measure: |
Note: | CAN Bus inactive status Field bus error: adjustable response (none, response 2)

8131h
33072d

Error code (hex): | 0x8131
Error: | Fieldbus synchronization error
Error reaction: | none
Measure: | Check connection and master
Note: | Failure of the sync telegram Field bus error: adjustable response (none, response 2)

8181h
33153d

Error code (hex): | 0x8181
Error: | Invalid velocity
Error reaction: | none
Measure: | Reduce setpoint value
Note: | Preset speed ins too high (also externally); command was rejected

8182h
33154d

Error code (hex): | 0x8182
Error: | CAM command error
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: |
Note: |

8183h
33155d

Error code (hex): | 0x8183
Error: | Watchdog test movement
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Acknowledge Error occurs for example if the response times of the PC are too long for RS232 communication.
Note: | Error is triggered if o40.3=0. Watchdog cannot be deactivated via o40.3=-1. Watchdog time=o40.3*100ms

8190h
33168d

Error code (hex): | 0x8190
Error: | CamCommand: unknown command
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Only emit commands that are possible: 1: SetC, 2: SetM (on O3011.1 ), 3: SetM on current input position of the master position acquisition (on O3021.2), 4: prepare coupling/decoupling by change-over, 5: prepare quadratic coupling, 6: prepare quadratic decoupling. As from Firmware version V02.05.02: 10: Setting the displayed master position, 11: Setting the master position for the curve in mode "relative", 12: Setting the master position for the curve in mode "absolute", 20: Cache segment data again
Note: | The preset Cam command does not exist.

8191h
33169d

Error code (hex): | 0x8191
Error: | CamCommand: SetC must be executed before SetM
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Please take the order of the commands SetC and SetM into consideration.
Note: | SetC (Cmd 1) must have been executed before SetM (Cmd 2) .

8192h
33170d

Error code (hex): | 0x8192
Error: | CamCommand: command not permitted at present
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Create the prerequisites for the command: SetM (Cmd 2,3) only if "global enable" (O3020.4) is not placed. Prepare coupling by change-over (Cmd 4) only if coupling / decoupling is not taking place at the same time. Prepare quadratic coupling (Cmd 5) only if coupling is not taking place at the same time and if SetM has already been executed. Prepare quadratic decoupling (Cmd 6) only if coupling is not taking place at the same time and if SetM has already been executed. Set master position for display (Cmd10) only if not synchronized (coupling or decoupling resp. curve mode). Set master position in Mode relative/absolute (Cmd11/12) only without master position enable for Cam (O3032.7 = 0).
Note: | The selected command is not permitted at present.

8193h
33171d

Error code (hex): | 0x8193
Error: | CamCommand: invalid table row entry for the selected cam
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Correct specification for selected curve (O3011.2) and/or start line of the curve (O3040).
Note: | The table row assigned to the selected curve (=3040.(O3011.2)) for SetC (Cmd1,11,12) is invalid (smaller or equal to zero or greater than the maximum number of rows of 20).

8194h
33172d

Error code (hex): | 0x8194
Error: | CamCommand: invalid coupling segment
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Select valid coupling segment (O3011.3) or verify curve memory.
Note: | Prepare coupling by change-over (Cmd 4): The coupling segment chosen in O3011.3 is invalid, as it is not available in the curve memory.

8195h
33173d

Error code (hex): | 0x8195
Error: | CamCommand: invalid segment
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Select valid segment or verify curve memory.
Note: | The coupling segment to be processed next is invalid, as it is not available in the curve memory. Additional information in the current table row (O3010.4) and in the current segment (O3010.5).

8196h
33174d

Error code (hex): | 0x8196
Error: | CamCommand: invalid master segment distance
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Specify permitted value for master segment distance (O3056) or master segment factor (O3058).
Note: | The master segment distance to be processed next is smaller or equal to zero. This is not permitted. Additional information in the current table row (O3010.4) and in the current segment (O3010.5).

8197h
33175d

Error code (hex): | 0x8197
Error: | CamCommand: invalid segment figure in cam memory
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Verify header or reduce number of segments.
Note: | The number of segments stated in the curve header exceeds the maximum value of 354 (without default coupling segment).

8199h
33177d

Error code (hex): | 0x8199
Error: | CamCommand: internal value range overflow
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Verify, if the configuration used makes sense. Send the configuration and cam data to technical support.
Note: | Internal calculation problem when processing the curve data.

819ah
33178d

Error code (hex): | 0x819a
Error: | CamCommand: invalid slope of quadratic coupling
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Verify the current segment (O3031.1) and its sequence, the selected coupling / decoupling positions (O1139.1 and =1140.1) and the selected delta values (O1129.4 and =1140.4)
Note: | The slope calculated when preparing the quadratic coupling and decoupling (Cmd 5,6) is invalid (smaller than or equal to zero).

819bh
33179d

Error code (hex): | 0x819b
Error: | CamCommand: invalid parameters for changing of master reset distance
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Verify the default values numerator (O3011.5) and/or denominator of the reset distance. Verify the configuration of master and master signal sources.
Note: | The default values numerator (O3011.5) and/or denominator of the reset distance (O3011.6) are invalid (smaller than zero or larger or equal to 2^23) or, with alternative reset distance: Denominator path/( master*numerator reset distance * numerator alternative reset distance (O3011.5) is larger than or equal to 2^47.

819ch
33180d

Error code (hex): | 0x819c
Error: | CamCommand: invalid master source selected
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Select valid source for switching or configure source to switch to.
Note: | The master source selected in =3011.8 is invalid or was not configured.

8612h
34322d

Error code (hex): | 0x8612
Error: | Reference Limit
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Reference position could not be accessed. One of the limit switches was detected twice. There was no home switch or feedback zero pulse. Homing was aborted
Note: | No reference point for machine zero detected within the travel range. The homing sequence was aborted. Check reference point feedback.

FF01h
65281d

Error code (hex): | 0xFF01
Error: | No object with this index available
Error reaction: | none
Measure: |
Note: | Object does not exist

FF02h
65282d

Error code (hex): | 0xFF02
Error: | No object with this subindex available
Error reaction: | none
Measure: |
Note: | the chosen subindex for this object does not exist

FF03h
65283d

Error code (hex): | 0xFF03
Error: | Object is "read only"
Error reaction: | none
Measure: |
Note: | No write access

FF04h
65284d

Error code (hex): | 0xFF04
Error: | Object cannot be read
Error reaction: | none
Measure: |
Note: | No read access

FF05h
65285d

Error code (hex): | 0xFF05
Error: | Version conflict; object data not valid in flash
Error reaction: | none
Measure: |
Note: | Internal error

FF06h
65286d

Error code (hex): | 0xFF06
Error: | No object for process data; object cannot be mapped
Error reaction: | none
Measure: |
Note: | This object cannot be mapped on the cyclic data

FF07h
65287d

Error code (hex): | 0xFF07
Error: | Data not valid
Error reaction: | none
Measure: |
Note: | No OPM text present

FF08h
65288d

Error code (hex): | 0xFF08
Error: | No convert function
Error reaction: | none
Measure: |
Note: | Internal error

FF10h
65296d

Error code (hex): | 0xFF10
Error: | Command syntax error
Error reaction: | none
Measure: |
Note: | Syntax error

FF11h
65297d

Error code (hex): | 0xFF11
Error: | Value not valid
Error reaction: | none
Measure: |
Note: | Argument incorrect

FF12h
65298d

Error code (hex): | 0xFF12
Error: | Checksum error
Error reaction: | none
Measure: |
Note: | Checksum CRC incorrect

FF13h
65299d

Error code (hex): | 0xFF13
Error: | Timeout error
Error reaction: | none
Measure: |
Note: | Active in binary protocol; 5 ms

FF14h
65300d

Error code (hex): | 0xFF14
Error: | Overflow error
Error reaction: | none
Measure: |
Note: | Utype error

FF15h
65301d

Error code (hex): | 0xFF15
Error: | Parity error
Error reaction: | none
Measure: |
Note: | Utype error

FF16h
65302d

Error code (hex): | 0xFF16
Error: | Frame error
Error reaction: | none
Measure: |
Note: | Utype error

FF20h
65312d

Error code (hex): | 0xFF20
Error: | Flash sector delete failed
Error reaction: | none
Measure: |
Note: | Error while deleting flash

FF21h
65313d

Error code (hex): | 0xFF21
Error: | Program flash cell failed
Error reaction: | none
Measure: |
Note: | Error while programming flash

FF22h
65314d

Error code (hex): | 0xFF22
Error: | Checksum error of prog. Flash area
Error reaction: | none
Measure: |
Note: | Error for flash checksum

FF23h
65315d

Error code (hex): | 0xFF23
Error: | DOWN/UPLOAD activated
Error reaction: | none
Measure: |
Note: | Download or upload is active

FF24h
65316d

Error code (hex): | 0xFF24
Error: | DOWN/UPLOAD not activated
Error reaction: | none
Measure: |
Note: | Download or upload is inactive

FF30h
65328d

Error code (hex): | 0xFF30
Error: | EEPROM Delay Count Error
Error reaction: | none
Measure: |
Note: | Internal error

FF40h
65344d

Error code (hex): | 0xFF40
Error: | Not enough memory for OSZI or AWL reserved
Error reaction: | none
Measure: |
Note: | An attempt was made to reserve too much memory (IEC, osci)

FF42h
65346d

Error code (hex): | 0xFF42
Error: | No objects available
Error reaction: | none
Measure: | Load application data into device (objects)
Note: | Application data error; no valid objects present LED red flashing

FF43h
65347d

Error code (hex): | 0xFF43
Error: | No IEC61131 program
Error reaction: | none
Measure: | Load application data into device (IEC61131 program). Turn device off and back on again.
Note: | Application data error; no IEC61131 program available LED red flashing

FF45h
65349d

Error code (hex): | 0xFF45
Error: | No FBI
Error reaction: | none
Measure: | De-energize motor, then perform function
Note: | Motor is energized! An attempt was made to execute a function at a time when the motor must be de-energized, e.g. device duplication via BDM.

FF46h
65350d

Error code (hex): | 0xFF46
Error: | Motor powered
Error reaction: | none
Measure: |
Note: | An attempt was made to perform a device duplication even though the source and target device are different (different order code)

FF47h
65351d

Error code (hex): | 0xFF47
Error: | Devicetype dif
Error reaction: | none
Measure: |
Note: | The hardware of the source is not compatible with the hardware of the target for duplicating a device

FF60h
65376d

Error code (hex): | 0xFF60
Error: | CANopen library
Error reaction: | none
Measure: |
Note: |

FF61h
65377d

Error code (hex): | 0xFF61
Error: | CANopen confirmation
Error reaction: | none
Measure: | CANopen Master did not receive a confirmation from the accessed CANopen node
Note: |

FF62h
65378d

Error code (hex): | 0xFF62
Error: | No CANopen Master
Error reaction: | none
Measure: |
Note: |

FF90h
65424d

Error code (hex): | 0xFF90
Error: | Feedback System isn't compatible to the Compax3 Feedback Option
Error reaction: | none
Measure: | “Replace” or update firmware, use device required for feedback.
Note: | The connected feedback system cannot be used with the firmware currently in use. (for example with commutation wizard F12 feedback for F10/F11 device and vice-versa).

FF91h
65425d

Error code (hex): | 0xFF91
Error: | Invalid combination of hall signals rough commutation
Error reaction: | none
Measure: | Check hall wiring and hall sensors for functionality. Eliminate any (EMC) malfunctions in hall signals.
Note: | Invalid hall combinations ”000” or ”111” were detected during hall commutation.

FF92h
65426d

Error code (hex): | 0xFF92
Error: | Invalid commutation
Error reaction: | none
Measure: | Switch device off and on again or execute commands 9 and 10 one after the other.
Note: | Only with F12 devices: Compax3 must be re-started, as the commutation or the configured motor was changed due to a configuration download. The error cannot be acknowledged.

FFA1h
65441d

Error code (hex): | 0xFFA1
Error: | SinCos Analog signals outside specification
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFA2h
65442d

Error code (hex): | 0xFFA2
Error: | SinCos Internal angle offset fault
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFA3h
65443d

Error code (hex): | 0xFFA3
Error: | SinCos Table destroyed via data field partition
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFA4h
65444d

Error code (hex): | 0xFFA4
Error: | SinCos Analog limits not available
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFA5h
65445d

Error code (hex): | 0xFFA5
Error: | SinCos Internal I²C-Bus not functioning I²T?
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFA6h
65446d

Error code (hex): | 0xFFA6
Error: | SinCos Internal checksum error
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFA7h
65447d

Error code (hex): | 0xFFA7
Error: | SinCos Feedback reset via program supervision
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFA8h
65448d

Error code (hex): | 0xFFA8
Error: | SinCos Counter overflow
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFA9h
65449d

Error code (hex): | 0xFFA9
Error: | SinCos Parity error
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFAAh
65450d

Error code (hex): | 0xFFAA
Error: | SinCos Checksum of transmitted data is faulty
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFABh
65451d

Error code (hex): | 0xFFAB
Error: | SinCos Unknown command code
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFACh
65452d

Error code (hex): | 0xFFAC
Error: | SinCos Number of transmitted data is faulty
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFADh
65453d

Error code (hex): | 0xFFAD
Error: | SinCos Improper command argument transmitted
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFAEh
65454d

Error code (hex): | 0xFFAE
Error: | SinCos the selected data field is not to be exceeded
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFAFh
65455d

Error code (hex): | 0xFFAF
Error: | SinCos Invalid access code
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFB0h
65456d

Error code (hex): | 0xFFB0
Error: | SinCos size of given data field cannot be changed
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFB1h
65457d

Error code (hex): | 0xFFB1
Error: | SinCos given word address outside data field
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFB2h
65458d

Error code (hex): | 0xFFB2
Error: | SinCos access to non-existing data field. data field
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFBCh
65468d

Error code (hex): | 0xFFBC
Error: | SinCos Absolute value control of the analog signals
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFBDh
65469d

Error code (hex): | 0xFFBD
Error: | SinCos Transmitter current approaching limit
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFBEh
65470d

Error code (hex): | 0xFFBE
Error: | SinCos Feedback temperature approaching limit
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFBFh
65471d

Error code (hex): | 0xFFBF
Error: | SinCos Speed exceeds normal, no position generation permitted
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFC0h
65472d

Error code (hex): | 0xFFC0
Error: | SinCos Position Singleturn unreliable
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFC1h
65473d

Error code (hex): | 0xFFC1
Error: | SinCos Position error Multiturn
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFC2h
65474d

Error code (hex): | 0xFFC2
Error: | SinCos Position error Multiturn
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFC3h
65475d

Error code (hex): | 0xFFC3
Error: | SinCos Position error Multiturn
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Change feedback
Note: | Feedback reports error

FFD0h
65488d

Error code (hex): | 0xFFD0
Error: | SinCos CRC
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Check wiring, check feedback Ensure EMC immunity by the aid of correct screening
Note: | Communication error with SinCos feedback

FFD1h
65489d

Error code (hex): | 0xFFD1
Error: | SinCos RX Timeout
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Check wiring, check feedback Ensure EMC immunity by the aid of correct screening
Note: | Communication error with SinCos feedback

FFD2h
65490d

Error code (hex): | 0xFFD2
Error: | SinCos RX Overrrun
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Check wiring, check feedback Ensure EMC immunity by the aid of correct screening
Note: | Communication error with SinCos feedback

FFD3h
65491d

Error code (hex): | 0xFFD3
Error: | SinCos RX Parity
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Check wiring, check feedback Ensure EMC immunity by the aid of correct screening
Note: | Communication error with SinCos feedback

FFD4h
65492d

Error code (hex): | 0xFFD4
Error: | SinCos RX Frame
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Check wiring, check feedback Ensure EMC immunity by the aid of correct screening
Note: | Communication error with SinCos feedback

FFD5h
65493d

Error code (hex): | 0xFFD5
Error: | Unknown SinCos encoder type
Error reaction: | none
Measure: | Update Compax3 firmware
Note: | The SinCos feedback sytem type connected is not supported

FFD6h
65494d

Error code (hex): | 0xFFD6
Error: | SinCos speed exceeds normal when writing encoder position
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Ensure that the motor is at a standsill
Note: | The speed when writing the feedback position was too high

FFE0h
65504d

Error code (hex): | 0xFFE0
Error: | Homing sequence attempted while moving or drive disabled
Error reaction: | none
Measure: | Do not call PLCopen function module MC_Home during an ongoing positioning process or while a stop command is running.
Note: | Error in the IEC61131-3 program sequence. PLCopen function module MC_home was called even though the axis was not at a standstill (state standstill AND drive energized)

FFE1h
65505d

Error code (hex): | 0xFFE1
Error: | CamOut not possible during coupling
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | PLCopen function module CamOut cannot be called during coupling process.
Note: | Error in the IEC61131-3 program sequence. PLCopen function module CamOut was called even though the axis was not yet coupled.

FFE2h
65506d

Error code (hex): | 0xFFE2
Error: | invalid parameter transfer when calling up a function block
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Call PLCopen function module with matching parameters.
Note: | Error in the IEC61131-3 program sequence. Function module was called with incorrect parameters.

FFE3h
65507d

Error code (hex): | 0xFFE3
Error: | Coupling // Decoupling only possible with C3_CamIn // Out Mode 0
Error reaction: | Reaction 2: Downramp / apply brake / de-energize.
Measure: | Coupling with a linear actuator only possible with Mode 0.
Note: | Error in the IEC61131-3 program sequence. An attempt was made with a linear actuator to couple with another mode than 0.


Compax3 Accessories

In this chapter you can read about:

Order code for Compax3

Accessories order code

Parker servo motors

Connections to the motor

EMC measures

External ballast resistors

Operator control module BDM

EAM06: terminal block for inputs and outputs

ZBH plug set

Interface cable

Profibus plug BUS08/01

CAN - plug BUS10/01

PIO: External Inputs/Outputs


Order code for Compax3

Order code device


Accessories order code

Order code for motor cables(2
 |  |  |  |  |  |  |  | / |  |
for SMH / MH56 / MH70 / MH105(3 | (1.5mm2 ; up to 13.8A) |  | M | O | K | 5 | 5 | / | ... | ...(1
for SMH / MH56 / MH70 / MH105(3 | (1.5mm2 ; up to 13.8A) | (cable chain compatible) | M | O | K | 5 | 4 | / | ... | ...(1
for SMH / MH56 / MH70 / MH105(3 | (2.5mm2 ; up to 18.9A) |  | M | O | K | 5 | 6 | / | ... | ...(1
for SMH / MH56 / MH70 / MH105(3 | (2.5mm2 ; up to 18.9A) | (cable chain compatible) | M | O | K | 5 | 7 | / | ... | ...(1
for MH145 / MH205(4 | (1.5mm2 ; up to 13.8A) |  | M | O | K | 6 | 0 | / | ... | ...(1
for MH145 / MH205(4 | (1.5mm2 ; up to 13.8A) | (cable chain compatible) | M | O | K | 6 | 3 | / | ... | ...(1
for MH145 / MH205(4 | (2.5mm2 ; up to 18.9A) |  | M | O | K | 5 | 9 | / | ... | ...(1
for MH145 / MH205(4 | (2.5mm2 ; up to 18.9A) | (cable chain compatible) | M | O | K | 6 | 4 | / | ... | ...(1
for MH145 / MH205(4 | (6mm2 ; up to 32.3A) | (cable chain compatible) | M | O | K | 6 | 1 | / | ... | ...(1
for MH145 / MH205(4 | (10mm2 ; up to 47.3A) | (cable chain compatible) | M | O | K | 6 | 2 | / | ... | ...(1
Order code for feedback cables
 |  |  |  |  |  |  | / |  |
for Resolver (2 |  | R | E | K | 4 | 2 | / | ... | ...(1
for Resolver (2 | (cable chain compatible) | R | E | K | 4 | 1 | / | ... | ...(1
for SinCos©–Feedback devices(2 | (cable chain compatible) | G | B | K | 2 | 4 | / | ... | ...(1
Encoder – Compax3 |  | G | B | K | 2 | 3 | / | ... | ...(1
for LXR linear motors | (cable chain compatible) | G | B | K | 3 | 3 | / | ... | ...(1
for BLMA linear motors | (cable chain compatible) | G | B | K | 3 | 2 | / | ... | ...(1
Order code for interface cables and plugs
 |  |  |  |  |  |  | / |  |
PC – Compax3 (RS232) |  | S | S | K | 0 | 1 | / | ... | ...(1
on X11 (Ref /Analog) | with flying leads | S | S | K | 2 | 1 | / | ... | ...(1
on X12 (I/Os digital) | with flying leads | S | S | K | 2 | 2 | / | ... | ...(1
on X11 (Ref /Analog) | for I/O –terminal block | S | S | K | 2 | 3 | / | ... | ...(1
on X12 (I/Os digital) | for I/O –terminal block | S | S | K | 2 | 4 | / | ... | ...(1
PC ó POP (RS232) |  | S | S | K | 2 | 5 | / | ... | ...(1
Compax3 ó POP (RS485) |  | S | S | K | 2 | 7 | / | ../ | ...(6
Compax3 HEDA ó Compax3 HEDA or PC ó C3powerPLmC |  | S | S | K | 2 | 8 | / | ../ | ...(5
Compax3 X11 ó Compax3 X11 (encoder coupling of 2 axes) |  | S | S | K | 2 | 9 | / | ... | ...(1
HEDA bus termination plug (for the first and last Compax3 in the HEDA – Bus) |  | B | U | S | 0 | 7 | / | 0 | 1
Profibus cable (2 | non prefabricated | S | S | L | 0 | 1 | / | ... | ...(1
Profibus plug |  | B | U | S | 0 | 8 | / | 0 | 1
CAN-Bus cable (2 | non prefabricated | S | S | L | 0 | 2 | / | ... | ...(1
CANbus connector |  | B | U | S | 1 | 0 | / | 0 | 1
Order Code connection set for Compax3
 |  |  |  |  |  |  | / |  |
for C3S0xxV2 | ZBH 02/01 | Z | B | H | 0 | 2 | / | 0 | 1
for C3S0xxV4 / S150V4 / S1xxV2 | ZBH 02/02 | Z | B | H | 0 | 2 | / | 0 | 2
for C3S300V4 | ZBH 02/03 | Z | B | H | 0 | 2 | / | 0 | 3
Order Code operating module
 |  |  |  |  |  | / |  |
Operating module | B | D | M | 0 | 1 | / | 0 | 1
Order Code terminal block
 |  |  |  |  |  |  | / |  |
for I/Os without luminous indicator | for X11, X12 | E | A | M | 0 | 6 | / | 0 | 1
for I/Os with luminous indicator | for X12 | E | A | M | 0 | 6 | / | 0 | 2
Order Code braking resistors
 |  |  |  |  |  |  | / |  |
for C3S063V2 or C3S075V4 | 0.18 / 2.3kW | B | R | M | 0 | 5 | / | 0 | 1
for C3S025V2 or C3S038V4 | 60 / 250W | B | R | M | 0 | 8 | / | 0 | 1
for C3S150V4 | 0.57 / 6.9kW | B | R | M | 0 | 6 | / | 0 | 2
for C3S150V2 and C3S300V4 | 4/01:0.57 / 6.9kW 4/02:0.74 / 8.9kW | B | R | M | 0 | 4 | / | 0 | ...
for C3S300V4 | 4/03:1.5 / 18kW |  |  |  |  |  |  |  |
for C3S100V2 | 0.45 / 6.9kW | B | R | M | 0 | 9 | / | 0 | 1
Order Code mains filter
 |  |  |  |  |  | / |  |
for C3S025V2 or S063V2 | N | F | I | 0 | 1 | / | 0 | 1
for C3S0xxV4, S150V4 or S1xxV2 | N | F | I | 0 | 1 | / | 0 | 2
for C3S300V4 | N | F | I | 0 | 1 | / | 0 | 3
Order Code motor output filter
 |  |  |  |  |  | / |  |
up to 6,3 A rated motor current | M | D | R | 0 | 1 | / | 0 | 4
Up to 16 A rated motor current | M | D | R | 0 | 1 | / | 0 | 1
up to 30 A rated motor current | M | D | R | 0 | 1 | / | 0 | 5
Order Code decentralized input terminals
PIO 2DI 24V DC 3.0ms | 2-channel digital input terminal | P | I | O | 4 | 0 | 0
PIO 4DI 24V DC 3.0ms | 4-channel digital input terminal | P | I | O | 4 | 0 | 2
PIO 8DI 24V DC 3.0ms | 8-channel digital input terminal | P | I | O | 4 | 3 | 0
PIO 2AI DC ± 10V differential input | 2 channel analog input terminal (± 10V differential input) | P | I | O | 4 | 5 | 6
PIO 4AI 0 - 10V DC S.E. | 4 channel analog input terminal (0-10V signal voltage) | P | I | O | 4 | 6 | 8
PIO 2AI 0 - 20mA differential input | 2 channel analog input terminal (0 - 20mA differential input) | P | I | O | 4 | 8 | 0

Order Code decentralized output terminals
PIO 2DO 24V DC 0.5A | 2 channel digital output terminal (output voltage 0.5A) | P | I | O | 5 | 0 | 1
PIO 4DO 24V DC 0.5A | 4 channel digital output terminal (output voltage 0.5A) | P | I | O | 5 | 0 | 4
PIO 8DO 24V DC 0.5A | 8 channel digital output terminal (output voltage 0.5A) | P | I | O | 5 | 3 | 0
PIO 2AO 0 - 10V DC | 2 channel analog output terminal (0-10V signal voltage) | P | I | O | 5 | 5 | 0
PIO 2AO 0 - 20mA | 2 channel analog output terminal (0-20mA signal voltage) | P | I | O | 5 | 5 | 2
PIO 2AO DC ± 10V | 2 channel analog output terminal (± 10V Signalspannung) | P | I | O | 5 | 5 | 6

Order Code CANopen Fieldbus Coupler
CANopen Standard | max. vectorial sum current for bus terminals 1650mA at 5V | P | I | O | 3 | 3 | 7
CANopen ECO | max. vectorial sum current for bus terminals 650mA at 5V | P | I | O | 3 | 4 | 7

(1 Length code 1
Length [m] | 1,0 | 2,5 | 5,0 | 7,5 | 10,0 | 12,5 | 15,0 | 20,0 | 25,0 | 30,0 | 35,0 | 40,0 | 45,0 | 50,0
Code | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 | 13 | 14

Example:

SSK01/09: length 25m

(2 Colours according to DESINA

(3 with motor plug

(4 with cable eye for motor terminal box

(5Length code 2 for SSK28
Length [m] | 0,25 | 0,5 | 1,0 | 3,0 | 5,0 | 10,0
Code | 20 | 21 | 01 | 22 | 03 | 05
(6 Order code: SSK27/nn/..

Length A (Pop - 1. Compax3) variable (the last two numbers according to the length code for cable, for example SSK27/nn/01)

Length B (1. Compax3 - 2. Compax3 - ... - n. Compax3) fixed 50 cm (only if there is more than 1 Compax3, i.e. nn greater than 01)

Number n (the last two digits)

Examples:

SSK27/05/.. for connecting from Pop to 5 Compax3.

SSK27/01/.. for connection from Pop to one Compax3

MOK55 and MOK54 can also be used for linear motors LXR406, LXR412 and BLMA.


Parker servo motors

In this chapter you can read about:

Direct drives

Rotary servo motors


Direct drives

In this chapter you can read about:

Transmitter systems for direct drives

Linear motors

Torque motors


Transmitter systems for direct drives

The Feedback option F12 makes it possible to operate linear motors as well as torque motors. Compax3 supports the following transmitter systems:

Special encoder systems for direct drives
Option F12

Analog hall sensors
  • Sinus - Cosinus Signal (max. 5Vss; typical 1Vss) 90° offset
  • U-V signal (max. 5Vss; typical 1Vss) 120° offset.

Encoder
(linear or rotatory)
  • Sinus-Cosinus (max. 5Vss; typical 1Vss) (max. 400kHz) or
  • TTL (RS422) (max. 5MHz)

    with the following modes of commutation:

  • automatic commutation or
  • Digital hall sensors

Distance coded feedback systems
  • Distance coding with 1VSS - Interface
  • Distance coding with RS422 - Interface (Encoder)

Feedback error compensation

  • Feedback error compensation (offset & amplification) for analog hall sensors and sine-cosine encoder can be activated via MotorManager.

The motor performs automatic commutation after:

  • Power on,
  • A configuration download or
  • An IEC program download

    The time duration (typically 5-10 sec) of automatic commutation can be optimized with the start current (see in the optimization display of the C3 ServoManager; given as a percentage of the reference current). Note that values that are too high will cause Error 0x73A6 to be triggered.

    Typically the motor moves by 4% of the pitch length or, with rotary direct drives 4% of 360°/number of pole pairs - maximum 50%.

Note the following conditions for automatic commutation
  • The linear motor must not be at the end limits for automatic commutation.
  • Actively working load torques are not permitted during automatic commutation.
  • Rubbing caused by friction deteriorates the effect of automatic commutation.
  • With the exception of missing commutation information, the controller/motor combination is configured and ready for operation (parameters correctly assigned for the linear motor/drive). The feedback and the direction of the field of rotation in effect must match.
  • The auto-commutating function must be adapted to fit the mechanics if necessary during commissioning.


Linear motors

Parker offers you a number of systems of linear motor drives:

Linear motors

Feed force (continuous/dynamic)

Stroke length:

LMDT ironless linear servo motors:

26 ... 1,463N

amost any

LMI iron-cored linear servo motors:

52 ... 6,000N

64 ... 999mm

Linear motors of the LXR series:

315N / 1,000N

up to 3m

Linear motor module BLMA:

605N / 1,720N

up to 6m


Torque motors

Parker offers you an extensive range of torque motors that can be adapted to your application. Please contact us for information.

Additional information can be found on the Internet in the direct drives section.


Rotary servo motors

Parker offers you an extensive range of servo motors that can be adapted to your application. Please contact us for information.

Additional information can be found in the Internet

or on the CD supplied in the documentations file:

Catalogue = SMH_MH_Kat engl.pdf

User guide = SMH_MH-Manual engl.pdf


Connections to the motor

In this chapter you can read about:

Resolver cable

SinCos cable

Overview of motor cables

Motor cable with plug

Motor cable for terminal box

Under the designation "REK.." (resolver cables) and "MOK.." (motor cables) we can deliver motor connecting cables in various lengths to order. If you wish to make up your own cables, please consult the cable plans shown below:

Order code for motor cables(2
 |  |  |  |  |  |  |  | / |  |
for SMH / MH56 / MH70 / MH105(3 | (1.5mm2 ; up to 13.8A) |  | M | O | K | 5 | 5 | / | ... | ...(1
for SMH / MH56 / MH70 / MH105(3 | (1.5mm2 ; up to 13.8A) | (cable chain compatible) | M | O | K | 5 | 4 | / | ... | ...(1
for SMH / MH56 / MH70 / MH105(3 | (2.5mm2 ; up to 18.9A) |  | M | O | K | 5 | 6 | / | ... | ...(1
for SMH / MH56 / MH70 / MH105(3 | (2.5mm2 ; up to 18.9A) | (cable chain compatible) | M | O | K | 5 | 7 | / | ... | ...(1
for MH145 / MH205(4 | (1.5mm2 ; up to 13.8A) |  | M | O | K | 6 | 0 | / | ... | ...(1
for MH145 / MH205(4 | (1.5mm2 ; up to 13.8A) | (cable chain compatible) | M | O | K | 6 | 3 | / | ... | ...(1
for MH145 / MH205(4 | (2.5mm2 ; up to 18.9A) |  | M | O | K | 5 | 9 | / | ... | ...(1
for MH145 / MH205(4 | (2.5mm2 ; up to 18.9A) | (cable chain compatible) | M | O | K | 6 | 4 | / | ... | ...(1
for MH145 / MH205(4 | (6mm2 ; up to 32.3A) | (cable chain compatible) | M | O | K | 6 | 1 | / | ... | ...(1
for MH145 / MH205(4 | (10mm2 ; up to 47.3A) | (cable chain compatible) | M | O | K | 6 | 2 | / | ... | ...(1
Order code for feedback cables
 |  |  |  |  |  |  | / |  |
for Resolver (2 |  | R | E | K | 4 | 2 | / | ... | ...(1
for Resolver (2 | (cable chain compatible) | R | E | K | 4 | 1 | / | ... | ...(1
for SinCos©–Feedback devices(2 | (cable chain compatible) | G | B | K | 2 | 4 | / | ... | ...(1
Encoder – Compax3 |  | G | B | K | 2 | 3 | / | ... | ...(1
for LXR linear motors | (cable chain compatible) | G | B | K | 3 | 3 | / | ... | ...(1
for BLMA linear motors | (cable chain compatible) | G | B | K | 3 | 2 | / | ... | ...(1


Resolver cable

REK42/..

The same cable (with changed conductor coloring) is available under the designation REK41/.. in a version which is suitable for cable chain systems.

You will find the length code in the Accessories order code.


SinCos cable

GBK24/..: Cable chain compatible

You will find the length code in the Accessories order code.


Overview of motor cables

Cross-section / max. permanent load | Motor connector SMH motors MH56, MH70, MH105 |  | Motor terminal box MH145, MH205
 | standard | cable chain compatible | standard | cable chain compatible
1.5mm2 / up to 13.8A | MOK55 | MOK54 | MOK60 | MOK63
2.5mm2 / up to 18.9A | MOK56 | MOK57 | MOK59 | MOK64
6mm2 / up to 32.3A | - | - | - | MOK61
10mm2 / up to 47.3A |  | -- | - | MOK62


Motor cable with plug

MOK55/.. (max. 13.8A)

Cable: 6x1,5mm2

MOK54/..: (max. 13.8A) cable chain compatible

Same structure (conductor coloring may be changed) as MOK55/.. available in cable chain compatible version.

MOK56/..: (max. 18.9A)

Same structure (conductor coloring/designations may be changed) as MOK55/.. but with 6x2.5mm2 .

MOK57/..: (max. 18.9A) cable chain compatible

Same structure (conductor coloring / designation may be changed) as MOK55, but with 4x2.5 + 2x1mm2 and cable chain compatible.

You will find the length code in the Accessories order code.


Motor cable for terminal box

MOK61/..: (max. 32.3 A) cable chain compatible

Cable: 4x6mm2 + 2x1mm2

MOK62/.. (max. 47.3 A) cable chain compatible

Same structure (conductor coloring/designations may be changed) as MOK61/.. but with 4x10mm2 + 2x1mm2 .

MOK60/.. (max. 13.8A) standard
MOK63/.. (max. 13.8 A) cable chain compatible

Same structure (conductor coloring/designations may be changed) as MOK61/.. but with 6x1.5mm2 .

MOK59/.. (max. 18.9A) standard
MOK64/.. (max. 18.9 A) cable chain compatible

Same structure (conductor coloring/designations may be changed) as MOK61/.. but with 6x2.5mm2 .

You will find the length code in the Accessories order code.


EMC measures

In this chapter you can read about:

Mains filter

Motor output filter


Mains filter

For radio interference suppression and compliance with teh emission limit values for a CE - conform operation we offer mains filters:

Observe the maximum permitted length of the connection between the mains filter and the device:

  • unshielded <0.5m;
  • screened < 5m (fully shielded on ground – e.g. ground of control cabinet)
Order Code mains filter
 |  |  |  |  |  | / |  |
for C3S025V2 or S063V2 | N | F | I | 0 | 1 | / | 0 | 1
for C3S0xxV4, S150V4 or S1xxV2 | N | F | I | 0 | 1 | / | 0 | 2
for C3S300V4 | N | F | I | 0 | 1 | / | 0 | 3


Mains filter NFI01/01

for Compax3 S025 V2 and Compax3 S063 V2

Dimensional drawing:


Mains filter NFI01/02

for Compax3 S0xx V4, Compax3 S150 V4 and Compax3 S1xx V2

Dimensional drawing:

Dimensional drawing NFI01/02


Mains filter for NFI01/03

for Compax3 S300

Dimensional drawing:

NFI01/03 Dimensional drawing


Motor output filter

In this chapter you can read about:

Motor output filter MDR01/04

Motor output filter MDR01/01

Motor output filter MDR01/05

Wiring of the motor output filter

We offer motor output filters for disturbance suppression when the motor connecting cables are long (>20m):

Order Code motor output filter
 |  |  |  |  |  | / |  |
up to 6,3 A rated motor current | M | D | R | 0 | 1 | / | 0 | 4
Up to 16 A rated motor current | M | D | R | 0 | 1 | / | 0 | 1
up to 30 A rated motor current | M | D | R | 0 | 1 | / | 0 | 5


Motor output filter MDR01/04

up to 6,3 A rated motor current

Dimensional drawing:


Motor output filter MDR01/01

Up to 16 A rated motor current

Dimensional drawing:

Dimensional drawing MDR01/01


Motor output filter MDR01/05

up to 30 A rated motor current

Dimensional drawing: On request


Wiring of the motor output filter

Wiring of the motor output filter


External ballast resistors

In this chapter you can read about:

Overview ballast resistors for Compax3

BRM8/01braking resistors

BRM9/01 braking resistor

BRM5/01 braking resistor

Braking resistor BRM6/02

Braking resistor BRM4/0x

Danger!
Hazards when handling ballast resistors!

Housing temperature up to 200°C!

Dangerous voltage!

The device may be operated only in the mounted state!

The external ballast resistors must be installed such that contact with the human body is prevented.

Install the connecting leads at the bottom.

Observe the instructions on the resistors (warning plate).

The ballast resistors are equipped with a 1.5m connecting lead.
Note that a length >2 m is not permitted.


Overview ballast resistors for Compax3

Ballast resistors for Compax3

Braking Resistor | Drive | sustained | dynamic
BRM8/01 (100W) | Compax3 S025 V2 Compax3 S015 V4 Compax3 S038 V4 | 60W | 250W (<1s; ³10s cooling time)
BRM5/01 (56W) | Compax3 S063 V2 Compax3 S075 V4 | 180W | 2300W (<0,4s; ³8s cooling time)
BRM6/02 (33W) | Compax3 S150 V4 | 570W | 6900W (<1s; ³20s cooling time)
BRM4/01 (15W) | Compax3 S300 V4 Compax3 S150 V2 | 570W | 6900W (<1s; ³20s cooling time)
BRM4/02 (15W) | Compax3 S300 V4 Compax3 S150 V2 | 740W | 8900W (<1s; ³20s cooling time)
BRM4/03 (15W) | Compax3 S300 V4 | 1500W | 18kW (<1s; ³20s cooling time)
BRM9/01 (22W) | Compax3 S100 V2 | 570W | 6900W (<1s; ³20s cooling time)


BRM8/01braking resistors

Dimensional drawing:


BRM9/01 braking resistor

Dimensional drawing:


BRM5/01 braking resistor

Dimensional drawing:

BRM5/01 Dimensional drawing


Braking resistor BRM6/02

Dimensional drawing:

1: thermal current overload cut-off


Braking resistor BRM4/0x

Dimensional drawing:

1: thermal current overload cut-off

Dimensions:
Size: | BRM4/01 | BRM4/02 | BRM4/03
A | 250 | 300 | 540
B | 330 | 380 | 620
C | 64 | 64 | 64


Operator control module BDM

Order Code operating module
 |  |  |  |  |  | / |  |
Operating module | B | D | M | 0 | 1 | / | 0 | 1
Flexible service and maintenance

Functions:
  • Mobile or stationary handling: can remain on the unit for display –and diagnostic purposes, or can be plugged into any unit.
  • Can be plugged in while in operation
  • Power supply via Compax3 servo control
  • Display with 2 times 16 places.
  • Menu-driven operation using 4 keys.
  • Displays and changing of values.
  • Display of Compax3– messages.
  • Duplication of device properties and IEC61131-3 program to another Compax3 with identical hardware.
  • Additional information can be found int he BDM manual This can be found on the Compax3 CD or on our Homepage: BDM-manual.


EAM06: Terminal block for inputs and outputs

Order Code terminal block
 |  |  |  |  |  |  | / |  |
for I/Os without luminous indicator | for X11, X12 | E | A | M | 0 | 6 | / | 0 | 1
for I/Os with luminous indicator | for X12 | E | A | M | 0 | 6 | / | 0 | 2

The terminal block EAM06/.. can be used to route the Compax3 plug connector X11 or X12 for further wiring to a terminal strip and to a Sub-D plug connector.

Via a supporting rail (Design: rail 1 or rail 2) the terminal block can be installed on a mounting rail in the control cabinet.

EAM06/ is available in2 variants:

  • EAM06/01: Terminal block for X11, X12 without luminous indicator
  • EAM06/02: Terminal block for X12 with luminous indicator

    Corresponding connecting cables EAM06 - Compax3 are available:

  • from X11 - EAM06/01: SSK23/..
  • from X12 - EAM06/xx: SSK24/..
EAM6/01: Terminal block without luminous indicator for X11 or X12

Width: 67.5mm

EAM6/02: Terminal block with luminous indicator for X12

Width: 67.5mm

Cable plan SSK23/..: X11 to EAM 06/01

Cable plan SSK24/..: X12 to EAM 06/xx


ZBH plug set

The plug set which is available as accessory comprises:

  • a shield terminal with large contact area for the motor cable shield, and
  • the mating plug connectors for the Compax3 plug connectors X1, X2, X3, and X4
Order Code connection set for Compax3
 |  |  |  |  |  |  | / |  |
for C3S0xxV2 | ZBH 02/01 | Z | B | H | 0 | 2 | / | 0 | 1
for C3S0xxV4 / S150V4 / S1xxV2 | ZBH 02/02 | Z | B | H | 0 | 2 | / | 0 | 2
for C3S300V4 | ZBH 02/03 | Z | B | H | 0 | 2 | / | 0 | 3

ZBH02/01: for Compax3 S0xx 1AC V2

ZBH02/02: for Compax3 S0xx 3AC V4, Compax3 S150 3AC V4 and Compax3 S1xx 3AC V2

ZBH02/03: for Compax3 S300 3AC V4

Plug connectors set ZBH02/03


Interface cable

In this chapter you can read about:

RS232 cable

RS485 cable to Pop

I/O interface X12

Ref X11

Encoder coupling of 2 Compax3 axes

Encoder cable
Order code for interface cables and plugs
 |  |  |  |  |  |  | / |  |
PC – Compax3 (RS232) |  | S | S | K | 0 | 1 | / | ... | ...(1
on X11 (Ref /Analog) | with flying leads | S | S | K | 2 | 1 | / | ... | ...(1
on X12 (I/Os digital) | with flying leads | S | S | K | 2 | 2 | / | ... | ...(1
on X11 (Ref /Analog) | for I/O –terminal block | S | S | K | 2 | 3 | / | ... | ...(1
on X12 (I/Os digital) | for I/O –terminal block | S | S | K | 2 | 4 | / | ... | ...(1
PC ó POP (RS232) |  | S | S | K | 2 | 5 | / | ... | ...(1
Compax3 ó POP (RS485) |  | S | S | K | 2 | 7 | / | ../ | ...(6
Compax3 HEDA ó Compax3 HEDA or PC ó C3powerPLmC |  | S | S | K | 2 | 8 | / | ../ | ...(5
Compax3 X11 ó Compax3 X11 (encoder coupling of 2 axes) |  | S | S | K | 2 | 9 | / | ... | ...(1
HEDA bus termination plug (for the first and last Compax3 in the HEDA – Bus) |  | B | U | S | 0 | 7 | / | 0 | 1
Profibus cable (2 | non prefabricated | S | S | L | 0 | 1 | / | ... | ...(1
Profibus plug |  | B | U | S | 0 | 8 | / | 0 | 1
CAN-Bus cable (2 | non prefabricated | S | S | L | 0 | 2 | / | ... | ...(1
CANbus connector |  | B | U | S | 1 | 0 | / | 0 | 1


RS232 cable

SSK1/..

You will find the length code in the Accessories order code.


RS485 cable to Pop

SSK27: Connection Pop - Compax3 - Compax3 - ...

Order code: SSK27/nn/..

Length A (Pop - 1. Compax3) variable (the last two numbers according to the length code for cable, for example SSK27/nn/01)

Length B (1. Compax3 - 2. Compax3 - ... - n. Compax3) fixed 50 cm (only if there is more than 1 Compax3, i.e. nn greater than 01)

Number n (the last two digits)

Examples:

SSK27/05/.. for connecting from Pop to 5 Compax3.

SSK27/01/.. for connection from Pop to one Compax3


I/O interface X12

SSK22/..: Cable for X12 with open ends

You will find the length code in the Accessories order code.


Ref X11

SSK21/..: Cable for X11 with open ends

You will find the length code in the Accessories order code.


Encoder coupling of 2 Compax3 axes

SSK29/..: Cable from Compax3 X11 to Compax3 X11

You will find the length code in the Accessories order code.


Encoder cable

GBK23/..: Connection Encoder - Compax3

You will find the length code in the Accessories order code.


Profibus plug BUS08/01

We offer a Profibus plug and special cable as meterware for Profibus wiring:

  • Profibus cable: SSL02/.. not prefabricated (color according to DESINA).
  • Profibus plug: BUS8/01 with 2 cable inputs (for one incoming A1, B1 and one continuing Profibus cable- A2, B2 -) and screw terminals as well as a switch for activating the terminal resistor.
    The terminal resistor must be activated on the first and on the last station (= switch setting ON).


CAN - plug BUS10/01

We offer a CAN plug and special cable in any length to order for the CAN-bus wiring:

  • CAN cable: SSL02/.. not prefabricated (colour according to DESINA).
  • CAN plug: BUS10/01 with 2 cable inputs and screw terminals as well as a switch for activating the terminal resistor.
    The terminal resistor must be activated on the first and on the last station (=switch setting ON).

    Note for integrated C3 powerPLmC (Compax3 interface designation "C1x")
    • the CAN bus of the C3 powerPLmC does already contain a terminal resistor.
    • Therefore it applies with the C3 powerPLmC:
      Put switch to OFF
      wire C3 powerPLmC always at the end of the CAN bus!

CAN wiring


PIO: Inputs/Outputs

Additional external digital and analog inputs and outputs can be integrated via CANopen.

For this purpose we offer the Parker I/O system (PIO).

PIO offers the convenience of exceptionally simple installation. The individual modules can be installed and removed without any tools.

Available modules:
Order Code decentralized input terminals
PIO 2DI 24V DC 3.0ms | 2-channel digital input terminal | P | I | O | 4 | 0 | 0
PIO 4DI 24V DC 3.0ms | 4-channel digital input terminal | P | I | O | 4 | 0 | 2
PIO 8DI 24V DC 3.0ms | 8-channel digital input terminal | P | I | O | 4 | 3 | 0
PIO 2AI DC ± 10V differential input | 2 channel analog input terminal (± 10V differential input) | P | I | O | 4 | 5 | 6
PIO 4AI 0 - 10V DC S.E. | 4 channel analog input terminal (0-10V signal voltage) | P | I | O | 4 | 6 | 8
PIO 2AI 0 - 20mA differential input | 2 channel analog input terminal (0 - 20mA differential input) | P | I | O | 4 | 8 | 0

Order Code decentralized output terminals
PIO 2DO 24V DC 0.5A | 2 channel digital output terminal (output voltage 0.5A) | P | I | O | 5 | 0 | 1
PIO 4DO 24V DC 0.5A | 4 channel digital output terminal (output voltage 0.5A) | P | I | O | 5 | 0 | 4
PIO 8DO 24V DC 0.5A | 8 channel digital output terminal (output voltage 0.5A) | P | I | O | 5 | 3 | 0
PIO 2AO 0 - 10V DC | 2 channel analog output terminal (0-10V signal voltage) | P | I | O | 5 | 5 | 0
PIO 2AO 0 - 20mA | 2 channel analog output terminal (0-20mA signal voltage) | P | I | O | 5 | 5 | 2
PIO 2AO DC ± 10V | 2 channel analog output terminal (± 10V Signalspannung) | P | I | O | 5 | 5 | 6

Order Code CANopen Fieldbus Coupler
CANopen Standard | max. vectorial sum current for bus terminals 1650mA at 5V | P | I | O | 3 | 3 | 7
CANopen ECO | max. vectorial sum current for bus terminals 650mA at 5V | P | I | O | 3 | 4 | 7

For additional information please refer to our catalog.


Previous Topic

Next Topic

Technical Data


C3 powerPLmC

In this chapter you can read about:

General information

Controller features

Programming

Visualization

Interfaces

Servo-stage


General information

Platform | 32Bit RISC Processor 200MHz
Boot FLASH | 1 Mbyte
Program memory FLASH | 4MByte
Working memory SDRAM | 16MByte
Data memory non volatile | 32kByte NVRAM
Real time clock | Yes, battery backed.
Operating system | Real time multitasking
Utilities | 24V DC


Controller features

User control program

compiled

Processing time

100ms for 1000AWL – lines

Task – kinds

Real time tasks:

  • Coasting
  • Cyclical
  • Event-controlled, internal events
  • Event-controlled, external events

Minimal cycle time

1ms

Online Programm Change

yes

Watchdog Timer

yes

Data exchange in distributed systems (network variables)

yes


Programming

Programming system | CoDeSyS for Automation Alliance
Programming languages | AWL, SFC, FBP, ST, LD, CFC
Command dimension | IEC61131-3
PLCopen - Modules | yes
Debug, Single Step, Watch function | yes
Write, read, force variables | yes
Import PLC programs | Siemens Import
Program administration | File – System, FTP
Program interface | Fast Ethernet


Visualization

Locally on the programming system | yes
Web - Server | yes
OPC server | yes


Interfaces

(Field)busses standard

CANopen master

Ethernet 10/100

Profibus DP Slave
  • Description: C13Txx
  • DP versions: DPV0/DPV1
  • Baud rate: up to 12MHz
  • Profibus ID: C313
  • Device master file: PAR_C313.GSD
  • Process data channel up to 122 words

Serial interfaces

none

Digital inputs/outputs option

External terminals (PIO)

Analogue inputs/outputs option

External terminals (PIO)


Servo-stage

Control platform of drive

DSP – system, independent of control stage


Compax3 servo-stage

In this chapter you can read about:

Mains connection V2

Mains connection 3AC V2

Mains connection V4

Control voltage 24 VDC

Output data 1AC V2

Output data 3AC V2

Output data Compax3 Sxxx 3*400VAC

Output data Compax3 Sxxx 3*480VAC

Switching frequencies of the motor current with corresponding nominal and peak currents

Accuracy

Motors and feedback systems supported

Motor holding brake output

Brake operation Compax3 1AC V2

Brake operation Compax3AC V2

Brake operation Compax3AC V4

Overview ballast resistors for Compax3

Mechanical data

Safety technology

UL certification

Insulation requirements

Ambient conditions

EC directives and harmonised EC norms

RS232 - / RS485 - interfaces

Signal interfaces

IEC6113-3 functions

Cam function


Mains connection V2

Mains connection for Compax3 S0xx 1AC V2

Controller type | S025 V2 | S063 V2
Mains voltage | Single phase 230VAC/240VAC 80-253 VAC/50-60Hz
Input current | 6Aeff | 13Aeff
Maximum fuse rating per device | 10 A (automatic circuit breaker K) | 16 A (automatic circuit breaker K)


Mains connection 3AC V2

Mains connection Compax3 S1xx 3AC V2

Controller type | S100 V2 | S150 V2
Mains voltage | Three phase 3* 230VAC/240VAC 80-253 VAC/50-60Hz
Input current | 10Aeff | 13Aeff
Maximum fuse rating per device | 16 A (automatic circuit breaker K) | 20 A (automatic circuit breaker K)


Mains connection V4

Mains connection Compax3 Sxxx 3AC V4

Controller type | S015 V4 | S038 V4 | S075 V4 | S150 V4 | S300 V4
Mains voltage | Three phase 3*400VAC/480VAC 80-528VAC / 50-60Hz
Input current | 3Aeff | 6Aeff | 10Aeff | 16Aeff | 22Aeff
Maximum fuse rating per device | 6A | 10A | 16A | 20A | 25A
 | Automatic circuit breaker K |  |  |  | D*

*for CE-conform operation: Automatic circuit breaker K S273-K.


Control voltage 24 VDC

Control voltage 24VDC (X4/1, X4/2)

Controller type | Compax3 family
Voltage range | 21 - 27VDC
Current drain of the device | 0.8A
Total current drain | 0.8 A + Total load of the digital outputs + current for the motor holding brake
Ripple | 0.5Vpp
Requirement according to safe extra low voltage (SELV) | yes


Output data 1AC V2

Output data Compax3 S0xx at 1*230VAC/240VAC

Controller type | S025 V2 | S063 V2
Output voltage | 3x 0-240V | 3x 0-240V
Nominal output current | 2.5Aeff | 6.3Aeff
Pulse current for 5s | 5.5Aeff | 12.6Aeff
Power | 1kVA | 2.5kVA
Switching frequency | 16kHz | 16kHz
Power loss for In | 30W | 60W
Efficiency | 95% | 96%


Output data 3AC V2

Output data Compax3 S1xx at 3*230VAC/240VAC

Controller type | S100 V2 | S150 V2
Output voltage | 3x 0-240V | 3x 0-240V
Nominal output current | 10Aeff | 15Aeff
Pulse current for 5s | 20Aeff | 30Aeff
Power | 4kVA | 6kVA
Switching frequency | 16kHz | 8kHz
Power loss for In | 80 W | 130W
Efficiency | 95% | 96%


Output data Compax3 Sxxx 3*400VAC

Output data Compax3 Sxxx at 3*400VAC

Controller type | S015 V4 | S038 V4 | S075 V4 | S150 V4 | S300 V4
Output voltage | 3x 0-400V
Nominal output current | 1.5Aeff | 3.8Aeff | 7.5 Aeff | 15Aeff | 30Aeff
Pulse current for 5s | 4.5Aeff | 9.0Aeff | 15Aeff | 30Aeff | 60Aeff
Power | 1kVA | 2.5kVA | 5kVA | 10kVA | 20kVA
Switching frequency | 16kHz | 16kHz | 16kHz | 8kHz | 8kHz
Power loss for In | 60W | 80 W | 120W | 160W | 350W
Efficiency | 92% | 95% | 96% | 97% | 97%


Output data Compax3 Sxxx 3*480VAC

Output data Compax3 Sxxx at 3*480VAC

Controller type | S015 V4 | S038 V4 | S075 V4 | S150 V4 | S300 V4
Output voltage | 3x 0-480V
Nominal output current | 1.5Aeff | 3.8Aeff | 6.5Aeff | 13.9Aeff | 30Aeff
Pulse current for 5s | 4.5Aeff | 7.5 Aeff | 15Aeff | 30Aeff | 60Aeff
Power | 1.25kVA | 3.1kVA | 6.2kVA | 11.5kVA | 25kVA
Switching frequency | 16kHz | 16kHz | 16kHz | 8kHz | 8kHz
Power loss for In | 60W | 80 W | 120W | 160W | 350W
Efficiency | 93% | 96% | 97% | 98% | 98%

Previous Topic

Next Topic

Switching frequencies of the motor current with corresponding nominal and peak currents

Resulting nominal and peak currents depending on the switching frequency

Compax3 S0xx V2 at 1*230VAC/240VAC
Switching frequency* |  | S025 V2 | S063 V2
16kHz | Inominal | 2.5Aeff | 6.3Aeff
 | Ipeak (<5s) | 5.5Aeff | 12.6Aeff
32kHz | Inominal | 2.5Aeff | 5.5Aeff
 | Ipeak (<5s) | 5.5Aeff | 12.6Aeff
Compax3 S1xx V2 at 3*230VAC/240VAC
Switching frequency* |  | S100 V2 | S150 V2
8kHz | Inominal | - | 15Aeff
 | Ipeak (<5s) | - | 30Aeff
16kHz | Inominal | 10Aeff | 12.5Aeff
 | Ipeak (<5s) | 20Aeff | 25Aeff
32kHz | Inominal | 8Aeff | 10Aeff
 | Ipeak (<5s) | 16Aeff | 20Aeff
Compax3 S0xx V4 at 3*400VAC
Switching frequency* |  | S015 V4 | S038 V4 | S075 V4 | S150 V4 | S300 V4
8kHz | Inominal | - | - | - | 15Aeff | 30Aeff
 | Ipeak (<5s) | - | - | - | 30Aeff | 60Aeff
16kHz | Inominal | 1.5Aeff | 3.8Aeff | 7.5Aeff | 10.0Aeff | 26Aeff
 | Ipeak (<5s) | 4.5Aeff | 9.0Aeff | 15.0Aeff | 20.0Aeff | 52Aeff
32kHz | Inominal | 1.5Aeff | 2.5Aeff | 3.7Aeff | 5.0Aeff | 14Aeff
 | Ipeak (<5s) | 3.0Aeff | 5.0Aeff | 10.0Aeff | 10.0Aeff | 28Aeff
Compax3 S0xx V4 at 3*480VAC
Switching frequency* |  | S015 V4 | S038 V4 | S075 V4 | S150 V4 | S300 V4
8kHz | Inominal | - | - | - | 13.9Aeff | 30Aeff
 | Ipeak (<5s) | - | - | - | 30Aeff | 60Aeff
16kHz | Inominal | 1.5Aeff | 3.8Aeff | 6.5Aeff | 8.0Aeff | 21.5Aeff
 | Ipeak (<5s) | 4.5Aeff | 7.5Aeff | 15.0Aeff | 16.0Aeff | 43Aeff
32kHz | Inominal | 1.0Aeff | 2.0Aeff | 2.7Aeff | 3.5Aeff | 10Aeff
 | Ipeak (<5s) | 2.0Aeff | 4.0Aeff | 8.0Aeff | 7.0Aeff | 20Aeff

The values marked with grey are the pre-set values (standard values)!

*corresponds to the frequency of the motor current


Accuracy

Accuracy at the motor

For option F10: Resolver
  • Position resolution: 16Bit (= 0.005°)
  • Absolute accuracy: ±0,167°

For option F11: SinCos
  • Position resolution: 19Bit (= 0.0002°)
  • Absolute accuracy: ±0,005°

For option F12: Direct drives
  • Maximum position resolution
    • Linear motor: 24 Bits per motor magnet spacing
    • Rotatory motor: 24 bits per motor revolution
  • Resolution for analog hall sensors with 1Vss signal:
    13.5 bits / motor magnet spacing
  • Resolution for analog hall sensors with 1Vss signal:
    13.5 bits / graduation of the scale of the encoder
  • Resolution for RS 422 encoders:
    4x encoder resolution
  • Exactitude:
    The exactitude of the position signal is above all determined by the exactitude of the feedback system used.


Motors and feedback systems supported

Motors and feedback systems supported

Motors

Direct drives

  • Linear motors
  • Torque motors
  • Sinusoidal commutated synchronous motors
    • Maximum rotating field frequency: 1,000Hz
    • Max. velocity at 8 pole motors: 15000min-1.
    • General max. speed:
      60*1000/number of pole pairs in [min-1].
  • Sinusoidal commutated asynchronous motors
    • Maximum rotating field frequency: 1,000Hz
    • General max. speed:
      60*1000/number of pole pairs - slip in [min-1].
    • Field suppression: typically up to triple (higher on request).
  • Temperature sensor: KTY84-130
  • 3 phase synchronous direct drives

Position encoder (Feedback)
Option F10: Resolver

Litton:
  • JSSBH-15-E-5
  • JSSBH-21-P4
  • RE-21-1-A05
  • RE-15-1-B04

Tamagawa:
  • 2018N321 E64

Siemens:
  • 23401-T2509-C202

Option F11: SinCos©

  • Singleturn (Stegmann)
  • Multiturn (Stegmann) Absolute position up to 4096 motor revolutions.
  • Feedback error compensation (offset & amplification) can be activated via MotorManager.

Special encoder systems for direct drives
Option F12

Analog hall sensors
  • Sinus - Cosinus Signal (max. 5Vss; typical 1Vss) 90° offset
  • U-V signal (max. 5Vss; typical 1Vss) 120° offset.

Encoder
(linear or rotatory)
  • Sinus-Cosinus (max. 5Vss; typical 1Vss) (max. 400kHz) or
  • TTL (RS422) (max. 5MHz)

    with the following modes of commutation:

  • automatic commutation or
  • Digital hall sensors

Distance coded feedback systems
  • Distance coding with 1VSS - Interface
  • Distance coding with RS422 - Interface (Encoder)

Feedback error compensation

  • Feedback error compensation (offset & amplification) for analog hall sensors and sine-cosine encoder can be activated via MotorManager.


Motor holding brake output

Motor holding brake output

Motor holding brake output | Compax3 family
Voltage range | 21 – 27VDC
Maximum output current (short circuit proof) | 1.6A


Brake operation Compax3 1AC V2

Braking operation Compax3 S0xx 1AC V2

Controller type | S025 V2 | S063 V2
Capacitance / storable energy | 560mF / 15Ws | 1120mF / 30Ws
Minimum ballast - resistance | 100W | 56W
Recommended nominal power rating | 20 ... 60W | 60 ... 180W
Pulse power rating for 1s | 1kW | 2.5kW


Brake operation Compax3AC V2

Braking operation Compax3 S1xx 3AC V2

Controller type | S100 V2 | S150 V2
Capacitance / storable energy | 780mF / 21Ws | 1170mF / 31Ws
Minimum ballast - resistance | 22W | 15W
Recommended nominal power rating | 60 ... 450W | 60 ... 600W
Pulse power rating for 1s | 4kW | 6kW


Brake operation Compax3AC V4

Brake operation Compax 3 Sxxx 3AC V4

Controller type | S015V4 | S038V4 | S075V4 | S150V4 | S300V4
Capacitance / storable energy | 235mF / 37Ws | 235mF / 37Ws | 470mF / 75Ws | 690mF / 110Ws | 1100mF / 176Ws
Minimum ballast - resistance | 100W | 100W | 56W | 22W | 15W
Recommended nominal power rating | 60 ... 100W | 60 ... 250W | 60 ... 500 W | 60 ... 1000 W | 60 ... 1000 W
Pulse power rating for 1s | 1kW | 2.5kW | 5kW | 10 kW | 42kW


Mechanical data

Mechanical data

Controller type | Dimensions HxWxD [mm] | Weight [kg]
Compax3 S025 V2 | 199 x 84 x 172 | 2.0
Compax3 S063 V2 | 199 x 100 x 172 | 2.5
Compax3 S015 V4 | 260 x 84 x 172 | 3.1
Compax3 S100 V2 | 260 x 115 x 172 | 4.3
Compax3 S150 V2 | 260 x 160 x 172 | 6.8
Compax3 S038 V4 | 260 x 100 x 172 | 3.5
Compax3 S075 V4 | 260 x 115 x 172 | 4.3
Compax3 S150 V4 | 260 x 160 x 172 | 6.8
Compax3 S300 V4 | 380 x 175 x 172 | 10.9
Protection type IP20


Safety technology

Safety technology

Safe standstill certified as per EN954-1
category 3: (BG-PRÜFZERT certification no.: 0403005)
  • For implementation of the ”protection against unexpected start-up” function described in EN1037.
  • Please refer to the circuitry examples circuitry examples.


UL certification

UL certification

conform to UL:
  • according to UL508C

Certified
  • E-File_No.: E235 342

The UL certification is documented by a ”UL” logo on the device (type specification plate).

”UL” logo

UL logo


Insulation requirements

Insulation requirements

Protection class | Protection class I according to EN 50 178 (VDE 0160 part 1)
Protection against human contact with dangerous voltages | According to DIN VDE 0106, part 100
Overvoltage category | Voltage class III according to HD 625 (VDE 0110-1)
Degree of contamination | Degree of contamination 2 according to HD 625 (VDE 0110 part 1) and EN 50 178 (VDE 0160 part 1)


Ambient conditions

Ambient conditions

General ambient conditions | According to EN 60 721-3-1 to 3-3 Climate (temperature/humidity/barometric pressure): Class 3K3
Permissible ambient temperature: |
Operation Storage Transport | 0 to +45 C Class 3K3 –25 to +70 C Class 2K3 –25 to +70 C Class 2K3
Tolerated humidity: | No condensation
Operation Storage Transport | <= 85% class 3K3 <= 95% class 2K3 <= 95% class 2K3 | (Relative humidity)
Elevation of operating site | <=1000m above sea level for 100% load ratings Please inquire for greater elevations
Cooling mode | Compax3 S025 V2 ... S150 V4: Convection Compax3 S300 V4: Forced air ventilation with fan in the heat dissipator
Sealing | IP20 protection class according to EN 60 529
EMC interference emission | Limit values according to EN 61 800-3, First environment (Commercial and residential area) Class ‘A‘ with integrated mains filter for up to 10 m cable length, otherwise with external mains filter
EMC disturbance immunity | Limit values for industrial utilization according to EN 61 800-3 (includes EN 50 081-2 and EN 50 082-2)


EC directives and harmonised EC norms

EC directives and harmonised EC norms

EC low voltage directive 73/23/EWG and RL 93/68/EWG | EN 50 178, General industrial safety norm Equipping electric power systems with electronic operating equipment HD 625, general electrical safety Insulation principles for electrical operating equipment EN 60 204-1, machinery standard partly applied
EC-EEC-directive 89/336/EWG | EN 61 800-3, EMC norm Product standard for variable speed drives EN 50 081-2 ... 50 082-2, EN 61 000-4-2 ...61 000-4-5


RS232 - / RS485 - interfaces

RS232 - / RS485 - interface

RS232
  • 115200 baud
  • Word length: 8 bits, 1 start bit, 1 stop bit
  • Hardware handshake XON, XOFF

RS485 (2 or 4-wire)
  • 9600, 19200, 38400, 57600 or 115200 baud
  • Word length 7/8 bit, 1 start bit, 1 stop bit
  • Parity (can be switched off) even/odd
  • 2 or 4-wire


Signal interfaces

Signal interfaces

Signal inputs / signal sources
  • Encoder – input track A/B (RS422)
    • up to max. 10MHz
    • internal quadrature of the resolution
  • Step / direction input (24V-level)
    Max. 300kHz at ³50W source impedance and minimum pulse width of 1,6µs.
  • +/-10V analog input
    14Bit; 62.5µs scanning rate.

Signal outputs
  • Encoder simulation
    • 1...16384 increments/revolution or pitch
    • Limit frequency 620kHz
  • Bypass function with encoder feedback with feedback module F12.

Signal transmission

HEDA (option M10 or M11)
Exchange of process values:

  • from Slave to Master
  • from Slave to Master and
  • from Slave to Slave.


IEC6113-3 functions

IEC6113-3 functions

General
  • Programmable based on IEC61131-3
  • Up to 5000 instructions
  • 500 16 Bit - variables
  • 150 32 Bit - variables
  • Recipe table with 288 variables
  • 3x16-bit retain-variable
  • 3x32-bit retain-variable

PLCOpen function modules
  • Positioning: absolute, relative, additive, endless
  • Electronic Gearbox (Gearing)
  • Machine Zero
  • Stop, energizing the power stage, Quit
  • Position, device status, reading axis error

IEC61131-3 standard modules
  • Up to 8 timers (TON, TOF, TP)
  • Triggers (R_TRIG, F_TRIG)
  • Flip-flops (RS, SR)
  • Counters (CTU, CTD, CTUD)

Device-specific function modules
  • generates an input process image
  • generates an output process image
  • access to recipe table

Inputs/Outputs
  • 8 digital inputs (24V level)
  • 4 digital outputs (24-V level)
  • Optional addition of 12 inputs/outputs


Cam function

T40 Functions: Cam

General
  • Cam control function
  • Programmable based on IEC61131-3
  • Position of selected master signal source via:
    • Encoder, Step / direction
      or +/-1 0V analog
    • HEDA
    • Virtual Master

Cam memory
  • 10.000 interpolation points
    (master / slave in 24 bit format)
    saved failure save.
  • Distance of interpolation points can be adapted to curve (non equidistant interpolation points)
  • Linear interpolation between points

Linking curve segments
  • Up to 20 cam segments can be produced.
  • Virtually random cam links (forwards and backwards)
  • Freely programmable, event-triggered curve branching.
  • Scalable cam segments and complete cam profiles

Coupling and decoupling functions
  • With the aid of a quadratic function.
  • By means of a change-over function
  • Without overspeeding by coupling over several master cycles.
  • Virtually free set-up of the coupling and decoupling movement
  • master-guided coupling movement.
  • Random standstill position

Mark synchronization
  • Master or slave oriented (simultaneous, cam-independent).
  • highly precise mark recognition (accuracy < 1 µs)

Cam generation with renowned Nolte tool.
  • Standard or extended range of functions
  • evaluation of the motion profiles.